IRC channel logs

2017-07-05.log

back to list of logs

<jsierles2>i'm building from the latest core-updates, and wget fails to build. anyone else see this?
<jsierles2>fails on 84 tests
<castilma>hey guys, after trying out guixsd in qemu I want to dual boot into it. since it is not as stable as ubuntu, I want ubuntu to handle grub. but since guixsd creates a new entry for every system generation, the only solution I see is chainloading, i.e. putting (bootloader (grub-configuration (device "(hd0,gpt5)"))) in config.scm. now the question: I have a bios system and my hdd is gpt partitioned, i.e. there is a 1MiB partition for grub.
<jonsger>castilma:
<castilma>jonsger: I see an empty message.
<jonsger>castilma: oh sorry, it was unintended. thunderbird irc...
<elreydelaswasas1>how can i fix the error grub install: error /gnu/store/bdzxdpw2Sk8v6lz54clz4zbilx47srj-grub-2.02/libgrub/x86_64-efi/modinfo.sh doesn´t exist. Release specify --target or .--directory. guixsystem: error: failed to install GRUB on device '/dev/sda'
<elreydelaswasas1>how can i fix guix system error: build failed: getting info about the Nix Store mount point: No such file or directory
<jsierles2>has anyone looked into using a different database for guix? postgresql or something instead of sqlite.
<alezost>jsierles2: I think noone looked at it
<sneek>Welcome back alezost, you have 1 message.
<sneek>alezost, civodul says: do you think guix-search-by-regexp could sort by relevance like 'guix package --search' does?
<efraim>I don't even know if there's a guile module for postgres, I think we've basically inherited sqlite from Nix
<jsierles2> http://www.nongnu.org/guile-pg/
<buenouanq>oh man, if someone would package guile-pg for me, I'd forever be thankful
<nee``````>buenouanq: I have a ugly/wip, but working package for guile-pg: https://hidamari.blue/git/packages/html/guile-pg.scm.html The metadata is wrong and it doesn't build for guile2.2
<ng0>wow, building julia takes a very long time
<ng0>I wanted to change my build machine anyway
<ng0>24+ hours already on this not so old computer
<efraim1>sneek: later tell civodul are the gccgo packages created by custom-gcc stripped at the end?
<sneek>Got it.
<efraim1>sneek: botsnack
<sneek>:)
<jsierles2>ng0: yeah, just it won't build on master due an issue with wget tests
<jsierles2>how does 'guix archive' work with regards to the sqlite database?
<boskovits>hello
<catonano>boskovits: hello
<catonano>jsierles2: jsierles nee`````` buenouanq i was wondering how does guile-pg compare to guile-squee
<catonano>maybe the place for this discussion is #guile
<boskovits>I would like to discuss the approach to bootstrap maven.
<boskovits>I see a lot of dependecies is already packaged.
<boskovits>I am willing to help packaging the rest.
<catonano>boskovits: the work on Maven is being done by rekado. But at the moment e is on vacation
<catonano>he is on vacation
<boskovits>Ok, thanks.
<boskovits>Do you know when he will be back?
<catonano>no, but he is here on thsi channel sometimes
<boskovits>Ok.
<boskovits>I guess then I will go on to package dependencies.
<quigonjinn>any idea about which of our packages provide epstool, fig2dev and pstoedit?
<boskovits>Main thing is, that I don't know, how should we represent maven artifact information.
<jsierles2>if i have a failing build from upstream, can I override it in my GUIX_PACKAGE_PATH?
<jsierles2>for example, wget tests fail now and I just want to disable its tests so it builds.
<boskovits>jsierles2: last time I tried that it worked for me.
<jsierles2>boskovits: did you inherit it or just write a new definition?
<boskovits>It was when a linux-libre tarball was missing.
<boskovits>I wrote a new definition, I don't know if inheriting works, but I think it should.
<boskovits>If you find out if inhetiting works please let me know. Thanks.
<jsierles2>will do
<ng0>as long as you give the new package no unique name but the same name as the one you want to override
<jsierles2>R users - do you have problems using install.packages() after having installed R with guix?
<jsierles2>i'm seeing "Error in gzfile(file, mode)". which suggests R cannot write to wherever it wants to put these libraries
<catonano>jsierles the whole point of Guix is to take the packages management from language specific pacage managers
<catonano>jsierles2: if you want to install some R package, you should do so with Guix
<jsierles2>catonano: yes i realize that
<jsierles2>you can have both too. my goals are different than yours
<catonano>oh
<jsierles2>anyway, looks like R can't write to /tmp
<catonano>ok
<jsierles2>any way to use more than one store path?
<jsierles2>similar to GUIX_PACKAGE_PATH, i'd like to store some builds in a private path.
<jsierles2>how can I make 'gfortran' available to a package's tests?
<efraim>I would add gfortran to the native-inputs
<jsierles2>thanks. didnt see that field documented
<jsierles2>hmm still fails
<jsierles2>needs to be in the path.
<jsierles2>./gnu/store/kpxi8h3669afr9r1bgvaf9ij3y4wdyyn-bash-minimal-4.4.12/bin/bash: gfortran: command not found
<jsierles2>gcc however is in the path
<jsierles2>maybe because r-build-system doesn't include gfortran
<dannym>jsierles2: very improbable. If it's in native-inputs the stuff will be in path. Try "guix environment yourpackage --pure", then run gfortran in there...
<dannym>(for testing)
<jsierles2>yup, sorry my mistake
<jsierles2>i had two packages that needed it, and didn't notice
<jsierles2>nice, got r-diversitree built
<bavier`>hello Guix
<boskovits>hello
<boskovits>I know this must be something trivial, but I just can't find my way around.
<boskovits>I am trying to match a literal { in a regexp in substitute*
<mekeor>boskovits: what's the code? what's the error message?
<mekeor>also, this might also be a question for #guile or #scheme
<boskovits>ok, i have another idea.
<boskovits>Yes, I suppose it belongs to there.
<boskovits>(substitute* "build.xml" (("dir=\\"${test.home}/java\\"") "dir=\\"${test.home}\\"")))
<boskovits>this is the first version
<boskovits>In unknown file: ?: 0 [make-regexp "dir=\\"${test.home}/java\\"" 1] ERROR: In procedure make-regexp: ERROR: In procedure make-regexp: Invalid preceding regular expression
<boskovits>this is the error for it
<boskovits>I guess it is because { needs to be quoted.
<bavier`>boskovits: yes, I think it needs to be "$\\\\{test"
<bavier`>otherwise it is expecting a repetition count
<boskovits>ok, that is also what I guessed.
<boskovits>And I see, that simply \\{ does not work, I get invalid character in escape sequence.
<boskovits>So ok, I will try with \\\\{
<boskovits>thanks
<bavier`>np
<elreydelaswasas1>which is the script we have to write in the config.scm template when we are installing guixsd living in Colombia ?
<elreydelaswasas1>which is the line content we have to write in the timezone line in the config.scm template when we are installing guixsd living in Colombia ?
<elreydelaswasas1>which is the line content we have to write in the timezone line in the config.scm template when we are installing guixsd living in Colombia ?
<ng0>elreydelaswasas1: I would suggest to send an email to help-guix@gnu.org as mentioned on https://www.gnu.org/software/guix/help/ , it seems your questions could be answered there better than in IRC.
<mekeor>elreydelaswasas1: the manual states: "You can run the tzselect command to find out which timezone string corresponds to your region."
<ng0>for timezone, I guess "America/Bogota"
<ng0>or "CO", whatever works
<ng0>oh yeah.. tzselect
<mekeor>elreydelaswasas1: see https://www.gnu.org/software/guix/manual/guix.html#operating_002dsystem-Reference
<quiliro>hello
<sneek>Welcome back quiliro, you have 1 message.
<sneek>quiliro, rekado_ says: When “make” fails just try again. Could be that you ran out of memory.
<quiliro>rekado: it did fail several times, i then stopped some services such as tor and xorg-server
<quiliro>rekado: and then make was successful
<quiliro>i turned the computer off after that
<quiliro>do i have to run those commsnds again to get back into the environment?
<quiliro>i will go into that environment and then run './pre-inst-env guix build openmolar1'
<quiliro>ran:
<quiliro>'guix environment guix ; ./bootstrap && ./configure --localstatedir=/var && make"
<quiliro>not exactly
<quiliro>it was:
<quiliro>'guix environment guix ; cd guix ; ./bootstrap && ./configure --localstatedir=/var && make'
<quiliro>now i get an error after './pre-inst-env guix build openmolar1'
<quiliro>ImportError: No module named 'PyQt5'
<quiliro>hw can i resolve that?
<quiliro>hello rekado
<quiliro>followed your instructions
<quiliro>and after hanging the computer sever times, i could get over make
<quiliro>but i get an error after:
<quiliro>'./pre-inst-env guix build openmolar1'
<quiliro>it is : ImportError: No module named 'PyQt5'
<quiliro>my medical.scm is http://paste.lisp.org/+7I4R
<quiliro>my complete error is:
<quiliro> http://paste.lisp.org/+7I4S
<quiliro>the commands i ran before were: 'guix environment guix ; cd guix ; ./bootstrap && ./configure --localstatedir=/var && make'
<efraim>You should try adding #:use-module (gnu packages qt) near the other use-modules and python-pyqt5 to the inputs
<quiliro>efraim thank you....you mean:
<quiliro>#:use-module (gnu packages qt)
<quiliro>#:use-module (gnu packages pytho-pyqt5)
<efraim>Just the first
<quiliro> [11:46]
<quiliro><quiliro> efraim thank you....you mean: [11:47]
<quiliro><quiliro> #:use-module (gnu packages qt) [11:49]
<quiliro><quiliro> #:use-module (gnu packages pytho-pyqt5)
<quiliro>
<quiliro>sorry
<quiliro>and the second? python-pyqt5?
<quiliro>where should i put that?
<efraim>After the (build-system ... line add (inputs `(("python-pyqt5" ,python-pyqt5)))
<quiliro>efraim: efraim1: is this correct?: http://paste.lisp.org/display/350091#1
<efraim>quiliro: that looks good
<quiliro>efraim: do i now have to run everything again or just the last command (pre-...)
<quiliro>?
<efraim>Just the ./pre... build command
<quiliro>now i get another error
<quiliro>ERROR: In procedure %resolve-variable:
<quiliro>ERROR: Unbound variable: python-pyqt5
<quiliro>efraim: http://paste.lisp.org/+7I4T
<efraim>So it sounds like python-pyqt5 is either wrong or not in gnu/packages/qt
<efraim>./pre-inst-env guix package -A pyqt should help us see whats wrong
<efraim>Looks like I was mistaken, the name of the package is just python-pyqt, so remove the 5 off the end of the names
<quiliro>efraim: ok
<quiliro>by the way, the new error was http://paste.lisp.org/+7I4T/1
<quiliro>i will test now and report
<quiliro>new medical.scm http://paste.lisp.org/display/350091#2
<quiliro>will test
<quiliro>./pre-inst-env guix build openmolar1
<quiliro>is working now
<quiliro>error
<janneke>o/
<quiliro> http://paste.lisp.org/display/350093#2
<quiliro>gettext is missing?
<quiliro>hello janneke
<quiliro>UserWarning: The version specified ('1.0.15-gd81f9e5') is an invalid version, this may not work as expected with newer versions of setuptools, pip, and PyPI. Please see PEP 440 for more details.
<quiliro>efraim: what do you think?
<quiliro>i got disconnected....did the paste reach the room?
<efraim>I think that's an impressive list of errors, only one of which made it choke
<quiliro>oh...will check the log
<efraim>Yeah, I saw the #2 paste
<quiliro>ok :-)
<efraim>And the 'invalid version' one
<quiliro>which one made it choke?
<quiliro>ok
<quiliro>error: option --single-version-externally-managed not recognized
<quiliro>how about that?
<quiliro>or missing gettext?
<efraim>the single version one
<quiliro>what to do?
<efraim>The gettext probably should've made check fail
<quiliro>on make?
<efraim>(arguments `#:phases (modify-phases %standard-phases (replace 'install (lambda _ (system* "python" "setup.py" "--prefix="(assoc-ref %outputs "out") "--root=/")))))
<efraim>Fum to type on a phone :)
<quiliro>efraim: haha
<efraim>Add that after (build-system... lime
<quiliro>ok
<efraim>Wait
<efraim>`(#:phases
<efraim>I missed an open parenrhesis before
<quiliro>so it is:
<quiliro>(arguments `(#:phases (modify-phases %standard-phases (replace
<efraim>And then add a ) at the end
<efraim>Normally its all broken into several lines
<quiliro>(arguments `(#:phases (modify-phases %standard-phases (replace 'install (lambda _ (system* "python" "setup.py"
<quiliro>is that correct?
<efraim>i think so
<quiliro>new medical.scm http://paste.lisp.org/display/350091#3
<quiliro>will run ./pre-...
<quiliro>new error:
<quiliro>find-files: /gnu/store/p6w4dvxkpx4sjy6d1ir9kmy6ngsx098i-openmolar1-1.0.15-gd81f9e5: No such file or directory
<efraim>ok, i see what I forgot
<efraim>change "setup.py" "--prefix..." to "setup.py" "install" "--prefix..."
<efraim>hopefully that will take care of it
<efraim>ACTION has to go for a while
<quiliro>efraim: thank you
<quiliro> http://paste.lisp.org/display/350091#4
<quiliro>still gives an error
<quiliro>find-files: /gnu/store/mpzbjcbip95n5dgn3m3rflv0p49yxb8g-openmolar1-1.0.15-gd81f9e5: No such file or directory
<quiliro>this too:
<quiliro>/gnu/store/3aw9x28la9nh8fzkm665d7fywxzbl15j-python-3.5.3/lib/python3.5/site-packages/setuptools/dist.py:340: UserWarning: The version specified ('1.0.15-gd81f9e5') is an invalid version, this may not work as expected with newer versions of setuptools, pip, and PyPI. Please see PEP 440 for more details.
<ng0>I think the dist warning can be ignored
<efraim>Install and setup.py are switched in #4
<quiliro>woops
<quiliro> http://paste.lisp.org/display/350091#5
<quiliro>it still gives error:
<quiliro>find-files: /gnu/store/1k12hq6czzvm561k9hf3xpw2s9b52k19-openmolar1-1.0.15-gd81f9e5: No such file or directory
<quiliro>also still get the gettext error
<rekado>quiliro: you don’t need the arguments field
<rekado>the default install phase already does the right thing
<rekado>ACTION has to go again
<quiliro>rekado: oh...so what do i have to do...it did not work without the arguments
<efraim>rekado: http://paste.lisp.org/display/350093#2
<quiliro>efraim: new output: http://paste.lisp.org/display/350093#3
<quiliro>rekado: check that one with the last medical.scm http://paste.lisp.org/display/350091#5
<quiliro>without arguments part, it gives error: option --single-version-externally-managed not recognized
<quiliro>after: "details." % self.metadata.version
<quiliro>what should i read to learn more about htis?
<quiliro>s/htis/this/
<quiliro>changed web page on openmolar1
<quiliro>to https://openmolar.com/om1
<quiliro> http://paste.lisp.org/display/350091#6
<quiliro>but still have problem with ./pre-...
<quiliro>by the way, this is gnu/packages/medical.scm
<reggggieee>hi all, i'm getting an error "guix package: error: profile contains conflicting entries for emacs-dash:out" when trying to upgrade/install/remove packages.
<reggggieee>it also says 'propagated from emacs-guix@0.3.1' which i have already removed, so I'm not sure what more I can do
<quiliro>rekado: what documentation do i have to read in order to fix this?
<quiliro>efraim: what doc would you suggest?
<pmikkelsen>hi guix
<quiliro>hi pmikkelsen
<quiliro>how can i update the git ?
<quiliro>i used git to download guix
<quiliro>maybe the prolem i have is an outdated guix
<quiliro>it is about 4 days old
<quiliro>it is 2 days old
<quiliro>i think
<bavier`>quiliro: you built guix from a git clone?
<quiliro>bavier`: yes
<bavier`>quiliro: then just `git pull && make`
<quiliro>bavier`: thank you
<quiliro>bavier`: meke: external command not found
<bavier`>quiliro: "make"
<quiliro>s/meke/make/
<quiliro>bavier`: yes...typo on chat...not on command line
<quiliro>~/guix $ git pull && make
<quiliro>Already up-to-date.
<quiliro>make: external command not found
<bavier`>quiliro: you can enter and environment for building guix with `guix environment --pure guix`
<quiliro>bavier`: ok
<quiliro>then i typed ': No such file or directory
<quiliro>phase `reset-gzip-timestamps' succeeded after 0.0 seconds
<quiliro>starting phase `compress-documentation'
<quiliro>/phase `compress-documentation' succeeded after 0.0 seconds
<quiliro>builder for `/gnu/store/b9362rwm1axs2fmbchkm624r7d8wbn9d-openmolar1-1.0.15-gd81f9e5.drv' failed to produce output path `/gnu/store/1k12hq6czzvm561k9hf3xpw2s9b52k19-openmolar1-1.0.15-gd81f9e5'
<quiliro>@ build-failed /gnu/store/b9362rwm1axs2fmbchkm624r7d8wbn9d-openmolar1-1.0.15-gd81f9e5.drv - 1 builder for `/gnu/store/b9362rwm1axs2fmbchkm624r7d8wbn9d-openmolar1-1.0.15-gd81f9e5.drv' failed to produce output path `/gnu/store/1k12hq6czzvm561k9hf3xpw2s9b52k19-openmolar1-1.0.15-gd81f9e5'
<quiliro>guix build: error: build failed: build of `/gnu/store/b9362rwm1axs2fmbchkm624r7d8wbn9d-openmolar1-1.0.15-gd81f9e5.drv' failed
<quiliro>quiliro@portkomputilo ~/guix [env]$ ls /gnu/store/1k12hq6czzvm561k9hf3xpw2s9b52k19-openmolar1-1.0.15-gd81f9e
<quiliro>ls: cannot access '/gnu/store/1k12hq6czzvm561k9hf3xpw2s9b52k19-openmolar1-1.0.15-gd81f9e': No such file or directory
<quiliro>quiliro@portkomputilo ~/guix [env]$ less /gnu/store/1k12hq6czzvm561k9hf3xpw2s9b52k19-openmolar1-1.0.15-gd81f9e5.lock
<quiliro>bash: less: command not found
<quiliro>quiliro@portkomputilo ~/guix [env]$ cat /gnu/store/1k12hq6czzvm561k9hf3xpw2s9b52k19-openmolar1-1.0.15-gd81f9e5.lock
<quiliro>cat: /gnu/store/1k12hq6czzvm561k9hf3xpw2s9b52k19-openmolar1-1.0.15-gd81f9e5.lock: Permission denied
<quiliro>quiliro@portkomputilo ~/guix [env]$exit
<quiliro>quiliro@portkomputilo ~/guix$ ls guix/
<quiliro>base16.go config.go docker.scm gnu-maintenance.go import/ packages.scm serialization.go ui.go
<quiliro>base16.scm config.scm download.go gnu-maintenance.scm licenses.go pk-crypto.go serialization.scm ui.scm
<quiliro>base32.go config.scm.in download.scm gnupg.go licenses.scm pk-crypto.scm sets.go upstream.go
<quiliro>base32.scm cpio.go elf.go gnupg.scm memoization.go pki.go sets.scm upstream.scm
<quiliro>base64.go cpio.scm elf.scm grafts.go memoization.scm pki.scm ssh.go utils.go
<quiliro>base64.scm cve.go ftp-client.go grafts.scm modules.go profiles.go ssh.scm utils.scm
<quiliro>build/ cve.scm ftp-client.scm graph.go modules.scm profiles.scm store/ workers.go
<quiliro>build-system/ cvs-download.go gcrypt.go graph.scm monad-repl.go records.go store.go workers.scm
<quiliro>build-system.go cvs-download.scm gcrypt.scm hash.go monad-repl.scm records.scm store.scm zlib.go
<quiliro>build-system.scm derivations.go gexp.go hash.scm monads.go scripts/ svn-download.go zlib.scm
<quiliro>cache.go derivations.scm gexp.scm hg-download.go monads.scm scripts.go svn-download.scm
<quiliro>cache.scm discovery.go git-download.go hg-download.scm nar.go scripts.scm tests/
<quiliro>combinators.go discovery.scm git-download.scm http-client.go nar.scm search-paths.go tests.go
<quiliro>combinators.scm docker.go git.scm http-client.scm packages.go search-paths.scm tests.scm
<davexunit>is there an op that can stop the flood?
<quiliro>quiliro@portkomputilo ~/guix$ ls guix/build
<rain1>its ok
<quiliro>ant-build-system.go download.scm gnu-build-system.go java-utils.scm python-build-system.go svn.scm
<quiliro>ant-build-system.scm dub-build-system.go gnu-build-system.scm lisp-utils.go python-build-system.scm syscalls.go
<quiliro>asdf-build-system.go dub-build-system.scm gnu-dist.go lisp-utils.scm qt-utils.go syscalls.scm
<quiliro>asdf-build-system.scm emacs-build-system.go gnu-dist.scm make-bootstrap.go qt-utils.scm texlive-build-system.go
<quiliro>bournish.go emacs-build-system.scm graft.go make-bootstrap.scm r-build-system.go texlive-build-system.scm
<quiliro>bournish.scm emacs-utils.go graft.scm ocaml-build-system.go r-build-system.scm union.go
<davexunit>quiliro: please stop
<rain1>you can just /ignore if it causing you problems
<quiliro>cargo-build-system.go emacs-utils.scm gremlin.go ocaml-build-system.scm rpath.go union.scm
<quiliro>cargo-build-system.scm font-build-system.go gremlin.scm perl-build-system.go rpath.scm utils.go
<quiliro>cmake-build-system.go font-build-system.scm haskell-build-system.go perl-build-system.scm ruby-build-system.go utils.scm
<quiliro>cmake-build-system.scm git.go haskell-build-system.scm profiles.go ruby-build-system.scm waf-build-system.go
<quiliro>cvs.go git.scm hg.go profiles.scm store-copy.go waf-build-system.scm
<quiliro>cvs.scm glib-or-gtk-build-system.go hg.scm pull.go store-copy.scm
<bavier`>quiliro: why the dump?
<quiliro>download.go glib-or-gtk-build-system.scm java-utils.go pull.scm svn.go
<quiliro>quiliro@portkomputilo ~/guix$ guix environment --pure guix
<quiliro>quiliro@portkomputilo ~/guix [env]$ ./bootstrap && ./configure --localstatedir=/var && make'
<quiliro>oh no
<quiliro>sorry for the flood
<quiliro>i made a mistake on paste
<rain1>that's fine, just be careful
<quiliro>davexunit: it was accidental...
<bavier`>yeah, looked like a paste error
<davexunit>I still would have kicked if I was an op to stop it
<quiliro>bavier`: i dont know...i dont handle emacs well enough yet
<davexunit>I thought freenode had flood detection
<quiliro>davexunit: i think it is not necessary...the best is to cut any paste that is long automatically
<quiliro>davexunit: exactly
<quiliro>i dont think it was good to do it...but i dont think it was so terrible either
<quiliro>no dead people
<quiliro>or agressions yet because of my pste
<davexunit>yeah I know it was an accident
<quiliro>i have flooded channels before...but eventually i have learne not to do it....thanks to nice people guiding me...not because of impositions
<davexunit>the purpose of a kick in this situation isn't for punishment, but to stop the flood. you'd be able to just rejoin the channel.
<quiliro>is it really necessary to kick in order to avoid flooding...cant it be cut automatically?
<davexunit>I thought freenode had a flood detection thing but maybe not.
<rain1>the paste stopped ages ago
<rain1>everyone can calm down now
<davexunit>everyone is calm?
<quiliro>is 70 KiB/s normal for ./pre-inst-env guix build openmolar1?
<quiliro>it is downloading a lot of packages again....is that because of --pure _
<quiliro>?
<quiliro>guix environment --pure guix
<rekado>quiliro: you may want to add “--no-grafts” to the “guix build” command.
<rekado>quiliro: instead of replacing the install phase you can do this: (arguments `(#:use-setuptools? #f))
<rekado>that gets me to an error in the install phase
<rekado>namely: “error: could not create '/usr': Permission denied”
<rekado>to fix this error I do this:
<quiliro>it is taking very long
<rekado>* unpack the sources: tar xf $(guix build -S openmolar1)
<quiliro>i did not get your error before
<rekado>* grep for “/usr”
<rekado>where are you stuck right now?
<quiliro>i used guix environment --pure guix
<rekado>you won’t need that unless you want to compile Guix
<quiliro>then ./bootstrap && ./configure --localstatedir=/var && make
<rekado>you only need bootstrap and configure once
<quiliro>then ./pre-inst-env guix build openmolar1
<rekado>ok
<quiliro>and i am on the last one now
<rekado>the last step is the only one you need
<quiliro>it is taking a lot of time....about 1 hour
<rekado>the last step is taking one hour?
<quiliro>let me see
<rekado>it really should not
<rekado>but I can imagine that the bootstrap, configure, and make steps take a long time
<quiliro>not at all
<rekado>you should not run bootstrap && configure unless you have a good reason
<quiliro>i also did git pull && make
<quiliro>but make failes
<rekado>oh.
<quiliro>that was before guix environment --pure guix
<rekado>it should fail outside of the environment, because you probably don’t have the things installed in your profile that it needs.
<quiliro>oh
<quiliro>i cd guix
<quiliro>it was not inside [
<quiliro>env]
<quiliro>if that is what you mean
<quiliro>the prompt did not show it
<rekado>you don’t need the environment for building your package
<rekado>you only need it to build Guix (e.g. after pulling changes from git)
<quiliro>i was wondering why no one answered
<quiliro>process finished with error
<quiliro>i will start again without --pure
<quiliro>rekado: do you agree?
<quiliro>guix environment guix
<quiliro> ./bootstrap && ./configure --localstatedir=/var && make
<quiliro>then ./pre-inst-env guix build openmolar1
<rekado>why do you bootstrap again?
<rekado>that’s not something you should do more than once
<rekado>I wrote this above
<rekado>ACTION already built openmolar
<quiliro>is is though with all bot the last command ./pre-...
<rekado>(but it has a runtime error)
<quiliro>ok
<quiliro>so what can i do?
<rekado>sorry, I’m out of time for today :(
<quiliro>rekado: ok...thank you....please tell me what i should investigate, read, explore
<quiliro>i want to learn in oreder
<quiliro>order to contribute time instead of consume it
<rekado>okay, just do “./pre-inst-env guix build openmolar1”, do not bother with “bootstrap” or “configure” again. It just consumes time.
<rekado>here’s my current version: http://paste.lisp.org/display/350100
<rekado>it builds, but it crashed when running openmolar
<rekado>ImportError: No module named 'MySQLdb'
<rekado>so you need to add the mysql binding for Python to the inputs
<rekado>…and then work from there until the next error
<rekado>ACTION waves everyone goodbye
<quiliro>rekado: thanks
<quiliro>anyone want to help me "add the mysql binding for Python to the inputs"?
<janneke>lat0r rekado!
<quiliro>computer hung
<quiliro>had to hard reboot
<quiliro>now i did 'cd guix' then 'guix environment guix' then './pre-inst-env guix build openmolar'
<quiliro>and last commsnd is running now
<quiliro>ping
<quiliro>am i connected?
<ng0>no :)
<quiliro>haha
<quiliro>thank you ng0
<quiliro>will someone help me with this one?
<quiliro>how can i download all guix irc logs?
<quiliro>i know they are in several web pages
<quiliro>but one per day...i want all...at least from a certain date
<quiliro>so i can read them at home offline
<ng0>that's not possible
<ng0>technically
<ng0>we hope that soon (not too soon) the logs will be in a better presentation. at the gnunet side we had some brainstorming about a new website, and the logs are part of that. they will be exported from the current format so that they can be used with a bot and log viewer which afaik should be searchable
<ng0>the source for all these websites is really just the messy database of the standard drupal irc bot.
<ng0>which uses sql.
<ng0>it's not messy, but I find it ridiculous to have all channels in one table.. that's like writing everything to one textfile.
<quiliro>hello again
<quiliro>please help me with what rekado recommended
<ng0>I'm writing a text right now. But I think you just need to search for python-mysql or smething and add it to the (inputs) list of the package you are creating
<catonano>quiliro: I think it's called python-mysqlclient
<quiliro>add this: `(("python-mysqlclient" ,python-mysqlclient))
<quiliro>between: (inputs
<quiliro>and : `(("python-pyqt" ,python-pyqt)))
<quiliro>is that correct?
<catonano>quiliro: right now it is like this:
<catonano> (inputs
<catonano> `(("python-pyqt" ,python-pyqt)))
<catonano>
<catonano>and it shold become like this:
<catonano> (inputs
<catonano> `(("python-pyqt" ,python-pyqt)
<catonano> ("python-mysqlclient" ,python-mysqlclient))
<catonano> )
<catonano>also you have to add (gnu pacages python) to the imports, at the top of thhe file
<quiliro>catonano: parenthis missmatch
<catonano>quiliro: in the fragment that I pasted, they match
<quiliro>catonano: now i see
<catonano>quiliro: ah, good
<quiliro>they closed the doors now...so i have to go...will i need a connection for this change?
<catonano>I'm afrai you will
<catonano>afraid
<quiliro>oh
<quiliro>i will continue tomorrow then
<catonano>because python-mysqlclient has to be downloaded
<quiliro>thank you
<catonano>quiliro: you're welcome
<quiliro>is there a way i can download it now and not when compiling everything?
<catonano>quiliro: you can install it with
<quiliro>i could build only that package
<catonano>guix package -i python-mysqlclient
<catonano>this will dwnload it and it will be in yourr store
<quiliro>will it be preserved in the [env] ?
<catonano>I think so
<quiliro>or used by it when in the store?
<catonano>I'm not sure 100% but I think so
<quiliro>ok
<catonano>more likely used by it if in the store