IRC channel logs

2017-06-25.log

back to list of logs

<quiliro>i cannot scp from from one server to another
<quiliro>command not found
<reepca>have you installed an ssh client?
<rain1>it would be nice if there was a way to find out which package provides a binary
<quiliro>openssh is installed
<rain1>i wonder if i could make atool to do this, but im not sure how
<quiliro>openssh contains both server and client
<reepca>quiliro: is the ssh command found?
<quiliro>yes
<quiliro>does the ssh daemon need to be herded_
<quiliro>?
<quiliro>started
<reepca>rain1: as far as I can tell it would require either adding more information to every package definition (would require quite a bit of changing) or knowing what every package looks like in its built form.
<reepca>quiliro: the daemon shouldn't be necessary for client stuff to work
<ng0>sneek: later tell quiliro: you have to include 'openssh' in the system wide available packages. This makes the 'scp' binary available to connecting users
<sneek>Will do.
<earthfail22>guys, how much on average would it take to complete installing guixsd?
<reepca>how much what? Time? Effort? Space?
<earthfail22>time it is now building and taking the whole night
<reepca>When I installed I don't think it took over an hour
<earthfail22>I must have done something wrong then. will see
<reepca>the time varies depending on stuff like substitute availability and what's already in your store
<earthfail22>reepca: fresh install it is building and compiling packages
<mekeor>hellui gox!
<reepca>o/
<janneke>o/
<rain1>hello
<janneke>hi rain1
<rain1>good news, i fixed an efficiecy bug and now my compiler bootstraps in 1 second
<janneke>whoa, nice work!
<janneke>it was ~50 seconds or so, right?
<rain1>yeah
<janneke>good
<rain1>i was accidentally searching the global variables each time they were referenced, instead of having them already resolved
<janneke>honest bug :-)
<janneke>rain1: really want to see how we can make good use of that
<janneke>also i didn't try out/follow up on your 8cc patch yet
<rain1>ah the thing was after removing the anon. union there is a few uses of va_list
<reepca>There's a lot of code in guix/store.scm that does basically what I want, but relies on RPCs for low-level functionality - mostly accessing the database. It feels weird duplicating code just to replace the implementation of some low-level thing. I wonder if there's a better way.
<janneke>oh yeah, that's right -- that needs more inspection and thought
<mekeor>any idea why "guix environment guix" results in "error: profile contains conflicting entries for gzip:out" for me?
<mekeor>i wonder if it was a mistake that i once did "./pre-inst-env guix package -i …"
<Introoter>What version of gnome does guix runm
<Introoter>run?*
<Introoter>nvm
<janneke>mekeor: why would that be a mistake? you can always [./pre-inst-env] guix package -r ...
<epronk>Good afternoon, guix!
<mekeor>hello epronk :)
<mekeor>nice to meet you
<epronk>mekeor: nice to meet you too. :)
<earthfail22>Hello guys, I was wondering is it possible to miss up the config while installing guixsd that it will not stop and repeat itself?
<mekeor>earthfail22: i don't understand your question
<janneke>morning epronk!
<mekeor>yes, i could run "./pre-inst-env guix package -r ..." but i already did "git pull", so the pre-installation-environment changed.
<mekeor>i had ghc-xmonad-contrib package installed both as system-package as well as user. i now removed all system-generations; also removed xmonad as user; removed all old user-generations; and finally ran "guix gc" both as root and as user. but there are still files and folders for ghc-xmonad-contrib in /gnu/store. why?
<mekeor>s/xmonad as user/ghc-xmonad-contrib as user/
<janneke>mekeor: try guix gc --list-live
<janneke>possibly with a nic grep; are the ghc-xmonad-contrib still live?
<epronk>the installation manual says "herd start shh-daemon" => "could not be found". I installed openssh. How do I get the service installed?
<epronk>I'm using the vm-image. The installation image might have that pre-configured.
<janneke>epronk: what does `herd status' say?
<janneke>ACTION hasn't switch to openssh, [still] using lsh
<epronk>janneke: 'herd status' has a long list of file-system, tty, guix-daemon, but no lsh or ssh.
<rekado_>epronk: you need to add the service to the list of services in your configuration file and reconfigure.
<janneke>epronk: see, e.g. 6.2.1 Using the Configuration System
<cbaines>I'm seeing some unicode placeholders (the box with numbers in it) when looking at the info docs for org-mode in Emacs, any ideas what I can do to fix this?
<cbaines>I'm guessing I might need to install some fonts (this is on GuixSD), but I don't know which ones
<janneke>cbaines: where do you see it, which node?
<cbaines>The "Activation" node, within the Introduction
<cbaines>I've tested on my other GuixSD machine, and it works there... just not on the one I'm using currently
<quigonjinn>is there any symbol for the "empty package"? I want to pass it to a record* to override the default field value.
<cbaines>quigonjinn, do you mean package as in Guix package?
<quigonjinn>cbaines: yes
<cbaines>Ok, I'm not sure there is really a thing as an empty package
<cbaines>What is the wider context?
<cbaines>and what does this record represent?
<quigonjinn>the context is that i want to create an xfce-desktop-service, whose xfce-desktop-configuration does not include the xfce package, so that I get only the extended polkit-service for thunar.
<quigonjinn>it's the xfce-desktop-configuration record*
<cbaines>ah, interesting
<efraim>While not directly answering your question you should be able to just add that service to the OS config
<quigonjinn>it should probably work to just extend the polkit service, like xfce-desktop-service-type does, but if I could pass the "empty" package, it would be more concise scode-wise
<quigonjinn>s/concise/compact/
<cbaines>quigonjinn, if I'm reading the definition of the service extension in the xfce-desktop-service-type for polkit correctly, it depends on the xfce-package
<cbaines>it uses package-direct-input-selector (which is defined in desktop.scm) to get the thunar package from the xfce-package, and then passes this through to the polkit service type
<cbaines>quigonjinn, you might want to use (simple-service ...) to just setup polkit
<quigonjinn>cbaines: right, I didn't understand that it gets the thunar package from the xfce-package. i'll do that, thanks
<cbaines>This might work...? (simple-service "polkit-thunar" polkit-service-type (list thunar))
***jonsger1 is now known as jonsger
<cbaines>bit its a real guess
<quigonjinn>cbaines: yes it works! thanks
<cbaines>great, you're welcome :)
<quigonjinn>it's a temporary solution for me until the bug with xfce gets fixed.
<quigonjinn>or i might get rid of it altogether :)
***jonsger1 is now known as jonsger
<mekeor>janneke: "guix gc --list-live" indeed lists about 33 lines containing ghc-xmonad-contrib. but why?
<janneke>mekeor: then ghc-xmonad-contrib (or a package thah depends on that) is present in a profile
<mekeor>janneke: can i find out in which profile? because i tried to delete it from everywhere
<mekeor>oh, wait
<mekeor>i found the profiles them
<janneke>good :-)
<mekeor>thanks :)
<janneke>yw
<ofosos_>hi guix
<ofosos_>I'm getting an error "profile contains conflicting entries" when trying to update, how can I remedy this?
<cbaines>By update, do you mean running guix package -u ?
<ofosos_>either guix package -i, or guix system reconfigure
<ofosos_>guix package -u ran fine
<cbaines>hmm, I did see some discussions about issues with XFCE on the mailing list, it wouldn't happen to be that would it?
<ofosos_>yeah, that happens with xfce, but I also get this with zlib for whatever reason
<cbaines>could you put the error up on http://paste.lisp.org ?
<ofosos__>the error is at http://paste.lisp.org/display/349468
<cbaines>ofosos__, looks like you have the same issue that is being tracked here https://debbugs.gnu.org/cgi/bugreport.cgi?bug=27467
<ofosos__>I also get this one with zlib, no idea how to fix it: http://paste.lisp.org/display/349469
<cbaines>for that one, what happens if you try running guix package -u zlib
<ofosos__>cbaines, that seems to pull in way more packages than i would suppose zlib does
<cbaines>hmm, it might be trying to build zlib...?
<ofosos__>ok, that fixed it, but now installing webkitgtk i get the same error for libX11 O_o
<cbaines>upgrading everything in your profile should stop this happening, but obviously you might not want to do that
<mekeor>ofosos__: i also get some conflicting entries with gzip if that was what you meant with "zlib"
<ofosos__> http://paste.lisp.org/display/349469#1 see here, now that should be in the system profile which i can't update :(
<ofosos__>(since xfce is broken)
<mekeor>ofosos__: ... IIRC, "guix pull" fixed it for me
<OriansJ``>morning guix
<jlicht>hello guix
<mekeor>hello OriansJ`` , hello jlicht :)
<jlicht>o/
<ofosos__>do i have to do anything special to go to 0.13? i think it's still using guile2.0, when iirc 0.13 should use guile 2.2
<OriansJ``>ofosos__: guix package --upgrade[=REGEXP] usually is all it takes to upgrade to a newer version of the program
<ofosos__>i mean guixsd in this case
<ofosos__>nope, doing guix pull doesn't change anything
<OriansJ``>ofosos__: guix system reconfigure should do it
<ofosos__>doesn't work bc of broken xfce
<OriansJ``>even with --keep-going
<ofosos__>yep, that doesn't help either
<ofosos__>can i somehow edit the package definition for the system profile in guixsd?
<ofosos__>when i do a guix edit as root i get confronted with a readonly file system, which is not so nice
<jlicht>ofosos__: I run guix from a git repo as specified *somewhere* in the online manual
<jlicht>You could also do this for your root user, which naturally would lead to guix-edit giving you editable files ;-)
<ofosos__>jep, found it, changed some stuff (it's in the README of the git repo), but I'm not sure how to propagate my changes so that system reconfigure can see them
<ofosos__>will system reconfigure simply pick stuff up, when i put it in the store via `guix build'?
<jlicht>ofosos__: your root user has their own profile, guix-tree and everything
<jlicht>the store is by defintion isolated from all other parts. If you mean changes to your local guix package definitions, you should make sure your root profile makes use of that guix source tree
<ofosos__>how do i do that?
<jlicht>for me, as root: cd .config/guix; ln -s <wherever your git checkout of guix is> ./latest
<jlicht>there should already be a symlink called latest in that directory; if you are not really sure of what you are doing yet, I recommend simply renaming instead of overwriting the symlink, so you can easily revert to a known working guix for root in case something goes terribly wrong ;-)
<jlicht>but maybe some of the more knowledgable folks around here can share their workflows: this is just what works for me :D
<dfh_>So. I just managed to get GuixSD installed on my new old X200s. Now trying to install some fonts. Not going all too well. I'm wondering, how can I tell what fonts are installed?
<janneke>hi OriansJ``!
<janneke>good news: I'm done with the hex2 transition
<ofosos__>hmm, interesting, how do i upgrade from guixsd 0.12.0 to 0.13.0?
<ofosos__>jlicht, that doesn't work for me, it's complaining that the stuff in /gnu/store/...-guix-0.12.0 ist older than the source file
<jlicht>ofosos__: you might want to build your source tree first. In your guix git checkout: guix environment --pure --container guix;
<jlicht>and then, if this is the first time you build guix: ./bootstrap.sh; ./configure --localstatedir=/var; make;
<jlicht>(and possibly make check, but be prepared to wait for quite some time
<OriansJ``>janneke: that is excellent news!
<janneke>OriansJ``: also, i created a fixed hex2 footer with ELF_str and ELF_sym that only include _start and main
<janneke>this allows for fairly nice gdb'ing and to at least see the disasembly with objdump
<OriansJ``>janneke: good work :D
<janneke>which makes the tool that creates those dynamically cease to be a blocker
<janneke>until we have that tool, the disassembly is much less nice: no function names, buh hey:-)
<janneke>OriansJ``: the only thing that i really need for mes 0.8 is a MESCC_Tools release ;-)
<janneke>so i can package and submit it to Guix -- mescc now depends on it
<OriansJ``>janneke: absolutely
<janneke>you saw my patches? guix.scm is almost done, you may want to have a look.
<OriansJ``>janneke: just did, merging now
<janneke>:-)
<OriansJ``>janneke: looks good, appears to build and install without issue
<janneke>OriansJ``: OK, great. for guix, i'd like to have a versioned release in git, say 0.1, so that the guix recipy can dowload a tarball rather than a git commit. can you do that for me?
<janneke>I will also update Nyacc in Guix (much overdue) so that we'll have all the new goodies from mwette to attack 8cc, pcc, tcc, whatnot
<OriansJ``>janneke: no problem
<janneke>OriansJ``: thank you
<OriansJ``>janneke: tagged release 0.1 is up
<janneke>yay, thanks&congrats!
<mekeor>how can i make "guix build" keep the logs? "guix build --log-file foo" leads to "guix build: error: no build log for '/gnu/store/…-foo-….drv'".
<quiliro>hello
<sneek>Welcome back quiliro, you have 1 message.
<sneek>quiliro, ng0 says: you have to include 'openssh' in the system wide available packages. This makes the 'scp' binary available to connecting users
<quiliro>oh!
<quiliro>why is ssh available and not scp?
<quiliro>ssh is also part of openssh
<quiliro>how is it possible to brose the web via emacs
<quiliro>?
<OriansJ``>quiliro: eww allows one to browse the web via emacs
<quiliro>OriansJ``: is it included in emacs or do i need to install it? in both cases, how can i run it?
<mekeor>quiliro: tbh, this is pretty off-topic. why not ask in #emacs?
<mekeor>quiliro: anyway, run EWW with "M-x eww RET"
<OriansJ``>quiliro: it is already included in the emacs provided by guix
<quiliro>emacs provides eww by default in any distro?
<OriansJ``>quiliro: well not the distros with stripped emacs but generally those with vanilla emacs, yes
<quiliro>or only in guix?
<quiliro>OriansJ``: thank you
<quiliro>what does emacs do when it is stripped? edit files only?
<quiliro>i guess that is a question for #emacs
<OriansJ``>quiliro: depends on how stripped it is
<quiliro>i will ask there
<quiliro>ok
<espectalll>Heya, has the GRUB test been patched?
<janneke>expectall: yes, 23a53a95f gnu: grub: Disable a flaky test.
<espectalll>Great!"
<espectalll>Have down `guix pull` already so let's see
<espectalll>*done
<AndChat438900>Hi all. I installed guix. all is good. I restarted my pc. The grub worked well. But after the grub there are several messages displayed on the screen and before going to the connection window guix blocked
<espectalll>By "connection window" you mean login screen, right?
<espectalll>And I guess you have installed GuixSD with a desktop service?
<mekeor>what do you mean by "blocked", AndChat438900
<mekeor>?
<AndChat438900>yes i installed by default
<AndChat438900>i changed just sdx by sda
<mekeor>only that won't be enough, i think.
<OriansJ``>AndChat438900: did you remember to setup a username and password?
<mekeor>i guess we need more information: at least some error message or something, AndChat438900
<AndChat438900> https://drive.google.com/file/d/0B_FDv4AsDit4WHFUU0l2S3FsZ0U/view?usp=drivesdk
<AndChat438900>this is screen shot for my pc
<mekeor>AndChat438900: can you paste your config.scm?
<AndChat438900>ok
<mekeor>AndChat438900: did you really only change sdx to sda? didn't you also have to adapt the UUID of the root-partition?
<AndChat438900>yes the grub work fine
<AndChat438900>(use-modules (gnu) (gnu system nss)) (use-service-modules desktop) (use-package-modules certs gnome) (operating-system (host-name "antelope") (timezone "Europe/Paris") (locale "en_US.utf8") ;; Assuming /dev/sdX is the target hard disk, and "my-root" ;; is the label of the target root file system. (bootloader (grub-configuration (device "/dev/sda"))) ;; Specify a mapped device for the encrypted root partition. ;; The UUID is that returned by 'cryptset
<espectalll>Next time, please upload the file with a pastebin, such as paste.lisp.org
<espectalll>seems like there's missing content
<mekeor>yeah, the interesting part is missing
***jonsger1 is now known as jonsger
<rekado_>ACTION plays a Star Trek game on a PS/2 386 running FreeDOS.
<OriansJ``>janneke: and we now have new and improved tests for MESCC_Tools, now we have examples for both x86 and amd64 working in M0 and a proper changelog so that it'll be a proper project from here on.
<janneke>OriansJ``: yay!
<janneke>so next big thing up is M0 xx86/amd64 aka M1 for Mes, right?
<OriansJ``>janneke: bingo
<janneke>unless rain1 decides to do something smart with their lisp compiler
<janneke>;-)
<mekeor>rekado_: cool, sounds like a fun weekend :)
<rain1>if you have efficiency trouble running something like nyacc then it is possible you can put this compiler in to accelerate it
<janneke>rain1: yeah, proud as i am about mes.c, i fear it has to go some time to make way for something written in hex2
<janneke>that could be something like your lisp compiler
<janneke>once we compile that to hex2
<janneke>and have the source in lisp, oh i dunno :-)
<janneke>OriansJ``: MESCC_Tools package submitted to guix!
<OriansJ``>janneke: SWEET!
<espectalll>Getting a 410 "Gone" error when trying to download the `texlive-texmf-2016` substitute
<espectalll>I don't know why is that getting download, as I haven't specified anything TeX-related on my `config.scm`
<espectalll>but anyway, should I do `guix pull` again? Seems like a huge waste of time
<jlicht>espectalll: texlive is a humongous substitute that for some technical reasons is not able to be hosted properly atm
<jlicht>it should be fixed Soon (tm), but till then I recommend running whatever command you were running with a --fallback flag
<espectalll>oh boy, time to compile TeXLive
<janneke>expectall: try something like: guix refresh --list-dependent texlive-minimal texlive
<espectalll>(I was doing `guix system reconfigure`)
<janneke>to get a clue why
<espectalll>(as I said, I don't even know why is it being installed)
<espectalll>…how can I check which package or service is installing a dependency?
<janneke>see above, guix refresh
<janneke>there are about 124 packages that depend on something texlive-texmf
<janneke>and as jlicht says, substitutes are being worked on
<espectalll>…the source code weights about 2 GB on .tar.xf…
<espectalll>…that's it, I can't install GuixSD :/
<espectalll>*.tar.xz
<espectalll>I don't think I can wait to compile so much
***Piece_Maker is now known as Acou_Bass
<espectalll>…oh, it actually installed quickly
<espectalll>who knew
<espectalll>OK, everything's fine, sorry (?)
<OriansJ``>espectalll: not all large programs take very long to compile. In fact some programs compile at the rate of 4bytes per 7 instructions, which on a 1Ghz system is about 4GB/second
<espectalll>huh, neat
<espectalll>I recall having bad experiences with TeX tho
<espectalll>but seems to be OK after all
<espectalll>…still getting an error
<espectalll>wait a sec
<koosha>re
<mekeor>does elogind also handle closing/claping a laptop?
<koosha>It's really mad . I tried installing guixsd on another machine but not installed again :/
<koosha>I got some errors .
<mekeor>mekeor: search for 'handle-lid-switch' in the manual
<mekeor>mekeor: aaah, thank you!
<mekeor>ACTION had to translate "lid" to his native language in order to understand it
<mekeor>koosha: we need error messages in order to be helpful. please, elaborate
<rekado_>it’s this game: https://archive.org/details/Trek-nTheNthIteration
<rekado_>(but I don’t have a colour display.)
<koosha_>rekado_: Hi friend
<koosha_>rekado_: I'm getting mad actually :D
<koosha_>rekado_: I tried installing GuixSD on another machine and I got a couple of errors .
<koosha_>These are the errors :
<koosha_>make: *** [/tmp/guix-build-qemu-minimal-2.9.0.drv-0/qemu-2.9.0/tests/Makefile.include:816: check-qtest-i386 Error 1
<koosha_>phase 'check' failed after 1099.3 seconds
<rekado_>wait, why are you building qemu?
<koosha_>builder for '/gnu/store/longstring-qemu-minimal-2.9.0.drv' failed with exit code 1
<koosha_>connot build derivstion '/gnu/store/longstring-grub-2.02.drv': 1 dependencies couldn't be built
<koosha_>guix system: error: build failed: build of '/gnu/store/longstring-grub-2.02.drv' failed
<koosha_>That's all .
<koosha_>rekado_: I don't know , I just ran 'guix system init'
<koosha_>rekado_: That's a question for me too .
<quiliro>koosha_: does the error mention something about using --fallback at the end?
<rekado_>koosha: does it download any packages from hydra.gnu.org or mirror.hydra.gnu.org at all?
<rekado_>quiliro: that won’t help, because koosha_ is already building qemu (and failing)
<quiliro>ok
<koosha_>quiliro: That was all the errors .
<rekado_>koosha_: did you run “guix pull” before “guix system init”?
<koosha_>rekado_: Yes , it has downloaded a lot .
<rekado_>koosha_: I just need to know if you’re using version 0.13.0 or current master
<koosha_>rekado_: I didn't run guix pull .
<rekado_>ok
<koosha_>rekado_: I download 0.13.0 .
<koosha_>Should I run 'guix pull' before that ?
<koosha_>*downloaded
<rekado_>what’s the long hash of grub?
<rekado_>we do have substitutes for grub
<koosha_>rekado_: Let me write it ...
<rekado_>/gnu/store/qk4lgkhmy0r24q36smykqkiwllryb8v4-grub-2.02.drv
<rekado_>
<rekado_>?
<koosha_>rekado_: no
<koosha_>rekado_: it has 'jfkk' at first .
<rekado_>that’s odd because what I wrote is the derivation for version 0.13.0
<koosha_>rekado_: What's the kernel for 0.13.0 ?
<rekado_>/gnu/store/fqc2kg4lq1lz1ymk41080jzb5q90icg0-linux-libre-4.11
<koosha_>rekado_: Right
<koosha_>rekado_: So what do you think about the problems ?
<kaiha>hi, I am new to guix and try to understand what is the reason of the following error:
<kaiha>guix system: error: profile contains conflicting entries for grep:out
<kaiha>guix system: error: first entry: grep@3.0:out /gnu/store/a20ik40vkrp3cjwzy0vga8v57ygxjm30-grep-3.0
<kaiha>guix system: error: second entry: grep@3.0:out /gnu/store/fsvrabj8615a9w2jcxvhqss4nrcl4y3j-grep-3.0
<kaiha>any hints?
<rekado_>kaiha: you have two different variants of grep in your profile. If this is the result of “guix package -i” try first to upgrade your whole profile with “guix package -u”
<kaiha>It is the result of `sudo guix system reconfigure /etc/config.scm`
<ng0>sneek: later tell civodul: about the email I sent today, I think I looked at it the wrong way. I am reading (gnu packages make-bootstrap) now which obviously comes before (gnu packages bootstrap)
<sneek>Will do.
<rekado_>kaiha: oh. What’s in your configuration’s list of packages?
<kaiha> (packages (cons* bash-completion
<kaiha> byobu
<kaiha> curl
<kaiha> dmenu
<kaiha> emacs
<kaiha> emacs-evil
<kaiha> emacs-helm
<kaiha> feh
<kaiha> ghc-xmonad-contrib
<kaiha> git
<kaiha> gnupg
<kaiha> grep
<kaiha> haskell-mode
<kaiha> i3-wm
<rekado_>please don’t do this on IRC.
<kaiha> i3status
<kaiha> magit
<kaiha> mc
<kaiha> neomutt
<kaiha> nss-certs
<kaiha> openssh
<kaiha> psmisc
<kaiha> rxvt-unicode
<kaiha> tmux
<kaiha> ratpoison
<kaiha> stalonetray
<rekado_>it’s customary to use a service like paste.lisp.org
<kaiha> xcompmgr
<kaiha> xinit
<kaiha> xmonad
<kaiha> xrandr
<kaiha> xset
<kaiha> xsetroot
<kaiha> zsh
<kaiha> %base-packages))y
<kaiha>rekado_: is this the list you asked for?
<ng0>maybe there's a need for "please use a pastebin (link to pastebin)" in the topic.
<kaiha>ok, my fault
<rekado_>kaiha: what happens if you remove “grep” from the list?
<kaiha>Then it works
<rekado_>the conflict detection is a little too zealous.
<mekeor>sneek: later tell civodul that maybe "please use a pastebin like paste.lisp.org" should be added to channel-topic?
<sneek>Okay.
<kaiha>rekado_: you mean, there is nothing I can do about it?
<ng0>well it is in the topic, but there is a need for a full sentence or at least a relation
<koosha_>Sorry , I've been annoying these days , but I don't have any OS yet so it's so important to get GuixSD installed .
<OriansJ``>koosha_: if you need something stable and working now, debian is a valid option and you can simply install the guix package manager on top.
<koosha_>OriansJ``: Yes I had that but now I need to install a new one and I decided to choose GuixSD it sounds exiting to me .
<OriansJ``>koosha_: then I congratulate you on finding your first bug
<koosha_>OriansJ``: It's the second machine that I try install guix on it and not able .
<quiliro>which scp says:
<quiliro>/home/quiliro/.guix-profile/bin/scp
<quiliro>but when i execute it, error says: bash: scp: command not found
<rekado_>koosha_: it is a different problem though.
<rain1>can you try ldd /home/quiliro/.guix-profile/bin/scp
<rekado_>koosha_: for some reason Guix wants to build grub, and it won’t build.
<rain1>what does it say?
<koosha_>rekado_: But I do think easier to solve than the previous .
<koosha_>rekado_: Also qemu
<rekado_>well, it’s because of grub that qemu is needed, and the tests for qemu appear to fail.
<koosha_>rekado_: Oh
<rekado_>koosha_: you aren’t doing this inside of a virtual machine, are you?
<koosha_>rekado_: No
<rekado_>ok
<rekado_>quiliro: are you scp’ing to a remote machine running GuixSD?
<quiliro>rekado_: yes...both use guixsd
<quiliro>one is lightweight-desktop.scm and the othe bare-bones.scm
<kaiha>quiliro: both ends need scp installed
<rekado_>quiliro: you may need to install scp as part of the system profile on both machines.
<quiliro>openssh is installed in both
<quiliro>i will recheck
<reepca>Hm, icecat's "secure connection failed" messages are mounting up... anyone else get "SEC_ERROR_OCSP_OLD_REDSPONSE" on trying to connect to https://phoronix.com?
<quiliro>for the root user, right?
<reepca>s/REDSPONSE/RESPONSE
<quiliro>user quiliro has openssh
<quiliro>but root not
<quiliro>root doesn-t
<rekado_>quiliro: I added openssh to my system configs.
***krkini is now known as kini
<quiliro>emacs
<OriansJ``>quiliro: yes that is the name of a program that can be installed on most gnu/linux distros
<rekado_>quiliro: wrong buffer? ;)
<quiliro>i mean to write /j #emacs
<quiliro>haha
<quiliro>sorry
<quiliro>OriansJ``: that is a very ample description...i would say it is the name of a very versatile text editor that integrates all user operations eficiently...as i have been told
<quiliro>it can be installed in almost all operating systems, including GNU
<quiliro>of course
<rekado_>quiliro: here’s my take: https://elephly.net/posts/2016-02-14-ilovefs-emacs.html
<koosha_>rekado_: Should I run "guix pull" before "guix system init" ?
<rekado_>this week is rough as far as substitutes are concerned
<rekado_>usually I would recommend running “guix pull” before init.
<rekado_>but these past days I’ve been struggling to get substitutes for many things
<rekado_>not fun
<rekado_>koosha_: that may work for you but you may just as likely end up having to build a lot of *other* things from source.
<rekado_>hard to tell at this point
<rekado_>we’re trying to increase the CPU power of our build farm
<rekado_>but this will take some time.
<rekado_>ACTION –> zzzZZ
<espectalll>Hmm, how do I know if Hydra substitutes are ready?
<koosha_>rekado_: It sounds this new version is more buggy , not ?
<espectalll>If I want to install GuixSD on the metal, I need to know that it won't take all day