IRC channel logs

2017-05-19.log

back to list of logs

<OriansJ>janneke: just a thought, wouldn't your compiler be simpler if you took the really easy way out for binary file generation?
<rain1>where can i learn about thsi compiler
<OriansJ>rain1: https://gitlab.com/janneke/mes
<OriansJ>He is writing a C compiler in Lisp
<rain1>thank you
<OriansJ>The easy way out was implemented in my stage0 https://savannah.nongnu.org/projects/stage0/ So instead of calculating the jumps, displacements and smaller details simply output label Hex like I did here http://git.savannah.nongnu.org/cgit/stage0.git/tree/stage1/stage1_assembler-2.hex2
<OriansJ>And as you can see here: http://git.savannah.nongnu.org/cgit/stage0.git/tree/stage1/High_level_prototypes/stage1_assembler-2.c it is a rather trivial and fast program for playing a linker
<Apteryx>Q: search-paths are useless at build time, right?
<Apteryx>(because they seem to depend on a profile, which I heard doesn't exist at build time)
<Apteryx>A: Yes.
<Apteryx>;)
<Apteryx>Oh, not so fast; search-paths are also used by the build systems.
<janneke>OriansJ: simplify compiler, easy way out -- that sounds great! :-) I'll have a look at your label/stage0 assembler solution, thanks!!!
<Apteryx>And I know the profile builder would look at search-paths to build for example the python library in the profile, but this is because we define a PYTHONPATH search-path. I don't see an EMACSLOADPATH defined anywhere.
<Apteryx>Please correct me if I'm wrong.
<rekado>Apteryx emacs-build-system defines %install-prefix and uses that as the argument to emacs-byte-compile-directory.
<Apteryx>rekado: OK! Thank you :)
<Apteryx>rekado: And how does those out/%install-suffix/elpa-version-name folders end up in our profile? Does the profile build simply create the union of everything? (every out/share folder would be recursively joined for example?)
<Apteryx>Looks like it would be handled by a function named union-build?
<rekado>Apteryx that’s right.
<catonano>git.savannah.gnu.org is down
<catonano>overpass-turbo.eu is down too. With the same error
<rekado>I can access it just fine
<rekado>e.g. http://git.savannah.gnu.org/cgit/guix/bootstrappable.git/
<catonano>I can't
<catonano>mastodon.social too
<catonano>SEC_ERROR_OCSP_SERVER_ERROR
<rekado>have you tried a different browser, e.g. epiphany?
<rekado>ACTION has to go
<civodul>Hello Guix!
<mekeor>Hello civodul :)
<snape>I haven't been able to watch a movie recently without my computer (X200 libreboot) to freeze for about 30 seconds and then reboot. Has anyone experienced the same thing? Linux 4.11.0, VLC and mpv
<snape>linux-libre, I mean
<Petter>With VLC I get sound but no video at the moment. MPV works fine though. On X200 Libreboot.
<snape>I forgot to say the freeze/reboot may happens once or twice in the same movie, not more
<civodul>that didn't happen with older kernels?
<civodul>i think rekado had problems on an X200 recently
<snape>that didn't happen with older kernels
<civodul>does /var/log/messages have any hints?
<snape>there is the reboot trace, but it starts with [0.000000] and there is nothing before
<snape>And I can't see anything weird in that reboot trace
<civodul>annoying
<rekado>ACTION is back
<rekado>snape: I have no problems watching a movie on my x200 with libreboot
<rekado>I have other problems but I’m certain they are due to failing hardware.
<rekado>ACTION built jgit – last Java dependency of the Axoloti patcher
<snape>ok, thanks rekado. I'll update my system and if the problem is still there I'll report a bug
<rekado>about the logs: is there something we need to do to ensure that old logs are kept?
<rekado>there’s a problem with script/guix
<rekado>say we have a globally installed Guix
<rekado>that script will check the user’s .config/guix/latest symlink and load modules from there.
<rekado>if a user did ‘guix pull’ then that symlink will point to Guile 2.2 modules.
<rekado>the globally installed Guix script, however, will still run with Guile 2.0
<rekado>this results in a crash.
<reepca>rekado: in my case running /usr/local/bin/guix manually (foreign distro, ubuntu) to do "guix package -s hello", *lot* of warnings / errors but no crash.
<rekado>I realize that the problem here is not with Guix but with the way this was deployed.
<rekado>there’s no good reason to have a global, shared installation of Guix when users have their own Guix anyway.
<rekado>reepca: what warnings do you get?
<rekado>reepca: where does that /usr/local/bin/guix come from?
<reepca>;;; WARNING: loading compiled file /home/reepca/.config/guix/latest/gnu/packages/wdiff.go failed:
<reepca>;;; ERROR: In procedure make_objcode_from_file: bad header on object file: "\\x7fELF\\x02\\x01\\x01�\\x00\\x00\\x00\\x00\\x00\\x00\\x00\\x00"
<reepca>
<reepca>the /usr/local/bin/guix comes from the binary install instructions
<rekado>reepca: this means that Guile 2.0 tries to load Guile 2.2 objects.
<rekado>reepca: if /usr/local/bin/guix was installed by running ‘sudo make install’… then you may want to overwrite it.
<rekado>you can get rid of these errors by replacing the installed Guix with a newly configured one.
<rekado>or you could do without a global Guix and just use it per user.
<reepca>hm, according to the install instructions it's actually a link to /var/guix/profiles/per-user/root/guix-profile/bin/guix, but apparently root is still on guile 2.0. What are the requirements for "guix pull" to switch to 2.2 again?
<rekado>reepca: you would just need to ‘guix pull’ as root then.
<thomassgn>anyone else get "Error: This version of PyQt5 and the commercial version of Qt have incompatible licenses"? I have a hunch this is from jupyter or some such, but not sure how to fix. Found some forum posts about it and the "fix" is to remove the license check from the configure script...
<brendyyn>I think I don't know but a few qt5 things seem to be nonfree
<thomassgn>mm
<civodul>brendyyn: i guess the "opensource" tarball that we use contains only free code no?
<brendyyn>Uh idk, but according to parabola's blacklist.txt, it comes down to qt5-webengine bundling nonfree codecs and chromium
<civodul>oh right, our qt5 package has a snippet to remove that
<brendyyn>Looking at qt.scm... yep
<brendyyn>Looks like parabola just outright removes it
<brendyyn>But there are useful free things that depend on it, but not the nonfree bits, so Guix's way with snippet seems better.
<civodul>yeah
<civodul>hmm i'm getting a certificate error on https://gnu.org
<catonano_>civodul: I had the same a few hours ago
<catonano_>I read it was related to some Icecat caching of certificate related materials
<kmicu>ACTION still gets ‘The OCSP server suggests trying again later.’ from gnu.org.
<catonano_>I just rebooted and it went away
<civodul>hmm weird
<civodul>it doesn't seem to be going away here
<kmicu>My Conkeror must be bad at cache invalidation then (it works in Firefox) :)
<civodul>i tried both Conkeror and IceCat, to no avail
<civodul>they use the same code but a different cache, i think
<kmicu>gnu.org works in FF/qutebrowser, but not in Conkeror. I will wipe out Conkeror’s cache files b/c restarting it does not help.
<kmicu>(Yep, gnu.org works on a Conkeror with a fresh profile. Damn you cache invalidation! ( ͡~ ͜ʖ ͡°))
<catonano_>civodul: if you move the setting related to this OCSP thing, the cache will be cleaned. Then you reboot
<catonano_>preferences -> advanced -> certificates
<civodul>kmicu: so for Conkeror what's the cache directory?
<civodul>well did you rm -rf ~/.cache/conkeror.mozdev.org/ ?
<kmicu>I have tested with a fresh profile ~/.conkeror.mozdev.org/conkeror/hash.default b/c only removing ~/.cache/conkeror.mozdev.org/conkeror/hash.default had no effect.
<civodul>ok
<brendyyn>0.13 yet?
<kmicu>civodul: I’m deeply sorry for confusing you: after ‘mv ~/.conkeror.mozdev.org ~/.conkeror.mozdev.org.bak’ conkeror/firefox still gives OCSP warning. I was misled by gnu.org defaulting to http:// version. :/
<Barnsey>Hi all, am having trouble with a backtrace error. How to fix guix if it cant pull?
<civodul>Barnsey: could you paste it?
<Barnsey>civodul: https://pastebin.com/7YAn13uj
<Barnsey>version is guix (GNU Guix) 20170215.17
<Barnsey>it's running in Debian Jessie
<civodul>Barnsey: could you use paste.lisp.org for instance? pastebin.com is inaccessible over Tor
<Barnsey>ahh, thanks, I accessed it over tor, just answered the robot...
<Barnsey> http://paste.lisp.org/+7FT1
<Barnsey>civodul: ^
<civodul>Barnsey: what does "guix package -A guile.*ssh" return?
<civodul>m-o: does the error above ring a bell?
<civodul>might be related to #26987
<m-o>civodul: no it seems to be another issue
<civodul>ok
<Barnsey>civodul: m-o: is there a way I can safely use an alternate guix binary to pull and overcome this issue?
<civodul>ok, a pretty old guix
<civodul>hmm
<Barnsey>yes, been a while since I updated this box...
<civodul>could you try:
<civodul>guix pull --url=https://git.savannah.gnu.org/cgit/guix.git/snapshot/75c260ba5ae7baec44d2b5bf6ae57734eeebcd2f.tar.gz
<civodul>Barnsey: ↑
<civodul>this will upgrade to an older commit
<civodul>from May 9
<Barnsey>civodul: ERROR: X.509 certificate of 'git.savannah.gnu.org' could not be verified
<civodul>Barnsey: try "http" instead of "https" for now
<Barnsey>backtrace
<Barnsey>civodul: ^
<rain1>janneke[cm]2: hello
<Barnsey>how about downloading the binary distribution and overlaying it on my existing files? will that work?
<Barnsey>hi janneke[cm]2
<janneke[cm]2>hi rain1
<Barnsey>oops, sorry rain1 ...
<rain1>hello
<rain1>I watched your talk about mes and I have looked at the hex assmbler too. this is really good!
<janneke[cm]2>rain1 thanks
<janneke[cm]2>yes, mescc needs to learn from the OriansJ's stage0
<rain1>I wrote a self hosting scheme compiler producing bytecode and a VM in C to run it maybe something of this can be useful
<civodul>Barnsey: sorry for the delay; what backtrace did you get?
<Barnsey>civodul: no problem, had to pop out myself... looks to be the same error as before.
<civodul>Barnsey: it can't be the same error as before since we took httpS out of the loop, no?
<Barnsey>civodul: sorry, I meant same as original paste
<civodul>hmm
<Barnsey>civodul: http://paste.lisp.org/+7FT7
<civodul>i don't see what's happening
<civodul>weird
<civodul>anyone else willing to do some bug-fixing? :-)
<janneke[cm]2>rain1 wow! yes...mes is a scheme interpreter, we need to go to compilation some time
<rain1>ok , maybe we can talk about it some time :)
<rain1>i am just reading both code bases to understand whats been already done better
<janneke[cm]2>yes, we need to get OriansJ involved too!
<janneke[cm]2>great!
<rain1>:D
<civodul>can anyone reproduce this guile-ssh-related crash? https://debbugs.gnu.org/cgi/bugreport.cgi?bug=26976#19
<civodul>perhaps with "guix copy"
***andreh1 is now known as andreh
<rain1>what guix copy command should i try?
<civodul>say "guix copy --to=somemachine.example.org guile"
<brendyyn>doesn't seem to support password login
<civodul>with the latest 'guix' package
<rain1>oh, i need ssh access to a second guix machine to test this
<civodul>brendyyn: yeah i think it tries the agent and then public key
<civodul>rain1: could be localhost actually
<brendyyn>well I'd do it if I knew how to setup the key
<rain1>I guess you use ssh-keygen
<brendyyn>ERROR: ERROR: Throw to key `node-repl-error' with args `("Evaluation failed" "scheme@(guile-user)> While compiling expression:\\nERROR: no code for module (guix)" ())'.
<quiliro>i have spent 20 hours installing the base system on a 64 bit celeron D
<quiliro>and it is not through yet
<quiliro>i have a guix installation on debian
<rain1>yeah i started installing ssh about 30 mins ago, just waiting for it..
<quiliro>is there a way to download on this debian the repos for offline installation?
<quiliro>maybe installing ngnix mirror
<quiliro>but how?
<bavier>quiliro: the base install is taking that long?
<quiliro>bavier: yes
<quiliro>bavier: i had to use --fallback
<bavier>quiliro: similar to the "base bones" example?
<bavier>s/base/bare/
<retard>What should my config.scm look like for the quickest install possible?
<bavier>retard: something like the bare-bones config
<bavier>doesn't have X, or a DE
<retard>What kind of install time should I be expecting? I'm going on day two now..
<quiliro>bavier: yes....did not add anything
<bavier>retard: depends on a lot of things, especially whether substitutes are available
<retard> bavier: ok, so 2 days isn't an unusual time?
<retard>I just wish I could verify if I was stuck in a loop or something, if that makes sense
<brendyyn>retard: Is there output?
<bavier>retard: loops shouldn't happen, but if you're building packages locally it could take a while depending on your machine's resources
<brendyyn>Often I'd find guix had stopped but not properly fallen back and showed the command prompt untill I pressed C-c
<retard>Yes there's a constant stream of output, and yeah my machine is an oldie with limited resources, so I suppose I shouldn't be worried?
<brendyyn>Na as long as it's doing stuff then it's working
<retard>Oh you can just press C-c to fall back?
<retard>don't have to type previous command --fallback?
<brendyyn>to cancel it I mean
<retard>Oh, I see
<brendyyn>what is it compiling atm?
<retard>"Libraries have been installed to.."
<retard>and a bunch of /gnu/store/.. stuff
<retard>but it;s going fast
<retard>my guixSD install is running a performance test, might that imply it's almost done with the install?
<jlicht>hello guix
<bavier>retard: Guix itself doesn't do any performance tests, but a package might
<bavier>hello jlicht
<jlicht>o/
<catonano>what is "o/" exactly ?
<ng0>fyeah.. I just solved my scrotwm problem. Now I have to wait a very long time to test it because I just cleaned out my store.
<ng0>is someone interested in testing it?
<ng0>sorry, not scrotwm.. spectrwm. I used it back when it was still called scrotwm, with its first release
<retard>Is there anyway to pause an install and save it's state to resume it later?
<jlicht>catonano: it seems to be a person raising their arm, as a gesture of greeting someone. Sadly, this person lost their hand in a terrible accident when they were younger :(
<jlicht>;)
<jlicht>great news on the npm dataset by the way!
<catonano>jlicht: yeah, I was stunned !
<ng0>I would test it, but I still have 500.000 of 700.000 emails to move to a new format.. takes some time.
<ng0>ah, damn... we have guix vm. I can do it.
<retard>So no way to interupt an install without totally starting over, right?
<quiliro>hello again
<bavier>retard: if you interrupt an install, the /gnu/store contents are still there, you just lose whatever progress has been made on the current package build
<retard>Oh, awesome. So then upon reboot, I would just run the "guix system init /mnt/etc/config.scm /mnt" command once more to continue after rebooting?
<retard>bavier: Oh, awesome. So then upon reboot, I would just run the "guix system init /mnt/etc/config.scm /mnt" command once more to continue after rebooting?
<quiliro>retard: yes
<retard>ok, thanks. Sorry for spamming, tight on time :)
<bavier>hmm, didn't know retard wanted to reboot. might not work as expected.
<help_vampire>taohansen: would you like me to post my config.scm to github?
<SovereignBleak>Hey that's me. Yeah post it as a gist.
<SovereignBleak>help_vampire:
<help_vampire>SovereignBleak: A gist?
<SovereignBleak> https://gist.github.com/
<SovereignBleak>Here's mine which should get you into an i3 and StumpWM environment.
<SovereignBleak>As in, you can choose which.
<SovereignBleak>Total time to build was ~30 minutes?
<help_vampire>SovereignBleak: Ok, one sec. I'm going to restart my install since I messed up the partitions, so all I have right now is my ideal template: https://gist.github.com/nofawkesgiven/b948d5a6eef2ab055b83c99cdcfc1ee0
<SovereignBleak> https://gist.github.com/taohansen/c5059ff0b1014e7ee07f8e83fc59fc66
<SovereignBleak>ng0: If you have time can you take a look at help_vampire's config.scm? He's doing a first time build of GuixSD and it takes *forever* so he bailed out.
<help_vampire>So the only changes I would make to it would be to change the bootloader to /sda/, get my encypted device uuid, and that's about it right?
<help_vampire>Aside from silly changes like username and such
<help_vampire>is my "target" correct in the mapped-device function?
<SovereignBleak>Looking at it, one sec.
<SovereignBleak>Man I am so outclassed for this right now it's hilarious. Still looking, give me asec.
<help_vampire>Also, what kind of partition scheme would you recommend for an aspiring dual booter?
<quiliro> (bootloader (grub-configuration (device "/dev/sdX")))
<quiliro>help_vampire: device?
<help_vampire>I updated it to sda
<help_vampire>I just copied and pasted templates real quick, I also still need to get encrypted device UUID
<quiliro>help_vampire: did you create the partition with label my-root?
<help_vampire>yes, just like the guide said
<SovereignBleak>Oh thank God someone comes in to save the day. Thanks quiliro!
<help_vampire>I'm going to be restarting and partitioning from scratch though, I messed up my partitons so it's all fair game atm
<help_vampire>Lol :)
<SovereignBleak>Alright I'm going back to watching the last episode of The Expanse. I've never used an encrypted partition scheme before and your config otherwise looks in line with my own. The best I could offer is to remove all the window managers but one (like i3-wm) and see if that mitigates your initial build time. Ping me if for some reason everyone else here far more
<SovereignBleak>qualified gets sucked into a void or something.
<quiliro>help_vampire: i suggest you define you swap too
<quiliro>it is in the manual
<quiliro>i did not do it
<help_vampire>label swap something like my-swap?
<quiliro>i have been suggested to use a bare-bones config.scm initially
<quiliro>then reconfigure with more
<rain1>i had some problems with lsh, it says no seed available but i just created one
<quiliro>i don't know...never done swap....but i suppose it is correct...test it
<quiliro>or leave it for guix system reconfigure
<quiliro>help_vampire: ^
<help_vampire>oh, thanks for ping. The only reason I'm wanting to avoid doing barebones then adding stuff later is because I wanted full disk encryption, and I'm unsure how that might affect (..effect?) things.
<help_vampire>quiliro:
<quiliro>help_vampire: oh...good point...i don't know about disk encryption either
<quiliro>but i don't think it would be affected
<help_vampire>Lol, maybe I'll abondon that idea for now then :)
<quiliro>no!
<quiliro>by breaking...we learn
<quiliro>help_vampire: ^
<help_vampire>quiliro: Ok, or not! Yeah, you're right. I'm also not sure how I should be partitioning my machine, which is BIOS. I just went dev/sda1 root, sda2 home, sda3 swap.. I don't know if I needed boot or not, for some reason I thought BIOS didn't
<quiliro>you do not need /boot
<help_vampire>Oh, perfect. Then I don't need to restart :) I am installing a very barebones right now, no ecnryption, just to see how things go. From what I've been told it shouldn't take more than an hour.
<quiliro>you do not need swap either
<quiliro>but it is good for hybernation
<quiliro>i think
<help_vampire>My computer only has 1G of RAM though, so I'm scared not to have it. I suppose if swap complicates things I could not do it next time around though
<help_vampire>quiliro: ^, and another question: in my .scm file, is the "target" correctly named? My root partition is name my-root, not "the-root-device"
<help_vampire>quiliro: and thanks for all the help
<help_vampire>!
<quiliro>help_vampire: it will take a lot of time
<quiliro>i have been here 24 hours with a celeron D machine
<quiliro>help_vampire: type: fdisk -l /dev/sda
<quiliro>on another console
<quiliro>and check the target name is correct (the label of the partition)
<quiliro>i have no experience with swap yet
<help_vampire>quiliro: Perhaps I was too impatient initially. What I did this time around though was insert the hard drvie I'm installing the OS on into a desktop, since it has better specs
<quiliro>help_vampire: perfect
<help_vampire>fdisk -l /dev/sda to see what the partitions are named?
<quiliro>but if no binaries are avaliable, it will take a lot of compile time too....not as much but not as installing debian!
<quiliro>help_vampire: yes
<help_vampire>quiliro: and the partition name should match the arguement of target in my .scm file? I know you haven't done the encryption route yet, but maybe you know this
<help_vampire>I just hope when I do encrypt that my mapped devices function is correct
<quiliro>help_vampire: i don't know if that affects the encryption....but i know target is supposed to be the label name.....but have uuid too...so i don't know if you need both...check an example scm with encryption...there must be in the manual
<destt>I've done the totally impractical and installed guix on the C.H.I.P. Pro
<quiliro>you can use another machine to install....all you have to do (if you do not specify another architecture) is make sure both machines are 32bit or 64 bit
<help_vampire>quiliro: will do, thanks. All of my intuition tells me it should be the same as what I set the root partition label too, but I trust that the guide wouldn't add unnecassary confusion as well.
<quiliro>what is the the C.H.I.P. Pro
<help_vampire>a single board computer
<quiliro>oh!
<quiliro>is it amd/intel 64 bit?
<bavier>destt: cool!
<destt>No, it's running arm
<help_vampire>damn
<help_vampire>nice
<destt>It's on top of a debian system
<destt>I'd like to figure out a way to get GuixSD running directly on it, but I have no idea how to compile linux
<quiliro>oh...guixsd has arm support?
<destt>no, it doesn't :(
<quiliro>oh
<quiliro>so you have to make the necesary scm files
<quiliro>guix will compile them
<bavier>quiliro: guix support arm packages, but guixsd cannot boot directly on arm, yet
<quiliro>them=the software
<quiliro>oh!
<quiliro>that is good news
<bavier>quiliro: so you can install guix as a package manager on top another distribution there
<quiliro>tru
<quiliro>e
<destt>Yeah, which is what I am doing
<destt>although I would like to help get GuixSD running on the CHIP pro
<quiliro>how about the beaglebone black?
<quiliro>will guix work the same way?
<bavier>destt: some others have been working on uboot support for guixsd
<destt>bavier: that is good to hear
<bavier>destt: your help would of course be appreciated :)
<help_vampire>I'm getting a hash error, where a package should have a different hash then it does. How might I work around this to continue install?
<destt>I would love to help!
<destt>...but I don't really know what I'm doing
<destt>!
<quiliro>help_vampire: you shouldn't get a hash error
<quiliro>that would mean the file you downloaded is not as was expected
<help_vampire>Yeah..
<quiliro>help_vampire: did the installation stop?
<quiliro>just start again...it will continue from there
<quiliro>where it left off
<civodul>help_vampire: could you paste the error to paste.lisp.org?
<quiliro>as long as (i think) you do not reboot
<help_vampire>yes, it tells me the sha256 has should've been something other than what it ws, then list a bunch of cannot build derivations "gnu/store/... : 1 dependcies couldn't be built, then at the bottom says guix system error: build failed then the package
<help_vampire>civodul: Is there a faster way to paste the error than typing every character? Would a picture of the screen work?
<help_vampire>Can't screenshot obviously since OS isn't installed yet
<civodul>help_vampire: sure, a picture is fine
<catern>hey #guix, I see that Nix has a mirror for source tarballs https://github.com/NixOS/nixos-org-configurations/blob/master/nixos-org/tarball-mirror.nix
<catern>is there one for Guix?
<catern>well, let me rephrase
<catern>are there substitutes for tarballs?
<catern>for all tarballs?
<civodul>catern: we have a content-addressed mirror via 'guix publish': https://www.gnu.org/software/guix/manual/html_node/Invoking-guix-publish.html
<civodul>nicer than copy-tarballs.pl if you ask me ;-)
<catern>but does it cover all tarballs?
<catern>the reason I ask is because I have a box which has restricted internet access - HTTP and HTTPS only - FTP not included
<civodul>it covers all the tarballs available the machine that runs it
<civodul>so hydra.gnu.org runs it, but eventually some of the tarballs get GC'd
<civodul>then mirror.hydra.gnu.org mirrors hydra.gnu.org and has more disk space
<catern>so that box could only get those tarballs through substitutes (or some other mirroring)
<civodul>which box?
<catern>my box
<catern>sorry, my box could only get tarballs accessible only through FTP, through substitutes
<civodul>if you use --no-substitutes, it'll try to fetch tarballs from upstream, and then from hydra.gnu.org
<catern>so I want to see if I can get some kind of certainty that it will be able to do so
<civodul>over ftp? no
<civodul>the c-a mirror is over http
<civodul>as shown in https://www.gnu.org/software/guix/manual/html_node/Invoking-guix-publish.html
<civodul>does that make sense?
<catern>ah, sorry, I have spoken confusingly I guess
<help_vampire>is there a command for an uninstalled GuixSD system to screenshot?
<help_vampire>civodul: ^, I'm trying to find a way to accurately submit the text
<catern>I have some box A which is behind a firewall, which only allows outbound HTTP and HTTPS connections. therefore box A is not able to directly access any source which is hosted with FTP.
<catern>fortunately, hydra.gnu.org is accessible over HTTP, so my box A can get any tarballs which would otherwise require use of FTP, from hydra.gnu.org
<civodul>catern: ok got it :-) so in that case it will fall back to http://hydra.gnu.org/file/...
<civodul>so that *should* be fine
<civodul>now there's always a risk that one file or another won't be available
<catern>yeah, that's what I'm worried about, and wondering if there's anything I could do
<catern>(I'm worried about the risk that a file will not be available)
<civodul>we can't give you a 100% guarantee
<civodul>also, some things are available over Git, svn, etc.
<civodul>and these are not mirrored
<civodul>well, they are mirrored as substitutes, but not in the content-addressed thing
<catern>oh no :(
<catern>could I set up my own mirror which did mirror those?
<catern>are those kind of packages very common?
<civodul>not very common
<civodul>i think the only way to know how well it would work is to give it a try :-)
<catern>okay :)
<rain1>hmm.. i cant run guix system reconfigure, tried many times with --fallback flag and its always failing
<civodul>rain1: could you paste the error message?
<civodul>it's most likely a problem with our substitute server
<OriansJ>janneke: I've seen rain1's work and I honestly feel that it could be the very thing we need to help bridge our projects.
<rain1>sorry I had restarted it and it scrolled the error off my screen, I am rerunning to get the error message. it takes a while
<civodul>ok
<civodul>sneek: seen mark_weaver
<sneek>I last saw mark_weaver on Jan 13 at 04:29 am UTC, saying: :).
<rain1> http://i.imgur.com/GHAmBAv.png i had t tak e ascreenshot because I cant install curl