IRC channel logs

2017-05-15.log

back to list of logs

<mekeor>civodul: do you know Matrix? (https://matrix.org/)
<DoublePlusGood23>How would I change the dir where a build-system looks for the configure script and whatnot
<lfam>DoublePlusGood23: Depends on the specifics
<lfam>Like, which build system? What's whatnot?
<lfam>Sometimes, you have to chdir or use with-directory-excursion. Other times, you can pass '--directory=...' to make
<DoublePlusGood23>lfam: it's not in the root of the archive
<DoublePlusGood23>gnu-build-system.
<lfam>If all the build system stuff is not in the root of the archive, then you'll probably need to chdir
<DoublePlusGood23>lfam: would I add another phase and a short lambda?
<lfam>Yes, I'd add it before the configure phase
<lfam>If you grep in gnu/packages for 'chdir' you should find some examples
<DoublePlusGood23>lfam: thanks :-)
<DoublePlusGood23>C-s worked for examples :p
<civodul>mekeor: no i didn't
<Apteryx>Wow, guile is using 1.4 gb of ram to build Guix!
<brendyyn>Apteryx: Probably wingo's super wiz-bang optimisation compiler
<Apteryx>:)
<Apteryx>Have we transitionned to build Guix with Guile 2.2 already?
<brendyyn>Apteryx: yep
<Apteryx>OK, that explains it :)
<brendyyn>Hey it's not much of an explanation
<Apteryx>After clearing the go files, and rerunnning ./bootstrap, ./configure --localstatedir=/var and make -j (successfully), when I attempt to run Guix from my git checkout I get errros such as: ERROR: In procedure make_objcode_from_file: bad header on object file: "\\x7fELF\\x02\\x01\\x01�\\x00\\x00\\x00\\x00\\x00\\x00\\x00\\x00". What gives?
<brendyyn>Apteryx: Yeah I had that too, that's guile 2.0 complaining about guile 2.2 .go files I think
<brendyyn>I think you have to fully upgrade your roots guix profile and then restart the updated guix-daemon
<brendyyn>It means you're basically 90% of the way to upgrading to guile 2.2
<Apteryx>brendyyn: Oh. I see. I should 'guix system reconfigure' and reboot I guess.
<brendyyn>Apteryx: Sure. I'm not on GuixSD yet so I haven't done that before
<Apteryx>brendyyn: That's what takes care of updating the guix-daemon. My root profile points to my user profile, so that's not it.
<Apteryx>Doing it right now. I hope to get some speed bost from the substitute servers this time around ;)
<brendyyn>I've got another laptop I've installed GuixSD on. It's going to take a week of compiling to upgrade from 0.12 to the latest revision at this point
<Apteryx>brendyyn: Eh! Been there, done that ;)
<paroneayea>ha
<paroneayea>lfam: I was looking with kind of some irritation at https://twitter.com/Pinboard/status/863885423327752192
<slyfox>why do you need to compile things?
<slyfox>doesn't hydra contain all the binaries?
<OriansJ>janneke: Why would it be alot of work? We simply leverage the MES C compiler have have working and simply swap out its parser to read S-expressions instead of C code
<Apteryx>slyfox: Unfortunately, no.
<paroneayea>I'm very tempted to point them at rekado's bootstrappable.org site
<Apteryx>Maybe you should.
<Apteryx>Could someone remind me how to define a udev rule in my config.scm? rekado showed me a snippet that did just that once, but I can't find it anymore...
<reepca>Apteryx: it looks like there might be what you're looking for in 6.2.15.2 of the manual, but I haven't read much about services yet so am not sure.
<Apteryx>reepca: Which node is that? I believe I'm using the manual from guix master (git), so it doesn't match the one online.
<reepca>GNU Distribution -> system configuration -> defining services -> service types and services
<Apteryx>reepca: OK. The node matches after all. It's just my lack of info navigation skills ;) Thanks!
<reepca>C-s searching through higher levels if you mash it enough is perhaps the best part about using Info in Emacs
<Apteryx>reepca: Right, I had not realise even the chapter numbering could be found that way!
<Apteryx>realized*
<DoublePlusGood23>reepca: woah that's brillant
<brendyyn>I always just looked up the manual In icecat since I coudn't get my head around info ;<
<Apteryx>brendyyn: I actually started digging info with Guix :). It's much better than manpages after getting used to.
<brendyyn>Apteryx: I've been trying to transition more to Emacs. I'm pretty good with magit now expect for merge conflicts I just throw my computer out the window when that happens
<Apteryx>brendyyn: Merge conflicts are always tricky. But ediff is awesome. Just press 'e' in magit to fire it up next time you have conflicting hunks. You'll want to know the '?' key to get the online help.
<brendyyn>I have gnus half set up but the nnmail-split-method doesn't work for me. I tried filtering ("mail.Guix" ".*@(.*)?gnu.org") and ("mail.gmailcrap" "^To.*brendan.tildesley@gmail.com") etc but It doesn't work properly. Some of guix-patches things end up in mail.Guix, mail.junk, mail
<brendyyn>So I'm still using icedove but that's really tedious to send patches with
<brendyyn>mail.misc, bogus i mean
<DoublePlusGood23>brendyyn: I use `git send-email`
<brendyyn>How do you set that up?
<DoublePlusGood23>brendyyn: according to my browser history I just used the docs https://git-scm.com/docs/git-send-email#_example
<reepca>agh, what's the proper triple to specify for cross-building for windows with mingw-w64? According to http://stackoverflow.com/questions/10493297/how-to-use-mingw-w64-with-cygwin it should be x86_64-w64-mingw32, but I get "guix pack: error: could not find bootstrap binary 'tar' for system 'x86_64-w64-mingw32'" on trying to pack stuff with that system specified with --system
<Apteryx>reepca: After 1 hour staring at the code I'm starting to know what to do. There's a udev-rule function I can use to define my personal udev-rule (two components: file name and actual rule as string). It returns a gexp (which means a file in the store) with the file name and its content under /gnu/store/???-some-gexp-name/lib/udev/rules.d/file-name. After that is defined I can cons my rule instance to the rules
<Apteryx>field of the udev-service object. This udev-service is part of %base-services which is part of %desktop-services so I can use `modify-services' on that
<Apteryx>brendyyn: I split list emails based on Return-Path. My split method is as follow: ("list.\\\\1" "^Return-Path: <\\\\(.*\\\\)-bounces.*@gnu.org>")
<brendyyn>Return-Path? I've never seen that in an email header before.
<Apteryx>brendyyn: It's the most correct way. I want email addressed with my email in the "To:" or "CC:" fields to come back to my Inbox; that helps with my reply times.
<Apteryx>The rest can go to folders where they'll accumulate until I have time to process it.
<Apteryx>brendyyn: The information I found useful to understand this was http://david.woodhou.se/reply-to-list.html
***Piece_Maker is now known as Acou_Bass
***orly_owl_ is now known as orly_owl
<reepca>--system=x86_64-linux-gnu also fails with a similar message... which is weird, because that's the system I'm on right now.
<DoublePlusGood23>more patches emailed. added libzen, libmediainfo and mediainfo the actual program
<Digit>ACTION in r&r, enthralled by https://media.libreplanet.org/u/libreplanet/m/the-lisp-machine-and-gnu/
<Apteryx>On GuixSD, do we have an equivalent group for "plugdev"? Or, should I just add my user to this group in my system definition? I'm trying to get adb to talk with an android device.
<Apteryx>Digit: r&r meaning?
<Digit>rest & relaxation ; recreation & recouperation ; recovery & rollocking. idk, mix n match, make your own. i think there is an original, but who can remember with all the backronyms.
<Apteryx>Thanks for the definition(s)!
<Apteryx>I was thinking rock & rolling, but that didn't really fit with the rest.
<Digit>i think its etymological roots are in usa military parlance, or at least hollywood's representation thereof.
<efraim> https://en.m.wikipedia.org/wiki/R%26R
<brendyyn>Anyone running wayland on Guix yet?
<Digit>i hate to bring up this dangerous idea, but... a lot of the good points about live extensibility, in that lisp talk, got me thinking the enlightenment wm/de/thing, it's kinda like that... now if only it were lisp. someone (with more skill than me) should rewrite enlightenment in lisp. ... maybe put clfswm at the heart of it, and then all that lovely existing enlightenment extensibility would be more pleasant on the eye, in lisp. ^_^
<Digit>n would go further. powerful combinations, alight my sleepy head... i'll be quiet now. zzz
<brendyyn>I still haven't really found a use for enlightement, apart from the fact that I use terminology.
<brendyyn>and some blog posts just say that Qt's QML is just as good anyway
<Digit>brendyyn: heh, tbh, that's all i use of it too, just terminology term. started theming it, got past aversion to its aparant heavy handedness for simple stuff. but turns out not as bad as i thought. expedites the user into a more empowered place, to start making their own gui even. that much seemed in same spirit as lisp machines n emacs n guix.
<janneke>efraim: I gave mes 0.6 a bit of arm love, it now fails where it should: when gcc reaches x86 asm instructions
<efraim>Fun :)
<Apteryx>Hmm. FAIL: grub_cmd_set_date
<brendyyn>The problem with being able to install multiple versions of packages is that all of a sudden you start installing heaps of different versions of them. I've got 4 or 5 versions of guile now
<reepca>Anyone else unable to cross-compile with guix pack?
<Apteryx>reepca: I'm sorry, I've never experimented with guix pack yet. Hopefully someone more knowledgeable can cheer in (civodul wrote the thing ;)
<reepca>Huh. So apparently --system in guix pack means "the system being built on", and --target means "the system being built for". From looking at the documentation I thought they both seemed like the same thing. Also i686-mingw works, x86_64-mingw doesn't, although from looking at bootstrap.scm I'd guess they both use the same linker.
<rekado>I may have to revive icedtea 1.13.13.
<rekado>there simply is no other JDK that can build icedtea 2 or 3.
<rekado>I tried jamvm with the development version of GNU classpath and ecj, but even the current development version of classpath doesn’t support Java 1.7.
<efraim>I guess you could not make it public?
<rekado>yes, that’s the plan
<rekado>I could also add a property to hide it.
<rekado>it’s a bit unfortunate that the bootstrap chain is longer than I hoped for.
<rekado>I also needed to rebuild jamvm and classpath multiple times to get rid of a dependency on the old sablevm.
<rekado>not doing this causes three different versions of classpath to be available at the time we build icedtea 1.
<rekado>one from sablevm, another is classpath 0.99 (used to build jamvm), and finally the dev version of classpath.
<reepca>So I'm in the process of packing some stuff for my brother's windows machine, and now it's downloading 2.39GB of texlive. Phew! I suppose that's for compiling the documentation?
<efraim>Tex is ginormous
<rekado>reepca: we’re currently getting the complete texlive distribution as one big blob. It’s on my list to break this up, but I haven’t gotten around to it yet.
<rekado>hmm, looks like it’s no longer possible to download the sources for the old openjdk 6.
<rekado>indeed, the java.net site has been shut down
<efraim>Debian mirrors to the rescue?
<rekado>I’ll try to get the files via mercurial
<efraim>Thinking out loud, one way to make TeX less painful would be to have a TeX-source package that takes the giant tarball and splits it into multiple outputs, each of which could be used independently to build parts of TeX
<efraim>Which is the GNOME release that is ABI stable?
<rekado>my boss would like someone to come up with a response to this blog post about conda: http://lh3.github.io/2015/12/07/bioconda-the-best-package-manager-so-far/
<rekado>the only downside Guix has compared to conda is that it needs root permissions for the daemon.
<rekado>the downsides of Conda are many, the most important being: no reproducibility
<roelj>rekado: Maybe we can work together on a response? The first paragraph in "Why conda?" already implies that it isn't reproducible without human involvement.
<rekado>yeah
<rekado>roelj: do you want to start with a draft?
<roelj>rekado: Sure
<rekado>excellent!
<civodul>Hello Guix!
<civodul>ACTION sees the compile-all.scm process above 1.5G resident on a 32-core machine :-/
<rekado>I ran out of memory on my machine.
<brendyyn>Greetings
<rekado>had to abort it and rerun make
<brendyyn>Seems like there is much work to do with GNOME integration. the change language settings are empty. What's up with that?
<wingo>brendyyn: i am not sure. you might have to look in source code and/or strace the config app
<fps>is there a bash version 4.4.A?
<fps> https://pastebin.com/TSxWhzJq\\
<fps>oops, remove the trailing backslash
<reepca>bleh, having trouble getting guix pack to build stuff for windows. SBCL fails because a name-path pair for "bash" (and possibly others) isn't getting passed to the build phases as inputs, and bash fails because of complaints about "./config.h:353:19: error: two or more data types in declaration specifiers", which some searching suggests might be a missing semicolon of all things. Anyone have experience cross-packing for windows?
<brendyyn>quite a lot of 'no such file or directory'
<brendyyn>how does one set fallback locales in Guix?
<brendyyn>if LANG is (locale ...), what is LANGUAGE
<fps>brendyyn: is LC_ALL="C"?
<brendyyn>That's a different thing. I have:
<brendyyn>LANG=zh_TW.UTF-8
<brendyyn>LANGUAGE=zh_TW:zh_CN:zh_SG:ja_JP:en_AU:en_NZ:en_GB:en_US
<fps>LANGUAGE seems to be a gettext thing
<brendyyn>oh
<brendyyn>not for GUI's ?
<brendyyn>wingo: Maybe we can systematically loot Fedora's configuration and Guixify it?
<wingo>brendyyn: i don't know what "fedora's configuration" means in this context
<wingo>usually what needs to happen is that all gnomey things share gsettings / dconf stuff
<wingo>and maybe that's not working
<brendyyn>wingo: GNOME packages and internationalisation stuff
<wingo>yeah it could also be that we are missing some packages or something
<wingo>from the default gnome-desktop install
<brendyyn>ok well im happy to help out if i can figure out what needs to be done
<wingo>so yeah in that way that would be great to figure out what changes between releases from a system POV
<brendyyn>Do we have "enabled locales" in Guix. I'm not sure what difference it makes but that's a thing that Arch has
<brendyyn>I suppose once they are enabled one can run LANG=... foo
<wingo>yes in a way
<wingo>you can install the full glibc-locales
<wingo>or just the glibc-utf8-locales
<wingo>but generally the set of available locales depends on what the user installs to their profile
<brendyyn>civodul: 1851M RES for me at the moment
<brendyyn>x86_64
<brendyyn>OH noes, my GRUB screen stopped being pretty
<civodul>oh, could it be due to the change lfam pushed yesterday?
<civodul>this one: https://debbugs.gnu.org/cgi/bugreport.cgi?bug=26875
<civodul>brendyyn: could you email the problem to 26875@debbugs.gnu.org Cc: lfam?
<brendyyn>Sure. I assumed it was because I changed my locale to zh_TW.utf8, but that makes more sense
<brendyyn>Is there no grub log I can look at?
<dimon__>is there a way to get a list of all installed packages?
<brendyyn>dimon__: guix package -I
<wingo>that's only for your user of course
<wingo>there can be system-installed packages too
<dimon__>I've got a list with guix package --list-instaled --profile=/run/current-system/profile
<dimon__>but it seems it's also just the ones I installed
<brendyyn>Ok so my I've been specifying a --substitute-url="http://10.1.1.61:8080/ and I'm 99% sure the package I'm installing is in 10.1.1.61's store, and it does "updating list of substitutes from 'http://10.1.1.61:880/'... 100%", but then downloads it from source anyway
<brendyyn>infact since I started installing I was using it but I never saw it pull a single substitute from it
<jlicht>hi guix
<htgoebel>Somebody please review http://debbugs.gnu.org/cgi/bugreport.cgi?bug=26938.
<htgoebel>it is required for updating KDE frameworks which need to go into the next release due to security issues.
<dimon__>wingo, were's the profile for the "base" system?
<wingo>dimon__: /run/current-system/profile
<dimon__>the kernel, for example, doesn't seem to be there
<brendyyn>htgoebel: The description looks too informal
<wingo>dimon__: /run/current-system
<brendyyn>" because Word users
<wingo>dimon__: /run/current-system/kernel
<wingo>etc
<brendyyn>+usually don't care about document structure"
<htgoebel>brendyyn: What is the problem with this? It's true :-)
<civodul>the memory consumption of Guile 2.2/compile-all.scm seems to be proportional to the number of cores
<civodul>on my laptop it's fine
<htgoebel>brendyyn: The text is tken from Debian btw
<civodul>but on that 32-core machine, it takes long and consumes a lot of RAM
<brendyyn>htgoebel: Well perhaps I'm just critisizing the debian packager, but it looks like a bit of a mild insult towards Word users which isn't necessary
<brendyyn>I think the description should just provide a paragraph on what the program does and what one might use it for.
<htgoebel>brendyyn: IC. what about "word documents are rarely structured at all"?
<brendyyn>Well I had a look here
<brendyyn> https://wagner.pp.ru/~vitus/software/catdoc/
<brendyyn>"catdoc does not preserve complex word formatting, but it can translate some non-ASCII characters into TeX escape codes. It's goal is to extract plain text and allow you to read it and, probably, reformat with TeX, according to TeXnical rules"
<civodul>htgoebel: the catdoc package LGTM!
<brendyyn>htgoebel: Something like that could replace the middle paragram, perhaps?
<brendyyn>paragraph
<htgoebel>civodul: Thanks for the quick review.
<htgoebel>brendyyn:You text looks good. But where yo you get this "according to TeXnical rules" from?
<htgoebel>brendyyn: Found it – it on the home-page
<brendyyn>I just copy-pasted it. you can delete that bit
<rekado->Now that I’m almost done with the Java bootstrap I wonder: is it really better to bootstrap like this?
<rekado->we could do without GCJ, which is unmaintained, but we would depend on jikes, sablevm, sablevm-classpath, jamvm, classpath-0.99, classpath-devel, ecj-3.2.2 …
<rekado->and not least: icedtea 1.13.13.
<rekado->to be fair, though: our previous bootstrap was incomplete.
<rekado>gcj depends on a binary ECJ.
<rekado>with the new bootstrap toolchain we can build ECJ from source.with the new bootstrap toolchain we can build ECJ from source.
<rekado>so it’s only a question of whether we want to build icedtea 2 with GCJ or with icedtea 1.
<rekado>either way, there’s no way around unmaintained tools like jikes, sablevm, and so on.
<dimon__>wingo, when running guix --list-installed --profile=/run/current-system/kernel it returns nothing
<wingo>the kernel isn't a normal package, it's part of your os, not installed as part of a profile
<wingo>you have to look to whatever file defines your operating system to get more info on the kernel package i think
<wingo>dunno
<wingo>maybe there is some info that would be nice to know
<brendyyn>guile emacs doesn't build for me. says can't find libjpeg
<dimon__>are there other packages that are outside a profile as well?
<wingo>yes, a service for example can reference a package
<rekado>the shepherd is still on Guile 2.0. I’ll check if we can upgrade it.
<htgoebel>While reviewing the KDE framework 5.34 logs, I found that quite a few optional requirements are not installed. Should I put then into the update-patch or should I create a new patch (for each of the packages)?
<rekado>htgoebel: please keep them separate
<tgunb>hey guys, I installed guixsd in qemu using the lightweight template, but removed xmonad from the package list. when trying to log in as root is seems to work first(i3 told me there is no configuration file and offered me to create the default file, ratpoison showed me a notification on how to get help.), but then nothing happens. I am stuck seeing only the default background. is that a known problem from misconfiguration or so? how can I login
<tgunb>with mingetty? I tried several key-combinations. Or is mingetty by default not set up?
<snape>tgunb: what do you mean by "then nothing happens"? What do you expect to happen?
<rekado>tgunb: sounds like you already get into X, but your window manager doesn’t start
<tgunb>rakdo: yes
<snape>maybe you could check your .xsession, making sure it contains something like: exec ratpoison
<rekado>and make sure that it is executable
<snape>and make sure its shebang is a file that exists
<tgunb>snape: hmmm, you made me really considering that I'm THAT stupid. I meant, no matter what I pressed, nothing happened. but maybe, that's just the default from i3 and ratpoison: no bars, just plain background image, and since i've never used neither i3 nor ratpoison, I didn't hit the right keys for starting a terminal or something. Regarding your second text: I don't know how to switch to terminal login/ if it is even started. so i'd need to ki
<rekado>I’m in the middle of building icedtea-1.13.13 with the bootstrap toolchain, and it seems to really work :)
<tgunb>ll qemu and boot the installation system to read .xsession(; hoping everything was written to disk before I pull the plug)
<tgunb>forget the second part: I thought .xsession-errors.
<snape>tgunb: ;) With ratpoison you can type 'C-t c' to spawn a terminal
<tgunb>I see a graphical display manager. does that really consider .xsession? how does it choose between to windowmanagers?
<snape>if you want to switch WM, you just need to 1) modify .xsession 2) pkill "your WM"
<tgunb>snape: I will try that when I'm home again
<tgunb>how does the dm start the right wm when I choose with F1?
<snape>tgunb: I'm not sure about the details, but a default GuixSD installation would include a Slim service (slim is a graphical login manager) and SliM will read the .xession. Depending on the last line of your .xsession file (exec some-wm), it will start some-wm
<snape>I heard you can switch from SliM, but I don't know how it works
<snape>If I want to switch, I modify .xsession and kill the running window manager
<snape>SliM will then re-read .xsession and start the new wm
<snape>s/re-read/re-execute
<tgunb>ok
<civodul>htgoebel: what's the status of KDE on GuixSD?
<htgoebel>civodul: AFAIK nobody worked on it.
<htgoebel>civodul: I just updated the framework to the current version. That's all I know.
<efraim>civodul: i'm about to `adduser` you to my aarch64 board and should I just grab your lsh key from guix-maintenance?
<paroneayea>moin moin
<brendyyn>Chinese characters don't display for me at all
<brendyyn>Can anyone on GuixSD see this: 好 ?
<fps>yes
<brendyyn>;(
<fps>oh, oops, not on guixsd
<brendyyn>@_@
<fps>i read it as "anyone on #guix see this" :))
<[df]_>brendyyn: I'm not on guixsd atm, but there are some cjk font packages in fonts.scm
<brendyyn>I'll try install some more. I've got dejavu which I thought had chinese
<[df]_>hmm, don't think so
<[df]_> https://dejavu-fonts.github.io/
<wingo>i can see one character
<wingo>i have gnu-unifont and gnu-freefont-ttf installed, maybe it is from that
<brendyyn>Does GNOME not see newly installed programs until you log out and back in again?
<wingo>i do not know
<brendyyn>seems that way
<rekado>ACTION suffers from bad connectivity today
<wingo>ACTION too
<snape>ACTION has only 33Mbit/s upload today :p
<rekado_>The bootstrap JDK is really slow…
<rekado_>I wonder why it built the JDK twice.
<efraim>once for build and once for check?
<rekado_>guess it’s doing two phases to remove the dependency on the bootstrap JDK
<rekado>phant0mas: the fix for glibc-hurd on i686 is much nicer when we do it on core-updates
<rekado>on master we apply the patch in a build phase, and I’d have to override the big build phase completely for glibc-hurd.
<rekado>on core-updates it’s just a matter of overriding the source field
<rekado>I’ll try to push the fix to core-updates tonight
<tgunb1>hey, there is no .xsession; neither in root nor in the user directories.
<nikita1>dear guix-users, who can help with the build of guix:
<nikita1>which version of libgcrypt is needed for guix build?
<phant0mas>rekado: ok
<phant0mas>is there some way to get automatic reports on hydra failed builds that are related to Hurd?
<phant0mas>instead of just randomly checking hydra logs? :P
<librenoob>Hi, I verified image, dd'ed it on stick, basically following manual, but after booting it (GNU with Linux-Libre 4.8.15 (beta)) I see a kernel panic, VHS: Unable to mount root fs on unknown-block(0,0). I've tried with AHCI and IDE settings in BIOS. I also switched USB socket and had yet another kernel panic with panic - not syncing: Attempted to kil
<librenoob>l init! exit code 0. (entry_SYSCALL_64_fastpath... in call trace. Any ideas? Does this sound familiar?
<tgunb1>librenoob: I'm no kernel hacker, but it sounds like the kernel trys to mount the fs on the very first block on your block device. but the first block should normally contain the partition table. in your config.scm did you set /dev/sda instead of /dev/sda1 as your root fs?
<librenoob>tgunb1: there is no config.scm yet, I try to boot GuixSD from USB stick.
<tgunb1>how did you guix system init?
<tgunb1>ah, ok.
<librenoob>I dd'ed GuixSD image into USB stick.
<librenoob>ACTION is going to check NixOS image, but he hoped for GuixSD system. :/
<paroneayea>o/
<ng0>hi
<grillon>hi ng0
<grillon>my BNC is often here but I don't have time to follow conversations so I quit. good bye
<ng0>i hope to beat my head on services long enough to contribute back to a project I used to particiapte in, opennicproject. for the time being it is a great project, and I think Tier2 and just user options can be made much easier when GuixSD is used. plus selfhosting, integration into dynamic dns
<ng0>one option is just bind, which should be very simple. but every simple service has turned out to have some kind of catch, so I am careful with just saying "hey, this will be done in no time"
<ng0>when some program wants termcap, we just ignore it (remove it)?
<ng0>i switched to using nntp for most lists, and I think an actual newsnet applciation would be better than alpine
<catonano>ng0: nntp for lists ?
<catonano>what do you mean, exactly ?
<ng0>nntp to email gateway, for example as provided by gmane
<ng0>because it is much easier to deal with stupid crossposting.
<ng0>and I am able to go down from 1.3Mio mails in one folder to a couple of thousand
<lfam>Takes a while to build Guix now :)
<lfam>I get to practice being patient
<catonano>I'd love to have a gateway between email and news
<catonano>I used to read news many years ago, in a previous life, I'd say
<ng0>gmane is still there. and other servers.. nntp and bbs is on my list of things to package
<catonano>There was an extremely nifty news client for Macinthoses (at the time that was what I had) and it depicted a graph of the "reply" dependencies among posts
<catonano>I can't remember its name, now
<catonano>but it was beautiful
<ng0>the usual suspects are tin, nn, slrt, etc.. there aren't many.
<catonano>ng0: mmm I don't tink so. It was on a Macintosh with the System 7.x
<catonano>it was before MacOs X. It was wit Motorola 60kk CPUs and NuBus buses
<catonano>as I wrote, it was in a previous life ;-)
<catonano>Motorola 68k
<ng0>I used Mac before OSX I think, student exchange in France around 2004 or 5.. afterwards we had some tiny macs in what can be translated as highschool
<lfam>Now you emulate those machines in a web browser on archive.org
<lfam>They might even have the program you're thinking about
<ng0>actually I have no interest of Mac history, so I might've used OSX even then
<catonano>lfam: II thhink it was MacSoup ! :-)
<catonano>here: http://www.macorchard.com/usenet/
<CharlieBrown>GuixSD has 755 permissions on user files, but CentOS has a more sane 700.
<catonano>I'd rather have a GNOME native client witht hhe same features
<librenoob>Could you share sha256sum from ftp://alpha.gnu.org/gnu/guix/guixsd-usb-install-0.12.0.x86_64-linux.xz ?
<ng0>actually you can use https:// and be more safe than just plain old ftp.
<librenoob>ACTION tested two laptops and two sticks, but GuixSD has a kernel panic and NixOS boots correctly. Does GuixSD only works on FSF approved hardware?
<lfam>Either way, you need to check the signature
<ng0>yep
<librenoob>I checked signature. It's ok.
<lfam>librenoob: No, it should boot on any hardware
<catonano>librenoob: 0pqmwz4bn70frpqgsmnxffch2i35i448r4a1cm1p3sb20rg5l0zx
<lfam>The SHA256 hash is fd035a5e0662e971436541918c08896544019973dd56fdf0cd0e1cbbc8e7155f
<lfam>Huh?!
<catonano>are they different ?
<lfam>Yeah, looks like it!
<lfam>Yours is not a SHA256 hash, from what I can tell. It's not long enough
<ng0>OSX 7.0 was in 1991.. I think I used DOS and some atari system a little bit later, around that time
<catonano>lfam: right, sorry
<catonano>ng0: eh :-)
<ng0>fd035a5e0662e971436541918c08896544019973dd56fdf0cd0e1cbbc8e7155f , 894f719485dd4f38d0e077814134d1159a6ca87cbd3214952b06e37932127d6d5573117942b229a33ad17f5f3810b6d91b8ef8b8e15ad5182764fd6c3f63e069
<lfam>Is that SHA256 and SHA512?
<ng0>System 7 was from 91 - 97, so I might've seen it at some persons house.
<ng0>si
<lfam>I hope librenoob didn't give up. I wonder what caused the boot failure on their machine
<catonano>say that I want to take a look at the code implementing the check phase in the python build system. Where do I look ?
<ng0>guix/build/python.scm or something like that
<lfam>catonano: A good way to find out is to do `git log --grep python-build-system`, and check the files that were modified
<ng0>there's one folder with the build systems
<catonano>guix/build-system/python.scm ?
<catonano>lfam: right
<catonano>let me try
<Walakea>have you heard about this one? http://rtos.com/products/guix/
<lfam>Yeah, try digging around for a while :) Of course, if it's urgent, just say so, and we'll help you more directly
<lfam>Walakea: Yup
<lfam>We'll cross that bridge when we come to it
<ng0>yes.. so far they didn't complain. if it's the Guix for sale product unrelated to opoerating syetems
<catonano>lfam: no, it's ok, thanks :-)
<ng0>and if there's the need for GuixSD on similar devices (just looked the page up again) then we could simply rename the system used for that :)
<ng0>GUI solution.. oh. page title mislead me
<Walakea>which libcrypt do i need to ./configure guix from source? Debian has lots of them
<lfam>Walakea: I'd guess libgcrypt20-dev (libgcrypt, not libcrypt)
<Walakea>thanks
<lfam>librenoob: Did you figure out the boot failure?
<lfam>librenoob: Many of us used that USB installer, so I can confirm that it *can* work.
<librenoob>lfam: checking 0.11 now, but verification gives me BAD signature from "Ludovic Courtès <ludo@gnu.org>". :/
<lfam>librenoob: Okay, I'm going to try verifying that signature too. But, don't use that old installer anyways. By now, it contains many publicly disclosed security vulnerabilities (in the packages) and we aren't offering binary substitutes for any of the packages
<ng0>or just wait a few days until 0.13 is out, if it happns this week
<lfam>librenoob: The signature verification works for me. I recommend double-checking that you are using the right signature file, and that the USB installer file downloaded fully
<librenoob>lfam: it works now. Signature verified for 0.12 and 0.11.
<librenoob>BTW thank you for feedback lfam
<lfam>No problem
<librenoob>Now I'm going to check if 0.11 also results in kernel panic.
<lfam>I suspect some problem with flashing the file to the USB stick
<lfam>It would help to know what hardware / virtualization you are using
<librenoob>lfam: it's not the problem with flashing the file if it works for everything but GuixSD :) Also I use 'dd' so there is not much room for an error. Hardware is one Lenovo i5 laptop and one old Core2Duo laptop. NixOS/Arch/etc works on both.
<lfam>librenoob: How did you invoke dd?
<lfam>librenoob: I agree it's suspicious that the other systems work, but it's possible that the data was not fully copied to the USB stick even though dd exited
<lfam>It depends on how you invokte it
<lfam>I would suspect problems with UEFI, but does the old core2duo machine have UEFI?
<lfam>And, can you tell us what you see before the kernel panic? Maybe take a picture of the screen?
<librenoob>lfam: old core2duo has no UEFI, invocation is the same as in manual.
<librenoob>Is that decompression step necessary?
<Walakea>i still don't understand very well what everything Guix can do
<lfam>librenoob: Yes, you need to decompress the archive
<lfam>Walakea: Feel free to ask questions :)
<librenoob>Is there a command that I could add during boot manu (via e) to page boot process so I could check the beginning of the panic trace?
<librenoob>I see warn_slowpath_null, smp_apic_timer_interrupt, mount_block_root, prepare_namespace, ret_from_fork... :P
<librenoob>(In panic's trace.)
<Walakea>does guix do anything with building software / packages?
<civodul>librenoob: does shift-pgup allow you to scroll up?
<civodul>Walakea: Guix is a tool to build software, among other things
<librenoob>civodul: nope. I switched stick to different port and now I get https://forum.manjaro.org/uploads/default/optimized/2X/6/61f29522d819e817bbb44cf571f30c916a914038_1_690x289.jpg
<librenoob>Maybe I try some different distro with a Linux-Libre kernel, not sure if that's GRUB problem or kernel problem.
<librenoob>ACTION is downloading Parabola to check if it's Linux-libre problem or a problem specific to GuixSD.
<lfam>librenoob: In your panic trace I see something about a Manjaro kernel. That seems unexpected
<lfam>ACTION runs final tests on the followup to my non-graphical GRUB thing
<librenoob>lfam: that's the same kind of error that I found during research. It's not from my computer/GuixSD.
<lfam>I see
<librenoob>GuixSD downloads fast, Parabola downloads 6 times slower... :P
<lfam>librenoob: Exactly what machine is the Lenovo i5?
<lfam>I have a Lenovo thinkpad using an i5 processor. I could try to reproduce
<librenoob>Some cheap G50.
<librenoob>lfam: oky doky, Parabola loads w/o issues :)
<lfam>rekado: I get this warning while building Guix: WARNING: (gnu packages sssd): imported module (gnu packages dns) overrides core binding `bind'
<librenoob>I will stop fighting for now, install NixOS, wait couple of days for GuixSD 0.13 and then try again. Maybe support for EFI will fix my current kernel panics in GRUB :P
<civodul>lfam: 'bind' is a core procedure in Guile, corresponding to bind(2)
<civodul>rekado: ↑
<civodul>so the variable should probably be called "isc-bind" or something
<ng0>if it's just the bind package, then maybe bind9 as everyone does it..
<nyberg>hello
<lfam>civodul: Regarding an operating-system declaration for the VM release image... where should I put it? :)
<lfam>Hi nyberg
<nyberg>I was wondering how guix installs packages for haskell
<efraim>ok, i'm looking at qtbase, it looks to me like it is (list lgpl3, gpl2, gpl3, gpl3+)
<reepca>Is there a way to tell "guix build" to build from source for the package itself, but use substitutes for its inputs?
<civodul>lfam: would it make sense under gnu/system/examples?
<lfam>civodul: Sure
<civodul>good
<lfam>reepca: guix environment foo -- guix build foo --no-substitutes
<reepca>lfam: ah, good idea, thanks.
<nyberg>I've been searching for quite a bit now on how to manage packages fully through guix but it seems to not update the ghc package database on where the libs are. I've tried guix import hackage netwire then guix package -f ghc-netwire.scm and guix package -i ghc-opengl but it looks as the global and local ghc misses it
<nyberg>I'm sure there must be something I've missed
<civodul>nyberg: the GHC database lives in your profile and is updated on each transaction (install/remove/upgrade)
<civodul>so it should be in sync with everything that's in the profile
<civodul>now, things that are outside of the profile are not take into account
<efraim>civodul: I need a public key entry to toss into .ssh/authorized_keys since the board doesn't have lsh installed
<nyberg>so a transaction of guix package -i ghc-opengl should update the profile or?
<civodul>nyberg: i think so
<civodul>nyberg: the code that does that lives in (guix profile), if you want to check
<nyberg>ah, nvm, seem to have found the problem
<librenoob>Hehehe, civodul, lfam, please, consider following Parabola's path and in the manual recommend 'dd ... && sync' for silly chaps as me ;P
<lfam>Ah, I figured it was something like that
<nyberg>thanks anyway (it seems to install only for 7.10.x and not 8.0.x)
<librenoob>I forget about syncing. NixOS image is 150mb. Arch is also small. GuixSD is 900MB after decompression so that '&& sync' really matters.
<civodul>librenoob: good idea, i'll add "sync" to the doc
<nyberg>seems I called it off too soon
<librenoob>Also you could respond to https://lists.gnu.org/archive/html/help-guix/2016-01/msg00103.html it's probably the same PEBCAK problem.
<lfam>Perhaps... over 1 year has passed
<librenoob>Better late than never :)
<slyfox>guix-master does not compile \\o/
<nyberg>just one more question before I go, how does one include a custom package in the system configuration?
<davidl>nyberg: I don't have a good answer but here: https://github.com/guix-mirror/guix/blob/357db1f91de9b3eb14be52a98cc804cdfd284f6d/gnu/tests/install.scm are examples of someone who is using shell-scripts which could probably be used for downloading let's say custom software from github or wherever.
<rekado>terrible connection
<rekado>every two minutes I’m disconnected :(
<rekado>Is Julien here?
<catonano>slyfox: this was discussed today both on the dev mailing list and on the help mailing list ;-)
<rekado>I neglected to review the antlr patches and now I wish I had taken the time to review them.
<rekado>I’ll make a couple of follow-up commits to bring them in line with the package guidelines.
<nyberg1>davidl: ah, meant a package imported from hackage but I'll take a look there too
<slyfox>catonano: ah, got it! apologies for early panic :)
<catonano>:-)
<rekado>built Icedtea 1.13.13 with only the new bootstrap toolchain. Now I just need to make icedtea-7 use that instead of GCJ, remove GCJ and we’re done.
<slyfox>after 'make clean' on master i wonder if it's ok (not an error, just a bunch of warnings): http://dpaste.com/0S25ZC1.txt
<civodul>slyfox: this site blocks Tor users, could you try another one, like paste.lisp.org? :-)
<civodul>but yeah, there's a tradition in Guile to emit warnings to entertain the user
<civodul>and as you can see, it works pretty well
<civodul>:-)
<catonano>slyfox: also, please note that this is what I saw https://imgur.com/a/9fZrk
<slyfox>civodul: http://paste.lisp.org/display/346785
<slyfox>yeah, same thing
<civodul>slyfox: these are not good
<civodul>are you on 2.0?
<civodul>i mean Guile 2.0?
<slyfox>yes, it's a guile-2.0 system
***kelsoo1 is now known as kelsoo
<civodul>would it be an option for you to upgrade to 2.2?
<civodul>2.2 has thread-safe ports, 2.0 doesn't
<civodul>and the warnings you see are likely related to that
<civodul>rekado: i'm glad you pushed a zillion commits because i've failed to get anything done today
<slyfox>gentoo has no guile-2.2 yet but i'll figure something out
<civodul>slyfox: maybe "guix package -u guile"? :-)
<slyfox>yeah, 'guix environment guix'
<civodul>rekado: i think your inet connection is flaky :-)