IRC channel logs

2017-04-13.log

back to list of logs

<buenouanq>Howdy friends, I have a path question.
<buenouanq>I'm trying to get php to run something via exec(), but it can't find anything.
<buenouanq>absolute paths here don't sound very smart or robust based on how I understand guix works
<buenouanq>I supposed this might be more a php thing than a guix thing though.
<brendyn>I keep getting this error when I try to build qtox http://paste.lisp.org/display/344161/raw
<bavier1>brendyn: there are some corrupt substitutes floating around.
<bavier1>brendyn: just use '--fallback' for now
<brendyn>ok.
<brendyn>Would it be more sensible to have /gnu/store/name-version-hash instead of /gnu/store/hash-name-version ?
<buenouanq>you are not the first to propose this
<brendyn>I used guix pack to pack qtox, then put it on my dads computer with an old version of linux mint. i tried to run the qtox binary but it says no such file or directory
<buenouanq>are you suing to a different user at all?
<rekado_>brendyn: how do you run the qtox binary and how did you use “guix pack”?
<brendyn>rekado_: guix pack qtox
<brendyn>then I extract the tarball, go into the qtox dir and run ./qtox
<wingo>every time guix builds bash, i question my life choices
<brendyn>wingo: recite the Emacs source code once over
<buenouanq>gnu's not unix not unix not unix not unix not unix...
<brendyn>buenouanq: If you speak each "not unix" twice as fast as the previous, you will get to the end in only twice the time
<civodul>Hello Guix!
<buenouanq>so, I've found something interesting and I don't know how exactly to trace it
<buenouanq>on guixsd <?php echo exec('echo $PATH'); ?> which should just be a normal shell call, returns `/usr/local/bin:/usr/local/sbin:/usr/bin:/usr/sbin:/bin:/sbin:.'
<buenouanq>but as the php user echo $PATH gives the expected `/home/php/.guix-profile/bin:/home/php/.guix-profile/sbin:/home/php/.guix-profile/bin:/home/php/.guix-profile/sbin:/run/setuid-programs:/run/current-system/profile/bin:/run/current-system/profile/sbin'
<rekado_>buenouanq: does PHP overwrite the PATH variable somewhere?
<buenouanq>it certainly looks that way
<buenouanq>I wonder if that's something that can be easily changed for the guix php packages.
<rekado_>buenouanq: you could grep through the code. You can fetch it with “guix build -S name-of-the-php-package”.
***jonsger1 is now known as jonsger
<quiliro>hello
<civodul>buenouanq: perhaps php uses libc's default PATH, which is incorrect on GuixSD
<civodul>as returned by "getconf PATH"
<civodul>it's only "/bin:/usr/bin" though
<quiliro>i am not able to see the animation in quicktime embedded on iceweasel
<quiliro>how can i do this?
<buenouanq>quicktime, now there's a word I haven't heard in a while
<buenouanq>does guix even have an iceweasel package?
<buenouanq>is iceweasel even a thing now that debian and mozilla were able to figure out the logo issue
<quiliro>buenouanq: i'm sorry..it is icecat
<quiliro>i don't even understand the diff
<quiliro>or why the double effort
<buenouanq>because freedom is important :3
<quiliro>i have problems with this page for example http://kmoddl.library.cornell.edu/resources.php?id=1924
<quiliro>iceweasel is in trisquel....do you mean trisquel is not free?
<buenouanq>[ffmpeg] http: HTTP error 403 Forbidden
<buenouanq>hmmm
<buenouanq>no no, sorry, I was refering to the firefox iceweasel logo thing mostly
<buenouanq>page you linked will not play for me either in the browser or mpv
<buenouanq>let me try some other things though
<quiliro>With Icecat, freedom is priority number 1 and privacy is a very close second, in my opinion. Others may see it differently.
<buenouanq>youtube-dl can download it
<quiliro>i would like it embedded to avoid one more step
<quiliro> https://trisquel.info/en/forum/icecat-v-weasel
<quiliro>that is the link from what I cited....sorry for the lack of quotes
<buenouanq>Icecat is GNU"s packaging of Firefox - So yes to what you said. I also happen to trust GNU more than Mozilla right now.
<quiliro>me too
<buenouanq>quiliro: I don't know how to help you, but there's prolly a plugin or something that will do what you need. I'm the sort of internet user that blocks everything and plays videos with dedicated video players ┐( '~')┌
<quiliro>i can play that media in mpv
<buenouanq>I was getting a 403 when I tried for some reason. But youtube-dl worked.
<quiliro>perhaps you lack ffmpeg or gstreamer-plugins-bad
<buenouanq>maybe
<buenouanq>I just have whatever mpv is in the guix repos
<quiliro>???
<brendyn>buenouanq: parabola has an iceweasel
<htgoebel1>Hi,
<htgoebel1>which package delivers the timezone zoneinfo file? I couldn't find them.
***htgoebel1 is now known as htgoebel
<snape>htgoebel: it's in gnu/system.scm
<snape>you can set it in your config.scm
<snape>(operating-system (host-name "antelope") (timezone "Europe/Paris") ...)
<htgoebel>snape: Well, I need the actual package delivering the files :-)
<snape>but it is not delivered by a package, it is delivered by guix system!
<quiliro>snape: what htgoebel is asking is in what file can the cities be added
<snape>oh I see
<htgoebel>Found it: tzdata
<snape>nice! sorry I didn't understand
<quiliro>htgoebel: where is tzdata?
<htgoebel>quiliro: PArton? tzdata is the name of the package, defined in base.
<quiliro>time zone data is usually in /usr/share/zoneinfo/posix/
<quiliro>but in guix....
<quiliro>i don't know
<quiliro>i do not have tzdata package installed
<snape>quiliro: it is in (file-append tzdata "/share/zoneinfo/" (operating-system-timezone os))
<snape>you don't need to have it installed
<quiliro>snape: where can i see the city files?
<quiliro>in /share/zoneinfo ?
<quiliro>i cannot find /share
<snape>ls $(guix build tzdata)/share/zoneinfo
<quiliro>thank you!
<snape>np :)
<quiliro>how can i add a city? i suppose i should do it upstream, right?
<snape>I think so...
<SovereignBleak>Could I use the 0.12 install media to install on a BIOS computer, make an ESP and dd it to a partition on my UEFI laptop?
<SovereignBleak>Just a thought since I'm impatient and don't want to wait for 0.13.
<htgoebel>quiliro: There is no need to add a city. This data is defined by IANA.
<quiliro>oh
<quiliro>htgoebel: i just found it in the CONTRIBUTING file of tzdata
<SovereignBleak>Why are zile and nvi included over the expected emacs and vi/vim?
<quiliro>SovereignBleak: because you specified so
<quiliro>are u on guixsd or just guix
<quiliro>?
<SovereignBleak>That's not true. The install image comes with these tools by default.
<SovereignBleak>quiliro: GuixSD.
<quiliro>it is the config.scm
<quiliro>SovereignBleak: ^
<quiliro>the one you configured
<SovereignBleak>No the one that comes by default.
<quiliro>that defines everything in the os
<SovereignBleak>I am bootstrapping my system with the image downloaded from the GuixSD website.
<quiliro>there are several
<SovereignBleak>Three tools are included by default.
<SovereignBleak>Nano, zile, and nvi.
<quiliro>there is config.scm, desktop.scm and another i cannot remember
<quiliro>depends the one you choose....that will install certain packages and those will have certain dependencies which will also be installed
<quiliro>nothing is default
<quiliro>you can change everything
<SovereignBleak>Yes there are various .scm skeleton files available in /etc/configuration/ but by default three tools are included on the image.
<quiliro>you make the os
<SovereignBleak>You are misunderstanding me.
<SovereignBleak>The system is not yet installed/.
<SovereignBleak>I am bootstrapping the system with the image downloaded from the GuixSD website.
<SovereignBleak>Which includes, by default the three aforementioned tools.
<quiliro>SovereignBleak: oh...perhaps the person that created that image considered he/she needed those tools...but you can choose your own
<rekado_>SovereignBleak: I think the only consideration was size.
<SovereignBleak>rekado_: Thank you, that answers my question.
<rekado_>SovereignBleak: however, even in that image you should be able to install software as you wish.
<rekado_>SovereignBleak: when I install GuixSD afresh I usually run “guix package -i emacs-no-x-toolkit”
<SovereignBleak>rekado_: I went ahead and installed vim right away. :-) I'm just trying to get a grasp on the initial weirdness of GuixSD.
<quiliro>rekado_: i was viewing your talk at fosdem a few minutes ago
<quiliro>i love it
<quiliro>rekado_: why no-x-toolkit ?
<rekado_>SovereignBleak: that initial weirdness can be confusing (I know it was for me). Feel free to ask here on by sending mail to help-guix@gnu.org.
<rekado_>quiliro: thanks
<rekado_>quiliro: no-x-toolkit because after booting into GuixSD from USB I don’t want to have to download GTK and all dependent libraries just to edit something.
<rekado_>quiliro: after installing the initial system I just install the whole manifest
<rekado_>I don’t like to install many things during the initial installation.
<SovereignBleak>rekado_: Any thoughts on good config.scms to start pilfering from? That helped me a lot in my initial getting to grips with NixOS.
<quiliro>rekado_: what manifest?
<quiliro>it would be nice for you to blog on your config
<quiliro>it would be useful to learn
<rekado_>quiliro: I maintain a manifest of all applications I want to have installed on my systems. You can instantiate a manifest with guix package --manifest=/path/to/manifest.scm
<rekado_>SovereignBleak: depends on what you want to do with the system.
<rekado_>SovereignBleak: my config is a bit messy because I added a couple of udev rules, custom services, et.c
<quiliro>would you publish your manifest.scm or something similar?
<rekado_>and I don’t keep everything in one file.
<rekado_>quiliro: a manifest is something like this: http://guix.mdc-berlin.de/documentation.html#sec-4-2
<rekado_>i.e. a list of packages and a little bit of code
<SovereignBleak>rekado_: Desktop intially. A friend wants me to set up a Ruby dev environment for him but I'd like to get familiar with syntax on my daily machine first before I start hacking something like that together.
<quiliro>what is the difference between these: emacs emacs-25.1 emacsclient
<rekado_>quiliro: “emacsclient” connects to a running Emacs server.
<rekado_>quiliro: it starts up instantaneously, unlike a heavily customized Emacs.
<quiliro>something similar as an x client connects to the x server?
<rekado_>(despite lazy loading my Emacs takes 7 seconds to start)
<rekado_>quiliro: sort of, but specific to Emacs.
<quiliro>cool
<quiliro>what is guixr?
<rekado_>oh, that’s just a wrapper script around “guix”, which we use for the cluster installation here at the institute.
<quiliro>rekado_: i guess it is a typo on the page you reffered to guixr package --manifest=/path/to/manifest
<rekado_>it allows users on different nodes and workstations to connect to the one single daemon instance.
<rekado_>the “r” stands for “remote”
<quiliro>oh!
<rekado_>other interpretations: hipster r (as in flickr, flattr, etc), or “r” for “rekado”.
<quiliro>lol
<wingo>ok i have a potluck server working, yay
<quiliro>congrats wingo
<quiliro>for what will you use it?
<quiliro>i found my own manifest file in /var/guix/profiles/per-user/quiliro/guix-profile/manifest
<wingo>a more distributed guix
<wingo>see guix-devel
<rekado_>quiliro: that’s a different manifest file.
<mekeor>MDC-berlin uses guix? nice!
<rekado_>mekeor: yes, we’ve been using it since 2014, I think.
<mekeor>so you are at mdc-berlin?
<rekado_>yes, I work there.
<mekeor>cool :)
<rekado_>I do Guix things for work.
<mekeor>that's awesome
<mekeor>so that's why there are so many bioinformatics packages ;)
<rekado_>yeah, that’s how the “(gnu packages bioinformatics)” module got started
<rekado_>in the early days I tried to package things with RPM and it was just a lot of pain and sadness.
<rekado_>then I remembered Guix from one of the early announcement emails and gave it a try.
<rekado_>it was missing many of the packages that we would need, but I thought my time would be better spent adding them to Guix than trying to adapt RPM.
<mekeor>nice :)
<SovereignBleak>I'm getting an unbound variable trying to init with sbcl-stumpwm in my packages list.
<SovereignBleak>It's a listed package for guix and I've even compared my config to another's. Not sure where I'm going wrong.
<SovereignBleak>Sorry guix init specifcally complains about sbcl-stumpwm as an unbound variable but doesn't care about i3-wm being in there too.
<mekeor>SovereignBleak: i'd guess you forgot to add it to use-modules ?
<SovereignBleak>mekeor: Bah what a newb I am. Does every package need a corresponding module entry?
<mekeor>SovereignBleak: you can do something like `guix package --show=some-package` to find out where it is defined
<SovereignBleak>mekeor: Thank you.
<mekeor>SovereignBleak: instead of only using use-modules, you can also use use-package-modules etc.. if you want, take a look at my config.scm: https://github.com/mekeor/config/blob/master/etc/guix/config.scm#L1-L21
<SovereignBleak>mekeor: I'm not sure what the difference is as of yet or even what modules are but I assume it's all in the guide.
<rekado_>SovereignBleak: you don’t need to care about modules when you use a package specification, i.e. a string like you would use on the command line.
<rekado_>SovereignBleak: you can turn a specification into a package value with “specification->package” from “(gnu packages)”
<rekado_>SovereignBleak: all packages in Guix are really Scheme values that are bound to variable names.
<rekado_>these variables are organized in Guile modules.
<rekado_>to refer to a package is to look up the package value that is bound to a variable name.
<SovereignBleak>rekado_: Okay, that's something for me to chew on. That --show flag helped me find the corresponding module for stumpwm.
<rekado_>SovereignBleak: note that for stumpwm you will need the “bin” output
<SovereignBleak>I mean I don't even know Guile, let alone Scheme, let alone Lisp in any great capacity so this is something of an uphill battle?
<rekado_>(and there’s something wrong with our stumpwm package, which makes it impossible to connect to the process with Emacs.)
<rekado_>ACTION is an inexperienced stumpwm user
<SovereignBleak>rekado_: So it is essentially a nonfunctional window manager currently?
<rekado_>SovereignBleak: no, you can use it, but you can’t just hack it from within Emacs with Slime or Swank or whatever
<rekado_>but don’t let this stop you
<rekado_>maybe you’ll figure out what needs to change to make it work right.
<SovereignBleak>rekado_: Okay, got it. Thank you.
<rekado_>Our research group offers a Guix+Cuirass master project / internship: http://bioinformatics.mdc-berlin.de/mastersprojects.html
<roelj>rekado_: Wow, really cool! When should this position be filled?
<rekado_>roelj: dunno
<rekado_>:)
<rekado_>my boss just asked me to edit the description
<rekado_>I guess it will be open soon after the Easter holidays
<roelj>It's good to see this great effort :)
<Guest26031>is it possible to use the Gnome graphical network manager? I was expecting a `network-manager-service` but it seems as though that doesn't exist.
<Guest26031>(I've installed `network-manager`and `network-manager-applet` in my GuixSD system config, but that doesn't seem to affect anything)
<Guest26031>What I'm particularly interested in is the interface to configure a 3G dongle
<mekeor>Guest26031: yes, there is network-manager-service-type
<mekeor>Guest26031: you might want to checkout my config https://github.com/mekeor/config/blob/master/etc/guix/config.scm#L114-L116 ;D
<mekeor>Guest26031: the exhausting thing about configuring guix to use network-manager is, that %desktop-services uses wicd-service, so you have to add everything from %desktop-services manually, AFAIK
<rekado_>mekeor: no, you can just delete the wicd-service from %desktop-services
<mekeor>oh, mmh. how'd you do that?
<mekeor>(delete 'wicd-service %desktop-services) or so?
<civodul>mekeor: not exactly, see https://www.gnu.org/software/guix/manual/html_node/Using-the-Configuration-System.html#System-Services
<civodul>there's an example there
<mekeor>wow, that's cool, thanks
<Guest26031>civodul: so you'd replace `%desktop-services` with http://paste.lisp.org/display/344214 ?
<civodul>Guest26031: yes, though it's called "network-manager-service-type", not "networking-..." :-)
<civodul>roelj: just stumbled upon this: https://ginflow.inria.fr/
<civodul>we need to fine-tune our talking points re GWL vs. this one ;-)
<Guest26031>civodul: thanks. Hmm, I get `unbound variable remove`. Not really a Schemer - is there something I need to import to get remove?
<Guest26031>not yet really a Schemer ;)
<rekado_>Guest26031: you need (use-modules (srfi srfi-1))
<Guest26031>rekado_: thanks!
<mekeor>Guest26031: why do you use `remove'? why don't you use `modify-services' which civodul has proposed (and linked to)?
<Guest26031>mekeor: oh, I just assumed that was what civodul meant, as `remove` is discussed on that page too
<rekado_>you can use it to remove the wicd-service from %desktop-services.
<mekeor>Guest26031: oh, didn't see that. then i guess both is fine :)
<efraim>`guix refresh -t gnu' shows libsigsegv, gnutls, less, libgpg-error, libiconv, bc, binutils - lots of fun
<wingo>:)
<andrss>it appears that hydra.gnu.org responds with 500 time to time
<andrss>and it causes packages to build locally
<civodul>andrss: unfortunately this machine is often overloaded
<civodul>you're using mirror.hydra.gnu.org though, right?
<andrss>yes
<civodul>ok, good
<wingo> https://lists.gnu.org/archive/html/guix-devel/2017-04/msg00250.html
<wingo>potluck potluck potluck
<efraim>is guix-potluck.org up?
<wingo>it is, but the service is off atm; see bottom of that mail
<wingo>you can git clone https://guix-potluck.org/git/target.git
<wingo>which has the compiled guix packages from when i had the server running
<civodul>wingo: wooow!
<civodul>crazy stuff!
<wingo>yeah!
<civodul>excellent
<civodul>the generated modules look fun
<civodul>so actually, like right now, we can clone this, add it to GUIX_PACKAGE_PATH, and boom
<civodul>wow
<wingo>yep
<wingo>yeah, i tried to keep it pretty simple :) i hope it makes "guix channel" a bit more concrete
<wingo>like there should be a simple implementation that just pulls from a git repo, compiles it, and adds to the path
<civodul>it makes "guix channel" more pressing anyway :-)
<wingo>:)
<civodul>yeah, we can start simple
<efraim>i think the x86_64 bootstrap-binaries-0 substitute is truncated on mirror.hydra.gnu.org, but it could just be my poor wifi
<civodul>efraim: do you have the URL?
<andrss>can guix make more tries to fetch a binary package before falling back to building it from source?
<civodul>andrss: for the nar, not the narinfo, right?
<andrss>what is the nar?
<andrss>i see
<andrss>that's what happens to me, guix downloads packages, ona package cannot be fetch, guix starts download sources and build them. If i stop it and start over, guix downloads binary packages again
<civodul>andrss: so is it the narinfo URL that returns 500 or the /nar URL?
<methalo>to pass the test for pcre package on Hurd i need disable '--enable-jit', it is valid?
<civodul>methalo: if needed, we can add this flag conditionally, only for GNU/Hurd
<civodul>that would be fine
<methalo>civodul: i will send the patch, thanks
<civodul>yw!
<civodul>maybe phant0mas has something to say also :-)
<civodul>(phant0mas is the expert for all things Hurd)
<efraim>civodul: it seems to have sorted itself out
<civodul>nice, i like that
<efraim>methalo: I have a couple similar special-case patches for aarch64 :)
<katco>i'm trying to use gnu global with exuberant-ctags as a plugin to parse some scala, and i suspect guix might be causing an issue but i'm not sure. is anyone familiar with this particular combination of things?
<phant0mas>hey methalo, if we only need it on the hurd try (if (hurd-triplet? ((or %current-system %current-target-system))..)
<phant0mas>and add whatever is needed
<methalo>hi phant0mas, i'll try
<phant0mas>methalo: if you have an issue, please tell me, maybe I can help :)
<bavier>is there any telemetry we could get from directory.fsf.org that would help us prioritize packaging efforts?
<bavier>or are we overloaded enough as it is?
<civodul>bavier: i think people aren't idle :-)
<efraim>we could upgrade our perl packages if you're looking for something to do :)
<bavier>efraim: :) I know what that's like
<bavier>yeah, I added the updater, but didn't start the actual updating process
<bavier>I'm a stuck on the clang update right now though
<roelj>bavier: To which version are you updating clang?
<bavier>roelj: using your patch actually
<roelj>bavier: Ah, cool. What are you stuck on? (We may be running into the same problems..)
<bavier>roelj: just seeing if we can use 3.9 to build other packages
<bavier>roelj: ldc doesn't build with clang 3.9
***azazel_ is now known as azazel
<bavier>roelj: I also worked a bit on re-enabling the rustc tests
***bmpvieira_ is now known as bmpvieira
<roelj>bavier: I got stuck on the build of "dub".
<bavier>roelj: ah, ok
<roelj>bavier: Which fails with 3.9
<bavier>roelj: we could have some packages stay at 3.8, but I'd rather fix the issues now so they aren't lost
<bavier>at least mesa works with 3.9 :)
<roelj>Nice :)
<roelj>I agree with fixing issues instead of keeping them at 3.8.
<bavier>roelj: did you get ldc to build with 3.9? or is that still a barrier to dub building?
<roelj>bavier: I haven't tried to build LDC with 3.9 actually
<bavier>roelj: it's a native-input for dub :)
<roelj>Hmm..
<roelj>then.. it may have succeeded.
<reggggieee>curious - is there still a problem with booting guixsd on an ssd with LUKS?
<andrss>civodul: i can't reproduce 500 now, but instread it gets invalid gzip files from the server
<andrss>reggggieee: no
<nee`>reggggieee: I'm on guixsd 0.12 on a luks encrypted SSD right now. I have grub on a normal drive though, so I can't say anything about grub.
<reggggieee>nee`: ah cool
<andrss>reggggieee: you will need it crypt_root option for kerner in grub.cfg
<andrss>s/it//
<andrss>if it's just LUKS, not LUKS+LVM
<reggggieee>andrss: okies
<reggggieee>thnx
<nee`>I'm trying to build guix from git. I use 'guix environment guix', and get 'configure: error: C preprocessor "/lib/cpp" fails sanity check'. Anything else I need? I'm trying to follow https://www.gnu.org/software/guix/manual/html_node/Building-from-Git.html
***Introoter_ is now known as Introoter
<snape>nee`: try guix environment -C guix instead
<nee`>snape: That works, thank you!
<snape>np :)
<snape>nee`: actually, if you have downloading issues, it is 'guix environment -C -N guix'...
***fkz is now known as Guest9979
<lfam>brendyn: The benefit of using /gnu/store/hash-name-version is that the position of the hash in the file-name string is known ahead of time. That is, it's always at the beginning. If we did name-version-hash, we'd have to write more complicated string parsing code to find the hash.
<lfam>brendyn: Also, in an ideal world, one would not need to look in /gnu/store often. So the directory structure should be optimized for machines and not people, in my opinion.
<paroneayea>beep
<mekeor>peeb
<bavier>boop
<ofosos>*burp*
<ofosos>so, hi guix
<ofosos>we discussed some stuff about the authorized_keys on the ml, anybody got an opinion on this? can i run some ideas by you?
<lfam>ofosos: I'm interesting in this subject but I can't chat now. Email is better :)
<ofosos>lfam: ok, I'm having a beer and digging through the guix/system code
<lfam>Heh, perfect :)
***methalo is now known as methalo_
<ofosos>civodul: moin :)
<ofosos>i would like to add (openssh-key user-account-openssh-key (default #f)) to <user-account>, but from (openssh-activation config) how do i go from `config' to the `os' definition
<civodul>ofosos: i think it shouldn't go to <user-account>
<civodul>instead we should have a special service, as i explained here and on the list i think
<ofosos>did you explain that in a recent disucssion? my search is not bringing up something useful
<ofosos>ok, it pulls something up from 2015
<ofosos>but that doesn't talk about a service
<ofosos>but your sample code does :)
<civodul>:-)
<civodul>i just gave https://git.savannah.gnu.org/cgit/guix/maintenance.git/tree/hydra/modules/sysadmin/people.scm#n56 as an example of how this could be done
<civodul>this: https://lists.gnu.org/archive/html/guix-devel/2017-04/msg00253.html
<ofosos>yep, that's completely clear. hmm. should this be one service for each of openssh/lsh? i think this could be done in a single service
<ofosos>with the lsh, i think removing public keys might be a problem, lsh stores these in $HOME IIRC. when you do `system reconfigure' they might end up lingering in the system
<ofosos>with openssh i'd like to go the way and place the keys in /etc/ssh/authorized_keys/%u, so that would be easy to manage
<civodul>ofosos: indeed, i didn't know about /etc/ssh/authorized_keys/%u
<civodul>in that case it's quite easy
<civodul>we simply need to extend etc-service-type
<ofosos>:)
<ofosos>yep, it's possible to specify multiple paths to the authorized keys file, this will need a change in the openssh service to do this
<civodul>yes
<civodul>i imagine openssh-configuration could have a new 'authorized-keys' field
<civodul>and that would be a list of user/key tuples
<civodul>WDYT?
<civodul>bah we should really have reimplemented Git in Scheme...
<ofosos>yep, as long as they're readonly in /etc, this will be reproducible, and it'll give the users all freedoms to use different keys. should be fine. no key management headaches, because of stale keys. i think this would work.
<ofosos>the initial thought to have this in (user..) is a bit naive, when you have different ssh implementations
<ofosos>i'll have to check how dropbear does this, maybe we can hit two flies
<ofosos>hmm, i do we need to install this into /etc or can we simply place it in the store? as far as i can see, that is what openssh-config-file does with the current configuration. that would be nice
<ofosos>so it would be (map (lambda (user) (computed-file (format #f "authorized_keys/~a" user)) users)
<ofosos>with the corresponding input to computed-file
<ofosos>and then setting AuthorizedKeysFile to (string-append #$output "authorized_keys/%u")
<civodul>ofosos: that would be (computed-file "authorized_keys" #~something-that-builds-the-whole-directory)
<civodul>ACTION -> zZz
<civodul>but happy to discuss it some more tomorrow!
<civodul>thanks for working on it, it's a long-overdue feature :-)