IRC channel logs

2017-04-03.log

back to list of logs

<kadintrooper>Anyone have qtwebengine installed on guixsd?
<mekeor>kadintrooper: there is no package called `qtwebengine` in the official repo...
<kadintrooper>Yeah, was wondering what the deal was because afaik qtwebkit is basically deprecated in favor of qtwebengine
<kadintrooper>Unless my understanding on that is wrong
<mekeor>you may feel invited to package it ;)
<kadintrooper>I might, if I figure out how to go about that ;P
<mekeor>kadintrooper: here you go → https://www.gnu.org/software/guix/manual/guix.html#Defining-Packages in case you didn't know ;)
<kadintrooper>Yeah, seeing if I can get it to work. Probably going to take a while lol
<lfam>Woohoo! "Merge branch 'core-updates'"
<kadintrooper>:)
<mekeor>yeeeeeeeaah, finally =D
<civodul>lfam: a relief! \\o/
<civodul>we're a bit "late", but i'm glad there were more people than usual working on it!
<civodul>ACTION -> zZz
<lfam>Yeah, it did take a while...
<lfam>Good night!
<catonano>wow ! What a feat !
<mekeor>ACTION finally removes the GIT_SSL_CAINFO work-around from ~/.zshenv
<kadintrooper>Is anyone familiar with how to use qmake in package definitions
<mekeor>kadintrooper: it might help to `git grep qmake` in the guix repo
<kadintrooper>Thank you :)
<Guest65650>Any suggestions on how to distinguish GuixSD from Guix on a foreign distro in a shell script?
***Guest65650 is now known as sturm
<lfam>sturm: You could try looking for '/run/current-system'
<lfam>Or something like that
<sturm>thanks lfam, will give that a shot
<kadintrooper>ERROR: In procedure scm_i_lreadparen: /home/kadin/my-packages/my-packages.scm:151:1: end of file
<kadintrooper>
<kadintrooper>:(
<reepca>At the risk of stating the obvious, it sounds like the parentheses are unbalanced.
<kadintrooper>I checked, it looks fine
<kadintrooper>wait
<kadintrooper>Nope I'm an idiot
<reepca>I'll fit right in
<kadintrooper>:P
<kadintrooper>python: command not found
<kadintrooper>Anyone know offhand what the python2 package is called? I can't find it
<kadintrooper>Oh wait it's in python
<kadintrooper>gyp: Call to '/bin/echo -n ${HOME}/goma' returned exit status 127 while in /tmp/guix-build-qtwebengine-5.8.0.drv-0/qtwebengine-opensource-src-5.8.0/src/core/resources/resources.gyp.
<kadintrooper>Ah, I guess I can just substitute it
<kadintrooper>Hopefully that's the only file ;-;
<mekeor>sturm: what about `uname -o` ?
<sturm>mekeor: both Trisquel 7 and GuixSD seem to give me "GNU/Linux"
<mekeor>oh, i see
<sturm>thanks though
<reepca>stackexchange suggests "lsb_release -a", don't know if that works on GuixSD or not
<lfam>Nope :)
<kadintrooper>Hmm, I have a phase before build that substitutes /bin/echo with (which "echo") but it doesn't seem to be working
<lfam>kadintrooper: Not working as in the substitution does not actually change the text?
<kadintrooper>Doesn't appear to
<kadintrooper>One sec
<lfam>I would just remove the '/bin/' string and leave 'echo' as-is. It should be a shell built-in
<lfam>Well, I'd do that if it that echo was only used at build-time. Otherwise it's worth substituting it with the full path to coreutils
<kadintrooper> http://0x0.st/vDL.png
<lfam>I find it useful to create substitution procedures in the Guile REPL. It's faster to debug them that way
<kadintrooper>Hmm
<lfam>`./pre-inst-env guile` and then (use-modules (guix build utils))
<lfam>From there, you just start writing (substitute* "" ...)
<lfam>I make a Git repo of the package's source code so I can easily see the effect and roll back changes
<kadintrooper>Good idea
<lfam>Also, I usually do these substitutions after the unpack phase. If you are waiting until the build phase, it's possible that /bin/echo has already been changed
<lfam>Did you do --keep-failed and verify that the source code still says /bin/echo?
<kadintrooper>No, I'll do that right now
<lfam>I'd do that first; it's possible that it's already patched
<reepca>Any idea where I can find more up-to-date guidelines for GNU GSoC submissions than at https://www.gnu.org/software/soc-projects/guidelines.html? I can't seem to find any reference to mid-term evaluations in the 2017 timeline, only 3 separate work periods.
<kadintrooper>I actually can't find where it calls /bin/echo
<kadintrooper>:/
<lfam>kadintrooper: Then perhaps you don't need the substitution at all
<reepca>perhaps it constructs the call somehow?
<kadintrooper>gyp: Call to '/bin/echo -n ${HOME}/goma' returned exit status 127 while in /tmp/guix-build-qtwebengine-5.8.0.drv-0/qtwebengine-opensource-src-5.8.0/src/core/resources/resources.gyp. is the error that I get
<reepca>the qtwebengine git server doesn't support shallow cloning, it'll take awhile for me to get the source on my machine to take a look :(
<reepca>er wait, I might be using it wrong
<reepca>oh okay, yeah I was using it wrong, trying to clone from the link to the cgit page...
<kadintrooper>Here I'll give my definition for it
<kadintrooper> http://0x0.st/vDw.scm
<kadintrooper>Could I not just symlink echo to /bin/ and then remove it after?
<kadintrooper>Aha found the files
<kadintrooper>Theres a few :(
<kadintrooper>Getting a different error now
<kadintrooper>gyp: Call to 'pkg-config 2> /dev/null --cflags x11' returned exit status 127
<kadintrooper>Oh that means command not found
<kadintrooper>Packaging is hard lol
<kadintrooper>Now it's returning status 1
<kadintrooper>This is a lot harder than I thought it would be
<kadintrooper>qwebengineurlrequestinfo.cpp:43:49: fatal error: content/public/common/resource_type.h: No such file or directory
<kadintrooper>B-b-but it's there
<reepca>ls /foo/bar tells me that /foo/bar doesn't exist, but not that /foo doesn't exist. The error could mean that it's looking in the wrong place for "content".
<kadintrooper>I'm not sure how I would fix that
<reepca>I'd guess that the current directory is wrong at some point
<reepca>or some list of directories to be searched isn't including the right stuff, but I'm not sure why that wouldn't work here and would work elsewhere
<kadintrooper>QtWebEngine is such a pita
<kadintrooper>Alright, I'm going to take a break from that, if anyone wants to poke around and see if they can find out what is wrong with this that would be great. http://0x0.st/vkr.scm currently can't get it to compile.
<rekado_>Hi Guix!
<reepca>hi
<rekado_>huh, I cannot jump to latest master.
<rekado_>fatal: cannot create directory at 'gnu/packages/bootstrap/aarch64-linux': Permission denied
<rekado_>happens with git reset --hard 245575eaf
<civodul>Hello Guix!
<reepca>hi
<reepca>posted a last-minute double-check of GSoC proposal on guix-devel
<civodul>hi reepca!
<civodul>cool, will take a look
<civodul>last-minute is unfortunate, but we'll see!
<civodul>rekado_: BTW i don't have any problems with current icecat/conkeror (core-updates-ish)
<Apteryx>Hi civodul! Sorry I hadn't time replying to your latest feedback about my mandb profile hook patch. I've been busy with the travels! I have a couple hours from now, so I'll try to address taht.
<htgoebel1>civodul: Re. "Hwo to debug and teacking builds" and networkmanager-qt:
<htgoebel1>The .so is not found, because the container *does not* include the store-object described in the "environment-variables".
<htgoebel1>I double checked and both "guix build" and "guix environment -C" are run via pre-inst-env in the same directory.
<htgoebel1>guix-daemon is the system one, not running via pre-inst-env
***htgoebel1 is now known as htgoebel
<htgoebel>civodul: Hmm, as far as I can debug it, it looks like somewhere the guile interpreter is changed.
<htgoebel>While in in my profile (and in scripts/guix) "/gnu/store/060piiiz4n…guile-2.0.13 is used, the profile.drv is referring to "/gnu/store/vmq9sbjjw…-guile-2.0.12".
<efraim>sneek: later tell htgoebel there was a CVE against guile-2.0.12 so it got a graft replacement of 2.0.13
<sneek>Got it.
<efraim>sneek: botsnack
<sneek>:)
<civodul>htgoebel: ah yes, on master (until yesterday), there was a graft for Guile, hence what you're seeing
<htgoebel>civodul: I don't understand the implications. Both my working tree and my system-wide guile are a few weeks old. And when using pre-inst-env I'd expect *all* components in a chain to use the guile used in this pre-inst-env. What is happening ehre?
<sneek>Welcome back htgoebel, you have 1 message.
<sneek>htgoebel, efraim says: there was a CVE against guile-2.0.12 so it got a graft replacement of 2.0.13
<ng0>hi, is someone else experiencing local issues on GuixSD with the core-updates merge?
<ng0>*locale
<ng0>tmux: invalid LC_ALL, LC_CTYPE or LANG
<ng0>etc
<civodul>ng0: take a look at https://www.gnu.org/software/guix/manual/html_node/Locales.html#Locale-Data-Compatibility-Considerations
<civodul>until all your software is upgraded to glibc 2.25, you need to add glibc-2.24 to your 'locales' field
<ng0>oh we have that situatio nagain where I need to include an older glibc
<ng0>thanks
<civodul>not an older libc, just the locale data from an older libc
<htgoebel>networkmanager-qt tests now pass, expect KDE Frameworks 5.32 later today :-)
<ng0>cool
<civodul>htgoebel: woohoo, good news!
<htgoebel>Yeah, the maintainer applied two patches.
<ng0>when I follow the documentation with (gnu packages base) in my config.scm, and add the locale-libcs with glibc-2.24, it doesn't work.
<ng0>guix system: error: failed to load '/etc/config.scm':
<ng0>/etc/config.scm:10:0: In procedure #<procedure 37b0820 ()>:
<ng0>/etc/config.scm:10:0: In procedure module-lookup: Unbound variable: glibc-2.24
<ng0>y
<ng0>where the line is this:
<ng0> (locale-libcs (list glibc-2.24 (canonical-package glibc)))
<civodul>try (specification->package "glibc@2.24")
<ng0>okay.. one of these undocumented finetunings which are not so well documented in guix documentation then :)
<ng0>and in context, do I replace the glibc-2.24 with the specification->package in the list I have now, or how do I patch it together?
<rekado_>ng0: specification->package returns a package value, so you can use it instead of a package varibale.
<rekado_>*variable
<ng0>which doesn't make it much clearer how it's "used" in the context of config.scm. inside (operation-system)? Outside? per define? in the list of what I just pasted but with parens?
<ng0>I think I got it
<ng0>at least the immediate mistakes dispeared
<rekado_>the list in what you’ve pasted contains (what you assume to be) package values, so you can use “(specification->package "some-spec")” instead of one of these package values.
<ng0>that was my first guess but I didn't go with it. now it worked. tahnks
<ng0>is it supposed to fail grafting?
<ng0>I have a paste in a moment
<ng0> https://ptpb.pw/T-Lx
<ng0>I pulled again, maybe I missed some commits
<civodul>hmm locale-multiple-versions.drv works for me
<civodul>from here i have 5 to 10 MiB/s for things in cache like the kernel
<ng0>okay, this fixed some issues, but I have some other issues in my profile now. like my email client aborting with "illegal operation" etc. I am positive that this can be fixed.
<civodul>uh, that one is weird
<ng0>I haven't tried the "normal" way to start it, I just torify it
<ng0>but the normal way fails too
<ng0>Reading /home/user/mail/... 0/32 (0%)Illegal instruction
<mbakke>oops, I pushed an update for lzip in core-updates, but hashed the wrong tarball
<mbakke>are there any chicken-and-egg problems by switching the tarball from gz to lz?
<ng0>also icecat is now broken. I reconfigure the system with glibc-2.24 added, but previously some grafts and changes happened with 2.25
<ng0>broken as in crashes without starting
<rekado_>I also have problems with icecat.
<rekado_>crashes on start
<rekado_>(same with a clean profile)
<ng0>icecat is now a "we're sorry" box-only for me
<ng0>oh
<mekeor>ACTION is glad he didn't reconfigure yet ô.Ô
<rekado_>FWIW: icecat is the only problematic package for me.
<ng0>for me neomutt is the other one.
<mekeor>ACTION didn't reconfigure because webkit-gtk wasn't substituted yet
<mekeor>what could be the reason for icecat to crash?
<ng0>spring is coming
<mekeor>:)
<ng0>the systemlog says it is libkyotocabinet or the part of mutt which uses libkyotocabinet which is the problem
<ng0>yep, it's definitely only kyotocabinet.
<ng0>rekado_: I fixed icecat starting by getting to a dialogue after reboot which told me to start in safe mode as it could be caused by addons
<ng0>and once I click anywhere in preferences, it quits again
<Apteryx>civodul: I cannot reproduce the error you are seeing with the manual-database profile hook patch I sent a couple days ago. It seems, as you said, that it would originate from (string-contains failing to match and returning #f, but I cannot explain it since this should never happen, given that `entries` is formed by finding the existing ".../share/man" subdirectories of the manifest-inputs... Thoughts?
<ng0>a new icecat profile helped (refresh) i think
<ng0>nope, still crashing
<civodul>Apteryx: i'll try to debug it further, then
<civodul>perhaps that happens when the profile has an entry lacking share/man?
<ng0>this is when I select Preferences > Applications in a new icecat profile: Apr 3 14:36:58 localhost vmunix: [ 4068.570637] Chrome_ChildThr[21145]: segfault at 0 ip 0000000000408a31 sp 00007fad5a7cf4f0 error 6 in plugin-container[400000+3b000]
<Apteryx>civodul: I'm about to send you a small patch which will print the bad manpage-path.
<Apteryx>It's just a (unless index (error ...))
<Apteryx>I'm suspecting find-files return bogus paths.
<Apteryx>*might
<civodul>Apteryx: great, i'll give it a try later today
<Apteryx>civodul: If an enty of your profile was lacking share/man, it wouldn't be added to the "entries" list, IIUC.
<yoosty>I think I found a bug with the systemd instructions on the page https://www.gnu.org/software/guix/manual/html_node/Binary-Installation.html#Binary-Installation
<yoosty>should I file a bug or..?
<Apteryx>Every entries should have "/share/man/", otherwise it's a bug in the code defining the "entries" variable.
<civodul>yoosty: could you check if the error is still at https://git.savannah.gnu.org/cgit/guix.git/tree/doc/guix.texi#n366 ?
<ng0>by the way, I wrote about the torbrowser tasks to the gnu-systems-discuss list or whatever it was you recommended, civodul. So far one person from parabola identified an additional problem to my findings
<civodul>cool
<civodul>glad to see others have looked into it
<civodul>hello mbakke!
<mbakke>hi civodul!
<civodul>how's everything?
<mbakke>good, i guess, going through a backlog of updates before starting the UEFI adventure :)
<mbakke>mesa 17.0.3 fails on a test :(
<yoosty>civodul: I believe the instructions on https://git.savannah.gnu.org/cgit/guix.git/tree/doc/guix.texi#n366 will work (I haven't tried it that way) but the systemd bug report (https://github.com/systemd/systemd/issues/3010) makes me think the proper methodology would be to run 'systemctl enable /root/.guix-profile/lib/systemd/system/guix-daemon.service' instead of "cp ... systemctl ... && systemctl ..."
<fps>civodul: i discussed a little idea with thomasd a while ago. maybe it's interesting, or maybe not. care to hear it?
<jmi2k_>Hello. Has something happened in the last month or two with locales? I'm having problems with GPG because of that. It says: "gpg: public key decryption failed: A locale function failed"
<ng0>I found out how to publish guix CI in freifunk meshnetwork: connect server to local freifunk network, done. sadly you have to memorize the IPv6 address and advertise it locally on the website of your local freifunk community as their idea of mesh does not include being independent from the internet in what they do :/
<jmi2k_>I've just reconfigured the system
<fps>civodul: let's say we have three packages, A, B and C. D depends on B and B depends on A. Now A undergoes a change to A' that keeps its ABI stable. Now B needs to be rebuilt because A changed to A'. If B and B' are built in a "sanitized" or "normalized" environment (path wise) then B' will be bit identical to B which could be found out after the fact of building B'. So B' just gets a new store key pointing to
<fps>B. And transitively C doesn't need to be rebuilt to C'. C' can directly be a new store key pointing to C
<civodul>ok
<civodul>what's your focus here? disk space?
<fps>civodul: saving build times and disk space
<fps>if the dependency chain gets even longer and the affected package A is a very basic package that undergoes an ABI compatible change then with the current system, everything that depends on A needs to get rebuilt or manually grafted
<fps>it's just discovering and making use of an invariant that's hidden right now.. it could get discovered at the first dependee level.
<civodul>fps: so for disk space there's deduplication already
<civodul>for build time, the idea you hvae here is very nice... in theory :-)
<civodul>*have
<fps>civodul: really? if B and B' are binary compatible then the different derivations show up in the binaries as paths
<fps>so they are not really binary compatible..
<civodul>Eelco Dolstra's PhD thesis has a whole discussion on "equivalence classes" and such
<civodul>that's probably roughly what you're aiming for
<fps>and the deduplication doesn't catch it. (i.e. the hello binary has a reference to /gnu/....../lib)
<fps>civodul: ok, i might check it out.. thanks for the pointer :)
<fps>[i.e. i can cook up an example of a change to the hello package where all that changes is some references to the output store key in the binaries]
<fps>since it's a "different derivation"
<fps>civodul: i'll read a bit first. thanks for the pointer again..
<bobpollaco>Hi there, I'm missing the 'clear' command in the terminal, is that correct?
<ng0>ncurses provides it :)
<efraim>If you want something 'fancy' you can add an alias clear = 'guix environment --ad-hoc ncurses -- clear', but it won't be very fast
<mck>Hey Guix! I was looking back at the packages and noticed icedtea-6 was removed
<mck>I was wondering why it was
<mbakke>hi lfam!impeccable timing
<mbakke>i just pushed an nss update, can you start a 'master' evaluation? :)
<mbakke>mck: icedtea-6 is no longer supported upstreamd and has known security bugs
<ofosos1>hi guix
<mck>mbakke: I wondered if that were the case... Thank you for confirming!
<lfam>mbakke: Okay :)
<lfam>mbakke: Done
***Deys_ is now known as Deys
<ofosos1>hi guys, should I use * gnu/packages/audio.scm (qjackctl): Add new package.
<ofosos1>or * audio.scm (qjackctl): Add new package
<ofosos1>?
<lfam>ofosos: The first one, although you can replace "Add new package" with "New variable."
<efraim>The first
<ofosos1>thanks!
<lfam>Does anyone know a way to build a GuixSD grub.cfg without building the rest of the system? I want to make changes to our GRUB code and it's slow to test it by building the whole system out
***steveeJ_ is now known as steveeJ
<wingo>is there a guix command that can sha256sum a git checkout?
<davexunit>wingo: guix hash -x
<efraim>Guix hash -r -x /path/to/repo
<lfam>wingo: There is `guix hash --recursive --exclude-vcs`, which returns the hash in the format used by Guix
<lfam>Lol
<davexunit>heh
<lfam>"Let me help!!!!"
<efraim>Do we have myrepos 1.20170129?
<lfam>efraim: No, an older version from last year
<efraim>I just noticed a newer one was released
<efraim>I'm on my phone, not sure when I'm going to fire up my computer next
<wingo>haha :)
<wingo>great tx everybody :)
<wingo>i guess if you want to hash a checkout you have to clone it first, given that it could contain other files
***phorse` is now known as phorse
<ofosos1>is there any (good) reason that moc doesn't include ogg support?
<lfam>ofosos1: If you can't find any discussion of it in the guix-devel or bug-guix mailing list archives, then probably no good reason
<ofosos1>lfam, can't find any. i'm trying my hand at a patch right nwo
<ofosos1>now
<ofosos1>great, german public radio works again :) if they provide nice ogg streams, i feel like using them
<yoosty>civodul: ah! I see the note in the doc about systemd linking already being discussed: http://lists.gnu.org/archive/html/guix-devel/2017-01/msg01199.html
<yoosty>thanks!
<civodul>good!
<mbakke>loading new web pages from a shell works for icecat
<mbakke>if you are experiencing a web browsing emergency
<yoosty>although, I didn't see a patch for that systemd doc change.. is it just going to be a revert to the old code?
<wingo>i tried writing a guix hash --git
<wingo>but it never gives me the same hash values :P
<yoosty>oh nevermind, didn't look hard enough ;)
<lfam>yoosty: You found 613d0895b92c677e0639d5e77c55043e38e020c8?
<wingo>ah, got it.
<lfam>yoosty: That's the one that I hope will make everything "just work"
<yoosty>I'll have to check later, I don't have the repo at the moment :-/
<lfam>yoosty: https://git.savannah.gnu.org/cgit/guix.git/commit/?id=613d0895b92c677e0639d5e77c55043e38e020c8
<yoosty>aaah, righton!
<bavier>oh weird, bootstrappable.org just became a guix substitute mirror
<rekado_>bavier: it’s hosted on bayfront.
<bavier>rekado_: oh, I see what happened; I visited "www.bootstrappable.org" rather than "bootstrappable.org"
<bavier>the former gives the guix substitute mirror page, and the latter the website I was expecting. :)