IRC channel logs

2017-02-20.log

back to list of logs

<Apteryx>rekado_: Cool. Bookmarked.
<Apteryx>:)
<ryanwatkins>Anybody here know how to have multiple frames, like [0, 1 .. n] ? Arbitrary tiling per "workspace" inside guile-wm?
<Apteryx>Must a keyword argument always be passed using the keyword? I'd like to be allowed to either use the keyword, or not use it (in this case it would fallback to positional arguments).
<katco>is anyone working on a scala package?
<katco>i'll take that as a no :)
<katco>so it looks like scala requires a tool called "sbt" to build, and sbt requires itself to build. how does guix approach these circular dependencies when packaging?
<Apteryx>katco: Typically you'd define a sbt-bootstrap or sbt-minimal package
<katco>Apteryx: oh, perfect! so it's ok if the end result is not perfectly buildable from source?
<Apteryx>katco: It's preferable, but if scala doesn't care to provide what is required to do so, well, it's a Scala issue rather than a Guix one (my personal opinion).
<CompanionCube>ACTION does not intend to package it would be interesting to know how to handle systems with weirder circular dependencies
<katco>Apteryx: awesome. yes, i'm finding it a bit strange that they've created this circular dependency, but at a certain level of maturity, systems tend to bootstrap upon themselves
<katco>Apteryx: i think if i tried really hard, i could create a chain; e.g. scala 2.9.2 is buildable with ant, and i *think* it's possible to build sbt with scala? i'm not sure tbh
<CompanionCube>ACTION is reminded of the circular deps of image-based systems
<baconicsynergy>We're getting so close to 5000 packages!!
<Apteryx>Cool :)
<Apteryx>Anyone knows if Emacs can "prettify" a Scheme script?
<Apteryx>I'm looking at the gexp generated service script, and their pretty unreadable.
<Apteryx>they're*
<Apteryx>If anyone could look at my current code (a service definition) to point me my mistake, I'd be very grateful: http://paste.lisp.org/display/339545
<Apteryx>The error detailed in the top comment appeared after I tried using (use-modules ...) in my start gexp procedure.
<Apteryx>Usually it seems to be used with a (begin ..., but I'm not sure if I need one here.
<catonano_>Apteryx: you are defining all-interfaces-minus-loopback in the body of a lambda
<catonano_>Apteryx: that' s not allowed
<Apteryx>catonano_: This works fine if I remove the (use-modules ...)
<Apteryx>Except that remove is an unbound symbol.
<Apteryx>Maybe some gexp magic that I don't yet understand.
<Apteryx>catonano_: Could I enclose the lambda definition in a let?
<Apteryx>And declare my procedures there (let* that is).
<Apteryx>(by the way, thanks for answering :)
<catonano_>Apteryx: I never played with services, neither with gexps. That said, I would try using the (use-modules.... form outside of the lambda
<catonano_>Apteryx: also the 2 defines
<catonano_>as for the let*
<catonano_>I'm not sure I understand how exactly you are thinking of arranging your forms
<Apteryx>catonano_: OK! I'll experiment some more. Thanks :)
<catonano_>Apteryx: you' re welcome:)
<efraim>Just how frozen are core-updates? There's some changes I'd like to push, other than my aarch64 patchset
***orly_owl_ is now known as orly_owl
<mvb>efraim: it hasn't been evalutated or synced with master in a while, so I think you're good
<catonano_>sneek: later tell thomasd Would you mind to take a look at this ? https://lists.gnu.org/archive/html/help-guix/2017-02/msg00088.html
<sneek>Will do.
<Sleep_Walker>catonano_: sorry for lame question but has your user set password?
<Sleep_Walker>it was immediate thought when I read the mail on bug-guix
<catonano_>Sleep_Walker: my user has a password, yes
<Sleep_Walker>the other reason is usually that X session started immediately fails
<Sleep_Walker>what X session do you use?
<catonano_>Sleep_Walker: Gnome.
<Sleep_Walker>I never used and and I don't have it installed :(
<Sleep_Walker>I'd go with ~/.xsession file and try to debug from there
<Sleep_Walker>redirect output to file with `exec > ~/.xsession-output 2>&1`
<Sleep_Walker>and start gnome from there
<Sleep_Walker>but I'm not even sure if your graphical login manager will prefer that file
<catonano_>Sleep_Walker: don' t sweat it. I remeber thomasd having run into the same issue I just can' t remember how he solved it
<Sleep_Walker>you could also start everything manually - first X, then gnome and see where it fals
<Sleep_Walker>ah, OK :)
<Sleep_Walker>*fails
<catonano_>Sleep_Walker: thanks, anyway :-)
<Sleep_Walker>you're welcome :)
<efraim>mvb: sounds good. So far I have a couple of patches against libpng and coreutils
<efraim>if I was good I'd merge in master first and really get it ready
<thomasd>Hi Guix!
<sneek>Welcome back thomasd, you have 1 message.
<sneek>thomasd, catonano_ says: Would you mind to take a look at this ? https://lists.gnu.org/archive/html/help-guix/2017-02/msg00088.html
<thomasd>catonano_ : yes, there is a problem creating user homes if /home is a separate partition.
<thomasd>(though I think I recall some commits that fix this, so maybe it's solved in the most recent GuixSD versions)
<catonano_>thomasd: I remember you found a workaround ?
<thomasd>as a workaround for now, just create the home directory with the root user
<thomasd>also, there is a home directory created on your root partition
<thomasd>which is then hidden when your /home partition is mounted
<thomasd>so what I suggest to do is:
<thomasd>0) log in as root 1) mount your root partition a second time at /mnt (mount <root-device> /mnt)
<thomasd>2) move the wrongly created home directory to the right place (mv /mnt/home/<user> /home/user)
<thomasd>3) maybe check ownership etc on /home/<user>, though it should be ok
<thomasd>4) log in as <user>
<catonano_>thomasd: ok, thanks so much
<thomasd>you're welcome, let me know if it works and hopefully have a lot of fun with GuixSD (never look back!) :)
<thomasd>also, maybe it's good to `rmdir /mnt/home` after you've moved your user's home, to avoid future confusion about multiple /home's
<thomasd>Can someone point me to that guix-devel thread listing the criteria for which patches should go where? (master/staging/core-updates, depending on # of packages to rebuild)
<catonano_>thomasd: thanks ! I' ll let you know !
<catonano_>thomasd: is it this one ? https://lists.gnu.org/archive/html/guix-devel/2017-02/msg00323.html
<catonano_>ah no sorry
<efraim>about 600 dependant packages for staging, don't remember the number for core-updates
<thomasd>efraim, catonano_: thanks. I wanted to reply to https://debbugs.gnu.org/db/25/25787.html Seems the author's concern about applying it on a different branch is not necessary (updates nss and sqlite, I count ~300 dependent packages)
<efraim>nss has other problems, including a 60(?) hour build time on mips, and sqlite has many many dependants
<thomasd>efraim, I also thought sqlite should return a huge list, but "guix refresh --list-dependent sqlite" returns "A single dependent package: php-7.0.14" on my system. Any idea why all the others don't show up?
<mvb>thomasd: try with sqlite@3.14
<mvb>it's 3.17 in 'core-updates'
<thomasd>mvb: OK :-D
<mvb>also, https://lists.gnu.org/archive/html/guix-devel/2016-10/msg00933.html
<thomasd>bookmarked...
<catonano_>thomasd: I just followed your suggestions and it works !!
<catonano_>how do I change the keyboard layout in the GuiSD Gnome environment ?
<catonano_>there are no input sources in the "Region and language" control panel
<thomasd>catonano_: for me it works when I press the "+" button in that menu
<thomasd>(there is a + button, right? :) that should open an "add an input source" menu)
<catonano_>thomasd: yes, but then the window that comes up is empty
<catonano_>and if I click the vertical 3 dots, another empty thing comes up
<catonano_>should I install anything ?
<rekado_>Does anyone already know what commit broke the use of older guix-daemons?
<rekado_>I think that's pretty serious and maybe there's something we can do about this to make it work again.
<thomasd>catonano_: going through my list of installed packages, I don't see anything directly related.
<catonano_>thomasd: mm
<thomasd>the only thing related to "multilingualism" is some aspell dictionaries (aspell-dict-fr, aspell-dict-de, ...), I don't know if that could have triggered something else
<thomasd>are you on a recent version?
<catonano_>thomasd: I downloaded the installation image from the site. It' s 0.12
<catonano_>I am doing guix pull right now
<catonano_>but as root "guix" command counldn' t be found
<thomasd>catonano_ : that's not normal
<catonano_>sigh
<thomasd>so what do you get for `which guix` as a user?
<thomasd>that should return /run/current-system/profile/bin/guix, both as root and as a regular user I think
<catonano_>"/run/current-system/profile/bin/guix"
<catonano_>this is as a regular user
<catonano_>for becoming root I just gave "su"
<catonano_>maybe that' s not enough ?
<catonano_>thomasd: I rebooted and logged in as root. Now guix pull is running
<thomasd>catonano_ should be "sudo", i.e. "sudo guix pull"
<catonano_>ah
<thomasd>otherwise, just su will get you a root prompt, from which you can also guix pull, I think
<catonano_>it' s compilimg, now
<rekado_>I suspect it's the bash graft that broke things
<catonano_>it seesm it's running correctly
<rekado_>i.e. commit 50b8a527e
<catonano_>"updated GNU Guix successfully deployed under root/.config/guix/latest"
<catonano_>rekado_: can I help in any way, regarding this bash graft ?
<thomasd>catonano_ : running `guix system reconfigure ...` should update your GNOME to the most recent version (hopefully without requiring you to build too much on your machine...). Fingers crossed that this fixes the "region and language" issue... :-/
<catonano_>is it "guix system reconfigure path/to/the/conf-file.scm" ?
<thomasd>yes
<rekado_>catonano_: no need. I'm currently investigating it.
<rekado_>trying to find a simple recipe to help people upgrade.
<catonano_>thanks to the both of you
<rekado_>This is the last "guix pull" that works for me: guix pull --url=http://git.savannah.gnu.org/cgit/guix.git/snapshot/afd532337.tar.gz
<catonano_>rekado_: what do you mean exactly with "the last" ?
<catonano_>did it break down after that ?
<rekado_>with a later version (e.g. master) you can no longer use an older daemon.
<catonano_>ah
<rekado_>I have an installation with a daemon at version 0.11.0
<catonano_>ah ok
<rekado_>that's what I'm testing against.
<catonano_>system reconfigure is running. Fingers crossed
<catonano_>I think it' s compiling a kernel o_O
<rekado_>there has been a recent kernel update
<thomasd>ah yes, they updated to 4.9.11 :)
<rekado_>there probably is no substitute for it yet
<thomasd>maybe you can git checkout the revision before that and reconfigure using that version.
<rekado_>or you could use the LTS kernel
<thomasd>ah yes, easier
<catonano_>thomasd: why ? Do you fear that this new kernel could be unstable or unreliable ?
<thomasd>catonano_ : no, just to save the waiting time
<catonano_>the LTS kernel ? I suppose it' s about tweaking some form in the config.scm file ?
<catonano_>thomasd: ah, that' s ok then. I' ll wait
<thomasd>to switch to the 4.9 kernel, for which a substitute is hopefully available, add "(kernel linux-libre-4.9)" to your config
<catonano_>thomasd: note taken !
<thomasd>otherwise, wait for ~60 minutes :)
<catonano_>let' s see ;-)
<thomasd>(maybe you'd need to add (use-modules (gnu packages linux)) as well, if you want to specify the kernel)
<catonano_>I saw a warning ! it swiftly scrolled outside of the screen !
<catonano_>thomasd: re (use-modules (gnu packages linux)): ok, just pasted that in the notes
<thomasd>well, guix system reconfigure will tell you if it can't find a package (such as linux-libre-4.9),
<catonano_>I'm excited ! I didn' t come so close to the bleeding edge zone for a very long time ! ;-)
<thomasd>from here, it looks like you're already bleeding a little :)
<thomasd>rekado_:
<catonano_>that' s what the bleeding edge zone is for ;-)
<thomasd>so is one solution to ask people to pull that afd53.. revision, upgrade the daemon, and pull again (not a very friendly solution)?
<rekado_>this works for me:
<rekado_> http://paste.lisp.org/display/339572
<rekado_>I don't understand the error enough to find a friendlier solution.
<rekado_>but I'll take another look; would be nice if this could be avoided.
<thomasd>so this is for Guix on a host system, I understand. On GuixSD I suppose you'd have to `herd restart guix-daemon`
<rekado_>yes, this is for Guix on a foreign distro.
<rekado_>On GuixSD the problem isn't as bad because people should regularly reconfigure their systems, which also updates the daemon.
<rekado_>in cases where this hasn't happened it's a matter of "guix pull"-ing the afd532337 version and using that to reconfigur.
<rekado_>*reconfigure.
<catonano_>It' s lunch time, people. I' ll be back soon !
<rekado_>catonano_: lunch for me too!
<thomasd>guten appetito
<catonano_>while compiling the laptop suddenly switched off. This usually happens when it gets too hot :-/
<efraim>sounds like what happens to one of my machines. you can pass a flag to the daemon to limit the number of cores it can use
***gnu_guix is now known as otaku
***otaku is now known as animefan
***animefan is now known as gnu_guix
<catonano_>efraim: thanks. I just edited the conf file to use the kernel 4.9 so it doesn' t need to compile it on its own
<catonano_>now it' s downloading substitutes at breakneck speed
<catonano_>well, I guix system reconfigured but there are still no input siurces in the Gnome control panel :-/
<thomasd>hmm, I first made some keyboard settings from xfce4. Maybe that's the difference?
<catonano_>thomasd: maybe
<catonano_>the "Web" browser doesn' t show the gmail screen :-/
<thomasd>you mean you can't login/see your inbox? I just tried and that seems to work here
<catonano_>thomasd: I mean that I load "gmail.com" and it shows me a blank white screen
<catonano_>ah !
<catonano_>it loaded it now
<catonano_>wonderfuò
<thomasd>catonano_: do you have xfce4 installed as well?
<catonano_>yes
<thomasd>what happens if you run xfce4-keyboard-settings (e.g. from a terminal) and go to the layout tab?
<rekado_>the problem with older stores seems to be triggered by an origin with patches.
<rekado_>If I remove the patches from the origin object "package-source-derivation" works fine.
<rekado_>according to a comment "package-source-derivation" is "somewhat deprecated".
<rekado_>Maybe it needs an update to deal with patches.
<catonano_>thomasd: there are many keyboard layouts to choose from !
<thomasd>catonano_: try choosing one there and see if it affects anything on the gnome side? (I'm really just guessing here, but since we're both on GuixSD, my situation should be reproducible ;-) )
<catonano_>ti doesn' t seem to affect the keyboard layout in Gedit. But there' s a general keyboard layout to select and now it' s set to "Generic 105 key (intl) PO"
<catonano_>I never chise anything like this with mainstream distros
<catonano_>I should probably investigate what my keyboard is exactly
<thomasd>and did anything appear in the gnome menus? I'm still wondering why there are entries for me to choose from, and not for you
<catonano_>no there' s nothing new in the gnome menus
<catonano_>maybe I should reboot or login again ?
<catonano_>don' t know
<catonano_>where should I look for the Gnome desktop keyboard files ?
<catonano_>just to know what exactly this installation of Gnome deploys
<thomasd>don't know :) don't expect rebooting is necessary, logging in again might help (did you restart your session after reconfiguring?). Are you sure the config directories in your home (like .local and .config) are writeable by you (after this /home issue you had initially)?
<catonano_>thomasd: yes I am the owner of all the contents in my home folder
<catonano_>ok, Iì ll tell you what
<catonano_>now I try to install redshift
<catonano_>and in the next few days I' ll stare at the screen while mumbling
<catonano_>with redshift the staring won' t disrupt my sleep cycle
<catonano_>how am I supposed to install redshift ? In my user profile ? Or as a system thing ?
<thomasd>I don't know, just try installing it in your profile first, and remove it again if it doesn't work?
<catonano_>thomasd: yes, that seems pragmatic
<catonano_>thomasd: ok, I think I' ll go to my cafe to have a coffee now. Back in a while
<rekado_>I installed it into my user profile, and I start it in ~/.xsession
<thomasd>what is the best way to make custom packages available in guix system reconfigure? It seems GUIX_PACKAGE_PATH is not taken into account for this?
<jmd>thomasd: If that's true, then it sounds like a bug.
<rekado_>I think I found a fix for the daemon problem.
<rekado_>for the bash patches we use "url-fetch/reset-patch-level"
<rekado_>when that method is called with the deprecated "in-band-downloader" (because old daemons don't have the built-in downloader), guile is #f.
<rekado_>a gross fix is to make it use %bootstrap-guile if "guile" is #f.
<rekado_>I just tried this and successfully used the latest Guix with a 0.10.0 daemon.
<thomasd>rekado_: congratulations! So is there a fix which isn't "gross"? :)
<rekado_>I don't know
<rekado_>I don't understand why sometimes the #:guile argument is #f.
<rekado_>If I understood that I guess I could find a fix that would be acceptable.
<rekado_>url-fetch/reset-patch-level appears to be consistently called with #f for #:guile
<rekado_>or rather: with no #:guile value at all.
<rekado_>maybe it just needs a better default
<jmd>I'm thinking that its about the right time for a second call for testing on the wip-installer branch. Does anyone have any requests before I do that?
<ng0>I think with new batteries I recently got, I'm running into variations of Ubuntu bug #583271, Redhat #656738 et cetera. Those are 7 years old now.. has anyone in the last year(s) run into this? (upower bug with 'the value of energy when full is much higher than design')
<Apteryx>catonano_: The service record has a modules field where I could put these extra modules requirements, so I could get rid of the problematic use-modules :)
<ng0>this is with 'after-market' batteries, the "original" batteries don't cause such problems
<catonano_>Apteryx: yeah !
<ng0>efraim: nice job with aarch64 :)
<efraim>I've never got much higher, most I got was 110%
<efraim>Thanks :)
<ng0>is there any overview with what is covered by aarch64?
<catonano_>which irc client do you use, people ? I use Polari but I' m afraid that' s not available in GuixSD. Not yet
<ng0>in devices I mean, now i know it's odroid-c at least
<ng0>irc clients are 'mostly' easy to package :)
<ng0>I fear when I do 3 more I have touched every irc client in existence >.<
<efraim>It should be any aarch64 board, there's no 'recommended' minimums that some vendors skip, like with armv7
***jonsger1 is now known as jonsger
<ng0>it's otherwise know as armv8?
<efraim>Offloading should probably be OK, I believe its currently targeting the base armv8.x-a
<catonano_>ng0: Ok ok I get it. Now, would you please let em kmow which one you use on a regular basis in GuixSD ?
<rekado_>catonano_: I use ERC (with znc on my server), which is part of Emacs.
<efraim>Armv8 technically includes armv8-r which is really aarch32
<ng0>catonano_: it wasn't meant to be read that way :) I'm just surprised there's more clients
<rekado_>jmd: I have a patch to make guile-ncurses an optional dependency
<efraim>Although I'm pretty sure offloading to an armv8.1-a board will yield binaries for 8.1, but not chip specific
<jmd>rekado_: How would that work?
<rekado_>jmd: the installer obviously won’t work without it, but people who don’t want guile-ncurses can build it without.
<ng0>too bad my phone is not v8
<jmd>rekado_: Build an installer you mean.
<jmd>- a disk image .
<efraim>Right now I'm racing Hydra and the core-updates merge, iirc Python3 still doesn't build
<rekado_>jmd: no, I meant that compiling Guix as such works without having guile-ncurses. The modules for the installer would just be excluded.
<rekado_>we do the same for other optional features such as the importers (guile-json).
<jmd>Oh I see.
<jmd>Which would be the default?
<ng0>catonano_: at least it looks as if polari has not many dependencies
<catonano_>ng0: well, I don' t know, I' m a bit weary of Gnome stuff
<catonano_>I' ll see
<ng0>I've just read the configure.ac of it
<catonano_>for now I need a backup plan for ircing from my brand new GuixSD installation
<ng0>i think every irc client should include in the description 'irc client' and if not, it should be fixed
<Sleep_Walker>efraim: \\o/ AARCH64! good work
<ng0>most of the are found, but not all
<ng0>for example weechat was not in the results
<catonano_>ng0: ok let me see
<rekado_>jmd: I don’t know. For Guix via GuixSD it obviously makes sense to include the installer, but for people who install Guix on foreign distros it would be good to avoid another dependency.
<ng0>catonano_: "guix package --search=irc"
<rekado_>jmd: I’ve just sent you my patch and Cc’d guix-devel.
<rekado_>jmd: I just tried the installer, haphazardly selected “Add users” (without touching anything else before that), and then noticed that I cannot back out of it any more.
<rekado_>jmd: is there a way to cancel an operation and return to the main menu?
<jmd>rekado_: I've pushed a fix for that in the last 10 minutes.
<jmd>Does anyone else get an error "tex exited with bad status, quitting" when running "make dvi" ?
<rekado_>jmd: hmm, I don’t see the fix on wip-installer. If it is 137cb414f11c1ce615cc50f77075e2a099095a3d then it doesn’t seem to work for me.
<rekado_>jmd: I get the same error on “make dvi”.
<rekado_>(on both “master” and “wip-installer”)
<jmd>In the "Add users" menu, "Continue" should go back to the main menu.
<rekado_>ah, I have to use the space key. RET won’t work on the buttons.
<jmd>That's correct. Maybe RET should active a selected button too.
<catonano>oh gosh. Is this the guix channel ?
<jmd>catonano: Last time I checked...
<Apteryx>catonano: Which IRC client are you trying? ;)
<catonano>Apteryx: irrssi
<catonano>I tried epic5 but I couldn= t figure out how to cnfigure it in thhe first 15 seconds so I ditched it
<Apteryx>catonano: OK. That's a proven one. Configuration is a bit ugly if I remember.
<catonano>no configuuration is a cream pie
<Apteryx>catonano: I'm using Weechat, per recommendation of ng0 (after I spammed the channel with a paste error -- weechat has a built-in feature to prevent that). It's quite good. I'd like to try ERC (builtin Emacs) too.
<catonano>the waz it looks is a bit weird, but I ll put up with that
<catonano>please considerr that with thhis keyboard I cant do emoticons
<catonano>weechat, you say
<Apteryx>Some feature I've been liking a lot is its smart filtering: I only seem connections/disconnections of people active in the prior 5 minutes. You have to enable this but it's easy.
***jonsger1 is now known as jonsger
<Apteryx>I only see*
<catonano>Apteryx: ah interesting
<ng0>epic5 and ircii can take some time to set up.
<Apteryx>It's a bit sad that the linter can only lint packages definition and not also modules or random procedures
<ng0>I still have epic5 blends to package, which provide clients around the epi5 base
<ng0>for those who don't consider themselves hardcore epic5 users and want a set of config values which just works
<ng0>if I should disappear, that's me testing wether the battery problem is fixed now
<ng0>last time with both CPUs at 100% load it switched off
<catonano>ng0: as for Polari, this is its build instructions page https://wiki.gnome.org/Newcomers/BuildGnome
<catonano>it seems to require jhbuild
<catonano>which is not in guix already
<catonano>see ? Gnome stuff
<ng0>I just read what's in its git
<ng0>there was no mention of jhquery, but maybe i skipped it
<catonano>is jhbuild included in the glib-or-gtk-build-system ?
<Apteryx>When I define a variable using (define some-var (operation with some result)), when I want to use it do I have to eval it (some-var) or just use its symbol name, some-var?
<Apteryx>The later, it seems.
<Apteryx>Otherwise it would try to eval the value, e.g. a string or integer or whatever which doesn't make sense (in my case).
<catonano>In teh control panel the gnome version is 3.0 but in the package deinition it is 3.22
<catonano>I just system reconfigured. Did I miss anything _
<catonano>?
<ng0>reboot?
<catonano>mm I think I did reboot already
<catonano>let me try again
<ng0>it's alright
<ng0>for me it's 3.0 aswell
<catonano>ah
<catonano>well it shouldn t be. Shouuld it ?
<catonano>on Fedora 25 it is 3.22.2
<Apteryx>Can I start a service from the service definition file manually? (I'm debugging a service I'm working on and this would speed the development process).
<Apteryx>I copied and indented the autogenerated /gnu/store.../<hash>-shepherd-networking.scm file to /tmp/shepherd-networking.scm and indented it so that I can understand what is going on. I'd like to tell shepherd start networking from /tmp/shepherd-networking.scm.
<jmd>When I browse https://www.gnu.org/software/guix/packages with LibreJS enabled I am advised that I should complain.
<Apteryx>Complaining is a full-time job with LibreJS.
<jmd>(consider this a complaint!)
<jmd>Apteryx: It would indeed benefit from a server side tool which webmasters could use to check their sites.
<Apteryx>Maybe. I'm not sure they'd be aware of it.
<Apteryx>I think I saw once a bug/discussion about some Guix page not being LibreJS compliant. Maybe you can find it on the ML.
<Apteryx>Otherwise I'd suggest you do raise the issue. It's embarrasing to complain to others if a even a GNU hosted website doesn't get it right.
<paroneayea>it still bums me out that librejs says "complain" :\\
<paroneayea>I think a nicer verb could be used
<Apteryx>paroneayea: Yes, it's quite negative.
<paroneayea>it encourages a negative tone which probably results in more people being turned off from librejs than anything, from what I've seen. I think saying more along the lines of "Help correct this nonfree js" would be more effective
<jmd>paroneayea: Maybe you should complain about this?
<Apteryx>:D
<paroneayea>jmd: ;)
<paroneayea>I have tho
<paroneayea>I think librejs is a great project, and I think it could be more effective with that comparatively simple change
***jonsger1 is now known as jonsger
<jmd>There are many such projects where that is true.
<Apteryx>Could a gentle soul comment on my service definition (I indented the gexp generated file): http://paste.lisp.org/display/339589
<Apteryx>catonano suggest that my `define' inside the "start" lambda were the problem, and it seems it is, but I fail to understand why Scheme can't cope with this.
<catonano_>paroneayea: just look at this tweet. https://twitter.com/BobSummerwill/status/760683648177868800
<catonano_>paroneayea: I was surprised at the negative mood about librejs
<catonano_>Apteryx: Scheme does deal with that. I think it' s something else, maybe gexpressions cant. i dont know
<paroneayea>catonano_: I think people are both too harsh on librejs, but also the "complain" thing sets up a negative taste for things... I've seen multiple projects *with* free javascript get really toxic negative emails to them about them having nonfree js, when they in fact had free js that wasn't just marked up appropriately
<paroneayea>instead of "you're doing the wrong thing, I'm complaining", it could be "it looks like you either aren't using free js or haven't marked it up... how can I help?"
<Apteryx>catonano_: At that point, the gexp has already finished its magic. Just evaluating the expression in your REPL will yield a "warning: possible unbound ..." :)
<Apteryx>catonano_: The code you saw before was service definition in Guix. The code you see now (my previous link) is the actual service (Scheme) derived from it.
<Apteryx>Well, both are Scheme but the later doesn't have gexps anymore ;)
<catonano_>if it says that all-interfaces-minus-loopback is unbound, then it' s unbound. My guess is that (remove loopback-network-interface? (all-network-interface-names)) doesnt return what you expect
<catonano_>but then again, I neve played with services before
<catonano_>Apteryx: what does (all-network-interface-names) return ?
<Apteryx>Believe it or not the problem is a typo.
<catonano_>it' s hard to tell, when it runs in the daemon environment
<catonano_>ah
<Apteryx> all-interfaces-minus-loop-loopback instead of all-interfaces-minus-loopback
<Apteryx>Ugh.
<catonano_>well, that happens :-)
<Apteryx>To answer your question, (all-network-interface-names) is some procedure which returns all the network interface names that your system has as a list. It's defined in (guix build syscalls). Basically it just parses a Linux file.
<Apteryx>you can eval the (use-modules ... sexp in your REPL, and then you should be able to eval the other define as well (provided you fix the typo I made).
<Apteryx>This work will allow you configure the dhcp-client-service to run either in IPv6 or IPv4 as well as select which interfaces you'd like to be used for dhcp (using a list of regexps (exact interface name would work too)).
<Apteryx>I had been using Wicd but it's a bit fat (40 MB for a client I seldom use) and doesn't support IPv6.
<jmd>Somebody ought to do a decent wicd-like program in Guile
<Apteryx>jmd: Sounds like a fun project (Guile/GTK+).
***snape` is now known as snape
***jonsger1 is now known as jonsger
<Apteryx>Can I not use (format #f (string-append "some thing" "something else")) ? It complains that the string is not a "string literal".
<efraim>i hate when that happens
<paroneayea>vps options sure seem cheap right now https://joshtronic.com/2017/02/14/five-dollar-showdown-linode-vs-digitalocean-vs-lightsaild-vs-vultr/
<janneke>sneek: later tell phant0mas, yes get the same. tests/00-initial-env.test is fine, but adding tests/00-repl-server.test hangs for quite some time (1 minute?) and then prints lotsa In procedure fport_fill_input: Resource temporarily unavailable\\nscheme@(repl-server)> While reading expression:\\nERROR: In procedure fport_fill_input: Resource temporarily unavailable\\nscheme@(repl-server
<sneek>Got it.
<janneke>sneek: botsnack
<sneek>:)
<snape>Apteryx: (format #f "~a" (string-append "some thing" "something else"))
<Apteryx>snape: Thanks!
<snape>np :)
<snape>Apteryx: https://www.gnu.org/software/guile/manual/html_node/Formatted-Output.html#Formatted-Output
<Apteryx>Powerful stuff!
<wingo>so powerful you always have to look at the manual, no matter how many times you've done the thing in the past :)
<ng0>Any advice for a font with bdf files, would just share/fonts/local/ be the right place, or does share/fonts/bdf work too?
<Apteryx>wingo: hehe
<wingo>any objections to a mechanical update of guile-next to guile 2.1.7 ?
<efraim>If it builds :)
<janneke>iwbn to have the (civodul's version of) reproducibility patches in 2.1.rsn
<wingo>civodul said he would do it :)
<wingo>the reproducibility things
<janneke>yeah
<wingo>i will leave it building overnight and if it builds i push the update i guess
<janneke>+1
<wingo>then if that works i can push fibers 1.0, wheeee
<janneke>whoohoo
<ng0>catonano_: what did you try with the keyboard so far?
<catonano_>I asked on the "newcomers" channel on the Gnome irc server
<ng0>I have no environment where it isn't set, but I remember there was something you have to do
<catonano_>they suggested me that the input sources functionality depends on the ibus sevice
<ng0>I assumed that having gnome implied using 'gnome-desktop-service' and %desktop-services :)
<ng0>there's a limited amount of services I use, but it's mostly similar to %desktop-services
<catonano_>gnome-desktop-services is used in my config indees
<catonano_>indeed
<catonano_>I'm not sure wether that cotains the ibus service
<catonano_>let me see
<ng0>there is no ibus service
<catonano_>ah
<ng0>but I know it works.. so I don't know what's wrong I'm afraid
<catonano_>here on fedora there' s a ibus-daemon running
<ng0>%desktop-services contains:
<ng0>avahi, wicd, udisks, upower, colord, geoclue, polkit, elogind, dbus, and something else
<catonano_>ok
<catonano_>well, any kind soul can reply on the mailing list
<catonano_>Wingo mentions some additional file systems here https://lists.gnu.org/archive/html/guix-devel/2015-08/msg00439.html
<snape>ng0: sshd can have many subsystems, right?
<ng0>I think so, I haven't seen an sshd config in a while
<janneke>t.c
<jonsger>oh well, why did I didn't use "-enable-kvm"
<snape>I need an advice on how to deal with long record names like openssh-configuration-challenge-response-authentication?
<snape>it goes further than 80chars
<snape>is there a.. good practice? rename it in a let?
<snape>not caring (for exceptions) about the 80 chars rule?
<snape>or maybe, changing the record name
<snape>the record *accessor* name, I mean
<snape>or the use of match
<snape>(see https://lists.gnu.org/archive/html/guix-devel/2016-11/msg00284.html)
<snape>Well, I'll shorten the record name (sorry for thinking out loud :))
***Guest51825 is now known as sturm
<ajgrf>i can't execute any `guix archive` command without getting "guix archive: error: corrupt input while restoring archive from #<closed: file 0>"
<ajgrf>anyone know why that might be?
<rekado_>ajgrf: what are the arguments to “guix archive”?
<ajgrf>guix archive --export -r /gnu/store/...-ledger-3.1.1
<ajgrf>but i can't get it to work with any other arguments either
<rekado_>ajgrf: I cannot reproduce this. Works for me with this command:
<rekado_>guix archive --export -r $(guix build emacs) > /tmp/bleh.nar
<ajgrf>i just tried that same command and it failed identically on two machines: one guixsd and the other debian
<ZombieChicken>Oh boy. New external hard drive and I'll finally be able to try migrating to GuixSD once I can get everything backed up
<ZombieChicken>rekado_: The command you posted outputted "guix archive: error: corrupt input while restoring archive from #<closed: file 0>
<ZombieChicken> on my system
<rekado_>hmm, it works fine on my GuixSD system running the latest version of the daemon.
<rekado_>what daemon version are you using?
<ajgrf>`guix-daemon --version` says 0.12.0
<ZombieChicken>rekado_: Just updated guix on my Gentoo machine. Exact same output