IRC channel logs

2016-12-30.log

back to list of logs

<marusich>replace "~/guix" with your local checkout of guix.
<ng0>hmm
<ng0>I'm not sure right how this could help, but i'll give it a try
<ng0>thanks
<marusich>I just looked, myself; maybe it isn't so helpful
<marusich>Looks like that's for constructing a wrapper script, so it adds stuff to the environment using shell syntax. I'm sure somebody somewhere in the packages has already added stuff to an env variable; maybe looking for usages of "setenv" will help
<ng0>probably right, yes
<marusich>For example, add-installed-pythonpath does this. I don't know if there is a helper procedure somewhere already for this sort of task.
<marusich>I found it just by grep -ring for setenv
<marusich>Another interesting grep is grep -r '":"' ~/guix
<ng0>ah, this is good
<ng0>thanks
<marusich>Looks like a lot of people have hacked around this just by doing
<marusich>something like this: /home/marusich/guix/gnu/packages/mail.scm: `("PYTHONPATH" ":" prefix (,(getenv "PYTHONPATH"))))
<marusich>Oh wait, that's probably a wrap-program invocation, but anyway you get the idea. Hopefully you can find a helpre procedure that does what you need already.
<ng0> (add-after 'unpack 'add-mozjs-to-pkgpath
<ng0> (lambda _
<ng0> (setenv "PKG_CONFIG_PATH"
<ng0> (string-append (,(getenv "PYTHONPATH")) ":"
<ng0> (,(assoc-ref %build-inputs "mozjs-38"))))))
<ng0>or something
<ng0>this has some erros, but something like it will work
<ng0>is this meta-games, trying to package games for months? :D
<marusich>Assuming that the rest of the build will see that value for PKG_CONFIG_PATH which you set, it seems reasonable...I wonder why the build system you're using isn't automatically setting up PKG_CONFIG_PATH correctly in your case, though.
<ng0>it is, but not for mozjs-38
<ng0>and setting it like this did not work
<ng0>ofc i should point to the right dir
<ng0>ah
<ng0>the .pc file is called js.pc
<marusich>Does mozjs-38 not deposit its pkg-config files into the right directory?
<ng0>lib/pkgconfig/
<marusich>Based on the code in pkg-config.scm, it looks like our pkg-config expects the pkg config files to show up in ("lib/pkgconfig" "lib64/pkgconfig" "share/pkgconfig"), so that seems right
<ng0>i get the idea.. i think i need to change the condition based on the mozjs filename.. or point directly there
<ng0>how do I string-append inside a string-append again?
<marusich>You could do (string-append a (string-append b c)), but that's the same as (string-append a b c), isn't it?
<ng0>I'll use a let
<ng0>oh, you are right
<ng0>ah and I might ahve found the /bin/sh in palemoon
<marusich>But ng0, it looks (maybe?) like the PKG_CONFIG_PATH is getting set and used by the build system (e.g., gnu-build-system). So, I don't think you should need to modify PKG_CONFIG_PATH yourself
<marusich>I'm not sure exactly what problem you're having, but that's something to keep in mind...
<ng0>Perhaps you should add the directory containing `mozjs-38.pc'
<ng0>so i think the problem is mozjs-38 naming is "js.pc"
<ng0>*it
<marusich>Seems possible?
<marusich>I gotta run - good luck though!
<ng0>thanks for your help
<ng0>ha!
<ng0>now i have to fix mozjs38 it seems, but i am past the previous error
<marusich>Excellent! Did you have to modify PKG_CONFIG_PATH?
<ng0>NixOS is the only system doing away with mozjs31... gentoo uses the bundled one.. I seem to be the only one trying with the -38 i packaged
<ng0>no
<marusich>Cool, good to know I was not crazy..
<ng0>I renamed the checked for mozjs-38 name to "js"
<ng0>could be i have to do as gentoo does and remove the debug options from the build
<ng0>they are implied and default
***GrimKriegor_ is now known as GrimKriegor
<ng0>i wonder if pagure could be the thing which would work if we ever switch... i've read "cross instance "fork" etc ability, but I have yet to try it
<ng0>lrwxrwxrwx 2 root root 79 Jan 1 1970 /gnu/store/xzq971blmjazq7bc267wcgna3bjw15js-mozjs-38.2.1.rc0/include/mozjs-/js/RequiredDefines.h -> /tmp/guix-build-mozjs-38.2.1.rc0.drv-0/mozjs-38.0.0/js/public/RequiredDefines.h urghs
<ng0>well what do you expect when you package something whichis not yet released and a moving target
<bldtg>Hello
<geemili1>What would be the best way to handle a project that only uses a call to `make`?
***geemili1 is now known as geemili
<geemili>Right now I'm using `trivial-build-system`, but I'm not quite sure how to call make from it.
<OrangeShark>geemili: you can use the gnu-build-system and just remove the configure step
<geemili>OrangeShark: I was doing that, but the version of gcc was too old
<geemili>Is there a way to specify a newer version of gcc?
<OrangeShark>oh I think I encountered a similar issue, let me see what I did with that
<OrangeShark>in native inputs, just put the gcc version
<OrangeShark>so like gcc-5
<OrangeShark>(native-inputs `(("gcc" ,gcc-5)))
<geemili>OrangeShark: Thanks
<OrangeShark>geemili: do you know how to remove a phase for the gnu-build-system?
<geemili>OrangeShark: Yeah
<OrangeShark>okay great :)
<geemili>That's one of the examples one the site :)
<geemili>How do I get the source input directory? This project has a the Makefile in a `src` directory, instead of the top directory
<geemili>Nvm
<geemili>Should test inputs be in `native-inputs` or `inputs`
<geemili>?
<mange>I think they should be in native-inputs, but I'm not confident enough to say that for sure.
<geemili>mange: I think so too, but the package turned out to have problems running its tests.
<mange>Are you doing kakoune?
<geemili>It only search `/bin` and `/usr/bin` for shell programs
<geemili>mange: Yes
<mange>Yeah, I played around with that yesterday after you asked a question about it. You'll need to patch it a bit. The tests are also a bit funny.
<mange>I've got a patch here that seems to work: https://lists.gnu.org/archive/html/guix-devel/2016-12/msg01128.html
<geemili>mange: Oh cool
<geemili>I wasn't sure if I should actually put a package for it out because there are no official releases
<mange>I'm not really sure either, but we can see how it goes.
<geemili>Also, is `./pre-inst-env` supposed to recompile every time it runs?
<mange>Do you mean all the guile messages (note: source file ... newer than compiled ...)? I get those too, but I don't know how to stop them.
<mange>Although I just re-ran `make` and `make clean` which stopped most of the messages for me. That's handy!
<vtomole>Hey anyone online right now?
<buenouanq>millions
<vtomole>:)
<vtomole>I'm having problems running guix on qemu
<vtomole>Problems with the filesystem
<buenouanq>I won't be able to help with that, sorry.
<mange>Can you tell us more about what's not working?
<vtomole>It boots , Then i press f12, then 2, then it crashes. I don't remeber then error exactly let me run it again
<vtomole>It works now, I tried it on a different system, turns out, you can't run guix vm in a vm
<vtomole>"ip eth0 up" gives me "unknown object eth0" but "ip a" lists "eth0"
<mange>Do you mean to use `ifconfig eth0 up`?
<vtomole>whoops sorry...
<vtomole>I'm now getting "in procedure getAdrrinfo not found" when running init.
<mange>Did you run dhclient?
<vtomole>It's in the wireless section of the manual, didn't think i needed to do it since i'm on vm. I'll do that now.
<mange>The stuff in the wireless section is indented a bit. The dhclient step is further to the left: it applies to both wireless and wired connections.
<vtomole>"no working leases in persistent database", is it possible to set it manually?
<mange>I'm certain it is, but I don't know how to do it.
<mange>This seems to say how to do it with ifconfig, but I can't vouch for it actually working. http://www.thegeekstuff.com/2009/03/ifconfig-7-examples-to-configure-network-interface/
<vtomole>mange: These dh-client problems. I wonder if running guix on vm is even possible... Running baremetal is my last resort, since i just want to know what it's about first...
<bldtg>If I want to test a package definition locally, I make use of GUIX_PACKAGE_PATH, right?
<jmd>bldtg: I think that is one way to do it.
<bldtg>jmd: hmm. I must not understand how it works then. when I add my path and then do something with guix package or guix build, I get "warning: failed to load '(package-name)" and "ERROR: no code for module (package-name)
<jmd>bldtg: I've never tried it. So I'm afraid I don't know.
<vtomole>anybody here ever run guix on qemu?
<gwonder>HI everyone, I'm looking for some support with a newly installed GuixSD installation. I've installed with the gnome desktop options, and I can boot but I can't figure out how to get NetworkManager running (at all, during boot or after) - from what I've read it may be something to do with disabling wicd somehow and enabling NetworkManager specifically
<gwonder>there's a paste of my current config.scm here: http://paste.lisp.org/display/335227
<gwonder>So I'm looking for advice on how I modify this file to get NetworkManager running, and when I make changes to this file are they enabled on reboot or do I have to do something to enable changes?
<gwonder>I can get networking using dhclient -v eno1
<mange>You can do something like this to ignore wicd: https://lists.gnu.org/archive/html/guix-devel/2015-11/msg00717.html
<gwonder>thanks, I literally have that open now
<gwonder>is it as simple as adding into the config.scm and rebooting?
<mange>No, you need to do `guix system reconfigure /path/to/config.scm`.
<gwonder>thanks, I knew I was missing something
<mange>You normally don't have to reboot, but I don't think reconfigure will stop running services, so it's safest to reboot to make sure everthing's in order.
<gwonder>should it worrk me that "herd start network-manager" and "herd start network-manager-service" both return "herd: service 'network-manager' could not be found"
<mange>After a reconfigure?
<gwonder>no
<gwonder>let me go reconfigure and come back :)
<mange>Yeah, nothing will change until you run reconfigure.
<gwonder>sorry where exactly would the snipped from https://lists.gnu.org/archive/html/guix-devel/2015-11/msg00717.html go in the config.scm file ? I tried dropping it verbatim after the services section and it complains about an "invalid filed specifier" - sorry, I'm sure this is silly questions
<gwonder>\\field
<mange>You would put that before your operating-system definition, and then replace %desktop-services with %desktop-services-sans-wicd.
<gwonder>ahh excellent thanks
<mange>Have you written scheme code before? By learning how to configure GuixSD you're accidentally learning scheme.
<gwonder>nope :) I'm a scheme virgin
<gwonder>this is my updated config.scm ( http://paste.lisp.org/display/335229 ), however it returns "/etc/config.scm:10:2: In procedure #<procedure 39537c0 ()>: /etc/config.scm:10:2: In procedure module-lookup: Unbound variable: remove"
<mange>The `remove' method comes from the (srfi srfi-1) module, so you could add that to the use-modules form up the top.
<vtomole>mange: my config file is exactly like his, but my error is "In ice-9/boot-9.scm: 160:13 [catch #t #<catch-closure 1b1020>..]
<vtomole>and a lot more errors...
<gwonder>sorry I got disconnected there so don't know if I posted my last question.
<gwonder>My updated config is http://paste.lisp.org/display/335230 and I get guix system: error: service 'networking' requires 'wpa-supplicant', which is not provided by any service
<roptat>hi, I'm trying to make an ocaml-build-system. It's currently working and I added around 100 ocaml packages. Should I make a separate patch for each of them, or add them in a single patch?
<gwonder>(I don't actually care about wpa_supplicant, but adding 'networking' to the modules at the top seems to force it as a requirement. Without 'networking' loaded at the top it reports network-manager-service as an unbound module, so I think it's required
<gwonder>(unbound vairable even)
<mange>You definitely need 'networking' in the service-modules section up the top. The network-manager service should then provide networking for wpa-supplicant. At what point is it complaining about that?
<mange>vtomole: Your problem is because you don't have 'networking' in the service-modules section up the top.
<roptat>I think you should add (service wpa-supplicant-service-type) to the list of services in your config.scm
<gwonder>thanks mange and roptat I'm having a look now
<vtomole>mange: the docs on the manual are oudated then... If i wanted to fix them, how would i do it?
<mange>vtomole: I think they're under the doc/ folder in the guix source tree. What is out of date in the docs?
<gwonder>I think I'm almost there, I'm getting "unbound variable wpa-supplicant-type" and from my previous errors that tells me I probably need to load another module at the top of the file - does anyone know what I need to load, or where to find the documentation for what I'm asking?
<gwonder>reference: http://paste.lisp.org/display/335232
<vtomole>mange: I mean this site: https://www.gnu.org/software/guix/manual/html_node/Using-the-Configuration-System.html#Using-the-Configuration-System
<vtomole>It doesn't have the network module imported
<gwonder>'network' as opposed to 'networking'
<roptat>it's wpa-supplicant-service-type
<roptat>not wpa-supplicant-type
<gwonder>thanks, I took what you said and found something else on my searching that had something different, and for some reason went with the other
<gwonder>it is now reconfiguring :D
<gwonder>thank you all for your help so far
<mange>vtomole: There are there example configurations on that page and all of them look fine. The first one, which uses 'networking' actually makes use of it, the other two don't reference anything from 'networking' so they don't include it in the use-service-modules form.
<mange>s/there/three
<baconicsynergy>So what do you guys think of a guix phone :o
<gwonder>just so it's archived for anyone in the future, here's my working configuration file with gnome and NetworkManager with a wicd disabled http://paste.lisp.org/display/335234
<vtomole>gwonder:Thanks
<gwonder>:)
<roptat>baconicsynergy, I'm running guix (not sd) on my phone :D
<baconicsynergy>roptat: no way!!
<baconicsynergy>did you compile it manually via termux?
<baconicsynergy>does it work well??
<roptat>no, I used adb, and a binary install
<vtomole>"/dev/sda2
<vtomole>does not exist but when i do cfdisk, it's there..
<roptat>it works great
<roptat>but you have to recreate and mount a few things at each reboot
<roptat>baconicsynergy, something like this: http://paste.lisp.org/+76O3
<roptat>you need root though
<vtomole>How do i fix "end-of-file" error? I'm pretty sure my parentheses are matching..
<ng0> https://github.com/NixOS/nixpkgs/blob/master/pkgs/development/interpreters/spidermonkey/31.nix#L46 any ideas on replicating this without the code getting too long? this is the major bug I need to fix with the mozjs-38 package i have
<ng0>wrong version
<ng0>well, it's the same in 38
<ng0>my ide awould be to just copy the folder(s) into /gnu/store/…out… and re-create the symlinks
<ng0>*idea
<rekado>vtomole: we need more context to assist you
<ng0>I think I can just pick the solution to copy the files there and not care about broken symlinks as they disapear
<ng0>this 0ad build is powered by ES technology: everything sucks
<joshuaBPMan_>Hello, I'm running guixSD (obviously). I can login to a virtual console, but I cannot start gnome. I'm getting two main errors. gnome-session-binary cannot parse desktop file xscreensaver.desktop and gnome-keyring-daemon couldn't access control socket /run/user/0/keyring/control no such file.
<joshuaBPMan_>I figured I'd post here, before I emailed a bug report.
<joshuaBPMan_>Also, I'm dual booting parabola.
<ng0>if it's not cwd, is there a variable for the root of /tmp/guix-build.../$name/ I can refer to?
<ng0>joshuaBPMan_: I'd suggest to hang around and wait, and if most people are indeed on holidays, vacations etc it's safer to post to the mailinglist or buglist if you get no reply here
<ng0>the config.scm might help. But I have no experience with dualbooting and GuixSD, I can#t help right now
<joshuaBPMan_>thanks ng0.
<ng0>almost got the question I asked solved... I have no clue where i was, but definitely not in the rootdir
<snape>how do you get scp to work on guix machines?
<snape>it looks like there's a problem with the PATH
<snape>scp not found
<ng0>with openssh?
<snape>yes
<snape>ssh my-guix-machine which ssh
<snape>which: no ssh in (/run/current-system/profile/bin)
<snape>which is normal since ssh is in ~/.guix-profile
<snape>guess I should install it as a system package
<ng0>no idea.. I have it as a user and it works
<snape>on a GuixSD server?
<snape>could do please tell me your ssh's binary location?
<snape>(on the server)
<ng0>no(t yet), at least not anymore
<roptat>I've run guix build --rounds=3 on a package, and it reports a non determinism issue. How do I investigate that?
<adfeno>What's our policy in regards to making recipes that download fonts from websites such as DaFont?
<ng0>since I had no time to configure the openssh-service, I am using lsh, but on client side scp to server (openssh and also lshd) worked
<roptat>Actually, where are the two build outputs?
<snape>ok thanks ng0
<ng0>adfeno: is there a place location or file somewhere with the license?
<adfeno>Unfortunately, there's no repository for the text font in question, and one of our recipes seems to depend on it.
<adfeno>Also, the package that comes from DaFont, comes with a readme file, and which has an informal license.
<roptat>adfeno, usually the font license is in the zip or tarball
<adfeno>The affected package is abbaye, it has a text font bundled inside, and I'm trying to unbundle such font.
<adfeno>The informal license seems to be similar to the Open Font License
<adfeno>Although I might be wrong.
<roptat>I could find the output of the first build, but not the second one
<ng0>i have mozjs-38 now at the "worksforme" state... needs some fixes before publishing though
<ng0>now its current lack of version is the problem.
<ng0>close enough
<ng0>:D
<ng0>is anyone more experienced with mozilla software?
<ng0>everything is in place (sort of) but the problem is the version
<ng0> https://pagure.io/guix-dev/commits/games/0ad the "Add mozjs-38" commit just don't want to transfer its version into directories and .pc files etc
<ng0>when I subsituted it in the .pc.in file it worked, but only for the .pc file
<ng0>it still ended up having directory "mozjs-" which isn't bothering me.. well i think i should test with minor "2" and maybe that will make 0ad happy and satisfied
<ng0>i hope this is something very obvious in the js/src/Makefile I missed
<OriansJ>Yesterday I found this and thought it might be interesting: http://git.elephly.net/gitweb.cgi?p=software/yale-haskell.git
<OriansJ>A way to bootstrap an early Haskell just using clisp
<rekado>OriansJ: that’s my port :)
<rekado>I don’t think it will be enough to bootstrap GHC.
<rekado>it doesn’t even support Haskell 98.
<rekado>that’s because the original Yale Haskell system was released in 1993(?)
<ng0>Okay, I am really stuck.
<ng0>I sent updated patches to the list
<ng0>*will send
<orbea>Hi, I maintain guix for slackare at slackbuilds.org and I just noticed this which I overlooked before. http://dpaste.com/35PJN4Y Its not a good practice to download stuff during the build process, is there anyway to disable this?
<orbea>*slackware
<davexunit>orbea: guix is special in this regard.
<davexunit>since it's bootstrapping a distribution of its own.
<orbea>why not include those sources in the guix tarball?
<davexunit>they aren't sources
<davexunit>they're bootstrap binaries
<orbea>files*
<davexunit>needed to build everything
<orbea>still, why not include them in the tarball?
<davexunit>there's a good reason but I don't remember it.
<davexunit>I agree that in general a build process shouldn't download things, but this is a special case.
<orbea>if I may be blunt, there is never a good reason to download stuff during compile
<davexunit>you could download them yourself and put them where they need to be
<orbea>alright, I will try that, thanks!
<davexunit>and then they won't be downloaded by the build process
<davexunit>good luck!
<davexunit>rekado: do you remember why ludo made the bootstrap binaries something that was downloaded during the build process?
<davexunit>I know there's a good reason for it because we're all in agreement that downloading during a build is bad but guix is the exception.
<davexunit>orbea: FWIW this is what Guix's package recipe for Guix does, so I know it works.
<rekado>davexunit: actually, I don’t know.
<davexunit>since no build environment can reach the network in Guix
<orbea>the main issue is that slackbuilds.org does not allow build scripts that allow that, their admins must of missed it too....
<davexunit>in guix we enforce this rule via linux namespaces
<davexunit>the build process only has access to loopback, no other network interfaces.
<ng0>searching for the reason of this, I wonder what happened to guix prefetch?
<davexunit>orbea: gnu/packages/package-management.scm has our package recipes for guix. there you'll find the logic and URIs for the bootstrap tarballs of various platforms.
<orbea>thanks, I'll take a look
<davexunit>the 'copy-bootstrap-guile' build phase copies the 4 bootstrap tarballs to the appropriate directory
<davexunit>the pattern is essentially: gnu/packages/bootstrap/$ARCH-linux/guile-$BOOTSTRAP_GUILE_VERSION.tar.xz
<davexunit>BOOTSTRAP_GUILE_VERSION is 2.0.9 for i686, x86_64, and mips64el, but 2.0.11 for armhf
<ng0>the reasons must pre-date the switch to guix-devel for communications
<ng0>obvious search found nothing in all of guix-devel here
<orbea>seems even more strange when those directories contain other binaries...
<orbea>bash, mkdir, tar and xz
<davexunit>orbea: it's the minimal set of binaries needed to build anything at all
<orbea>yea, I get that, but if they exist in the tarball, why not guile?
<ng0>maybe the answer to this question should be added to the bootstrap section in the documentation
<davexunit>ng0: yes, it should. need to ask ludo.
<ng0>I had someone asking a variation of this as well
<davexunit>he did this all those years ago..
<davexunit>I just don't recall the rationale, but I know it was a conscious decision.
<ng0>the old archives, before bug-guix became a bug-only list are lost, right?
<orbea>copying them to directories in the build script before compiling seems to work :)
<mthl>ng0: https://lists.gnu.org/archive/html/bug-guix/
<ng0>ah, they aren't gone
<ng0>this decision was way before 2012 though. so someone should ask ludovic
<ng0>or not documented
<ng0>well
<ng0>I wonder what other systems do that they don't run into problems with mozjs-38
<ng0>iyzsong worked on the previous versions, and andreas ... which does not mean they know how to fix version 38
<orbea>another potential issue, guile-json should still be optional or did that change? was with 0.11.0, but 0.12.0 does this. http://dpaste.com/26X2ZVV
<davexunit>f
<davexunit>oops
<davexunit>orbea: I don't see the error message in that paste, but sounds like you're right.
<davexunit>whoever added the crate importer forgot to make it contingent upon guile-json being available
<orbea>full build log in case it helps http://dpaste.com/0DQYR85
<davexunit>guile-json is indeed still optional
<davexunit>as a workaround you can hack the makefile to ignore that importer
<orbea>ah, okay, will try,thanks
<davexunit>orbea: FWIW I just pushed a commit to master that fixes this.
<orbea>ah, thanks!
<davexunit>so it will be fixed for the next release
<davexunit>since the patch is for Makefile.am, you can't just apply the patch to the source tarball without having the autotools available to rebuild the Makefile.
<orbea>that probably wont be a problem here
<orbea>slackware is pretty complete ootb
<davexunit>sure, just pointing out the need to do the autotools dance
<orbea>thanks :)
<fr33domlover>Hello
<fr33domlover>Does Guix's weechat work when not on GuixSD? I get a python error
<fr33domlover>When I run weechat with scripts disabled it seems to work but nothing gets loaded except for the core, no plugins
<fr33domlover>It looks like weechat tries to use the Python that's installed in /usr/bin i.e. not from Guix
<ng0>hm.. let me grep the build dir
<ng0>sounds like a bug
<ng0>actually there's an open bug about this
<lfam>Does anyone use our Nagios package?
<lfam>It's got some critical bugs
<lfam>davexunit: ?
<davexunit>lfam: I don't use it, sorry.
<lfam>Okay, good :)
<davexunit>nagios is a dinosaur.
<lfam>Our package is pre-dinosaur
<lfam>If we can't keep it up to date against publicly known RCE bugs...
<rekado>I think Ludo added it
<lfam>Yes, and left a comment about the difficulties involved in updating it
<lfam> http://seclists.org/oss-sec/2016/q4/714
<lfam> http://seclists.org/oss-sec/2016/q4/715
<lfam>I'm not sure what to do about this
<lfam>Maybe we should deprecate the package
<lfam>Currently, our deprecated-package procedure requires us to provide another package that supersedes the deprecated package. I can't use #f for this
<ng0>in at least one case a package was jus tdropped
<lfam>We should develop a guideline about what we do in cases like this
<lfam>Do you remember what package that was, ng0? If not, I can search the mailing archives :)
<ng0>lispf4
<lfam>Right. That wasn't due to security problems, though. That was due to other issues. I bet our Nagios still works; it's just unsafe to use.
<ng0>and so far I have found no replacement, so on my todo list is writing a lisp like this
<ng0>yes...
<ng0>is nagios no longer developed?
<lfam>Nagios was added in November.
<lfam>Nagios is developed, but we added an older version due to bundling issues
<lfam>See the comment in the package definition
<ng0>which module?
<ng0>got it
<lfam>`guix package --show=nagios | grep location`
<lfam>:)
<ng0>and we don#t have nagularjs?
<lfam>If you have recutils installed, you can do this:
<lfam>guix package -s nagios | recsel -e "name ~ 'nagios'" -p location
<lfam>`guix package -s` and `guix package --show` are designed to work with the recutils
<lfam>Anyways, it appears we don't have angular
<ng0>hopelessly stuck with 0ad and mozjs again, for real now. I'll just wait for an reply on the message I've sent
<ng0>good night :)
<lfam>The field is open to anyone who wants to try updating Python to 3.6 :)
<orbea>are compile warnings and errors like this anything to worry about? http://dpaste.com/1QBSRGC
<orbea>seems to compile otherwise
<lfam>orbea: Try searching the guix-devel and bug-guix archives for clarification. It works for me, too. I think the idea is that it works at run-time, but we don't want to depend on those things while building. But I'm not sure :)
<orbea>ah, makes sense
<orbea>and now to wait for guix pull ^_^
<orbea>thanks for the help everyone!
<bldtg>hello
<efraim>lfam: just dropping in for a few seconds, I'm quite certain that python-2.7.13 can be dropped in for 2.7.12
<efraim>in regards to python updates
<lfam>efraim: Yeah, I just built certbot with it, no problems at all
<efraim>yay
<lfam>I want to get this python-tests branch merged first
<bldtg>I set GUIX_PACKAGE_PATH to a directory with package definitions, and whenever I use guix package or guix build I get "failed to load '(package-name)': ERROR: no code for module (package-name).
<bldtg>Imust be doing something wrong
<lfam>bldtg: Probably the module path exported by your custom package definitions doesn't match the filesystem path underneath GUIX_PACKAGE_PATH
<lfam>The module path is exported by (define-module)
<efraim>sneek: later tell ludo I'm going to write a more indepth "help with aarch64 port" post later, but as far as I can tell, the crux of my problem can be seen in this diff between stage1 and stage2 of gcc-final, in the libXXX config.log-s https://i.imgur.com/5LP41Il.jpg , if you want to take a look at it first
<sneek>Okay.
<efraim>sneek: botsnacj
<efraim>sneek: botsnack
<sneek>:)
<lfam>efraim: Why a photo? :)
<lfam>The visually-impaired can't help you with this :)
<lfam>Also, shouldn't you tell civodul?
<bldtg>aha, somethinng is happening
<bldtg>I got a whole bunch of errors. yay
<bldtg>but I fixed the original problem, so thanks for that :)
<roelj>Can anyone explain how the 'all-package-modules' works? How can it know which symbols are package recipes?
<bldtg>:o I got it to work!
<lfam>bldtg: Awesome :)
<bldtg>oh whoops forgot the hash
<thomasd>hi #guix
<thomasd>using the gnome/xfce desktop template, I can only log in as root, not as another (configured) user. do i need to enable some specific settings to allow non-root users to log in?
<bldtg>you need to set a user password
<thomasd>I've done that. I can log in when I remove the desktop part and reconfigure
<thomasd>it seems like logging in fails "halfway". I can't find /var/log/syslog to try to see what's going on. any ideas how to diagnose the issue?
<lfam>thomasd: Is there anything in '/var/log/messages'?
<thomasd>lfam: nothing about the failed login attempt
<thomasd>in `/var/log/secure', i see "session opened for user thomas by (uid=0)",
<thomasd>followed by "session closed for user thomas" 20 seconds later
<lfam>Does it correspond to use of sudo?
<thomasd>no, it's my attempt to log in,
<thomasd>(I didn't get to the stage where I can use sudo :) )
<lfam>Are you able to log in from the console on another TTY?
<thomasd>how can I do that? (btw I'm on a vm)
<thomasd>ok, os that works
<lfam>ctrl+alt+fn-key switches TTYs for me on the Debian system I'm using. I don't remember if it's different on GuixSD, or if QEMU complicates it
<lfam>I'm not sure of a good way to debug this. The crude thing I'd try is to reproduce the failed login and then kill the x server from another TTY. Then I'd go back to the first TTY and read the console output
<lfam>Ideally everything started by shepherd would get stdout and stderr redirected somewhere
<thomasd>yes, in a similar vein, I just managed to take a screenshot :D
<thomasd>something about "unable to connect to D-Bus: /gnu/store/.../dbus-launch terminated abnormally with the following error: No protocol specified
<thomasd>and "Autolaunch error: X11 initialization failed."
<lfam>Does anyone have an example of how to set up the default log rotation? The example in 7.2.7.3 Log Rotation results in "Wrong number of arguments to #<procedure mcron-service (jobs #:optional mcron)>"