IRC channel logs

2016-12-24.log

back to list of logs

<espectalll[m]>I'll be straight on this one: what does the error `no code for module` mean, when trying to build a package script?
<espectalll[m]>If the error is too generic, no problem – I can actually send my current `.scm`
<OrangeShark>espectalll[m]: sounds like you might of misspelled a module name
<espectalll[m]>Yeah, it could be a stupid mistake of that sort
<espectalll[m]>I'll check carefully…
<OrangeShark>it should say what module in the error
<espectalll[m]>It does, seems OK
<espectalll[m]>(it's the one I'm trying to build)
<OrangeShark>oh it the name of the module you created?
<espectalll[m]>yes
<OrangeShark>did you set the path or use the option to add a path?
<espectalll[m]>I added a custom folder to `GUIX_PACKAGE_PATH`
<espectalll[m]>then added `rust-ansi-term.scm` (that's the package) at the root of such directory
<OrangeShark>is the module called (rust ansi term)?
<espectalll[m]>It's `rust-ansi-term`
<OrangeShark>(rust-ansi-term)
<OrangeShark>so the scm file should be at the root of the directory specified in GUIX_PACKAGE_PATH
<espectalll[m]>correct
<espectalll[m]>In fact
<OrangeShark>so if you have ~/guix-packages then it should be ~/guix-packages/rust-ansi-term.scm
<espectalll[m]>I just noticed the error appears no matter the Guix command I use
<espectalll[m]>so the path is definitely right
<espectalll[m]>Posted a File: https://matrix.org/_matrix/media/v1/download/matrix.org/rjLAAOQnhhsPYNJpNlTzAGlU - rust-ansi-term.scm (1KB)
<espectalll[m]>here it is, just in case
<OrangeShark>espectalll[m]: oh, you need to use guile define-module
<OrangeShark> https://www.gnu.org/software/guix/manual/html_node/Defining-Packages.html#Defining-Packages
<OrangeShark>shows in the example how it works
<espectalll[m]>OK, now I'm questioning my reading comprehension
<OrangeShark>so your module would be called (define-module (rust-ansi-term) #:use-module ...)
<espectalll[m]>sorry for asking such dumb questions >-<
<espectalll[m]>I really should learn to calm down and read better
<OrangeShark>it is fine, I was confused at how guile modules worked at first too.
<OrangeShark>one thing that confused me was that it uses the path as part of the module name so if you want a module (foo bar baz) you would want to create a file at the root directory as foo/bar/baz.scm
<espectalll[m]>I've also been reading `ruby.scm` straight from the Git
<espectalll[m]>so I don't know how I get it this wrong at first…
<espectalll[m]>but well, I guess it doesn't have to be *that* intuitive
<espectalll[m]>Oh, yeah, the directory tree reminds me of Java
<espectalll[m]>When I discovered it at first it was indeed confusing – also felt verbose
<espectalll[m]>yeah, I guess it's fine ^_^
<espectalll[m]>…still the same error
<OrangeShark>can you show the file again?
<espectalll[m]>Sure…
<espectalll[m]>Posted a File: https://matrix.org/_matrix/media/v1/download/matrix.org/MzlnkjerPxxaGZUJpjXjFPey - rust-ansi-term.scm (1KB)
<OrangeShark>oh, no need for the gnu packages part
<OrangeShark>that means you put the file in gnu/packages/rust-ansi-term.scm
<espectalll[m]>…oh, of course
<OrangeShark>or did you move it into a directory like that?
<espectalll[m]>how is it possible that I just talked about it yet still forgot
<OrangeShark>you don't need to put it in gnu packages
<espectalll[m]>OK, it works 100%!
<OrangeShark>gnu packages is just how guix organizes their own packages
<OrangeShark>great :)
<espectalll[m]>well, not 100%
<espectalll[m]>still a build error
<espectalll[m]>but it downloaded the crate, which is the most basic
<espectalll[m]>this one is more of a configuration setting related to Cargo
<espectalll[m]> `error: the lock file needs to to be updated but --locked was passed to prevent this`
<OrangeShark>I wonder if we even have any rust packages yet
<espectalll[m]>No packages are list at the website
<espectalll[m]>*listed
<espectalll[m]>I probably am one of the first people doing this
<OrangeShark>ohh, was added 9 days ago
<espectalll[m]>I'll send a report to the mailing list I guess
<espectalll[m]>and sleep
<espectalll[m]>it's about 1:30 AM here, and I've been with Guix all day already
<espectalll[m]>worth it ^_^
<OrangeShark>haha, good night espectalll[m] :)
<espectalll[m]>Good nite!
<espectalll[m]>Thank you for the help!
<OrangeShark>no problem
<jje>get the following error when trying to start quasselclient http://paste.lisp.org/+76BD
<red__>Greetings. Current NixOS user considering putting toes into the guix pool
<buenouanq>DO IT
<red__>haha, any advice flr someone familiar with one a
<red__>so not starting from zeroish?
<red__>what i really neex s a deep dive video where the first 40m are trying to convince me that deterministic and immutable is good
<rekado_>ha, that was simple: I just ported Yale Haskell to CLISP.
<rekado_>porting it to Guile turned out to be a lot more difficult
<rekado_>red__: aren’t you already convinced of this coming from NixOS?
<red__>exactly rekado_
<red__>i'm actually deleriously happy with NixOS with one fundamental exception.
<red__>i need to escape systemd to a more sane init.
<red__>and i've been looking for a good excuse to learn a lisp
<red__>so a look at guix seemed more than appropriate
<red__>even fate.
<rekado_>red__: can’t say if shepherd is “sane”. It certainly does much less than systemd, for better or worse.
<red__>is shepard actually pid 1?
<rekado_>yes.
<red__>I'm less concerned by how processes and daemons start and more concerned about the insane attack surface that's in the one process that can't die.
<red__>I wish I understood this obsession to make init more than 20 lines of code :-/
<red__>thanks for the heads-up
<red__>given that sheperd comes from dmd which comes from hurd... does that mean that there's a potential for a guix/hurd?
<rekado_>what makes you say that dmd comes from hurd?
<red__> https://www.gnu.org/software/shepherd/
<red__>"Its development was then closely related to the GNU Hurd, although it has always supported GNU/Linux as well"
<rekado_>aside from that: yes, Guix already runs on the Hurd and can build native Hurd applications, but we don’t have a prebuilt GuixSD image for the Hurd.
<red__>" It is intended for use on GNU/Hurd, but it is supposed to work on every POSIX-like system where Guile is available"
<rekado_>red__: I’m not sure if dmd was ever used on the Hurd, to be honest.
<red__>I'm a huge fan of microkernels... an opportunity to leverage hurd is a huge plus in my bpok
<red__>book
<red__>may even put some dev cycles into that
<albertoefg>sneek: later tell lfam that i wish him happy holidays
<sneek>Okay.
<red__>Well, here goes my first guix system init, wish me luck!~
<red__>although it's just hanging...
<red__>I'll let it run overnight I guess (it's 02:51 here)
<red__>ah, thar she goes... mirror.hydra.gnu.org!
<red__>although I'm just getting pages and pages of "substitute: updating list of substitutes from 'https://mirror.hydra.gnu.org',...
<red__>is that normal?
<nand1>red__: I was getting that too on a recent install, but will eventually count up in percentage instead of just displaying 100%
<red__>Thanks, I'll let it run then. Later!
***orly_owl_ is now known as orly_owl
<ng0>Hi. There hasn't been any major breakthrough for cupsd with printers requiring the HP printer driver/modules like (most of) the DeskJet series does?
<ng0>I mean, printing without requiring packaging/using the HP modules is not possible.. right
<ng0>But can we not just package hplip? The license on the surface is GPL2
<ng0>I don't know about blobs etc
<rekado_>I don’t understand the question.
<rekado_>for some HP printers you’ll need hplip
<ng0>I understood hplip as controversal, but maybe my memory is wrong about this
<ng0>I think the question is, could I package hplip and would it be accepted, or would it be against our guidelines?
<ng0>but we already have hplip.. my bad, I did not search
<ng0>If I understand our cups-service documentation right, I need to add hplip to: cups-configuration parameter: package-list extensions .. or maybe it'll just work, I'll try in a few days
<ng0>we use "lpadmin" for cups admins, not "lp", correct?
<ng0>erronous parameter.. hm, I don't need to print right now but getting hplip in there shouldn't be too hard
<ng0>have a nice weekend
<ng0>what would be the absolute path to point hp-setup to for the ppd files? are they in /run/current-system/ or do I rather use one of the user profile .guix-profile paths?
<ng0>I'll be back
<ng0>dring hp-setup -i for the .ppd.gz files in hplip I get: TypeError: cannot use a string pattern on a bytes-like object
<adfeno>Hm...
<adfeno>Was this error raised by hp-setup or by Guile/Guix?
<ng0>hp-setup
<ng0>I get to the point where I can specify the ppd file, and when I enter the path to the file in /home/ng0/.guix-profile/share/ppd/HP/model-i-use.ppd.gz
<adfeno>Although I'm not an expert tech person, I'll try helping you out.... I just have to see what hp-setup expects to receive as an argument for -i.
<ng0>well i use -i as it is interactive setup
<ng0>I'm used to having the qt setup, but for whatever reason we do not build thatr
<adfeno>Hm....
<adfeno>Do you by chance specify the path tothe ppd.gz file directly followed by the -i option?
<ng0>I can paste the full error
<ng0>no
<adfeno>Oh.... OK
<ng0>-i is dialogue based
<adfeno>Hm... And are you planning to automate the hp-setup -i usage somehow?
<adfeno>(I.e.: Create a Guix recipe that uses `hp-setup -i`)
<ng0>no
<ng0>I rarely print, and I'm okay with just using the setup
<adfeno>Hm... This is mostly interesting, so it really seems to be an hp-setup specific problem then... Well... I'll try to dive into it to see what I can find out.
<ng0>this is a partial output, with additional edits where my printer name + serial was: https://ptpb.pw/Rwx2
<ng0>I know the printer works because it worked on Gentoo this way
<ng0>what I don't remember is wether the files on gentoo where .gz aswell
<ng0>but I guess so
<ng0>I'll try without -i now
<ng0>was there a reason why Qt5 support wasn't added to hplip?
<adfeno>Hm... a bug in hplip's setup.py... Good thing the backtrace isn't that long (I easily get lost when following backtraces, specially if the codes don't have comments explaining what to expect for).
<adfeno>Is the `hp-setup` provided by the hplip package?
<adfeno>(I don't remember, this is why I ask)
<ng0>yes
<adfeno>OK... I'm getting the sources now.
<ng0>I think I have the time to add pyqt5 support in two days
<ng0>i wonder if this is still true, as it is still linked to in the gentoo wiki: https://bugs.launchpad.net/hplip/+bug/718069
<ng0>fixed apparently
<ng0>do you understand what the nickname problem is about? nickname_pat is mentioned in line 72
<adfeno>ng0: Still downloading sources... :)
<adfeno>Got it. :)
<adfeno>Now I'll read it to see if I can understand what is going on.
<ng0>ah, okay :) thanks
<ng0>If I do /home/ng0/.guix-profile/share/ppd/HP/PRINTER_series.ppd or /home/ng0/.guix-profile/share/ppd/HP/PRINTER_series , the error is not found / not an ppd file, so the .gz ending is expected
<ng0>*do use
<ng0>we also should alter whatever hp-check uses, it checks some paths which we do not have
<ng0>24 errors, 1 warning
<adfeno>I wonder what does `search([Something])` and `group([Some number])` do in the Python programming language.
<adfeno>These might get us the answr we need.
<adfeno>Besides, I have noticed that nickname_pat seems to be a regular expression of some sort, it seems to expect "NickName:" in the begining of a string.
<ng0>harmut might know
<ng0>hu
<ng0>that's weird
<ng0>the printer "nickname" is asked for AFTER pointing to the ppd file if I remember it correctly
<ng0>if it greps for the printer name based on the queue name and explicitly tries not all small letters (queue name is misc cases), it will fail
<ng0>I've got some debug output.. but I need to understand it in relation to my printer name
<ng0>maybe it doesn#t understand the ending _series
<adfeno>If I got line 560 right: it might do something like this: take the regular expression defined in nickname_pat...
<adfeno>... , use it to search for a match inside "nickname" variable (and return only the matching part), and use this result to return only the last match that corresponds to the first regexp group defined (hence `group(1)` which always prints only the last match of group 1).
<adfeno>Now, it's only a matter of understanding what are athe contents of the "nickname" variable.
<ng0>we are not flexible in using either old or new algorithm in the build or both at the same time?
<adfeno>ng0: Sorry, but I'm afraid my limited knowledge can't answer the last question.
<ng0>I also read complains about missing various python libs, so I'm not sure wether those need to be propagated and hplip just builds currently but doesn't really work
<ng0>our printer has no access to the network in any way, so I guess I could also paste the whole verbose outputs
<adfeno>Ok... so `nickname = gzip.GzipFile(file_path, 'r').read(4096)` tries to extract the gzip file and read the first 4096 bytes to be put inside the "nickname" variable.
<ng0>extract.. in the store?
<adfeno>ACTION wonders what could these 4096 bytes hold.
<adfeno>ng0: Perhaps not.
<adfeno>Let' me see.
<ng0>would the output of hp-setup -i -a -g help? that's --automic --debug --interactive
<ng0>the way I read it, for my model no matching ppd file is found in the .dat file so it falls back to old algorithm
<ng0>but the section of the printer is found
<adfeno>Hm...
<ng0>when it comes to the printing queue setup, the ending "_series" part is dropped, if the .ppd.gz is search for without the _series, it could fail
<adfeno>Just one question: have you got past the error you informed me earlier (that is: TypeError: cannot use a string pattern on a bytes-like object)?
<ng0>no
<adfeno>Oh... OK then, so we are indeed working at the stage-or-problem.
<ng0>detection succeeds, but as soon as the ppd file needs to be located and then manually specified, it fails
<ng0>*printer detection that is
<adfeno>ng0: I guess we must try what you suggested: hp-setup -i -a -g
<ng0>another thing.. I just tried to add it simply in the cups webinterface, with the ppd defined, and I get a complain that hpcups is not available
<adfeno>Oh boy...
<ng0>Idle - "File "/gnu/store/pd200v2q8vdxy6ycsxjsskxavc5q2jvk-cups-server-bin/lib/cups/filter/hpcups" not available: No such file or directory"
<ng0>As this never connected to the internet or network printer is pretty save, is an email to guix-devel@ as a paste okay for you?
<adfeno>Well... It's better to email it to guix-devel since I don't know if I'll be able to solve it.
<adfeno>:)
<adfeno>And also, this is strange.... the recipe for cups currently enables hpcups
<adfeno>ACtually, the recipe for hplip enables it.
<ng0>adfeno: sent
<ng0>oh, I had to chnage a bit, hpcups is recognized
<adfeno>I just wonder if hpcups is really provided by some package. I mean, the recipe for hplip seems to enable it, but I at least am not sure if hplip provides it.
<ng0>but
<ng0>processing since
<ng0>Sat 24 Dec 2016 01:59:10 PM UTC
<ng0>"Color Manager: no profiles specified in PPD"
<ng0>do I need cups in global packages available in addition to the service? I thought just having the service is enough
<ng0>I need to go now.. thanks for your help
<jmd>Are we building staging or what?
<taylan>ACTION wonders who's in charge of the website
<lfam>I just joined; which website?
<sneek>lfam, you have 1 message.
<sneek>lfam, albertoefg says: that i wish him happy holidays
<taylan>lfam: I mean gnu.org/s/guix. a small text change to the About page should be trivial to do I think so I wanted to ask them if they've seen the related bug report. (I'm now wondering if there was a reason, like FSF requirements, to list GuixSD as a "GNU/Linux distribution" on that page though...)
<lfam>taylan: We're in charge of that site. The code is in the guix-artwork.git repository: http://git.savannah.gnu.org/cgit/guix/guix-artwork.git
<lfam>I don't know if there's a particular we reason we say GNU/Linux instead of GNU.
<lfam>It's funny how wikipedia turned out. It's not that different from the old paper encyclopedia model now ;)
<taylan>lfam: what's the "old paper encyclopedia model"? :)
<lfam>Petulant editors guarding their little kingdoms ;)
<lfam>taylan ^
<lfam>It's an uncharitable thing to say, but there's some human truth in it, I think
<lfam>I remember when a person could actually do "drive-by" edits of wikipedia
<taylan>hehe
<taylan>yeah Wikipedia is just turf wars when it comes to somewhat subjective/opinionated topics...
<lfam>People :)
<taylan>indeed :D
<taylan>lfam: thanks for the link to the artwork repo. I sent a patch to my bug report now :P
<taylan>'git blame' didn't indicate anything like a switch from "GNU distribution" to "GNU/Linux distribution" on that page; it said the latter ever since the whole paragraph was added. besides if there were a policy for it, I'm pretty sure it would apply to the home page as well...
<taylan>apparently it was Ludo who added the paragraph so I guess I can ask him when he's around
<lfam>Maybe we should keep the word "Linux" somewhere or people might think that Guix only works on Hurd. I've had to correct that misconception twice!
<lfam>And many other misconceptions... it's a bit annoying to explain yet again that Guix is not a "Scheme wrapper of Nix"
<lfam>"The amount of energy necessary to refute bullshit is an order of magnitude bigger than to produce it."
<lfam>Now I'm going off-topic ;)
<adfeno>Wow! :)
<kqb>Hi, I'm trying to install guix in a QubesOS HVM.
<kqb> (1) There is a problem with the network
<kqb>(2) a nix post said, it might be useful to disable ip6
<kqb>how do I go about solving (1) maybe with the help of (2)?
<kqb>(# dmesg) does not yield anything that indicates a problem with the network interface.
<kqb> I looked for "net", "IP", "link".
<taylan>guix master branch failing to build with guile 2.2, saying module (json) not found. bummer. wonder if I did something wrong.