IRC channel logs

2016-12-04.log

back to list of logs

<rekado>sneek: later tell civodul I set “fastcgi_temp_path /var/run/nginx/fastcgi_temp;” in my nginx config. Not sure if that’s needed, but it’s what our default-nginx-config does.
<sneek>Okay.
<rekado>paroneayea: the poll library is part of fibers. I think you’ll only have to patch the sources to hard-code the eventual path to the library in the store.
<rekado>(I think I did build fibers successfully a couple of weeks ago when I tested it in rcas-web)
<rwp>lfam paroneayea and everyone, I have found and fixed the group acount problem that caused the git push permission denied problems yesterday.
<rwp>I have once again switched the git service over to the new server. It is working for me.
<rwp>It would be awsome to hear from the folks here that were having problems yesterday that it is working for you today.
<rwp>Or if not then that too. :-)
<Apteryx>rekado: Thanks (for the answer regarding lsh. I guess I'll have to resort to Bash aliases to emulate .ssh/config with lsh.
***Piece_Maker is now known as Acou_Bass
<efraim>ooops, my header comment made it into golang.scm
***Guest53808 is now known as sturm
<thomassgn>Is there any overview of available services in configuration? I found some in the manual, but am sort of hoping there are more secretly lying around...
<ng0>i'm afraid there aren't any, but additions are very welcome in that part
<thomassgn>Also is there a preferred method of writing text files to the store or /etc/?
<thomassgn>ng0: hehe, yep. So I'll go grab my scheme book again... :)
<ng0>the store is read-only, files in there should not be changed :)
<ng0>but you can add files in /etc/ or for example if you have an .onion already generated from previous systems, you can add/change the one which is being generated by the hidden-service service in /var/...
<thomassgn>yes, I mean to write the file contents as part of the system configuration. Then it could be added RO to the store.
<ng0>i wonder if I should remove the guix package for gentoo. I no longer do any gentoo related things, but maybe people get the wrong impression. it would have to be marked 'install one time only, otherwise this will break your guix installation if you randomly emerge version updates'
<ng0>but the problem is, gentoo users seem to want the package
<ng0>so there must be something to do other than just pointing it out in a message
<thomassgn>I ran nix on gentoo for some time before changing entirely...
<ng0>did version updates of the package (in gentoo) affect you?
<jmd>There are a number of services available and several do indeed write to the store during configuration.
<thomassgn>I installed it outside of portage
<ng0>oh, ok
<thomassgn>jmd: Ah, ofcrourse, that's what I'm looking for I guess
<thomassgn>I'll have a look at e.g. nginx service.
<thomassgn>thanks
<ng0>on the other hand, gentoo is already a system where people are highly selfresponsible to get their information on software they run, so i'll just change the postinstall note. I already included "RTFM"
<thomassgn>nginx uses a function 'plain-file' defined in git-root/guix/gexps.scm; theres several other similar functions there.
<thomassgn>for future reference :)
<roptat>hi
<roptat>are bootstrap-tarballs enough to build guix itself (without guix)?
<efraim>They're enough to bootstrap the system, you'll still need the source tarballs for each piece of software
<efraim>You'll also need the Guix source to have the build instructions
<efraim>So I guess it would be the bootstrap tarballs and the guix-daemon
<roptat>ok, so I need guix-daemon anyway
<roptat>but why are they called bootstrap if they can't be used to build guix?
<efraim>All software is compiled against other software, and they are the statically compiled binaries at the bottom of Guix's software stack
<roptat>oh I see, thanks
<roptat>so if you want to port to another architecture, they are not enough to build guix on the new hardware, you need to cross-compile more packages to the new architecture?
<efraim>You just have to cross compile the bootstrap binaries and then compile the Guix source on the target hardware
<efraim>Then everything will build up from the base
<efraim>That's the short version at least
<roptat>ok, thanks
<rekado_>b
<rekado_>(“C-x b”, sorry)
<thomassgn>I'm getting an error I don't understand from reconfiguring my system, have a paste with config an error (error at bottom) here http://paste.lisp.org/display/333235
<thomassgn>error message is '/etc/config.scm:9:0: Wrong number of arguments to #<procedure cons (_ _)>' Line 9 is '(operating-system' ...
<ng0>can you pastebin the config?
<thomassgn>it's on the paste url I posted...
<thomassgn>or do you mean you prefer pastebin over paste.lisp.prg?
<Petter>Maybe you need a (bootloader). I'm just guessing though.
<Petter>And now I see you have. Nevermind.
<ng0>oh
<thomassgn>:)
<rekado_>cons takes an atom and a list
<thomassgn>The system is running with an older version of that file, what's been added is the mapped-devices...
<rekado_>use cons*
<rekado_>in file-systems
<thomassgn>ok, 2 sec
<thomassgn>that gives me a whole different set of errors :)
<rekado_>paste it please
<rekado_>can you reference “mapped-devices” without having defined it anywhere?
<thomassgn>have annotated the paste, refresh and the error is at the bottom of page
<thomassgn>what do you mean by referencing mapped devices without defining anywhere? taking out the (gnu system mapped-devices) from top of conf?
<rekado_>your extra-modules look wrong
<rekado_>#:extra-modules '("raid0") '("raid1")
<rekado_>shouldn’t this be #:extra-modules '("raid0" "raid1")
<rekado_>?
<thomassgn>ah, ok. I nabbed it from one of the system tests in the repo ... :P
<rekado_>though I must say I don’t know these modules
<rekado_>my modules look like this: "snd-seq.ko" "snd-seq-midi-event.ko" "snd-seq-midi.ko" "snd-seq-device.ko"
<rekado_>note that these are all file names of actual kernel modules.
<rekado_>I don’t know if “raid0” and “raid1” are actual kernel modules.
<thomassgn>but things like that are what I'm still not familiar with as I don't know much about scheme/lisp.
<rekado_>that’s unrelated to scheme
<rekado_>you’re adding extra kernel modules to the initrd.
<rekado_>these kernel modules actually have to exist
<thomassgn>I'm not sure. raid looks like it's working already, so I might just take it out.
<rekado_>what I mentioned earlier is “(dependencies mapped-devices)”
<rekado_>I don’t think this will work because “mapped-devices” is not defined anywhere.
<thomassgn>oh, what I said about scheme was in relation to me writing #:extra-modules '("raid0") '("raid1")
<rekado_>ah, ok
<thomassgn>mapped-devices is defined on line 31
<rekado_>what you wrote is “pass the list containing the string "raid0" as the named argument ‘extra-modules’; then also pass the list containing "raid1" as an additional ordered argument.
<thomassgn>it worked now, after changing to #:extra-modules '("raid0" "raid1")
<rekado_>‘mapped-devices’ is a field in the ‘operating-system’ expression. That’s not a definition.
<thomassgn>ah, allright. oh... heheh
<rekado_>you could (define my-devices (list (mapped-device …))) and then use that
<rekado_>(mapped-devices my-devices) … (dependencies my-devices)
<rekado_>I haven’t done this myself, so it might not actually work this way :)
<thomassgn>mm, that is what they've done in the test.scm I found the raid stuff with the modules and so on...
<rekado_>what’s the path of this test.scm file?
<thomassgn>it's in the repo i got from http://git.savannah.gnu.org/r/guix.git and the file is gnu/tests/install.scm
<rekado_>oh, so maybe referencing other fields in the operating-system expression is indeed possible.
<rekado_>and I confirmed that there are kernel modules raid0 and raid1:
<rekado_>/run/current-system/kernel/lib/modules/4.1.35-gnu/kernel/drivers/md/raid0.ko
<rekado_>/run/current-system/kernel/lib/modules/4.1.35-gnu/kernel/drivers/md/raid1.ko
<rekado_>(seems that the module extension ‘.ko’ is now optional)
<thomassgn>nice. I just modprobed them in, not sure that was necessary.
<ng0>i think the symbol installed for utox is too large. I see if I can fix it. in awesome it is most of the time just a white box.
<roptat>I'm trying to "port" guix to my android device, so I've installed the armhf binary distribution. When I ran guix pull, it downloaded new guix and new packages, and now it needs to build module-import
<roptat>but it fails with the error "guix pull: error: build failed: cloning builder process: Invalid argument"
<roptat>do you have any idea what could go wrong here?
<roptat>it seems CLONE_NEWPID is not supported by my kernel, too bad
<roptat>is there a way to disable the use of namespaces?
<roptat>nevermind, it seems to work with --disable-chroot
<ng0>wow, that's cool :)
<ng0>i think some people are already working on some arm architecture thing?
<ng0>you mean guix on top of android?
<roptat>yes, guix is already ported to arm
<roptat>I get many issues because guix is built with glibc, and not android
<roptat>hm... android's libc
<ng0>android does not use musl, uclibc, uclibc-ng or glib?
<ng0>i'm in sleepy panda procastrination on my half finished uclibc-ng
<ng0>what does android do different?
<ng0>i've never used it nor seen the interiors of it :)
<roptat>there libc is called bionic
<roptat>and there filesystem is different
<ng0>bionic is written from scratch?
<roptat>no idea
<roptat>it has a lot of hardcoded things in it
<ng0>oh
<roptat>and it manages users and groups differently (maybe it is even hardcoded)
<roptat>I had to create /gnu and mount some partition on it (because / is the initramfs), same thing for /var
<roptat>I had to create /etc/{protocols,services,passwd,group}
<roptat>and /etc/resolv.conf
<roptat>almost there...
<ng0>confusing, there's even an 14x14 png installed with utox but awesome taskbar goes for a much larger resolution
<ng0> https://github.com/uTox/uTox/issues/185 there would be an open bug exactly about this problem, if I could open this bug. gives me an github 500
<roptat>ok, another issue, guix pull tries to build guile-ssh, and first clones "https://github.com/artyom-poptsov/libguile-ssh.git/" but cannot resolve hostname
<roptat>"fatal: unable to access 'https://github.com/artyom-poptsov/libguile-ssh.git/': Couldn't resolve host 'github.com'"
<roptat>but it's able to resolve hydra.gnu.org for instance
<efraim>interesting
<roptat>and there's no issue if I use git from my profile to clone that repo
<roptat>can I guix download the repo in some way?
<ng0>does arm equal arm? ie a software build for any arm will work on armhf for example? jolla phones use this architecture too
<efraim>arm is armhf with neon
<ng0>neon is I assume something on hardware level again
<efraim>its in the top of gcc.scm, arm is armv7-a with hardfloat, thumb and neon
<efraim>yeah, it has to do with floating point something
<ng0>ah :) so i don't think that jolla will stick around long enough to serve as a potential not fully functional port for guixsd, but it'd be interesting to get the daemon into harbor
<ng0>sorry.. not daemon. guix.
<civodul>hey hey!
<sneek>Welcome back civodul, you have 1 message.
<sneek>civodul, rekado says: I set “fastcgi_temp_path /var/run/nginx/fastcgi_temp;” in my nginx config. Not sure if that’s needed, but it’s what our default-nginx-config does.
<roptat>it seems my build user can't access /etc/resolv.conf (and /etc/services)
<antelope>Hello! Thank you for your help with GuixSD installation. Yesterday I was cinnamon.. and asked you about everything. If you can, please, teach me how to install grub for GuicSD. During the installation it failed to install, and aslo all usual utilities like grub-install dissapeared after the installation.
<jin>can you post you config.scm? antelope
<antelope>aha:) one second
<antelope>I apologize, I cannot copy in these editors. How to copy in nano?
<roptat>antelope, use cat maybe?
<antelope>cat file-name and after?
<antelope>will it be on the screen?
<Apteryx>antelope: try it, but yes :)
<antelope>aha:) I have already do it
<ng0>antelope: do you have curl available?
<Apteryx>Or, you could probably just use your mouse to select the part you want to copy, and then press the middle button (the wheel) to paste it anywhere.
<antelope>;; This is an operating system configuration template
<antelope>;; for a "desktop" setup with GNOME and Xfce.
<antelope>(use-modules (gnu) (gnu system nss))
<antelope>(use-service-modules desktop)
<antelope>(use-package-modules certs)
<Apteryx>oops
<ng0>iirc: cat whatever.scm | curl -F "c=@${1:--}" https://ptpb.pw/ will paste to ptpb.pw we should really include wgetpaste in the next install-image
<antelope>:)
<antelope>was I blocked because of too long message?
<Petter>Yes, * antelope has quit (Excess Flood)
<antelope>it is like in manual, standard config.scm
<antelope>I see but you asked me to send the file, sorry
<ng0>is this for a dual install? or just guixsd?
<ng0>you don't have grub-install in guixsd as this is handled by the system config (default: /etc/config.scm)
<antelope>for the dual, yes, I ahve also old Windows 7 and Aptosid there
<ng0>oh. okay then I can't help
<antelope>why? today I made a separate disk 500 Mb with ext3 specially to install there grub
<antelope>guix refused to install on the root partition /dev/sda8, and I did new /dev/sda3
<Petter>Ah, primary vs. logical partition?
<ng0>oh, simply because I have no experience at all with guixsd and dualboot there (yet).
<antelope>/dev/sda3 is primary and the root is logical
<antelope>maybe it can be specified in guix package -i grub where it should be installed?
<antelope>I boot now from Aptosid
<ng0>(bootloader (grub-configuration (device "/dev/sda"))) <- maybe this also takes a partition instead of devices, or a mapped-device which is a partition
<jin>i use /dev/sda but i dont have other OS
<antelope>do you know what is the correct solution for me now? Should I do 'guix system reconfigure ..' everything with new option that the grub is on a separate partition /dev/sda3?
<antelope>because on this computer windows manager boots everything
<antelope>but it can get grub but not linux kernel
<antelope>ok, thank you, I will try myself, have a good night and good day to morrow:)
***atw` is now known as atw
<baconicsynergy>xiug ih
<Petter>kiug olleh
<lfam>ydwoh
<civodul>howdy lfam :-)
<lfam>You figured out the cipher!
<lfam>Anyone have some ideas about this documentation build failure for the latest version of the i3 window manager? http://paste.lisp.org/display/333291
<lfam>The package does include docbook-xml 4.5. I'm not sure if the build system is trying to download that, or some other thing
<rekado_>it’s trying to download the dtd
<rekado_>for validation
<rekado_>if it uses xsltproc you can pass --nonet
<lfam>rekado_: I'm looking at the package definition of udisks and wondering if I need to do something like its #:make-flags
<lfam>It doesn't use xsltproc from what I can tell
<civodul>lfam: i think you need to add xslt as an input, which will define the XML or XSLsomething variables that you need
<civodul>and maybe libxml2 as well
<lfam>Providing libxml2 did make the XML validation error go away
<civodul>great
<lfam>Setting XML_CATALOG_FILES as in (gnu packages udisks) made the rest of it work, too
<lfam>Now to tackle the failing test suite :)
<civodul>of udisks?
<civodul>lfam: so are we building 'staging' yet? :-)
<lfam>civodul: No, the failing test suite of i3
<lfam>Staging should be building. I asked Hydra to evaluate the new staging jobset 1 or 2 hours ago
<lfam>Hm, perhaps it's not. Looks like the evaluation failed
<lfam>ACTION looks into it
<lfam>civodul: "No space left on device" https://hydra.gnu.org/jobset/gnu/staging#tabs-errors
<lfam>Also, there are very many "possible unbound variable" warnings in that log
<civodul>baah
<civodul>well there's some space left right now
<civodul>maybe mark_weaver run the GC in the meantime?
<lfam>Should I remove the python-build-system jobset?
<ng0>i'm currently (well next 4 - 12 hours) building libreoffice and will submit a patch, once it is functional, which adds the libreoffice symlink to it
<ng0>I think it's illogical to have the soffice only.
<civodul>lfam: you can mark it as "disabled" and "hidden" (rather than actually removing it)
<lfam>Okay
<lfam>It seems to already be the case :)
<albertoefg>lfam hello
<lfam>Hi albertoefg!
<albertoefg>:)
<albertoefg>how are you my friend
<lfam>Okay, but sad because of the party that burned in Oakland, California yesterady morning. I am connected to those people...
<lfam>My friends are okay but their friends are not
<lfam>I guess it's off-topic for this channel
<albertoefg>??
<albertoefg>link?
<lfam> http://www.nytimes.com/2016/12/04/us/warehouse-party-fire-oakland-search.html
<albertoefg>i am sorry man :(
<lfam>I'm okay... I'm trying to send kindness to my friends in California
<lfam>A huge part of their community died
<civodul>:-(
<atw>.
<sneek>atw, you have 1 message.
<sneek>atw, rekado says: To get around a “410 Gone” add “--fallback” to the command you were running.
<albertoefg>:(
<albertoefg>sneek
<sneek>Someone once said sneek is a *silly* bot
<albertoefg>sneek help
<albertoefg>sneek what is gnu
<ng0>sneek: what is the meaning of life
<albertoefg>sneek
<sneek>I've heard sneek is a *silly* bot
<lfam>Sneek agrees, there's no satisfying answer
<albertoefg>sneek: what is free software
<albertoefg>sneek: where is California
<albertoefg>sneek tell lfam hello
<sneek>lfam, albertoefg says: hello
<lfam>sneek: Have a botsnack for delivering that message to me!
<sneek>:)
<lfam>sneek: later tell albertoefg: Maybe we play hedgewars later :)
<sneek>Got it.
<albertoefg>oh
<sneek>albertoefg, you have 1 message.
<sneek>albertoefg, lfam says: Maybe we play hedgewars later :)
<albertoefg>why somethings don't work?
<lfam>Some sneek things?
<albertoefg>yes
<lfam>Like what?
<albertoefg>how do you add a bot
<albertoefg>like when i ased where or what and sneek didn't answer :/
<lfam>sneek doesn't know everything :)
<lfam>I think you can teach sneek things, however
<albertoefg>oh i thought sneek loked at google or something like that
<albertoefg>:)
<albertoefg>sneek who is lfam
<albertoefg>sneek: who is albertoefg
<albertoefg>sneek who is lfam
<lfam>You can ask me, I'm right here :)
<albertoefg>lol
<albertoefg>how can i add a bot to lgn
<albertoefg>do i have to be OP?
<lfam>I don't know where sneek comes from...
<lfam>Sometimes sneek goes on vacation for a few days or even weeks. That's fine. Everyone should be able to do that
<rwp>lfam, Two steps forward and one back. I snagged on git clone --depth 1 in both git:// and http:// for different reasons.
<rwp>So you will have noticed the IP flip back again. But regardless I feel some progress is being made because everything else was working well.
<lfam>rwp: Sounds like there are a lot of moving parts. Thanks for tending the Savannah :)
<rwp>There are a lot of moving parts. And with git I am at least familiar.
<rwp>I dread getting down to hg and bzr where I have never used those tools.
<rwp>Or tla too for that matter. That one is on the list too.
<lfam>Hm, indeed. I don't know them either.
<lfam>Do you think you can reach out to the projects that are using those tools?
<rwp>I will worry about that bridge when I get there. First things first.
<lfam>Yes, that's always a good plan when things seem overwhelming. No point carrying that dread the whole way
<rwp>Yes. At the moment I am stepping through the debugger in git-daemon to try to understand where it is making decisions.
<rwp>But then it does various fork() calls to handle connections. Which takes a little more setup to debug. But making progress.
<ng0>96°C compiling... i should take my laptop outside, environment to cool it down
<lfam>96°C ?!
<atw>I'm trying to use connman-service, but when I reconfigure I'm getting "'networking' requires 'wpa-supplicant', which is not provided by any service". Do I need to add another service or package to my config.scm?
<rwp>That is quite warm.
<ng0>yeah, libreoffice
<ng0>it gets warm
<ng0>outside it's around -5
<lfam>atw: That's a longstanding bug, but I thought we'd fixed it recently. Have you updated your Guix with `guix pull` recently?
<atw>hmm, thought I just did...
<rwp>I would blame insufficient airflow through your laptop. Some of those are not designed for continuous high workload.
<lfam>atw: Hm, try adding the wpa-supplicant service to your services field?
<lfam>ng0: I'd keep it inside to warm up my home ;)
<lfam>atw: See commit e25c904f2c7995f0e241f9ec0b6ea1a26f1df127
<atw>I just did a sudo guix pull, but I did point root's guix to one I compiled, so that might be complicating things?
<atw>will try. Is it just (wpa-supplicant-service) or...?
<lfam>If you pointed root's Guix to the one you built from Git, that will override an earlier `guix pull`. So your Git repo would need to be built with that commit for it to have an effect when reconfiguring the system. But, I'm not sure exactly how to use the connman-service, so I'm not sure if you are seeing the results of the commit or not.
<lfam>The wpa-supplicant service should be documented in the manual
<lfam>If efraim is around, he is the person that added the connman-service. Maybe he can help you
<atw>I pointed root's guix to my own build, then did guix pull
<lfam>Oh, your own non-Git build? Okay, then you should be up to date
<lfam>Just to clarify, `guix pull` and symlinking ~/.config/guix/latest to something you built are mutually exclusive. Doing one will override the other
<lfam>They both build Guix from source and make a symlink from ~/.config/guix/latest to the built Guix.
<atw>ah, right
<atw>after my sudo guix pull, that symlink was modified a few minutes ago
<atw>so I am up to date
<lfam>You could also check the recent guix-devel and bug-guix archives for discussion of these services. They *should* work now :)
<atw>lfam: thanks for the help, I
<atw>will do my reading ☺
<lfam>Okay! Like I said, it should work. If you can't get it to work, please file a bug :)
<lfam>Or send a message to help-guix@gnu.rog
<lfam>help-guix@gnu.org