IRC channel logs

2016-11-26.log

back to list of logs

<adfeno>Hi all! How can I force Guix to "recompile" a package recipe (the .scm file, so as to turn it into a .go file)?
<adfeno>Currently, every Guix command warns me that samba.scm is newer than compiled .go file.
<rekado>adfeno: run “make” in the working directory
<adfeno>rekado: Do you mean: Go to ".config/guix/latest" and do `make`?
<adfeno>Hm...
<adfeno>Perhaps I can use Guile to try to compile samba.scm again
<adfeno>It is actually the original samba.scm file that came from my latest `guix pull` (previously, I was trying to work on a bug involving Samba configuration file, but I successfully reverted the patch using `patch -p1 -R`, so it should be working now).
<adfeno>Also, my **current** attempt to do `guix pull` results in failure about a missing "ssh"-related module.
<adfeno>My last successful `guix pull` was one week ago.
<albertoefg>adfeno
<albertoefg>hello
<adfeno>Hi alberto :)
<rekado>adfeno: do you use “guix pull” only or Guix from git?
<albertoefg>how are you
<rekado>you should only get the warning about a newer scm file if you have changed the sources.
<adfeno>rekado: I don't use Guix from git.
<adfeno>rekado: Indeed, I did change the sources so that I could test a patch that tries to fix a problem with Samba.
<adfeno>albertoefg: I'm fine. :)
<albertoefg>you haven't been on Trisquel
<rekado>adfeno: when you use “guix pull” shouldn’t the sources be immutable?
<albertoefg>Do you still have problems with openmailbox.org on Thunderbird
<rekado>adfeno: did you remount /gnu/store as read-write?
<rekado>adfeno: this should not be done. Things in the store should never be modified by anyone.
<adfeno>Hm... I see...
<adfeno>↑ rekado
<adfeno>(conversation with albertoefg moved privately)
<rekado>adfeno: if you want to play with the packages guix provides I suggest using Guix from git.
<rekado>adfeno: alteratively you could have custom package definitions and add them by setting the environment variable GUIX_PACKAGE_PATH.
<rekado>ACTION —> zzZZ
<adfeno>Hm.... Indeed...
<adfeno>Is it possible to use guile command to compile samba.scm to a .go file in the same directory?
<baconicsynergy>hiyo!
<sneek>Welcome back baconicsynergy, you have 1 message.
<sneek>baconicsynergy, alezost says: you need to use a variable, not a string, so it should be: (kernel linux-libre-4.4)
<baconicsynergy>sneek later tell alezost thank you very much. I'm getting an 'unbound variable: linux-libre-4.4.33' error
<sneek>Will do.
<baconicsynergy>thanks sneek
<baconicsynergy>is there a module i need to declare prior?
<ng0___>seems like one of the latest offloading commits broke master
<baconicsynergy>yup, can confirm
<ng0___>I can't paste the error, this is on the system which I am setting up
<ng0___>(no code for module (ssh key)) #f) and so forth
<baconicsynergy>thats the one
<adfeno>Yep.
<adfeno>Got this one too.
<adfeno>While doing guix pull.
<adfeno>Loading goes fine, but compiling gives ths error.
<adfeno>I thought that it had to do with my wrong-doing of patching my samba.scm file. But it's not related.
<adfeno>(and also, I didn't commit anything, :D)
<ng0___>there were some offloading and guile-ssh commits
<ng0___>seems related to that
<ng0___> ut I can't check atm
<baconicsynergy>ng0___: when declaring a specific kernel, I'm getting an unbound variable error. do I need to declare a module?
<ng0___>idk at the moment. unbound variable, you need to load that module first, whatever it is
<ng0___>where/however you define your package modules
<adfeno>About my problem with patched-and-reverted samba .scm and .go files: I managed to make their modification times equal to the others in the same directory.
<ng0___>in my case (use-package-modules linux) it would be
<baconicsynergy>awesome ty let me try it out
<adfeno>... (and the note about sources newer than compiled ones disappeared)
<baconicsynergy>ng0___: step in the right direction, it works properly when i only specify (kernel linux-libre), but i want to specify 4.4.33. hmmmmm
<adfeno>If you excuse me, it's late night here. :) So I must give my eyes some rest. See you tomorrow, Bye!
<baconicsynergy>gniht
<baconicsynergy>ng0___: nvm, i got it! i had to specify 4.4, not 4.4.33
<baconicsynergy>cool cool cool lets get x back up and running!
<ng0___>take a look at the content of the file and the name of the package if you are not sure
<ng0___>i'll stick around one more hour, but I guess it'd be solved tomorrow only. can someone report the broken master on the mailing list?
<baconicsynergy>awesome success with the kernel downgrade, everything is working perfectly again
<baconicsynergy>ty for helping me with my stupid questions
<ng0___>adfeno: can you post the problem to the mailing list? I have no access to email right now and I'm off now
<ng0___>ciao
<Haworth>Hello everyone. I may be a bit out of my depth here, but I was wondering if it is possible to convert the GuixSD USB installation image into a bootable disk image.
<Haworth>As in, for burning on a DVD.
<jroh>Is there a good way to have `guix pull` use an older tarball of guix-latest? I keep getting an error from guile-ssh or something on a fresh install and if I reconfigure to update my config I seem to be getting downgrades because I haven't had a good pull yet.
<lfam>jroh: I'm looking into it
<lfam>jroh: If this problem is in the recent changes to the SSH offloading code, you can download a snapshot of the Git repo from before that change. For example, from this commit: http://git.savannah.gnu.org/cgit/guix.git/commit/?id=6634180f9eabc70cdc5bc8e9ce2ff0f9250625bc
<lfam>You want the "download" link that gives a tarball
<lfam>Then, do `guix pull --url=/path/to/tarball`
<lfam>I'm testing that commit now, but it seems like a good bet
<lfam>Remember that `guix pull` is per-user, so you'll need to do it for each user that you want to have the latest Guix packages
<jroh>Thanks! I'll give that a shot
<lfam>jroh: Using that commit worked for me.
<jroh>sweet. looks like it worked for me too
<Sleep_Walker>what can I miss if mount looks for mount.nfs on wrong places?
<Sleep_Walker>hm, it seems that mount from util-linux is not able to look for mount helpers elsewhere
<ng0___>civodul: I am pretty sure this is the commit which broke master. http://git.savannah.gnu.org/cgit/guix.git/commit/?id=21531add3205e400707c8fbfd841845f9a71863a
<ng0___>ah, not around.
<ng0___>sneek, later tell civodul: I am pretty sure this is the commit which broke master. http://git.savannah.gnu.org/cgit/guix.git/commit/?id=21531add3205e400707c8fbfd841845f9a71863a
<sneek>Will do.
<ng0___>sneek: later tell civodul: https://ptpb.pw/_Z9_
<sneek>Will do.
<ng0___>sneek: later tell civodul: never mind, i just checked my inbox and saw someone else reported on it already.
<sneek>Will do.
<iyzsong>hello guix!
<Petter>Hello Guik! :P
<rekado>ng0__: have you installed Guile SSH?
<iyzsong>ah, guix pull is broken, with ("no code for module" (ssh key))
<ng0__>rekado: no, this is in the install medium
<ng0__>if however guile-ssh is an requirement now and not an option, I'll create my own image
<iyzsong>I installed guile-ssh, but 'guix pull' still fail. It seems we should add it to 'build-aux/build-self.scm' like guile-json.
<ng0__>can you make the change and test?
<ng0__>I have no usable device atm to do this
<iyzsong>ok, I'm trying.
<iyzsong>ng0__: fixed :-)
<ng0__>thanks :)
<ng0__>not entirely though
<iyzsong>ah, oops.. and I wrote a wrong commit message.
<ng0__>i have to compare wether this is on both systems
<ng0__>but I guess so due to the nature of guix
<ng0__>hmm
<ng0__>on this system it works
<ng0__>in the 0.11 install medium it doesn't
<ng0__>i'll create my own image then
<ng0__>I'll try to paste the error output
<ng0__>so someone can or can not fix this
<ng0__>iyzsong: for live systems it is fixed
<ng0__>output from within the 0.11 medium is coming in a few moments
<iyzsong>yeah, ok.
<ng0__>damn, curl did not fetch the error message
<ng0__>it's something about ssh/log and 'in procedure dynamic-link: file: "libguile-ssh", message: "file not found"
<iyzsong>um, the guile-ssh's *.go files are broken before commit 92b7258, and I add that to load-compiled-path. so it fails when run 'pull' with guix before that commit (as the 0.11 install media)..
<ng0__>ah, ok
<ng0__>i'm just creating a new one
<baconicsynergy>good morning guix
<iyzsong>baconicsynergy: morning!
<boegel>anyone in here involved with the GNU Guile devroom at FOSDEM'17?
<jmd>boegel: Dunno. I offered to talk there, but I haven't heard anything yet.
<boegel>jmd: I was wondering when the announcements would go out...
<wingo>guix package: error: kcachegrind: unknown package
<wingo>noooooo
***lashdu is now known as drtan
<baconicsynergy>im thinking about writing a song about guix, using guix
<baconicsynergy>i've got ardour and thats all i really need record mix and master
<baconicsynergy>i'll license it under the FAL too lol
<Petter>Cool! :)
<Petter>What kind of music do you make?
<baconicsynergy>All sorts! I love post rock, mathy shit, and jazz
<baconicsynergy>I don't like to limit muhself tho
<baconicsynergy>brb gotta run a quick errand
<alezost>baconicsynergy: hi!
<sneek>Welcome back alezost, you have 1 message.
<sneek>alezost, baconicsynergy says: thank you very much. I'm getting an 'unbound variable: linux-libre-4.4.33' error
<alezost>as I told it should be linux-libre-4.4, but I see you figured it out :-)
<efraim>i'm working on the gst-plugins-good CVEs
<lfam>efraim: I'm about to push fixes for CVE-2016-{9634,9635,9636}
<efraim>lfam: oh good, I got stuck in a loop between debian's 4 patches and everyone elses 2 patches and all the different branches of their trees
<lfam>Yeah, it's a pain
<lfam>I'm using the 4 patches
<efraim>its 4 patches in their 1.10 branch
<efraim> https://cgit.freedesktop.org/gstreamer/gst-plugins-good/log/?h=1.10
<lfam>The 4 commits starting with "flxdec: add some write bounds checking", right?
<efraim>yeah, the 4 flxdec patches in a row
<lfam>I gotta say, Red Hat's fix makes a lot more sense to me now ;) https://bugzilla.redhat.com/show_bug.cgi?id=1397441#c3
<efraim>"no more FLC videos for you!!"
<lfam>efraim: Pushed!
<efraim>yay!
<lfam>I guess we'll be seeing a lot of gstreamer patches soon
<efraim> http://site.icu-project.org/download/58 looks like its time to update icu4c in core-updates
<efraim>jasper is still getting hammered, i'm about to start pulling individual commits while waiting for the next make-dist release
<lfam>At least jasper doesn't have many users
<lfam>efraim: Looks like we need to add the icu-project.org home-page to the list of source URLs for icu4c. Sourceforge doesn't have the two latest releases
<efraim>I was just going to move it
<lfam>I saw in the log that there was an issue with the URL in the past. I wonder if it will work for us now
<lfam>Sigh, they sign an MD5 hash of the tarball...
<efraim>yeah, thats a WTF for me
<lfam>Well, okay, you'll take care of it? :)
<efraim>sure
<lfam>Old habits die hard
<efraim>do you want cve-2016-9559 for imagemagick?
<efraim>it says fixed in 7.0.3.7, don't know if its in 6.9 also
<lfam>efraim: It was fixed in 6.9.6-5 (commit 1c795ce9fe1d6feac8bc36c2e6c5ba7110b671b1), we have the fix
<efraim>ok
<lfam> https://github.com/ImageMagick/ImageMagick/commit/1c795ce9fe1d6feac8bc36c2e6c5ba7110b671b1
<drtan>Hi! Have you ever thought to make Guix the GNU operating system. That is a distribution that integrates all GNU projects into single user experience?
<albertoefg>drtan: I am not sure if all GNU projects are suited for everyone
<efraim>lfam: i assume 6.9.6-5 also covers cve-2016-9298
<lfam>efraim: That was fixed in 6.9.6-4 (commit d2d9c8feb028570c592a438a5f4d4191391402bd): https://github.com/ImageMagick/ImageMagick/commit/d2d9c8feb028570c592a438a5f4d4191391402bd
<lfam>I update imagemagick when I see a new release. Usually the CVEs are not named by the time I push
<drtan>Well, there are not that many desktop environments. GNOME seems to play its own game and WindowMaker/GNUstep doesn't receive much care.
<drtan>I'm looking from the perspective of a typical, non-IT user. I wonder what should be done to create that kind of integrated experience where everyone seems to play in isolation.
<lfam>Of course we'd welcome the efforts of other GNU hackers if they wanted to focus on Guix. But it's up to them
<drtan>This is not I want to complain or look for fault. I am genuinely keen to help, but I can't find a place to start.
<lfam>drtan: You are interested in a distro that relatively unskilled users can use with different desktop environments? Is that what you're interested in?
<lfam>If we define your goal more clearly, we can think of some ways to achieve it :)
<drtan>Let's say I want to build a full featured graphical installer for Guix. Should I build it with GTK3 assuming GNOME is the best option for Guix or with GNUstep libraries, to push something more GNU-friendly.
<drtan>Yeah, I want freedom for unskilled users first and Guix is such an amazing FSDG-compliant distro.
<lfam>Hm, good question. I'd say it's up to you. They are both GNU projects. I think that GNOME will appeal more to users who are coming from the popular non-free operating systems. Those users are most likely to be unfamiliar with GNU / Linux, and thus they will tend to prefer a graphical installer, in my opinion
<lfam>OTOH, I bet that the GNOME installer will be larger and require a more powerful computer than the GNUstep installer
<lfam>So there's a trade-off
<drtan>I use GNOME by myself, because of its maturity. The show stopper however is that it goes many times against software freedom and bad design (like the systemd issue).
<lfam>How does GNOME deny freedom to users?
<drtan>GNOME encourages users to have Facebook or Google accounts.
<orbea>o.O
<orbea>why?
<drtan>Latest improvements integrate whatever is as sharing features and file manager integration.
<drtan>I don't know.
<orbea>well, i wasn't going to use gnome anyways...
<lfam>That's in poor taste, but I don't think it violates the four software freedoms. I don't know what it means with respect to the FSDG
<orbea>google and facebook certainly violate those freedoms
<drtan>I don't think either, but it bothers me personally.
<orbea>and suggesting to use something that does is bad enough
<drtan>I would expect more careful approach from a GNU project.
<drtan>Do you see the future of Guix in hands of unskilled users?
<lfam>What do you mean?
<drtan>I mean a user profile of the distro. Would you classify Guix as a distro for advanced users only?
<lfam>It's not a goal of the project to be for advanced users. But it's a young distro, so we don't yet have all the bells and whistles like graphical installers
<lfam>It depends on if people want to make those things. It's not an explicit goal to support bioinformatics research, but we do, because several people from that field contribute to Guix and use it in their work
<lfam>I don't that GuixSD is fit for totally non-technical users right now. At least, they'd struggle to install it
<lfam>Once installed, they might find it harder to break than something like Ubuntu, however
<drtan>Let me be honest with you. I find Guix very interesting distro and I thought I would talk to you to see if integrating any of known graphical environments as a default would be a better option.
<lfam>I think we'd be interested in a graphical, or even ncurses, installer.
<lfam>There isn't really a "default" system, though. We offer a few templates for bare-bones, desktop, and lightweight-desktop systems
<drtan>Yes, freedom is also about choice, so I understand this. Although having different installer for all of them would be difficult to maintain. ncurses installer seems like middle ground option then.
<lfam>There has been some discussion about this subject: http://lists.gnu.org/archive/html/guix-devel/2016-03/msg01024.html
<lfam>And possible other threads
<ng0>ncurses would not work for possible future touch scree compatible devices though.. but you have to start somewhere (and I don't have such devices)
<lfam>I think it's okay to work on supporting one class of device at a time
<ng0>yes
<ng0>"you have to start somewhere"
<drtan>After installation, users have to manage software. GNOME has nice integration with PackageKit. So it would be an easy one. But GNUstep is so tempting. :)
<lfam>I think you should work on the thing that interests you. Motivation is not fungible :)
<Haworth>Speaking of installation, I've been wondering if it's possible to convert the usb installation image into a format I can burn to a DVD.
<drtan>I have got a vision of GNU OS, because there is so much good GNU software that doesn't receive enough publicity. I feel so frustrated that noone from programmers I know, know what GNU is.
<lfam>Haworth: I don't know how to burn a DVD, but I'm sure that is possible
<lfam>And I'd be interested in learning how :)
<Haworth>Was burn the wrong term to use?
<lfam>No, I simply don't know how to take the installer image and put it on a dvd
<drtan>It probably requires some conversion to ISO file format.
<Haworth>Right, but I think the first step would be somehow accessing the contents of the usb installer which, according to something I read yesterday, is just a raw disk image.
<lfam>Exactly, you put it on a USB stick with `dd`
<lfam>And then boot from the USB stick
<ng0>should iso be a goal? are there still old computers who can't boot from usb? I wanted it for some time, but I think almost no one uses iso unless their hardware requires it
<ng0>or does it make installing for vps providers easier?
<lfam>That's why I want to make an ISO, to use GuixSD on a VPS
<lfam>Does anyone know how? :)
<paroneayea>if we could get to the point where we have a usb stick with dd, iirc it isn't too hard to develop an ISO also.l
<Haworth>Well, I'm not saying it should be a goal for the project - It's just something I'm personally trying to accomplish.
<paroneayea>so we can focus on the USB stick and worry about the ISO after
<lfam>Since new computers generally don't have optical drives, I don't think we should use ISO by default
<ng0>but I just remembered, for my project I need to have iso as an option in addition to the raw image and pre-installed devices
<ng0>from what I heard it should be easy (iso)
<drtan> http://askubuntu.com/questions/240803/convert-bootable-usb-to-iso-file
<drtan>I read in an answer that you can employ dd for conversion.
<lfam>Xorriso looks like a promising tool for this
<civodul>lfam: just like we have the code that makes the USB image, we could have code that runs xorriso to create an ISO image
<sneek>civodul, you have 3 messages.
<sneek>civodul, ng0___ says: I am pretty sure this is the commit which broke master. http://git.savannah.gnu.org/cgit/guix.git/commit/?id=21531add3205e400707c8fbfd841845f9a71863a
<sneek>civodul, ng0___ says: https://ptpb.pw/_Z9_
<sneek>civodul, ng0___ says: never mind, i just checked my inbox and saw someone else reported on it already.
<lfam>civodul: Yes, I'm poking around :)
<civodul>cool :-)
<civodul>we could have 'guix system iso-image' or something
<ng0>civodul: fixed. though I had to throw out my optical drive as it is indeed as stated in libreboot documentation one of the failing ones
<ng0>other than that, i think I have to dive a bit more into grub and libreboot to get all out of this new luks option
<civodul>ng0: did you notice anything wrong with LUKS support?
<ng0>no, just differences between lenovo bios and libreboot devices, that's all
<orbea>why libreboot?
<orbea>the dev is not a good person...
<ng0>people in general are not good persons
<ng0>this is too offtopic for this channel.
<orbea>well, if you want to deal with someone that started that drama on the gnu mailing list I guess that is your call
<buenouanq>lol
<lfam>Please, let's refrain from saying things like "not a good person" in this channel :)
<orbea>should I been more specific?
<orbea>i was honestly being as tactful and nice about the subject as possible...
<ng0>I don't want this discussion.
<lfam>No, I mean saying negative things about individuals is off-topic in this channel.
<orbea>I was talking about libreboot, the individual is very on-topic to the software.
<orbea>but I guess you could just say libreboot is off-topic :shrug:
<lfam>We frequently discuss how to use libreboot with Guix. But let's keep this channel's vibes positive
<paroneayea>lfam: +1
<orbea>so nothing negative should ever be said even if there is good reason to say it?
<buenouanq>musicians are not their music, artists are not their art, devs are not their projects - the author is dead. now let's all get along~
<drtan>Yes, discuss software not people.
<orbea>i guess this place is not a good fit for me
<orbea>bye
<lfam>Hm :( I wasn't trying to be rude
<paroneayea>I think you were describing things in a polite request
<paroneayea>I wouldn't stress it lfam
<paroneayea>unrelated: anyone notice in rhythmbox that sometime recently many streaming "radio" connections have started to be a little bit skip'y?
<paroneayea>I've been noticing this on somafm stations especially, but I try it on other computers and I'm not having problems there, nor with local music.
<drtan>It's been like that for at least a year or two for me.
<paroneayea>drtan: really? I haven't had that issue until recently. It doesn't seem like network lag.
<drtan>A year ago I wanted to use it as my radio player and whatever stream I entered it failed.
<drtan>And I had the same problem earlier. Just one one of built in streams worked.
<drtan>I didn't dig into the problem though.
<paroneayea>hm ok. this is a pretty specifically recent change for me.
<paroneayea>maybe I could try rhythmbox from one of my old profiles.
<lfam>git-bisect your distro
<lfam>:)
<paroneayea>yeah, we need "guix bisect" :)
<buenouanq>M-x figure-it-out
<buenouanq>M-x do-what-i-want-not-what-i-type
<lfam>I have a patch for that in one of my old branches...
<drtan>It made me to check the latest version. Version 3.4.1 seems better.