IRC channel logs

2016-11-02.log

back to list of logs

<OriansJ>those of you who are following my stage0 project. I just added a forth interpreter to the bootstrap toolset. Up next is the lisp interpreter, followed by the C compiler than we are home free
<civodul>sounds fun
<civodul>you should send an update/summary to guix-devel
<civodul>and maybe team up with janneke?
<civodul>ACTION -> zZz
<holamundo>hi!!! does anyone know of a good guide to building packages for guixsd? i have almost ported a package but i am struggling a bit with the package definitions.
<holamundo>note: i read the manual ;)
<bavier1>holamundo: the manual, and maybe just perusing the existing packages
<bavier1>OriansJ: definitely send an update to guix-devel, I'd be interested to hear more about your project
<bavier1>I'm off-and-on playing with the bootstrap-compiler idea too
<OriansJ>bavier1: it is literally a full bootstrap from a single 280 byte binary [Hex monitor] to include a text editor, assembler, linker and now a forth. Each piece written in the pieces created before them and the core binary is available in hex and assembly [Only 160 instructions]
<OriansJ> https://github.com/oriansj/stage0
<OriansJ>With prototypes written in C for some of the harder to grep pieces, lots of comments and a VM which can run in under 64KB
<OriansJ>Its been largely a fun hobby for me. But to be honest a few of the parts needed to do a proper hex bootstrap were a MASSIVE pain in the ass.
<OriansJ>creating the text editor, using only a hex monitor was a serious lesson in patience. Creating the web IDE in python and having it load a library built from the source of the VM was actually alot of fun
<OriansJ>all of the pieces have fully deterministic builds and produce identical checksums, even when run on some quite exotic hardware.
<davexunit>mesa 13 is out http://www.phoronix.com/scan.php?page=article&item=mesa-13&num=1
<davexunit>core-updates? ;)
<lfam>sneek: later ask rekado: I wonder if you seeing this issue in the icecat crash? <http://seclists.org/oss-sec/2016/q4/44>
<sneek>Will do.
<lfam>Seems like an expensive bug to exploit if the patch summary is correct. It would require targets to download images > 4 GBhttps://bugs.freedesktop.org/show_bug.cgi?id=98165
<holamundo>re: icecat: icecat crashes for me every few hours, and submitting a report fails. i would if i could but don't have time to spend on it
<lfam>I made icecat crash in < 5 minutes by visiting youtube, twitter, and some local news sites
<holamundo>:D
<Apteryx>ng0: Regarding your choice of Linux-libre... I do think it's nice to buy unblobbed hardware when available. ThinkPenguin have cheap wifi USB dongles using free firmware.
<Apteryx>And probably have the equivalent for bluetooth. Although I agree that using all your usb ports on a laptop to replace working but blobbed hardware is not ideal...
<Apteryx>I was under the impression that it's still possible to use blobs with Linux-libre if you *really* mean it.
<kadintrooper>Hallo
<Apteryx>Hey, hi
<kadintrooper>Hello again
<kadintrooper>Turns out the install to the .img didn't work :/
<kadintrooper>Straight up wont boot
<kadintrooper>I guess I'll have to try again
<Apteryx>kadintrooper: :(. Did you have some error output?
<Apteryx>*Did you get some errors
<kadintrooper>Nope
<kadintrooper>Not that I'm aware of anyway
<kadintrooper>is guix generally slow to install things?/
<kadintrooper>Or is it just the fact that I'm running it in a vm
<Apteryx>kadintrooper: It really depends on the packages you install.
<Apteryx>Some are huge and pull in tons of dependencies, some are light and simple.
<Apteryx>Also, sometimes when Guix cannot find a pre-built "derivative" (someone correct me if my terminology is wrong), it has to build it from source and this can be long.
<kadintrooper>Ah
<kadintrooper>I can't install anything because it can't find /etc/resolv.conf
<kadintrooper>:/
<kadintrooper>I need to run this on a usb but I can't find one lol
<Apteryx>Yeah, I got that too! It seems the file is empty by default. I had to use the installed wicd-client to set some static DNS addresses which I got from my IP. Not sure if this is a bug or if I should be configuring something more in my config.scm.
<Apteryx>wicd will manage /etc/resolv.conf
<Apteryx>If you don't configure it it's quite possible it clears it every boot.
<kadintrooper>I think I found the issue
<kadintrooper>For the /etc/resolv anyway
<Apteryx>Maybe an option would be to uninstall wicd and put the DNS addresses by hand in /etc/resolv.conf... That's on my todo to learn how to fix this from the declarative config.
<kadintrooper>Alright that fixed it
<kadintrooper>ifconfig ens3 up
<kadintrooper>dhclient -v ens3
<kadintrooper>:)
<Apteryx>Eh! Do you have wicd installed? I think it's part of the default %desktop-services.
<kadintrooper>I'm in the install iso rn
<Apteryx>OK :)
<kadintrooper>I kinda wanna try installing to the .img again but I also kinda want to wait until I have a usb so I can actually install it to my hdd
<Apteryx>kadintrooper: How did you do it to install the .img, the last time?
<kadintrooper>guix init /dev/sda1 or whatever the command is
<kadintrooper>Er
<kadintrooper>/mnt/
<kadintrooper>I followed the install guide
<Apteryx>And guix was running in the VM?
<kadintrooper>Yes
<Apteryx>err, guixSD
<kadintrooper>Yes
<Apteryx>The thing is then GuixSD wouldn't see your real hard drive, rigt? But an virtual drive. So how did you mount the actual (physical) partition you wanted guixSD to install itself to?
<kadintrooper>No it was just a .img
<kadintrooper>qemu-system -drive file=guixsd.img
<kadintrooper>along those lines
<kadintrooper>I wonder if that would work for an actual drivce
<kadintrooper>drive
<kadintrooper>just -drive file=/dev/sdx
<kadintrooper>hmmmmm
<Apteryx>OK, so you ran guixsd directly from the .img, this I understand..., but you followed the installed guide and installed it to where exactly?
<Apteryx>Ah, you installed it to the guixsd.img?
<kadintrooper>Yes
<kadintrooper>I ran it from the usb install image
<Apteryx>Would be interesting indeed to use an actual partition as -drive file=...
<kadintrooper>mhm
<Apteryx>But before you try anything, you said it didn't work; so you followed the installation procedure to install it onto your guixsd.img, and it wouldn't boot after it finished successfully?
<kadintrooper>Correct
<Apteryx>Are you sure you got the grub configuration part of the config.scm right? I remember it confused me a bit at first!
<kadintrooper>Uh
<kadintrooper>Grub install did fail
<kadintrooper>But I thought I could boot right from the hdd
<kadintrooper>err, .img
<Apteryx>You still need grub
<Apteryx>:)
<kadintrooper>aaaa
<kadintrooper>but why
<kadintrooper>"grub-install: error: failed to get the canonical path of `unionfs'
<Apteryx>Well, you always need a bootloader to start anything, right?
<kadintrooper>I don't use grub for my arch install
<kadintrooper>I just boot straight off the ssd
<Apteryx>What do you use?
<kadintrooper>Nothing
<Apteryx>That's news to me. Do they have a wiki page explaining how it works?
<kadintrooper>Not that I'm aware of
<kadintrooper>It just worked
<kadintrooper>Ugh I really don't want to go through the entire install guide again
<Apteryx>There probably is one installed for you, and you don't need to be aware of it.
<Apteryx>From archlinux's "boot loaders" page: "In order to boot Arch Linux, a Linux-capable boot loader must be installed to the Master Boot Record or the GUID Partition Table. It is the first piece of software started by the BIOS or UEFI. It is responsible for loading the kernel with the wanted kernel parameters, and initial RAM disk before initiating the boot process."
<kadintrooper>My drive is encrypted, turn the computer on, put in my password and kicks me to tty
<kadintrooper>Must be a bootloader then, but not grub
<kadintrooper>Maybe it's the systemd one
<Apteryx>OK! Possible! Never tried that one yet.
<kadintrooper>Gonna try a reinstall, brb
<Apteryx>Good luck! Make sure the grub install passes.
<kadintrooper>So
<kadintrooper>What was the issue with the grub install
<kadintrooper> https://i.sli.mg/JWb9Tl.png
<kadintrooper>I just want to make sure I don't f it up again lol
<kadintrooper>Apteryx: Do you see any issues with this?
<Apteryx>kadintrooper: Looks OK, assuming your device is /dev/sda and your partition is ext4 with label of "my-root".
<kadintrooper>indeed
<kadintrooper>I will try this again
<Apteryx>It's exactly the same as mine :)
<Apteryx>OK!
<kadintrooper>Hopefully it works this time
<holamundo>syslinux?
<kadintrooper>I'm not sure how long it takes to complete, I do need to sleep at some point in the next few hours
<kadintrooper>holamundo: Possibly
<Apteryx>kadintrooper: Haha! I remember when failing the grub install step I could edit the file, rerun the guix sytsem init and it would skip over what was already done.
<Apteryx>So just don't reboot until you get it right. Worst case leave your system running, and get good sleep! You might find what's wrong with a fresh mind!
<rekado>lfam: I don’t think this is the bug I’m seeing.
<sneek>rekado, you have 1 message.
<sneek>rekado, lfam says: I wonder if you seeing this issue in the icecat crash? <http://seclists.org/oss-sec/2016/q4/44>
<rekado>It crashes sometimes when “cairo_surface_destroy” and finally “_cairo_xlib_shm_surface_flush” is called. libX11 is the one complaining, it seems.
<lfam>rekado: Yeah, I after thinking about it for a while, it seemed implausible
<marusich>Icecat crashing? Funny, mine just crashed, too...
<lfam>Does it work when using skia instead?
<lfam>Maybe we can select that while compiling
<amz3>sneek: later tell civodul yes the bindings make good progress
<sneek>Got it.
<amz3>sneek: later tell civodul can you explain me in layman terms how you need to do with libgit2?
<sneek>Got it.
<rekado>with skia I don’t get crashes (so far), but some fonts are poorly rendered.
<ng0>mornin'
<ng0>guix reconfigure finished succesfully over night
<ng0>from core-updates
<amz3>\\o/
<ng0>on x86_64 system
<lfam>Yay
<ng0>commit_ 40330e555f2548d738fbcfac6fa5d80ab1bb2eb2
<rekado>nice!
<marusich>cool. I'm reconfiguring right now, actually.
<rekado>I’m still trying to make space on my machine…
<ng0>btw: new curl release
<ng0>I'll work on new gnurl release this evening, I just mapped out my appointments for this week
<ng0>rekado: you think we can get new curl into core-updates or is it too late for that?
<rekado>core-updates is frozen. We shouldn’t rebuild the world again. Guess we should graft it in master…?
<ng0>ok
<ng0>damn daylight saving times... ok, i will do the curl update, i have woken up too early
<ng0>should I update the curl-7.50.3 package or the old one?
<ng0>the 7.50.3 i assume, by the "replacement" in old one
<ng0>builds okay. I'll send the patch in some minutes
<rekado>is this ABI compatible?
<rekado>I mean: is this a mere security release or an actual new version?
<ng0> https://curl.haxx.se/changes.html#7_51_0
<ng0>bugfixes, plus 2 changes
<ng0>should I list all the CVEs in the commit message?
<ng0>as far as I understood their mailinglist, the update is a big deal in security fixes
<rekado>it is. It was announced early for major distros to give them time to rebuild.
<rekado>subscriptions to the distro list are not possible right now :-/
<ng0>i know, I should've had time to build gnurl in time, but I am busy with life
<ng0>s/build/release
<ng0>patch is send
<ng0>distro list? the one at seclists.org / insecure.org ?
<kadintrooper> https://i.sli.mg/lcOPlQ.png
<ng0>Apteryx: that's not what I meant, nice or not. What I do is thinking about and working on a system which uses GuixSD as a base. When it can be integrated almost 1:1 with Guix, I'm more than happy, the only problem I see is coverage of hardware of linux-libre. There are a number of solutions I have for this, but if the difference in wifi and graphics isn't so big anymore I'd try to roll with linux-libre and
<ng0>think about solutions for more open support later on my roadmap
<ng0>getting blobs back into linux-libre would mean shipping our own linux definition, which will be terrible if people decide to init the system on bare metal and then do a guix pull
<adfeno>Any of you using GNUnet and with errors that ARM isn't running when issueing `gnunet-arm -I`?
<sneek>Welcome back adfeno, you have 1 message.
<sneek>adfeno, lfam says: Khard can be used to edit VCF files
<adfeno>sneek: Thanks :)
<ng0>I assume you have started gnunet-arm ?
<adfeno>Yep.
<ng0>ah i seeamatus is helping
<adfeno>Set it to start on @reboot, both for gnunet user, and my own user.
<ng0>better solve it in #gnunet
<ng0>i can help with guix specific parts if no one can handle it
<adfeno>I managed to get an strace as gnunet user.
<adfeno>Note: In order to prevent having to switch back and forth, we're discussing this in #guix right now.
<ng0>s/#guix/#gnunet
<adfeno>s/#guix/#gnunet/
<csanchezdll>is there an easy way to run a build just to a certain phase and examine the results?
<csanchezdll>I would like to examin how a pre-configure phase substitute* changes the source code
<davexunit>csanchezdll: no
<quigonjinn>csanchezdll: you can add a phase that returns #f after it, and run 'guix build ... --keep-failed'
<rekado>csanchezdll: you can add a phase that fails and then...
<rekado>what quigonjinn said.
<csanchezdll>oh, I see
<davexunit>guix itself has no idea what phases are
<csanchezdll>yup, that is good enough
<csanchezdll>thanks! :)
<davexunit>sometimes I wonder if phases should be promoted to first-class
<davexunit>but I'm not so sure it's a good idea
<csanchezdll>well... probably not needed in the general case
<rekado>still struggling with GNU pascal. Even when building with GCC 4.3.5 it’s pretty broken.
<rekado>makes me wonder if maybe it can only be built on i386
<csanchezdll>I am dwelling into gcc package subtitutions fot the libgcc_s hack, which needs to be updated for bootstrapping powerpc
<davexunit>didn't realize there were many people out there still using powerpc :)
<davexunit>debian just dropped it
<davexunit>running guixsd on a nintendo wii is appealing, though ;)
***orly_owl_ is now known as orly_owl
<civodul>davexunit: re first-class phases, i wonder too!
<civodul>it would probably make sense
<efraim>csanchezdll: how far are you getting now? I'm getting stuck on 'configure on glibc-boot0
<csanchezdll>efraim: almost done I think
<csanchezdll>final toolchain in place
<efraim>Nice
<csanchezdll>building guile fails on tests due to the libgcc_s need for pthreads and the substitution hack on gcc being tailored for i386 only
<csanchezdll>main problem is building time, my ibook g4 is really slooooow
<csanchezdll>and now I will need to rebuild gcc-final which will retrigger a lot of builds
<csanchezdll>but I am learning a lot... for example the dynamic linker change in gcc also needed some tweaking for powerpc
<civodul>csanchezdll: yeah gcc.scm modifies gnu-user*.h for that, but perhaps you need to extend that pattern to match the ppc files
<csanchezdll>I had never really known how the dynamic binaries worked internally
<csanchezdll>civodul: yes I have seen it, the substitutions need a bit of reworking to apply to powerpc
<csanchezdll>thats the reason I wanted to see how source code looked like after pre-configure phase
<ng0>okay... next time I take notes. So there was something about curl which currently is bad and can be extended with no breakage om other distros, it was something about inconsistent environment variables, but what was the environment variable? anyone remember this? curl_ca_path?
<ng0>like it is used in most places, but some occurences of absolute/relative pathnames still exist?
<ng0>I want to fix this for gnurl-7.51.0, I fail to find the email this was mentioned in
<quigonjinn`>ng0: this must be the problem with kicad's github plugin as well, which uses curl
<ng0>I think there were occurences of a presumed default "/etc/...." ?
<ng0>just guessing so I can narrow down what to search for
<ng0>and to make sure I'm not imagining a discussion which never happened
<ng0>greping for things, now it feels like there was no discussion last month.. strange
<ng0>quigonjinn`: could it be that we use CURL_CA_PATH wrong?
<ng0>I'll spend the evening reading relevant sources before pushing the update
<quigonjinn`>ng0: i actually didn't know the existence of the CURL_CA_PATH envronment variable. I'll have to check that
<ng0>it's documented in guix, and https://curl.haxx.se/docs/sslcerts.html
<ng0>i see nothing obvious to fix
<ng0>in the code of curl i mean
<roundhouse>Hi, I'm trying to install guixsd with qemu 2.7.0 but I can't get the networking figured out. The command from the guixsd website fails with unkown command "-net default"
<roundhouse>if I omit "-net default", dhclient -v eth0 fails. If I don't specify any net options, dhclient -v passes but I can't ping any website
<roundhouse>nvm, suddenly it works. For the log, it worked for me without any "-net" options in the qemu command line.
<rekado>ng0: re CURL_CA_PATH: libcurl needs to be patched.
<rekado>ng0: it has a hardcoded default path which we can replace with a call to getenv
<ng0>i know
<ng0>but what exactly, how and where?
<ng0>i have already pushed gnurl, and I'm about to upload the release, so any fix gets into the next version
<ng0>let me specify the question
<rekado>I don’t have time to search the sources for you right now
<ng0>what I mean is, do you have any threads on guix-devel (wasn't succesful in searching) where the problem is obvious? I've seen some default paths in the sources, but you seem to know more about the problem than I do.
<Common_Era>Hi.
<adfeno>Hi Common_Era :)
<ng0>there was also no obvious bug report on curl, so someone should create one. there it could be made obvious what needs to be fixed in curl/gnurl. I can't report it, because I have no idea what exactly needs to be fixed.
<rekado>it’s no bug in curl.
<rekado>it’s by design.
<ng0>I use the word bug also for things which should be extended etc
<Common_Era>How are you all?
<adfeno>Common_Era: I'm fine. :)
<Common_Era>That's good.
<Common_Era>How can I read and send remote mail with Emacs on GuixSD. The emacs manual is unclear about remote email providers and there is very little information on Guix online.
<adfeno>Indeed...
<adfeno>I use a software called sendemail (please note the "e" between "send" and "mail").
<adfeno>It was already available in the Trisquel's repository (although it's not installed by default).
<Common_Era>Do you know if it will work. If so, isn't the build-from-source process differnt here?
<adfeno>Hm...
<adfeno>I don't know for sure (haven't tested since I'm not an Emacs user, but I might test in the future).
<Common_Era>Alright. Hmm.
<adfeno>What I currently do is: edit the message, put it in a text file, and set that text file as message body to sendemail.
<ng0>sounds awful.
<ng0>Common_Era: depends on what you want
<adfeno>ng0: Indeed... :)
<ng0>there's Gnus, mu4e, notmuch, sendmail, etc
<ng0>Gnus and others can interact with getmail and getmail replacements
<ng0>eh wrong
<ng0>sendmail
<Common_Era>I think I'm figuring out the rmail manual a bit.
<Common_Era>Then I'll look at sendmail.
<rekado>Common_Era: I’m using a combination of offlineimap, msmtp, and mu4e.
<rekado>offlineimap gets my mail (and syncs my local mail back to the server), msmtp sends email, and mu4e is the Emacs interface for all that.
<Neko`>hi
<Neko`>is there anything to do with elogind, and how use it ?
<civodul>impatient people!
<adfeno>Wow :)
<lfam>Any ideas why Inkscape has begun failing on armhf core-updates? https://hydra.gnu.org/build/1593106
<ng0___>so i reconfigured.... result is i can no longer boot
<sneek>Welcome back ng0___, you have 2 messages.
<sneek>ng0___, lfam says: regarding the GNOME logout button: https://bugs.gnu.org/23193
<sneek>ng0___, efraim says: I tried the psyclpc source again and it magically worked, first try
<ng0___>either something with the new kernel is funky or grub has a grave mistake
<lfam_>ng0___: Yikes!
<lfam_>Which kernel version are you using?
<ng0___>i get to libreboot grub, but that's it.
<ng0___>current head
<ng0___>of master i mean
<lfam_>linux-libre@4.8.5?
<ng0___>4.8.6
<ng0___>i will try manual boot now with grub console, i hope i can make this work
<ng0___>i don't get an error message from libreboot grub, just the background image with no text after the first entry was selected
<ng0___>harddrive led is active
<ng0___>maybe i should update libreboot?
<lfam_>Maybe. I'm checking if I can reproduce on my non-libreboot machine
<ng0___>waited 2 minutes, nothing
<ng0___>wauza
<ng0___>that was a long wait
<ng0___>now i arrived at the guix grub i think
<ng0___>looking different then before oO
<ng0___>right now I don't want to update this computer i'm writing on
<ng0___>this feels very odd
<lfam_>We changed how we generate the GRUB picture. Is that what you mean by "looking different then before"?
<ng0___>it#s just gone
<lfam_>My internet connection is working extremely slowly right now, which is unusual.
<lfam_>Hopefully it won't take too long for me to try reproducing your issue
<ng0___>mitm for the source is unlikely as the hash was all right
<ng0___>so if i roll back, will it affect my profile, or only the system-profile?
<ng0___>hm.......
<ng0___>doesn't matter which generation i select
<lfam_>Currently the system roll-back command is still on guix-devel. It is possible to edit some files to achieve the roll-back manually, but I'm not sure how.
<ng0___>screen stays black after guix-grub selection
<lfam_>I've seen mark_weaver work some magic in similar situations before. I wonder if he is around...
<ng0___>how can I reach the grub of guix, and then the screen turn black? it should be functional, unless something in the kernel changed...
<lfam_>I'm building Guix from master now. I will reconfigure my laptop and try rebooting. Hopefully, I can download the substitutes quickly enough
<Common_Era>Hi.
<lfam_>I'm going to reboot my cable modem. I'll be right back
<ng0___>i will respond delayed, I'm using one output of this screen now to check wether this screen will turn on
<ng0___>wot
<ng0___>now i was dropped to grub edit
<ng0___>what slow sloth bug is going on
<lfam>I'm back. Strangely, rebooting my cable modem made my internet connection fast again. That's never happened in the years I've had this set-up. Oh well
<lfam>I should look into that later
<Common_Era>What's happening with everyone?
<lfam>Is that a general "What's up?" greeting, or is everything experiencing some strange problems :/
<lfam>s/everything/everyone
<lfam>I'm starting the reconfigure now
<Common_Era>Let's go with both, seeing as you all appear to be having problems.
<lfam>Heh :)
<lfam>Hopefully I don't have the same problem as ng0___. It will be very annoying if I can't boot that machine!
<ng0___>i hope i can fix this before 8th
<Common_Era>What's the problem?
<lfam>ng0 reconfigured their GuixSD / Libreboot system and now it won't boot
<Common_Era>Oh.
<lfam>I'm reconfiguring my GuixSD / non-libreboot system to see if I can reproduce it
<Common_Era>That sucks.
<lfam>Wow... it seems like the entire system is being grafted!
<Common_Era>I'm not helpful and don't know what "grafted" means.