IRC channel logs

2016-10-16.log

back to list of logs

<lfam>sneek: later tell efraim: Indeed, libgit2 0.24.2 builds for me on ext4, but not on btrfs
<sneek>Will do.
<reepca>Man, wireless is such a headache... apparently wicd (which I thought would be listed in herd status if it was being started as a service automatically, but apparently isn't) kept crashing (some error about expecting 3 arguments and getting 1?) in /var/log/wicd/wicd.log, and I kept trying the instructions in the guix manual for wireless but got nowhere, and it turned out I just needed to put key_mgmt=NONE. Of course, I tried that, but I
<reepca>put key_mgmt=None. <sarcasm> but it should really be obvious that it should be all caps, programming is really consistent about that - between None, nil, null and NULL, the obvious one is clearly NONE. </sarcasm> </rant>
<lfam>Recutils fails to build on core-updates because bash-4.4's getopt.h requires stdc.h: https://hydra.gnu.org/build/1538148/log/tail-reload
<lfam>Any idea where that header is supposed to come from?
<lfam>Oh, I see. It's also in bash:include
<lfam>Huh. In Bash 4.3, the path is './include/bash/stdc.h'
<lfam>In Bash 4.4, the path is './include/bash/include/stdc.h'
<lfam>Is that right?
<lfam>Looking at the youtube-dl test suite... LOL
<lfam>I thought that program was just for youtube
<jin>hi lfam
<lfam>Hi jin
<jin>i have some questions about submit patches
<lfam>Okay, I hope I can answer them :)
<jin>i have two patches [PATCH 1/2] and [PATCH 2/2]
<jin>I suppose I send a patch for each mail, or both in one?
<lfam>jin: The best method is to use `git send-email`. If that is too hard to set up, then you can send them as attachments in the same mail.
<lfam>One nice thing about `git send-email` is that, if you have multiple patches, they will be threaded correctly in the recipients' mailbox
<jin>lfam: okay, I'll try to do the right thing.
<lfam>The right thing is to send patches :)
<jin>ok
<jin>thanks
<lfam>So much breakage from Python 3.5.2...
<lfam>Many test suites were silently skipped under Python 3.4.5. Now they fail
<reepca>so would it be safe to guess that the stop-the-world freezes would probably stop if I switched to using a hard drive instead of a flash drive for the system? Now that I know how to get the wifi up and running I can switch to using guix as my primary system on the laptop.
<lfam>reepca: Sometimes I experience what seem like freezes but is actually just extremely high load due to I/O contention. I have a load monitor on my screen at all times so I can correlate the heavy I/O and the apparent slowness. That's on Debian, not GuixSD, however. I don't sit at my GuixSD system enough to notice slowdowns
<lfam>Having run a little ARM board on an SD card, I can say that flash is not a great medium for a user-facing OS
<lfam>Maybe if you make the flash drive read-only and keep all state in RAM
<lfam>If you can leave `top` or `uptime` in a loop on screen and try triggering the "freeze", you might get confirmation that it's caused by I/O problems
<reepca>It's an old laptop, only has 2GB of RAM. And I'm still quite in the process of adding packages and stuff. I'm hoping that somehow I'll be able to easily transfer the entire system to /dev/sdb. Would just changing config.scm to put the bootloader and file system on /dev/sda and running guix system reconfigure do that ?
<reepca>er, transfer the entire system to /dev/sda
<lfam>I don't think that `guix system reconfigure` will migrate everything to a new partition, but I haven't tried it or looked at the code with that in mind.
<reepca>Yeah, I'm wondering how I would change it to also transfer all the packages belonging to root and my user
<lfam>I'm not sure...
<lfam>Is your internet very slow or unreliable?
<lfam>Or metered?
<lfam>I would just reinstall on the new media, myself
<reepca>not metered as badly as at home, but 60GB/week. It's not too bad, but it does seem to have been a bit unreliable as of late
<reepca>just got 2 corrupt packages while trying to install icedtea
<lfam>What's the error message?
<lfam>It might be a network failure. You can work around those by passing --fallback to the command that failed, or by trying again
<reepca>"bzip2: Compressed file ends unexpectedly; perhaps it is corrupted? *Possible* reason folows. bzip2: Inappropriate ioctl for device Input file = (stdin), output file = (stdout)
<reepca>"
<reepca>I am running it with --fallback, this happened before
<lfam>Sounds like a network failure to me. As if the download terminated part way through
<reepca>could be, I was trying to install a couple of things and test out icecat's smoothess at playing music from youtube at the same time.
<lfam>Otherwise the mirror is serving some corrupted file, in which case we should remove it
<reepca>I'm not convinced the wifi is working 100% smoothly, though, I've gotten a bunch of messages like "wlan0: deauthenticated from <hex> (Reason:
<lfam>Did you try searching the net for that message?
<reepca>A bit, but haven't found much relevant so far. It's mostly just there in logs people post, not the thing being actively discussed
<lfam>In that case, it is probably more of an informational message than an error
<reepca>oh, also, I got that info bar thing for i3 installed. Nice to be able to see the time again :D. But anyway, I notice there's a part that says "W: (059% at <SSID>) <ipaddr>"
<lfam>Amazing... python-pycairo doesn't run the tests and it still fails on core-updates :)
<reepca>Is that the signal strength/quality it's denoting there?
<lfam>reepca: Yes, I think it's the RSSI
<lfam>Recieved Signal Strength Indicator
<lfam>At least, the number goes up when I am close my wifi access point
<reepca>so I assume the 0 is there just as a placeholder, right? I ask because I noticed that when I looked at top it said GiB Mem : 56.7/1.944 and that confused the heck out of me
<reepca>and I'm not sure what to believe anymore >.>
<lfam>I have the extra '0' too
<lfam>I don't believe it refers to memory usage. Although I took the RAM meter out of my status bar since I didn't find it useful and I needed the space
<lfam>There should be a file 'i3status.conf' somewhere that you can copy to '~/.i3status.conf' and adapt to your needs
<lfam>It's documented on i3wm.org
<lfam>Btw, by "somewhere" I mean somewhere in your i3 package's store directory
<reepca>I'm referring to running top. Up where it's got the bars for cpu usage and swap and stuff, there's one for memory usage, and the number there is 57.2/1.944 for some reason for me
<lfam>Oh :
<lfam>)
<lfam>Yes, the new top :) I'm on Debian at the moment and I still have the old top
<lfam>I'm sure the top manual explains it all
<reepca>I really don't know how they could explain it... it just says "GiB Mem : 57.3/1.944". This is what happens when your computer science professor cares more about the output looking nice and aligning the decimal places than about having the right output
<reepca>I should screenshot it
<lfam>I've seen it, I just don't recall the meaning of it and I can't check easily now
<lfam>You could report it as a bug :)
<lfam>"pickling" What a strange name for a computer science concept!
<lfam>I feel like I'm reading Dr. Seuss
<reepca>huh, the man page says that it's the percentage used / the total amount.
<reepca>... how is that intuitive in the slightest?
<reepca>at least I know now, I guess
<lfam>Interesting
<lfam>It's intuitive know that you know it ;)
<lfam>s/know/now
<reepca>at the cost of the intuitiveness of everything else that uses a fraction, yes.
<reepca>I really shouldn't be complaining, I mock my brother for being scared of emacs because C-c isn't copy
<lfam>57.3/1.944 is very dense. It tells you both how much RAM there is, and how much you are using as a percentage. You can know how much you are using in bytes if you know those two figures. I guess they are really trying to make use of the space.
<reepca>oh, another thing I meant to mention... I installed python-pip, but the pip command is still not accessible for some reason
<lfam>I think you can press 't' to toggle 'views' in top
<lfam>Check in your ~/.guix-profile/bin folder. That's where the binary will be if there is one. Otherwise, do `guix build python-pip` and inspect the store directory
<reepca>the binaries are in the store directory
<reepca>but for some reason not in .guix-profile/bin
<reepca>huh, re-ran guix package -i python_pip and it's in .guix-profile/bin now.
<reepca>weird.
<reepca>wait, is PATH used to determine where to put stuff by any chance?
<reepca>So question... how can I actually install stuff with pip? Do I need to specify a special directory to put it in instead of letting it try its default thing? Trying to install something seems to always result in it erroring out when trying to write something to /gnu/store/blah, saying it's a read-only file system.
<iyzsong>reepca: Yeah, but it's not guix related, you can use 'pip install --user <...>' (into ~/.local) or use virtualenv.
<ZombieChicken>Well, after forever I've managed to get Guix to work properly on my Gentoo system
<marusich>ZombieChicken, that's great! Congrats ^^
<ZombieChicken>Yeah. Now I can look at doing something with it and maybe test some things out and actually contribute
<ng0>nice
<ng0>is there anything I have to improve?
<ng0>or was it entirely 'follow the manual' what I already echo out
<janneke>ZombieChicken: grand!
<ZombieChicken>ng0: I installed it via the binary install method. As far as I am concerned, the ebuild is broken
<ng0>oh
<ZombieChicken>but I can't tell what is wrong with it
<ng0>hm weird
<ng0>for me it worked in a vmwhich started from stage3
<ZombieChicken>Yeah, I have no clue
<ng0>but that's why the ebuildis labeled as experimental
<ng0>same for the nix ebuild
<ZombieChicken>Something tells me the problem lies in /var/guix being /var/lib/guix, but I can't be for sure
<ng0>so thanksfor testing :)
<ZombieChicken>np
<ng0>yeah the locations differ...
<ng0>but theoretically this shouldn't be a problem
<ng0>in practice I even installed hello and more software
<ng0>the problem with gentoo is reproducing bugs
<ZombieChicken>If guix isn't handling things like that sanely (storing /var/guix in a global constant/variable), then a patch might have missed something and only half patched things
<ZombieChicken>I did have a problem after the initial install via binary instructions, but that was just a wrong symlink in $HOME. After that, guix pull fixed things
<ZombieChicken>ng0: Yeah. Gentoo and Guix(SD) are kind of diametric opposites in that regard
<ng0>I have one working case and one broken case now. hm^^
<ZombieChicken>Well
<ZombieChicken>I guess I could send you my make.conf, world file, and package.* files
<ZombieChicken>that would let you pretty much duplicate my entire install
<ZombieChicken>and all 800+ packages
<ng0>i wouldn't do it right now, but at some point in the next months
<ng0>because... gentoo. compiling.compiling in a vm.
<ZombieChicken>Yeah. I'm currently trying to define a system for a LiveUSB for Guix
<ZombieChicken>so I can think about working towards actually contributing
<ng0>but yeah, feel free to send the files my way
<ZombieChicken>ok
<ZombieChicken>which reminds me, I need to find a sane way to keep an address book
<ng0>I'm away now. thanks for testing :)
<ng0>I think this needs to be passed to configure. I might already do that, I haven't read the ebuild. works at my side and architecture I assumed it works in general for the arch
<ZombieChicken>ng0: What arch are you using?
<ng0>for the VMs it is x86_64, or amd64
<ZombieChicken>same here
<ng0>They currently run in qemu on NixOS
<ZombieChicken>ng0: files sent
<ng0>ok, thanks
<ZombieChicken>eix -I finds 804 packages, just fyi
<ZombieChicken>So you know what you are getting in to if you decide to build the whole thing for some reason
<ng0>i doubt all of it is necessary, but taking a look at what might have caused it will help
<ZombieChicken>yeah
<ng0>for the record, you used guix, not guix-bin?
<ZombieChicken>guix binary install
<ng0>no I mean when you used the ebuil
<ZombieChicken>guix
<ng0>ok
<ZombieChicken>checking
<ZombieChicken>yeah, guix
<ng0>got to eat something now. ttyl
<janneke>is there a way to run a package's build-aux/gitlog-to-changelog when building a guix package from its git download?
<janneke>can the package description find out where git-dir lives, e.g.?
<jmd>janneke: Not in general so far as I'm aware.
<jmd>We tend to build pacakges from git repos only as a last resort.
<ng0>how's the progress on kde as a desktop manager going?
<janneke>jmd: yes, that's for packages in the distribution
<janneke>however, i'm writing a packages' guix.scm
<jmd>I don't know what that is.
<ng0>a definition for the package to include in its distribution i'd asume
<janneke>yes, see: Invoking `guix package', in the manual
<rekado>hmm, bug 24703 looks bad.
<efraim>sneek: later tell civodul: on a scale of acceptable to terrible idea, what if I build aarch64 out to guix with 'guix-daemon --disable-chroot' and then use that guix-daemon to rebuild everything?
<sneek>Welcome back efraim, you have 1 message.
<sneek>efraim, lfam says: Indeed, libgit2 0.24.2 builds for me on ext4, but not on btrfs
<sneek>Got it.
<ZombieChicken>rekado: Link?
<ng0> https://debbugs.gnu.org/cgi/bugreport.cgi?bug=24703
<ng0>indeed, very bad
<ZombieChicken>Hrm
<ZombieChicken>What exactly is the problem? Is it the linked program expecting a file in a specific place and crapping itself if it can't, thus breaking the /gnu/store system?
<rekado>this means we cannot easily replace references, which is needed for grafting
<ZombieChicken>and grafting is Guix's security patch feature, right?
<ng0>i think it was described in a news in the savannah profile of guix, which can be found on the guix website
<ng0>i haven't read all of it though
<ng0>so far it goes as magic patching for me, until I have read the post on it
<rekado>the idea is: a package embeds a couple of references. Changing the references would usually involve rebuilding the package with updated references. Another way is to create a copy of the package with all references patched.
<rekado>this allows us to only rebuild the package that actually needs rebuilding.
<rekado>patching references is much cheaper than completely rebuilding all downstream packages.
<ZombieChicken>So its a shortcut just to save compile time?
<rekado>yes, it’s a shortcut.
<ZombieChicken>Okay, that makes sense I guess
<rekado>rebuilding the full graph takes a long time and that’s not okay when security vulnerabilities are involved
<ZombieChicken>I completely understand that
<jmd>It's also a compromise. Since it means things are no longer purely functional.
<rekado>I don’t think so. The grafted package depends on the ungrafted package. To build it you’d need to build the ungrafted package first.
<rekado>you could think of this as a special derivation that takes the ungrafted package as an input.
<jmd>I suppose so. But the tests are not re-run following the graft.
<jmd>We just have to cross our fingers that the graft hasn't broken anything.
<rekado>correct. They are “special”.
<ZombieChicken>I forsee a very large /var partition in my near future
<jmd>Does nix have grafts or anything similar?
<ng0> /var isn't so big ... /gnu/store/ will get big though
<ng0>I do build very much, and I clean 70 GB from all 2 or 3 /gnu/store 's in 2 month
<ng0>*months
<jmd>I never fully understood why /gnu/store and /var are in completely different places.
<jmd>One is useless without the other.
<rekado>I guess it’s because of convention. “/var/$package” is the conventional place for persistent state.
<ZombieChicken>That would make sense, except Guix already pretty much ignores the FHS from what I've seen
<jmd>I vote that we move /var/guix/db to /gnu/db
<jmd>Is there some special environment one has to use when calling eval in guix services?
<jmd>(current-module) appears to be empty.
<thomassgn>how would I add an ssh public key to my useraccount in config?
<thomassgn>would could...
<thomassgn>I see the plain file function, could I make it write directly to a set path? or link from the store?
<ZombieChicken>I don't know, but I seem to recall something that might do something like that. I'll check real quick
<thomassgn>awesome
<ZombieChicken>You are refering to a config like bare-bones.scm or the like, right?
<ZombieChicken>For system init?
<thomassgn>yes\\
<thomassgn>started from the one in the guixsd manual
<ZombieChicken>I don't see a way to right now, sorry
<ZombieChicken>I misread what I thought would do it
<thomassgn>right, thanks anyway
<thomassgn>:)
<ZombieChicken>Now that you mention that, I wonder if there is a sane way to have system init install packages on a per-user basis, so you could configure an entire system without having to install anything as the user after the initial install
<thomassgn>hmm
<ZombieChicken>doesn't look like it
<jmd>ZombieChicken: Currently I don't think it is possible. But theoretically we could do it.
<ZombieChicken>Yeah. It would be nice
<ZombieChicken>Adding SSH pubkeys to the keyring would be nice, too, especially in places where a person is installing a large number of systems.
<jmd>Right. The question however then arises what to do with the corresponding private keys.
<ZombieChicken>Leave that to the user to mess with?
<jmd>Then there would seem little point to it ....
<ZombieChicken>Other than letting a user SSH into the new system without having to go through the hassle of installing their pubkey on every new system they install?
<thomassgn>I think it's a good idea to allow putting in a pubkey in the config. I usually set what keypair to use for what addresses in my ssh config and then add the pubkey to the correct configs...
<thomassgn>currently I'm using nixos, but want to switch to guix
<ZombieChicken>Yeah. It's basically just saving the user the trouble of allowing SSH auth via Password, running ssh-addkey (or whatever the commad is), then reconfigure SSH to disallow password auth
<thomassgn>This also allows me to add new users with ssh access only through config
<thomassgn>(which bypasses what ZombieChicken says and allows me to not touch pw creation for users
<jmd>Oh I see. Yes.
<jmd>I agree it would be a good idea.
<ZombieChicken>plus it's a pubkey. It's kind of good to have it everywhere
<thomassgn>I see the file-like objects documentation, but they basically return a string do they?
<ZombieChicken>I'm not entirely sure
<ng0>so why is my git service adding a functionality inclusion for ssh a bad idea? Sorry if I'm very slow on responding on this
<ZombieChicken>I'm still stumbling through it all myself atm
<ZombieChicken>I'm not sure I understand what you are suggesting ng0
<ng0>sorry, I was not refering to any recent discussion
<ng0>I will provide context, one minute
<ng0> http://lists.gnu.org/archive/html/guix-devel/2016-09/msg02315.html
<ng0>oh nvm
<ng0>I remembered it wrong
<ng0>I'll try to fix this up today and see if it's in the state where I can document and send it as a patch
<ZombieChicken>ok
<ng0>probably faster than writing a go-build-system and just package gogs
<thomassgn>Seeing as we have full access to guile in config.scm, I'll try just using the regular file I/O functions... https://en.wikibooks.org/wiki/Scheme_Programming/Input_and_Output
<civodul>grr emacsclient fails like this: https://lists.gnu.org/archive/html/emacs-devel/2016-06/msg00003.html
<sneek>civodul, you have 1 message.
<sneek>civodul, efraim says: on a scale of acceptable to terrible idea, what if I build aarch64 out to guix with 'guix-daemon --disable-chroot' and then use that guix-daemon to rebuild everything?
<ng0>do we have an mpd service yet?
<ng0>or does mpd just work
<civodul>efraim: why do that?
<alezost>ng0: I think mpd should be run by a user, so making a (root) service for it will be strange
<ng0>in gentoo we somehow had the global user service.. i don't know if I ever ran it like that though
<ng0>so something to start mpd automatically would be nice.
<ng0>so you just start whatever client you use to connect to it, and not mpd in addition
<ZombieChicken> https://paste.pound-python.org/show/gE3UvdSVuK7yfvHNXzZR/
<ZombieChicken>^ Thats the init file Gentoo uses
<ZombieChicken>fwiw
<ZombieChicken>for mpd
<ng0>wasn't there a 'run mpd as user' thing?
<ZombieChicken>You could
<ng0>but this service seems to have no configuration options like git.. so that's probably something I found in the wiki
<ZombieChicken>I never used it. I just had it run MPD on boot
<ZombieChicken>wait, you mean run MPD as a nonroot user in daemon mode?
<ZombieChicken>or something like that?
<ng0>yeah
<ng0>no
<ng0>start mpd as a user process, but as a service which only runs for the user
<ZombieChicken>Fairly sure MPD drops privs if it is started as root and configured to do that
<ZombieChicken>Ah. I don't know tbh
<ng0>i think that was a option
<ng0>the mpd user
<ZombieChicken>Apparently if "user" isn't defined in /etc/mpd.conf, it will run as the executing user
<ZombieChicken>Honestly, if you are wanting a music service and don't want something running as a system daemon like MPD (which I think is supposed to run as a system process), you should probably look at something like moc
<efraim>civodul: because with what I have now it'll build not in a chroot but won't in a chroot, but using the armhf binary install the guix-daemon works as expected
<ng0>ZombieChicken: what if you want a headless small devices jukebox?
<ng0>you don't just run moc
<ZombieChicken>ng0: Yeah. MPD /can/ use a password for access
<ZombieChicken>I was just going through the conf file and seeing what it said
<ng0>you can also make mpd use remote databases etc
<ng0>so if you run more than one mpd, you maybe want a service
<ZombieChicken>Perhaps. That is well beyond my use case for it
<ng0>I looked into this a couple of years ago
<ng0>it's all possible, and probably the reason why other systems have services
<ZombieChicken>yeah. I'm fairly sure MPD is made to run a single instance and each user connects to it, so it makes sense for it to be run as a service
<civodul>efraim: oh, the guix-daemon chroot issue you reported some time ago?
<civodul>so we never ellucidated it?
<civodul>-l
<civodul>well, ok
<ng0>ZombieChicken: do you remember how user-mpd is setup? "touch database" and all the other files mpd.conf specifies? I just copied an old mpd/ncmpcpp config pair
<efraim>civodul: looking at the test logs and the PPC bootstrap attempt I think its really exposing a bug in the bootstrap tar
<ng0>regarding system service: https://wiki.archlinux.org/index.php/Music_Player_Daemon#Timeline_of_MPD_startup
<ZombieChicken>ng0: No
<ng0>i think it is created on start
<ng0>and errors to those not existing so you need to touch
<ng0>worked just with adjusting paths and updating mpd database
<lfam>Holy cow, Jasper development is active again: https://github.com/mdadams/jasper/
<alezost>wow, mark_weaver discovered something scary about how store references can be represented in a compiled code: <http://bugs.gnu.org/24703>
<lfam>Yeah, those obfuscated references are bad news :(
<civodul>efraim: yes, the tar issue seems to be problematic
<htgoebel>Hi
<lfam>Howdy
<htgoebel>I have an application incuding a .desktop file and using the gnu build system. How do I need to post-process this file?
<lfam>I don't know offhand, but there are examples in some other packages
<lfam>Recently on core-updates we handled some .desktop files in the gtk+@3 package
<lfam>I bet you will get some inspiration there
<htgoebel>ifam: I did not spot anything in core-uptates. But shouldn't do patch-dot-desktop-files, which is a phase in gnu-build-system, do the post-processing already? For me the "Exec=…" entry does not get patched.
<htgoebel>lfam: Me fool: patch-dot-desktop-files is new in core-updates :-)
<jmd>htgoebel: Yes patch-dot-desktop-files is new.
<jmd>It's not a disaster if a .desktop doesn't get patched. So I would not worry about doing it for now.
<enderby>Hi, I'm trying to install/setup guix on debian. When I do 'guix archive --authorize < ~root/.guix-profile/share/guix/hydra.gnu.org.pub' I get a "warning: failed to install locale: Invalid argument
<enderby>but when I try to do 'guix package -i glibc-locales' to setup, it tries to build it from scratch
<enderby>I'm trying to use substitutes
<lfam>enderby: That's just a warning, so you can ignore it if you choose
<lfam>Did you just install Guix? From the 0.11.0 release?
<enderby>yes 0.11.0
<lfam>Okay, the reason that you would build glibc-locales from source instead of using a binary substitute is either 1) we garbage collected that substitute or 2) There is some networking problem between you and our build farm.
<lfam>You should do `guix pull` and then upgrade any packages you've installed no matter what. Otherwise you are missing lots of important bug fixes, including security fixes
<lfam>If you do that, you increase the chance we still have a substitute
<enderby>ah
<enderby>i will try that thanks
<lfam>We *should* have substitutes for the 0.11.0 release but who knows? :)
<ng0>in gnu/services/ssh.scm (openssh service) I do not understand this in (define (openssh-activation config)
<ng0> (mkdir-p (dirname #$(openssh-configuration-pid-file config)))
<ng0>why config in the end?
<lfam>enderby: Once you have the locales package installed in root's profile, you can put something like this is your systemd guix-daemon.service:
<lfam>Environment=GUIX_LOCPATH=/root/.guix-profile/lib/locale
<lfam>That works for me
<ng0>I think it's guile related, but this is in the specific domain of guix, so I chose to ask here
<enderby>got it, thanks
<lfam>ng0: I'm not sure, but #$ is a G-expression, which is explained in the Guix manual. I'd have to re-read that section to say any more :)
<ng0>what I can read is: take the dirname from openssh-configuration-pid-file and create it.. but I see no 'config' in the openssh service
<ng0>hm.. okay, I should read that section
<rekado>g-expressions are just a different kind of quoting.
<paroneayea>hiya, *!
<lfam>Amazing. If you go to the trouble to run python-requests-toolbelt's test suite on core-updates, you will see dozens of test failures and then the test suite "passes".
<paroneayea>anyone have an idea for a relatively "should be easy to package" package I can point someone at to start with?
<paroneayea>I was going to suggest http://tangramgames.dk/games/duckmarines/ but the music is non-free and I don't know how hard it will be to stub out.
<rekado>`(1 2 ,(- 4 1)) is equivalent to '(1 2 3)
<ng0>or some random python package
<lfam>Yeah, a basic Python package. Maybe something from Suckless (that's how I started, I knew it couldn't be too complicated!)
<rekado>in G-expressions the quote and unquote characters are different.
<rekado>and the quoting is done to refer to store items
<ng0>hm
<ng0>paroneayea: scron .. if we don't have this already
<paroneayea>ng0: thanks
<ng0>oh i think i guess-get it
<ng0>i mean i get it in the way that I understand it, but can not explain it exactly
<ng0>in the way like I understand some languages when I learned them before I understood the grammar
<rekado>ng0: in G-expressions we can refer to package variables instead of their actual store paths. That’s pretty much all there is to it.
<ng0>"config" is used all over the place in other defines. So I assume this is something shepherd works with in the end
<paroneayea>hey thank goodness for email
<lfam>I hope ya like it cause we've got plenty
<paroneayea>it's so nice to query list activity and find out we already talked about a lot of the guixops questions I was starting to form in my head
<janneke>*lol*
<lfam>Speaking of plenty, the subversion test suite takes plenty long!
<ng0>I can't break anything if I convert the mbox files gnu.org has of guix-devel and put them in place where right now my message are?
<ng0>to get a complete offline archive
<rekado>not if you have backups :)
<ng0>2000 emails/months are not enough, I need to add all the old ones I previously deleted ;D
<lfam>Not a bad idea...
<ng0>does neomutt support tagging/search-inboxes? I only had the hybrid-mutt in gentoo and it was useful.. notmuch is notenough at times
<lfam>I use "vanilla" Mutt and mu together. It's pretty good although I think mu would be better if I used mu4e. My mutt / mu macros are not very good
<lfam>It doesn't do tagging but it does do really fast search
<ng0>nice addition, htgoebel :)
<ng0>the last patch i mean
<ng0>vanilla mutt was irritating and i did not like it
<ng0>too much which I was used to just gone
<lfam>I thought it was too different from Debian's Mutt, but then I realized that all the things I was missing were just configuration files. So I copied them from Debian :)
<ng0>well, the mutt gentoo uses is far from vanilla :D
<ng0>you can make it vanilla though
<lfam>Debian's too. I think all the distros have a franken-mutt
***Apteryx is now known as apteryx
<ng0>there are some features I want which are not existing at the moment or which I am working on but therefore take time, why I would choose Guix on Gentoo again on at least one system instead of GuixSD
<ng0>s/but/and
<ng0>though I think the only features I really miss are printing (almost done now, thanks wingo) and full disk encryption..the rest I want is more or less just being worked on
<lfam>Wow, I didn't realize that anything depended on icecat. I was sure that geierlein was the first
<rekado>lfam: some things depend on xulrunner
<rekado>and that comes with icecat
<rekado>same with conqueror.
<rekado>*conkeror
<rekado>disappointed to see that supertuxkart hasn’t been packaged yet :(
<rekado>I’d really like to play it tonight
<lfam>I know something you can do to make this happen ;)
<rekado>already working on it
<ng0>i should check if all the 0ad dependencies are in master now
<rekado>hope I can do this in time to play tonight with my partner
<ng0>i should delete my gitlab guix repositories.. I don't even push anymore
<ng0>to much switching
<ng0>*too
<ng0>i see
<ng0>the dispatch.scm was not applied
<ng0>i think this was needed for some part of 0ad unbundling some file
<ng0>but I think as long as we work towards unbundling, using that one bundled dependency of 0ad should be okay
<ng0>i think this was for nvtt.. and nvtt is optional
<lfam>paroneayea: Can you try fixing beautifulsoup4 on core-updates? I remember you thought you had an idea of what was wrong with it.
<ng0>wow. I like the new diff color view of emacs
<ng0>easier to spot some differences
<rekado>do you mean in magit?
<ng0>SMerge mode
<ng0>i don't use magit
<lfam>sneek: later tell efraim: Lots of onionshare's dependencies are failing on core-updates. Maybe you want to try fixing them? :)
<sneek>Okay.
<paroneayea>notably I have two mascots I've drawn that people have put in supertuxkart :)
<paroneayea>both gavroche and nolok
<paroneayea>so I should probably play it
<paroneayea>:)
<rekado>also updating extremetuxracer now. They are now using sfml.
<paroneayea>rekado: cool, thanks!
<paroneayea>when I give talks about guix sometimes I joke that you can tell we're a real distro because we have tuxracer ;)
<paroneayea>you aren't real unless you can slide down a mountain collecting fish.
<ng0>i think i have just build 0ad...
<ng0>i'm waiting for the huge build to come back to me
<ng0>oh
<ng0>that wasjust data
<ng0>i think we can also unbundle the fonts later on..
<ng0>do I need to do anything special for gmake, or is it usually just working?
<rekado>I don’t understand the question
<atw>Is it possible to make user services with (shep)herd?
<ng0>I think me neither.. I have to see if/how 0ad will fail to ask a more specific question
<rekado>atw: yes, it is.
<rekado>atw: I’m using it to start JACK, for example.
<atw>nice! Is there documentation on that?
<rekado>atw: you’d use a different instance of shepherd then, not init 1, of course. Just install the “shepherd” package into your profile, then edit ~/.config/shepherd/init.scm
<paroneayea>my brother is packaging kobodeluxe \\o/
<ng0>0ad is just a game.... can't they use something easy to build
<rekado>supertuxkart is almost done, fails the final linking stage
<rekado>games are complicated
<paroneayea>rekado: go go go!
<paroneayea>yeah games are complicated
<paroneayea>rekado: I've started packaging like three roguelikes and given up halfway through each ;)
<ng0>but 0ad is nice. I have started packaging gtkradiant... nope nope di nope
<paroneayea>"it's just an ncurses game, how hard could it be"
<paroneayea>*gazes upon a thousand bundled dependencies*
<paroneayea>:'(
<ng0>gtk radiant: it's just a ... wait a moment, where is the build system?
<ng0>the special linux "build"
<ng0>"build" :D:D ._.
<ng0>y...
<ng0>fully ack with the comment in the gentoo ebuild. "this is the most stupid build system"
<rekado>can’t be worse than all this bioinformatics software
<rekado>there’s so much that’s not in Guix upstream because it’s held together by spit and hair.
<rekado>bioinfo software is the worst.
<paroneayea>wow spit and hair
<paroneayea>that's even worse than rubber bands and bubblegum
<ng0>iirc gtk-radiant is just prebuild and nothing else, but still gpl. i have to look at it more in detail, but I don't think we can make an exception there?
<ng0>if it works at all that is.. because standard locations etc.. I have paused this because I did not understand it immediatelly
<ng0>it felt like I did not see the source
<ng0>one day I will write the ebuild to guix-package converter and it will be a bright sunny winterday and i will laugh like someone with extra big clownshoes because there's no more need to translate the few differences between gentoo and guix
<rekado>no, we won’t make exceptions for adding binaries other than for few cases of bootstrapping.
<ng0>there has to be a source though.. so maybe I just found the wrong download when I tried gtk-radiant.
<ng0>people contribute on github.
<rekado>bleh, looks like supertuxracer depends on an unreleased version of irrlicht (which comes bundled)
<rekado>ACTION puts on hacking gloves
<atw>rekado: but then...how do you start your user's init?
<rekado>atw: I just start shepherd as a user when I log in.
<paroneayea>of course, kobodeluxe turns out to need 8 patches for it to work
<paroneayea>guess you gotta train someone how to become a guix contributor the hard way ;)
<ng0>when you know someone who wants the really hard way, send them my way... I have uclibc-ng and its packaging moves at the speed of goth sloths
<ng0>it's just doing lots of configuring etc, like with the kernel
<civodul>"held together by spit and hair", i like that phrase :-)
<paroneayea>heya civodul o/
<paroneayea>ACTION rebases wip-deploy
<civodul>yay!
<paroneayea>if I make sure that wip-deploy works still after rebase, should I push the rebased version?
<civodul>paroneayea: sure!
<civodul>at least it will remind people of its existence ;-)
<paroneayea>:)
<ng0> http://paste.lisp.org/display/328736 wat.
<ng0>games are weird
<ng0>it's interesting enough to not let me just abandon this
<ng0>do we have something like "tc-export" ?
<ng0>we have tc
<ng0>hm
<ng0>src_compile() { tc-export AR
<ng0>i just hope this catches up by itself
<rekado>ng0: what’s weird about the paste?
<ng0>probably nothing. or everything. I'll just stop commenting it
<ng0>I'm getting somewhere now
<ng0>is there a shortcut to change directory to the root of the build directory?
<rekado>it’s in the root by default, no?
<ng0>I just use chdir "../../.." but maybe there's something shorter
<ng0>no, not at that point
<ng0>I need to jump around directories, the build system of the game is a game :)
<rekado>use with-directory-excursion instead of chdir.
<ng0>is that document in guile documentation?
<rekado>no
<ng0>*documented
<ng0>ok, what is this then? I have read this more than once but I do not understand it
<rekado>see build/utils.scm
<ng0>ok
<rekado>it just enters a directory, does things, then leaves.
<ng0>oh
<ng0>okay, so it does exactly what the name sounds like :)
<ng0>grml
<ng0>so 0ad bundles mozjs 31something with patches applied and it will break if you just use system mozjs
<ng0>is it worth the effort to unbundle it and keep the mozjs-0ad in sync with what 0ad bundles with each release?
<rekado>similar situation with supertuxkart :(
<ng0>the patches are provided as .diffs
<ng0>but how do you unbundle this? download 0ad and erase everything except the spidermonkey dir?
<ng0>they also bundle "fcollada" which seems to have no diffs applied
<ng0>well they build fcollada with their own build flags, but that's all:
<ng0># FCollada is not aliasing-safe, so disallow dangerous optimisations
<ng0># (TODO: It'd be nice to fix FCollada, but that looks hard)
<ng0>"patch-source-shebang" (?) takes a path, patch-shebang just a file or list of file, right
<ng0>i really think I need to unbundle this so it's easier for me to build it. I know I can fetch the mozjs source from upstream, but afaik the diff + the libraries/source/spidermonkey of 0ad is not anywhere outside of the 0ad source
<ng0>which is unfortunate
<ng0>anyone got ideas on how to handle this?
<ng0>well they have this https://github.com/0ad/0ad as a mirror, but they do not tag the release points
<ng0>and their trac does not tag either
<roptat>yay, I changed my graphics card with a very old one, and X starts \\o/
<ng0>Is anyone interested in the progress? I think I'll pause for a good while on 0ad.. so if anyone has a good idea on how to unbundle and process, it should be easy after unbundling
<ng0>or even building the bundle
<ng0>I think i don't find this very productive for myself.. in the end this is 100% community service because I do not take the time anymore to play games
<ng0>so I'll just post my progress as a snapshot, free for someone to pickup, but if nothing happens until next time I decide to work on it, I'll continue
<rekado>roptat: heh, nice :)
<Petter>0 A.D. strikes a chord with me, but I don't play games anymore either.
<ng0>if you only focus on what you do and ignore everything else, the amount of emails isn't so bad..