IRC channel logs

2016-09-22.log

back to list of logs

<bavier>I'd really like to work out this offloading-with-different-storedir thing
<Common_Era>Alright, my package definition no longer gives any errors, not it gives me the "accepted pid connection" message and nothing else. Is this correct?
<Common_Era>Is there no simpler way to install a Guile program in GuixSD? I don't plan on releasing yet.
<Common_Era>Just for testing, I mean.
<Common_Era>Nothing?
<Common_Era>I would really like to get to coding, but I have no way to test.
<Common_Era>I'm so confused and slightly disappointed.
<Common_Era>I like the distribution, I like the packages, I like you guys (you've been very helpful), and I'm fine with any amount of configuration, but I really wish I knew what to do here.
<Common_Era>Alright.
<Common_Era>Hmmmmm.
<Common_Era>I really can't figure this out.
<Common_Era>Does anybody know a simpler way to test my Guile program in GuixSD than writing a package definition.
<Common_Era>Or does anyone know why my package definition returns the PID connection message and nothing else?
<Common_Era>I'm desperate.
<Common_Era>Am I being stupid?
<Common_Era>I just want to start actually programming.
<Common_Era> I give up.
<OrangeShark>Common_Era: what command are you running to get that message?
<Common_Era>guix package -f <my package definition>
<Common_Era>Is that the intended output? Because, if so, I'm unable to load my module.
<Common_Era>The package isn't installed, it seems.
<OrangeShark>no, that doesn't sound right
<Common_Era>Hmm.
<OrangeShark>what does it say before that message?
<OrangeShark>or is that the only output?
<Common_Era>Nothing. The entire message is "accepted connection from pid 814, user ben"
<OrangeShark>hmm, that sounds like a message from the daemon
<Common_Era>That message is there on every package install for anything, but there's usually stuff after it.
<Common_Era>And I just tried restarting guix-daemon and there's no difference.
<OrangeShark>are you running the daemon on that terminal?
<OrangeShark>I guess in the background?
<Common_Era>I just ran "sudo herd restart guix-daemon", the command I always use.
<OrangeShark>oh you are on GuixSD
<Common_Era>Yes.
<OrangeShark>I don't recall the daemon messages showing up when you run commands like that on GuixSD
<Common_Era>Strange.
<OrangeShark>not sure if that issue would affect installing your package though
<Common_Era>I just ran "guix package -i gcc" to test it. The message is there too, so...
<Common_Era>No, I wouldn't think it would.
<OrangeShark>I should try running GuixSD again
<Common_Era>I got it running on my Mac, even without EFI support, which I'm very proud of, but it's all very new. Surprisingly big jump from Debian and OS X.
<OrangeShark>ah a Mac, I think I remember someone asking how did you manage to do that :P
<Common_Era>Yeah, I'm supposed to write an email to guix-devel, so I'll be doing that tomorrow. It was a lot of grub.cfg and copying missing files. I also didn't have access to grub-install or update-grub because they apparently
<Common_Era>don't install on OS X.
<Common_Era>I am happy it works, though. i took three days trying to make it happen.
<Common_Era>I had to write a rEFInd menu entry to boot from the USB to install it, but that wasn't even the hard part.
<Common_Era>Sorry, I think I'm kind of bragging, so I'll stop.
<OrangeShark>if you don't mind can post the guix package? Or is it something you don't want to share yet?
<Common_Era>I'd rather not share the code yet, but I can post the definition.
<OrangeShark>okay, post the definition
<Common_Era>Okay.
<Common_Era> http://paste.lisp.org/+704B
<OrangeShark>hmm, I don't think you can use file: like that
<Common_Era>No? It was doing this before I tried it like that. Earlier, I uploaded it to sandstorm.io, but I thought that that might be the problem, so I changed it, but it's the same problem.
<OrangeShark>oh hmm
<OrangeShark>when you run guix package -i something, is the "accepted connection from pid" the only message?
<Common_Era>No, other stuff happens there.
<OrangeShark>was thinking maybe there is somehow a build error but it not printing
<Common_Era>Hmm.
<OrangeShark>it should show it downloading the file and then going through the various build phases
<Common_Era>Yeah, that's what other packages always do. I just tested it with hello and it works correctly,
<OrangeShark>oh wait
<OrangeShark>when you do guix package -f
<OrangeShark>the file it evaluates suppose to have the package be the last expression
<OrangeShark>you are storing it in a variable
<Common_Era>Oh. Dang... I'll try it.
<OrangeShark>you can add the last line msg
<OrangeShark>or a different method is to have this file in the GUIX_PACKAGE_PATH
<OrangeShark>in my .bash_profile I have the line "export GUIX_PACKAGE_PATH=$HOME/guix-packages"
<OrangeShark>then in my home directory I have guix-packages. For you, you would want to make it ~/guix-package/gnu/packages/msg/msg.scm
<OrangeShark>so guix can find it
<Common_Era>I think I fixed it. Thank you so much.
<OrangeShark>no problem :)
<OrangeShark>You might want to mention the "accepted connection from pid" issue on the mailing list, could be a bug
<Common_Era>Okay.
<adfeno>Hi all! :)
<adfeno>I have installed GNUnet, and I have a question: Is it normal for `gnunet-gns-import.sh` to take a long time and keep the terminal busy?
<adfeno>It seems that it does run, but doesn't exit.
<adfeno>Reading the script and looking at the running procesess I can see the last process.
<adfeno>I'll stop it and continue the setup. Bye!
<j-r>I'm working on a package for keychain. Should I create a new file for this?
<ola_>hi
<hersh>ola
<adfeno>Hi all :D
<adfeno>I made some progress in the attempt to make recipe for Crypto++ (cryptopp), but something is still wrong...
<lfam>ACTION prepares openssl updates
<JamesRichardson>Anyone know if the mailing list (guix-devel) is down or delayed?
<JamesRichardson>never mind. Some messages just came through (not mine), one asking a similar question. ;)
<adfeno>Hi, how do I make a directory inside the unpack phase?
<brendyn>inside? Can't you add a phase before or after?
<adfeno>The unpacker will be using that directory to put files inside.
<adfeno>I currently have:
<adfeno>(add-before `unpack `make-source-dir (lambda* _ (mkdir "source")))
<brendyn>Which build system are you using?
<adfeno>(replace `unpack (lambda* (#:key source #:allow-other-keys) (and (zero? (system* "unzip" source "-d" "source")) (begin (chdir "source") #t))))
<adfeno>brendyn: I'm using gnu
<brendyn>Then why do you need a special unpack phase to begin with?
<adfeno>Because the source file is a .zip which is a "zipbomb".
<adfeno>(extracts itself in the current directory.
<adfeno>At least this is what I was instructed to do by Ben Woodcroft in guix-devel mailing list.
<adfeno>However, his recommendations don't seem to work.
<adfeno>He told me to replace the unpack phase by that one I pointed out.
<adfeno>But unzip still extracts things in the same directory.
<adfeno>Then, strangely, "something" prints out the following line: source is under "[some file that's not a directory]" and then comes a Backtrace.
<adfeno>About that file, in which chdir expects for a directory.
<brendyn>Maybe delete the make-source-dir phase and just put it in before (system*
<adfeno>Hm... OK.
<brendyn>You can look at java-swt in java.scm
<brendyn>I mean, before (zero?
<brendyn>Also what is the begin for?
<adfeno>About "begin": Hm... I don't know...
<adfeno>Woodcroft suggested it.
<brendyn>(and (mkdir "src") (system* "unzip" source "-d" "src") (chdir "src"))
<brendyn>(and (mkdir "src") (zero? (system* "unzip" source "-d" "src")) (chdir "src"))
<adfeno>OK, now I have: (replace `unpack (lambda* (#:key source #:allow-other-keys) (and (mkdir "source") (zero? (system* "unzip" source "-d" "source")) (chdir "source"))))
<brendyn>Can you use ' instead of ` :P
<adfeno>The "add-before" modifier is gone.
<adfeno>brendyn: What's the difference between ' and `?
<adfeno>I see some recipes using one or another.
<adfeno>I have tried replacing all matches for ` in my recipes, but then Guix starts ignoring package inputs.
<adfeno>s/ignoring/considering as invalid/
<brendyn>In this case it does the same thing. ' is (quote ...), that simply quotes an expression. ` is quasiquote, which adds the , syntax that is like and exception. `("openssl" ,openssl) says "Don't evaluate this, except for expressions marked by ,"
<brendyn>So you need ` whenever you use ,
<adfeno>Oh... I see :)
<brendyn>`unpack is simply 'unpack, as there is nothing else there that needs evaluating.
<adfeno>Result: chdir still attempts to "change directory" to a file.
<adfeno>(note: the replacing of ` with ' didn't change the result).
<brendyn>you can try building with the -K flag, and then you can look in the build directory in /tmp to see what is there
<brendyn>guix build foo -K
<adfeno>Will do.
<adfeno>Hm...
<adfeno>I went there, and there's no "source" directory.
<adfeno>Should I do (string-append out "source") ?
<adfeno>... when making the directory and when changing to it?
<adfeno>I'll try using guix environment and guile to use mkdir
<adfeno>Hm...
<adfeno>Hm... Doesn't work stilll..
<adfeno>I'll reply to guix-devel mailing list topic about Crypto++ (cryptopp) and wait for more suggestions there
<adfeno>Bye.
<ng0>chromium is a bundle bomb. but i progress.
<ng0>*make progress
<ng0>i feel sorry for the people who have to keep track of all of its dependencies to package it at google.
<davexunit>chromium is probably the worst piece of software ever in this regard
<davexunit>someone from red hat that maintains the chromium package used to constantly make fun of how terrible it is
<ng0>:D
<ng0>I'm working on and off on packaging pike, and its just a puzzle.
<ng0> https://gitlab.com/secushare/guixpkgs/blob/master/n0is/packages/lpc.scm I don't even know atm what the current error is.
<efraim>Were the Mac PPCs big endian?
<dvc>my beagle bone black died. I can't get anything with the olimex PL2303 serial to usb cable :/
<dvc>I oh the documentation is wrong Pin 4.....Green.....Transmit
<dvc>
<dvc> Pin 5.....Red.......Receive
<dvc>
<dvc>reversed them
<ng0>it would almost be easier to do use-module gnu packages * for inox/chromium.
<efraim>lol
<ng0>and people make jokes about emacs as an operating system...
<ng0>2 more lines and I'm at 40 modules
<ng0>I'm done for today. 43 modules of gnu packages to get a start with inox/chromium... wow.
<efraim>have you started with the patches?
<efraim>I was thinking they might be worth handling like the bash patches, that get downloaded and hashed rather than stored in the repo
<ng0>no, I'm getting there. will do that soon. but if you like to, you can take over? It's in my projects interest to have an alternative to icecat in the system images which get shipped out, but if you deal with it anyway? I sorted out most dependencies.
<efraim>I don't think I can build it, my machine has 2GB of ram and a spinning HD
<ng0>i mean.. i'm doing it, it just takes a bit more time. but with the aur pkgbuild + gentoo ebuild there's a good scratch of what i need to do
<ng0>oh okay
<ng0>how do you test qemu images which need to be altered (writeable) again? I'm sitting on this gnunet-service for so long now...
<efraim>the last time I had to test a service I built the image and launched it with /./gnu/store/...system.sh or something like that
<efraim>I don't remember if I had to make changes to it
<efraim>maybe you have to copy it out of the store?
<ng0>that did not work out so good.
<ng0>i don't remember the reasons for failure
<ng0>maybe I should set up this system again and use guix from a git checkout
<ng0>but that means some time where I can not use the laptop
<ng0>and i can't do that right now
<dvc>ng0: guix system vm allows you to write. It just won't persist a reboot and /gnu/store is readonly
<dvc>are you trying to use guix from within the vm?
<ng0>the service (gnunet) needs to populate some files, and fetch an initial host list etc..
<ng0>./pre-inst-env guix system vm gnunet-vm.scm was my invocation of vm iirc
<ng0> ./pre-inst-env guix system vm gnunet-vm.scm was my invocation of vm iirc
<ng0>woops
<ng0>i tried more, like copying the vm file to my user home etc, but nothing made the 'filesystem is readonly' message go away
<ng0>maybe it's the kind of file-system i used
<ng0>I use the dummy system
<ng0> http://krosos.sdf.org/static/gnunet/gnunet-service-testvm.scm
<jmd>Who is it that hosts hydra.gnu.org?
<JamesRichardson>I'm missing or not quite understanding something... What is the best way to handle configurations of applications? I gather that if I wish to say run Exim, I somehow have to get the configuration into /etc (or somewhere exim can find it). I'm not quite sure how to do such a thing, nor am I finding information in the manuals.
<JamesRichardson>Is there an example somewhere?
<jmd>JamesRichardson: You haave to run a service.
<jmd>(exim isn't even packaged so far as I'm aware)
<ng0>it is.
<jmd>ng0: Oh right. so it is.
<JamesRichardson>It's packaged, but with the default config. I understand I need to run a service. I don't understand how to give exim the config I want it.
<JamesRichardson>I have a config for exim, just don't know how to define the service to have exim use it. I'll dig into the Shepherd docs a bit more.
<ng0>do we have a simple exim service? if not and you know how exim works, it is a welcome contribution :)
<ng0>we need moar services.
<jmd>ng0: Yes.
<JamesRichardson>I know how exim works. ;)
<JamesRichardson>Guess I have a project for (probably next) weekend.
<jmd>JamesRichardson: You must be about the only person who does.
<ng0>on mail servers.. what about my opensmtpd patches, do I have to send again or can the commiter do the tiny changes left?
<JamesRichardson>Hopefully not the *only* person. I ran exim at a smallish ISP in the early 2000's. Still use it for most things now.
<dvc>ng0: I use (file-systems (cons (file-system (device "/dev/vda1") (mount-point "/") (type "ext4")) %base-file-systems))
<dvc>
<ng0>thanks, i'll test this tomorrow
<dvc>I'll try your vm config tomorrow if you still can't get it to work...
<dvc>done for today, device bringup is tricky...
<rekado>sneek: later tell Common_Era Make sure that your user account is not a member of the group that is reserved for build users.
<sneek>Okay.
<bavier>ng0: I'm sure the commiter can make the changes
<ng0>ok
<ng0>so i can touch files, it's not a write problem.
<ng0>i get a problem with networking.. I'll look into that
<ng0>and $HOME of gnunet is empty, so maybe it's just a service problem. all the sub services are up, I just have to debug that