IRC channel logs

2016-09-18.log

back to list of logs

<Petter>rekado: Do you have an easy way of setting the time manually?
<Petter>I realize setting the time manually isn't ideal. What I do is change to root user in a terminal, find the following date command and run it.
<Petter>date -s "$(curl -v gnu.org 2>&1 >/dev/null | sed -n 's/^< Date: //p;')"
<Petter>But that's old, now I use:
<Petter>date -s "$(curl -Is gnu.org | sed -n 's/^Date: //p')"
<FNTM-U3>could one install guix os on xfs partition
<brendyn>How can I make patch-shebangs happen before the build?
<FNTM-U3>could one install guix os on xfs partition?
<FNTM-U3>anyone?
<brendyn>I don't know if anyone has done that yet
<brendyn>Can anyone spot why this substitute* fails? http://paste.lisp.org/display/326402
<brendyn>oh it finds a .pyd file
<brendyn>Hmm I'm trying to package something for python2 but I keep getting references to python3 during the build process
<bldtg>hello
<brendyn>hi
<bldtg>I can't figure out how to get networkmanager working in guixsd
<janneke>bldtg: i don't think it's officially supported yet
<janneke>what works is networking using Wicd
<bldtg>Ah ok. I assumed if it was available it worked.
<janneke>yes, I'd like it to be that way, apparently we're not totally there yet
<bldtg>Glad gnome is working at least
<brendyn>I think their are a few Gnome fanboys around ;)
<brendyn>there
<bldtg>I prefer the title "gnome enthusiast"
<brendyn>Currently I'm yet to get any desktop function apart from my tiling wm
<bldtg>Which tiling wm do you have?
<brendyn>i3
<brendyn>I've been looking to switch over to wayland though, so I might end up on Sway.
<brendyn>I think maybe using something like Gnome session with a tiling wm embedded would be ideal.
<bldtg>There are tiling extensions, aren't there?
<brendyn>Not sure, they probably suck. I've seen some
<janneke>brendyn: i really hope to get gnome+guile-wm going and have a hackable wm again, just like in the old days
<brendyn>janneke: What does guile-wm let you do?
<janneke>brendyn: i'm not getting it really going yet
<janneke>i would like to have my configuration in a file that i can put in GIT
<janneke>and i'd like the configuration to be easy programmable: keystroke->any action
<janneke>and being able to repl the actions like with sawfish would be awesome
<brendyn>janneke: I think I have a phobia of python now ;/
<brendyn>"Sometimes packages have propagated inputs: these are dependencies that automatically get installed along with the required package (see"
<brendyn>I'm having trouble understanding what a propagated input is
<rekado>brendyn: a propagated input will appear in a profile when the package that references it is installed
<rekado>regular inputs are not instaled into a profile. Instead the binary contains references to them.
<rekado>this doesn’t work with Python because modules are looked up by name only, not by path.
<rekado>so we cannot hardcode path references.
<rekado>“import something” looks up “something” in the PYTHONPATH.
<janneke>brendyn: :-)
<brendyn>Currenly I have duplicity which requires python2-dropbox which requires python2-typing, but I get Import of duplicity.backends.dpbxbackend Failed: No module named typing
<janneke>i've been a fairly fanatic proponent of python for over 10y
<brendyn>I've been wasting too much time on this package
<rekado>brendyn: you may need a wrapper script around the executable
<brendyn>janneke: I'm still only learning to program so I wouldn't know much about it.
<rekado>it would set the PYTHONPATH first
<rekado>brendyn: we do this in a couple of packages that depend on Python stuff
<brendyn>How does one do that?
<rekado>let me look for an example
<brendyn>Thanks
<rekado>brendyn: couger in bioinformatics
<brendyn>janneke: There are all these python backends and I can't even tell if they are even used or not
<janneke>and now, with every python package that's added to guixsd i go: this would have made me happy, it will make a lot of people happy, but don't we already have this in guile, and more simple too?
<brendyn>pytnon2-{gdata,gobject} and gvfs
<rekado>brendyn: there’s a wrap-program phase
<rekado>it takes the current PYTHONPATH and creates a wrapper for /bin/couger
<rekado>this ensures that when the real /bin/couger is run PYTHONPATH is set such that all the Python modules can be found.
<rekado>note that in this case you don’t need to propagate any inputs.
<rekado>you only need propagation for plain Python modules, not for applications using Python modules.
<brendyn>Maybe this is why gdata kept importing all this python3 stuff despite me never refering to python3
<brendyn>Right, so I'm wondering where I actually need to put this.
<rekado>I’d need to see your package definitions.
<brendyn>janneke: I was undert the impression guile lacked a lot of things compared to python libraries
<brendyn>rekado: 1 sec
<rekado>my only problem with Guile is that it’s difficult to discover libraries.
<zenified>rekado: also in sys,path
<rekado>often I’d implement things that other people had already written
<brendyn>I guess we need module libraries
<brendyn>rekado: http://paste.lisp.org/display/326416
<rekado>as much as I dislike per-language package managers, Guile could really benefit from wider adoption of guildhall or similar
<rekado>brendyn: you have python-2 in the inputs, but since this is the python-build-system “python” will be an implicit input.
<brendyn>The gdata one is completely borked, so just ignore that for a moment. With the rest of it, everything builds fine and I've used it on my backups, but I just see the dropbox backend complaining about typing
<rekado>to override the python package you need to set (arguments `(#:python ,python-2))
<rekado>oh, you did
<rekado>(unusual order)
<brendyn>only in duplicity. Maybe I need it in the other ones too?
<brendyn>Isn't that what package-with-python2 does?
<rekado>no, package-with-python2 takes care of this
<rekado>but …
<rekado>python2-gdata should set (arguments …)
<rekado>and remove “python-2” from the inputs
<rekado>the way it is now you’d build the python 3 version
<brendyn>Right well I don't think a python3 version exists
<rekado>ACTION has to go now
<brendyn>;/
<brendyn>so you don't know why I get the typing error?
<rekado>is this at runtime or at build time?
<brendyn>runtiem
<brendyn>When I run duplicity
<rekado>okay, then you need to wrap the duplicity executable
<rekado>see the “couger” example
<rekado>just add a phase after “install” in the duplicity package
<brendyn>ok ill copy paste that and see what happens
<rekado>cool
<rekado>ACTION waves
<brendyn>bai
<janneke>brendyn: true, guile also lacks a lot
<brendyn>Hmm I'm wondering if I should make a separate output so people don't have to install dropbox and amazon crap
<brendyn># of packages brendyn has submitted: 2. # of packages brendyn has half baked definitions for: 7
<jmd>What kind of regexps does substitute* accept?
<janneke>jmd: try: (use-modules (guix build utils)) ,decribe substitute*
<brendyn>Is there a way to make guile load everything so that geiser works properly?
<brendyn>Like substitute* isn't found
<jmd> /join #debian
<jmd>Oops
<janneke>brendyn: everything?
<ng0>I'm attempting to package inox.The amount of unbundling is high.. whic his good. but so many lines for unbundling.
<dvc>ng0: awesome! are you starting from scratch?
<dvc>efraim already started packaging it and I picked it up
<dvc>I can post efraim's code plus a few changes I made if you want to use that as a basis
<ng0>oh.. okay, if you want to continue it? I just wrote from scratch based on what i found on gpo, by gentoo
<dvc>jmd: since you have a mips machine, can you look at the binutils problem?
<ng0>i just thought no one does it so i have to.
<dvc>ng0: oh no - I only spent a little time on it - I'm really working on other stuff
<dvc>efraim dropped it too
<ng0>me too, would be a sideproject.
<jmd>dvc: Which binutils problem is that?
<dvc>jmd: ludo posted on the mailinglist - there is a binutils build failure on mips which is holding up core-updates
<jmd>Ok. I'll read the list.
<dvc>jmd: http://lists.gnu.org/archive/html/guix-devel/2016-09/msg01081.html
<dvc>ng0: https://github.com/dvc94ch/guix inox branch
<dvc>incase it's helpful
<ng0>okay, thanks
<ng0>i don't promise to pick it up, but if I make some progress I'll post it to the list for someone else to progress with it
<dvc>it would be really nice to have somewhere to put packages that someone started but need someone to bring them home
<ng0>i have a one-to-serve-them-all repository where I do forced-updates of work in progress things, in addition to the preparation repositories. maybe we could have some kind of pastebin for this.. idk
<ng0>i started working on packaging the new tcc, and they have a 'mob' branch where anyone can push to.
<ng0> http://repo.or.cz/tinycc.git
<ng0>dvc, where does it fail? i had this base: https://data.gpo.zugaina.org/prism-overlay/www-client/inox/
<ng0>any useful comments before I repeat something already done?
<dvc>ng0: nothing works yet... I think efraim just tried translating the aur PKG_BUILD, I added a substitute echo which I had from an earlier work on packaging chromium and qtwebengine and the inox-patches origin. You'll basically have to check each and every line =P
<ng0>ah, okay.
<ng0>so my base i started with the ebuild will be useful.
<ng0>i think i will test the gnunet and git services next week. this needs to be published :/
<ng0>for python.scm and all the big ones.. can't we have a (gnu packages python tests) (gnu packages python networking) etc to break it up? Of course moving around just for moving around is to be avoided.. but those files are growing long.
***jonsger1 is now known as jonsger
<quigonjinn>rekado: did you post the patches for arm-none-eabi in guix-devel?
<ng0> https://github.com/kurtmckee/feedparser/blob/develop/LICENSE 1 is bsd-2 (?) but what's the documentation license?
<ng0> https://en.wikipedia.org/wiki/FreeBSD_Documentation_License got it
***jonsger1 is now known as jonsger
<dvc>can guix build xdg-utils make use of guix records?
<dvc>xdg-utils doesn't exist yet...
<jmd>dvc: There is a xdg-utils package.
***jonsger1 is now known as jonsger
<dvc>I'm not talking about a package, but some helpers for creating desktop and appdata files
<dvc>the specs are quite extensive - packages that don't supply a desktop file all write their own implementation
<dvc>I'm wondering what the best way to do this is. Can there be multiple build systems for a package? If someone adds a <xdg-desktop-entry> to the properties field of a package can we select an xdg-build-system that creates a desktop file and validates it using desktop-file-validate from the xdg-desktop-utils package?
<efraim>We can pull in a phase from another build system if needed
<efraim>There's also the option of like with ghostscript-gs where we used gostscript as an input and then modified it
<efraim>But that seems more hack-y
<jmd>What do other oses do? I don't think normally the packagers create .desktop files. It's the job of the maintainers.
<ng0>but that's what they do.
<efraim>If I had to guess Debian would generate one and add it as a patch
<ng0>if a package has no .desktop, most systems leave it or create one themselves and include them. gentoo includes them in files/ of the ebuild directory.
<ng0>i personally just try to upstream
<dvc>I think it's nice to be able to create one yourself, especially for small scripts that you'd like to start from a launcher.
<efraim>Without the .desktop file their program won't show up correctly in menus, so IMO its their job to provide one
<dvc>ok - so I'll stop working on this feature - or does someone think it's useful?
<jmd>dvc: Sorry. I'm not exactly sure what it is you're working on.
<dvc>a way to add desktop files to packages that don't have one
<dvc>or appdata files - are used by package managers for example - we can dump the metadata that guix packages already have into an xml format
<dvc>jmd: see xmonad as an example
<jmd>I think it might be useful as a semi-automatic tool to identify packages which don't have one - and possibly should - and maybe to generate a suggestion for one. But I don't think it should blindly put one in.
<dvc>ah no of course not
<dvc>jmd: that's what I was thinking too
<jmd>Actually, I've been looking at ludo's suggestion to add a phase which adds the full path to .desktop files' Exec= line.
<dvc>that would be a good idea also
<dvc>TryExec too...
<dvc>and then there are [Desktop Action ...] sections that also contain Exec=...
<jmd>Yes. It does TryExec
<dvc>jmd: has a patch already been submitted?
<dvc>I think I missed that one
<jmd>Not yet.
<jmd>It would have to go into core-updates.
<dvc>and what's with packages that don't contain desktop files?
<jmd>It'll ignore those.
<dvc>or ugly low res icons
<dvc>no I mean how do we handle them
<jmd>Hey! You're talking artificial inteligence now!
<dvc>funny - I wasn't asking about an automated solution
<jmd>You need to write a scheme predicate: icon-is-ugly?
<jmd>(if (or (icon-is-ugly? i) (icon-is-low-res? i)) (beautify-icon i))
<dvc>ok - I'll go do something else now... ;) did you get anywhere with the binutils mips build failure?
<jmd>I don't have guix on that machine. I will have to install it.
<ng0>in case upstream does not respond to the recommendation that their release model is suboptimal, debian mirrors should be acceptable?
<jmd>I don't know. Ask on the list.
<ng0>I'd like to wait until I get a response by upstream.
<quigonjinn>who was trying to package gforth the other time?
<ng0>i'm on that
<ng0> https://gitlab.com/packaging-guix/guix see branch forth
<ng0>hackedi-nucky stuff, i force-overwrite regulary, so this is just for mirroring.
<ng0>why, you want to take over or have some insights?
<ng0> https://notabug.org/packaging-guix/guix/commit/19532b25fc26255ef0a3d133dc1637cbe6727669 mirror of thatrepo
<quigonjinn>ng0: I needed the program today, but as I use guix on parabola, i got it from there. I wondered how did the packaging go, and if some help is needed so that i put it in my todo list.
<adfeno>Hi all! :D
<ng0>well you can assemble a patch from the branch and witness the build errors first hand. I work on it, but I work on many things in parallel
<adfeno>I have a question: How would I make sure that, when making a package definition inherit python2-twisted's, how to make sure that the original inputs are preserved, even if inserting new ones?
<ng0>on old languages, there's also this bug with lispf4 if you feel the desire for adventure: https://debbugs.gnu.org/cgi/bugreport.cgi?bug=22732
<adfeno>I know I have to use: (inherit python2-twisted)
<quigonjinn>ng0: alright, i'll put those in my list, to give a look to
<adfeno>But from my observations: if you specify an input declaration, it replaces the original.
<adfeno>I'm asking because, since I'm trying to make a recipe for Tahoe-LAFS, I also need to make a recipe for python2-twisted with the "'tls' extra" (as people who program in Python call it).
<cehteh>there isnt a 'non-hackish' facility to install packages per group instead per user yet?
<adfeno>cehteh: As far as I know, per group would require the group to have its own directory in the system.
<cehteh>its own profile at least
<adfeno>It might work, we just need to think about how to implement it. :)
<cehteh>someone some (longer) time explained me here how it could be hacked, i can check my irclogs
<ng0>reading my chat with darcs developers/users yesterday, and now reading this: http://darcs.net/FAQ#basic-usage-2-interacting-with-other-repositories I'd say darcs is finished - just the 20 failing tests need to be fixed if possible.
<cehteh>but it would be really nice if such gets an official blessing
<cehteh>having guix package --user and --group options which could be set to defaults by config or env vars
<ng0>there's either a bug in my curl_ssl environemnt variable, or (more likely) the variable i tried to set does not exist and darcs switched https off entirely.
<ng0>someone told me that HTTP_ turns up but not HTTPS_ in the source
<ng0>maybe pijul just had a typo on their website, with the darcs command using https
<adfeno>About inheriting inputs: I think I got it now.
<ng0>after all pijul was my only darcs reference and motivation.
<ng0> http://hub.darcs.net/ does also not mention https
<ng0>and i would expect a hosted solution to offer and point out https
<ng0>and the links i find in search results start with darcs get http:// ... etc
<adfeno>Hm....
<adfeno>It didn't work
<adfeno>The package didn't inherit the inputs.
<snape>is there a way to see the logs of a service that the shepherd failed to start?
<snape>(other than execute that service manually)
<snape>(and check stdout)
<jmd>snape: only if the syslog service is running I think.
<snape>weird. it is running.
<dvc>no there isn't
<dvc>snape: there is a patch in shepherd master
<dvc>to allow passing #:log-file for debugging purposes
<dvc>failed services will log to tty1 so if it's verbose you can't see all
<snape>thank you dvc
<snape>Actually, I don't know how to see a server's tty1
<dvc>snape: what's your setup?
<dvc>if you type tty in a terminal what does it say?
<snape>a server without screen, testing the dovecot service
<snape>/dev/pts/0
<dvc>so you are using remote-viewer?
<dvc>or how are you connecting?
<snape>ssh
<dvc>ah - no chance
<dvc>attach a screen to your server or use shepherd master
<dvc>then you can add #:log-file /var/log/dovecot.log to the make-fork+exec-constructor
<snape>make-forkexec-constructor you mean
<dvc>ah yes exactly
<snape>yes I'll do that
<snape>and by the way
<snape>I did "sudo herd restart syslogd"
<snape>and after that I lost my ssh connection
<snape>I had to reboot
<snape>is that normal?
<snape>(I could still ping)
<dvc>what ssh server are you using?
<snape>lsh
<dvc>I think lsh depends on syslog so when you restart syslog it should restart lsh
<dvc>but I'm not sure if it works...
<snape>:)
<adfeno>Oh... package-inputs worked! :)
<adfeno>I just didn't see it earlier because it had a line wrap. ;)
<dvc>does anyone have experience with debugging packages with gdb? The problem I'm running into is that many programs are wrapped and gdb keeps complaining about not detecting a binary
<dvc>is there a way to get gdb to run a script that runs a script that runs a binary?
<dvc>would be nice if gdb --args $(which PROGRAM-NAME) ... would work
<adfeno>Perhaps you need to change the script to use gdb to run the binary?
<adfeno>Besides, it's for testing purposes, so you'll probably revert it, right?
<dvc>adfeno: I'm talking about the standard scripts that are generated by wrap-program
<adfeno>Oh....
<dvc>I can't go modifying store paths
<dvc>but maybe I could replace wrap-program with wrap-program-debug for testing purposes
<adfeno>I see... Sorry for jumping into conclusions.
<adfeno>dvc: Great! :)
<snape>dvc, I guess you can copy store paths scripts somewhere else and modify them afterwards, too
<dvc>the case I have the binary is wrapped multiple times - it's a nuissance. I need to read up on debugging and start with a simpler package like hello
<dvc> https://www.gnu.org/software/guix/manual/html_node/Installing-Debugging-Files.html
<quigonjinn>how should one go about providing additional changes to a set of patches on the mailing list? send an updated patch series, provide additional patches on top pf the existing, or just propose plain code changes to the person who made the package?
<kyamashita>quigonjinn: Choices 1 or 3, or some combination of the two.
<Common_Era>Hello. I've written a custom Refind entry to boot from the GuixSD USB drive on my iMac. It boots and I get the banner on top and it goes through a bunch of stuff really quickly, but then either the mount procedure fails (No such file or directory), if I set --root=/dev/sdb1 or whatever, or, if I set --root=gnu-disk-image, it waits for partition gnu-disk-image to appear for a couple seconds, doesn't find it and errors itself into a
<Common_Era>o figure out what a good option to pass to --root is.
<Common_Era>Anyone know anything?
<Common_Era>By the way, I'm only using this Mac out of lack of access to anything else.
<adfeno>Common_Era: Your third to last message was cut...
<Common_Era>Pardon?
<adfeno>Was cut here: "doesn't find it and errors itself into a "
<Common_Era>Oh, oay. I'll fix it.
<adfeno>Common_Era: Just send us the missing part. It happens to everybody when the message is too long.
<Common_Era>It errors itself into a new Guile prompt. I'm just trying to figure out what a good option to pass to --root.
<Common_Era>I'm farther than I've ever been and I have some pride from the menu entry, but I don't want it to all go to waste.
<adfeno>Common_Era: This issue with GuixSD and other operating systems happens to almost everybody here... I once tried installing GuixSD, but I also got some boot-up issues, and my boot-loader, that came from GuixSD, didn't recognize my previous operating system...
<Common_Era>I don't need the other operating systems. I'll lose Mac OS X, if need be, and I was planning on removing my Debian anyway.
<adfeno>... Luckly, I had a spare USB thumb drive that had a live version of the previous operating system. So I didn't have to reinstall (I just told the live system to install its bootloader back).
<Common_Era>If I ever do want OS X back, I'll use internet recovery, which seems to be stuck on this thing, luckily.
<adfeno>Common_Era: :D I'm glad that you do want to throw Mac OS to the trash. :)
<Common_Era>:)
<adfeno>Non-(free/libre) software is always an injustice, even in voting machines.
<Common_Era>;) I've looked at GuixSD's grub.cfg, and it has --root set to gnu-disk-image, which seems logical, but it doesn't work, as I described.
<adfeno>s/./, cars or pacemakers/
<Common_Era>I've been a frequent lurker, just staring at the GNU website on my Mac, without making the switch, but always thinking about it. I've jumped the hurdle and I just want it to work.
<kyamashita>Common_Era: I have a similar problem with an old desktop machine of mine. I'm sorry to say that I've yet to solve it.
<adfeno>In my case, the distribution was Trisquel, a free/libre one, so I couldn't "simply throw it out". :)
<Common_Era>Hmm.
<Common_Era>Makes sense. I have a half-baked program I'm writing on Debian, but I've backed it up elsewhere. Really, I have no ties that I can't easily cut.
<adfeno>Common_Era: I'm looking at the documentation now, to see what I can do to help.
<adfeno>Right now, I'm using only Guix, installed in my copy of Trisquel.
<kyamashita>GRUB works fine for other distributions on that machine, like Trisquel, Dragora, and even the GuixSD USB installation image. But booting the installed GuixSD distribution, even when mirrored from another working installation, does not work.
<ng0>well you use what yoz have to use. i have to use gentoo to double check and release applications and ebuilds. I can't just get rid of it.
<adfeno>ACTION shakes when he remembers that he still has to try installing GuixSD along-side with Trisquel.
<ng0>I run gentoo in a qemu on NixOS
<ng0>that's the closest to getting rid of it
<Common_Era>Thank you. I've been through it. There's not much about actually booting from the USB, it assumes that's simple, which it should be, but isn't. I've set --root to /dev/sdb1, /dev/sdc1, the partition's label (guix-root), gnu-disk-image, and GuixSD's /root directory. All with a similar result.
<Common_Era>One of Refind's examples of a custom menu entry has --root=/dev/sda3, so I can't see a reason that --root=/dev/sdb1 shouldn't work.
<Common_Era>I'm wondering if it has to be a partition on the internal hard disk.
<Common_Era>But I don't think that makes much sense.
<adfeno>Common_Era: Can you tell me where exactly did you get the grub.cfg file containing "gnu-disk-image" as "root"?
<adfeno>I mean: "root" set to "gnu-disk-image"
<adfeno>Is the grub.cfg in your system? Or did you see it in the Internet somewhere?
<Common_Era>I mounted the GuixSD USB to a folder that I just called Guix. In Guix, the file is at boot/grub/grub.cfg
<adfeno>Hm....
<Common_Era>And I'm editing the refind configuration file at /boot/efi/EFI/refind/refind.conf.
<adfeno>From what I can recall... block devices with numbers are always partitions.
<adfeno>So "sdb1" is a partition inside "sdb"
<Common_Era>Yes, that's correct.
<Common_Era>Should it just be the /dev/sdb? I don't think that sounds right.
<adfeno>No, keep the number.
<Common_Era>Yeah.
<Common_Era>Going to try with /dev/sdc1 because it seems to like switching,
<adfeno>Yep...
<Common_Era>?
<adfeno>"Yep..." ... devices like to switch paths.
<Common_Era>Oh, okay.
<Common_Era>If I set it to either /dev/sdb1 or /dev/sdc1 ( the two it likes ), it hangs at [sdc] Attached SCSI removable disk.
<kyamashita>When I try to boot GuixSD from my desktop hard drive, it reports sda-sdd as block devices, yet it won't mount anything. I honestly think that my desktop just has an odd BIOS. Not saying that this is the case here, but maybe these instances are connected somehow...
<adfeno>Common_Era: Check if the **partition** where GuixSD is installed is really called "gnu-disk-image".
<kyamashita>My desktop hangs right after it repots sda-sdd as block devices, that is.
<adfeno>s/called/labelled/
<Common_Era>kyamashita: GuixSD isn't installed, this is from the USB.
<Common_Era>adfeno: Will do.
<kyamashita>Oooooh!
<Common_Era>It wasn't. Retrying it labeled that way now.
<Common_Era>I can't believe i didn't think of that.
<adfeno>Labels are convenient since you don't have to remember the path of the block device.
<Common_Era>It works...
<Common_Era>Thank you so much!
<adfeno>But You have to make sure that the block device has the label you want.
<Common_Era>I got to the root@gnu ~# prompt!
<kyamashita>Yay!
<Common_Era>Time to follow the installation guide.
<Common_Era>Thanks, everyone.
<adfeno>:)
<adfeno>You're welcome. :)
<Common_Era>Wow, even the Wifi works!
<adfeno>Common_Era: Lucky hardware. :)
<Common_Era>I guess so.
<ZombieChicken>Anyone have any suggestions on how to test if I have a working network connection from within a Qemu VM? Apparently ping doesn't work (Qemu "bug", we'll say), and neither wget nor curl seem to be installed in the default USB install media
<adfeno>Does it have awk?
<ZombieChicken>seems to
<ZombieChicken>never heard of using awk to test a network connection before, though
<adfeno>It only works with GNU awk.
<adfeno>The other ones ("POSIX-ly correct" ones) don't allow such test.
<kyamashita>adfeno: Oh gosh I saw this feature in GNU awk's documentation a few days ago. :P
<adfeno>Hahahaha
<ZombieChicken>So how the heck do I use awk for that kind of thing?
<adfeno>ZombieChicken: I'll check the docs again, (it's also new to me, but interesting)
<ZombieChicken>I'm really confused why something like wget or curl wouldn't be in an installation medium
<adfeno>ZombieChicken: Does the installation have "lynx"?
<ZombieChicken>Nope
<ZombieChicken>This is a fresh download. Checked out against the .sig on the site, too
<adfeno>Hm...
<ZombieChicken>guixsd-usb-install-0.11.0x86_64-linux
<kyamashita>ZombieChicken: You could always use ifconfig <interface> up, dhclient -v <interface>, guix pull
<ZombieChicken>guixsd-usb-install-0.11.0.x86_64-linux Sorry, missed a period there
<ZombieChicken>I'm trying guix pull right now
<ZombieChicken>that seems to have done it. Thanks
<kyamashita>You're welcome. :-D
<ZombieChicken>If a dev runs across this, maybe include wget/curl or something in the install medium for these purposes. "guix pull" isn't exactly an intuitive way to check if a network is usable
<kyamashita>I remember ping working for me inside of qemu...
<kyamashita>ng0: Are you here?
<ZombieChicken>kyamashita: It doesn't for me for one reason or another. I looked at the Arch wiki and it says Qemu is doing it's own weird thing with networking
<ng0>yes
<ng0> https://gitlab.com/packaging-guix/guix/commit/36fa25f9a8fd472561e96e40e6d7fedd725ee42b should I file this as too small to contribute to guix?
<kyamashita>ng0: PHP 7's ./configure script wants MySQL 4.1 for some reason.
<ng0>what's our mysql?
<kyamashita>5.7.15
<ng0>you can package an inherit version of mysql@4.1
<adfeno>ZombieChicken: Phew... I don't have to make an awk script to test network... It's interesting to do, but it takes three lines of code.
<kyamashita>I'll take a look at the config.log first.
<ZombieChicken>adfeno: One command with one arguement > three lines of awk, imo anyways
<kyamashita>Anyone know what --with-pdo-mysql gives PHP the ability to do?
<ZombieChicken>Ah, something I should have asked; does Guix have anything like USE flags ala Gentoo?
<kyamashita>ZombieChicken: Not that I know of.
<ng0> https://data.gpo.zugaina.org/pross/dev-lang/php/php-7.0.9.ebuild this doesn't show any limitation to mysql4
<ZombieChicken>That is a shame
<kyamashita>ng0: That's why I find this odd.
<ng0>ZombieChicken: no, but creating and maintaining your own versions of packages is easy
<ZombieChicken>ng0: You mean forking a build script just to set different build options?
<ZombieChicken>I have over 800 packages on my gentoo install. That is a /lot/ of forking...
<ng0>you don't necessarily need all.
<ng0> https://gitlab.com/secushare/guixpkgs this is one way to do it.. this is a preparation repository, but it can give you a view on something 'overlay' like
<adfeno>You can perhaps use (inherit [package name]) to inherit most things.
<kyamashita>ng0: This seems to be the culprit: "ld: cannot find -lmysqlclient_r"
<ng0>i originally had an guixpkgs repo where i moved from our overlay (youbroketheinternet-overlay) to guix paclkages, but most packages either ended up in the secushare preparing one or directly upstream, master.
<ng0>hm
<kyamashita>Unfortunately, I don't know how to fix that. I don't think we have a package that covers this yet.
<Common_Era>Guix system init is reporting that modinfo.sh for Grub doesn't exist. And fails to install Grub on device /dev/sda.
<ng0>that looks like you need to set some library path?
<kyamashita>modinfo.sh? This is the first I'm hearing about this script.
<Common_Era>It should be in (random digits)-grub-2.02beta3/lib/grub/x86_64-efi/, but x86_64-efi doesn't exist there.
<Common_Era>Only i386-pc.
<kyamashita>Ah. Guix doesn't have EFI support yet, IIRC.
<Common_Era>I hate my life.
<kyamashita>:-/
<Common_Era>Is there a way I could set it to use the other way. Refind can boot through a BIOS.
<Common_Era>I'm not very knowledgeable here.
<Common_Era>Was it all for nothing?
<kyamashita>Common_Era: Like set the computer to use BIOS? Or set GRUB to support EFI?
<kyamashita>ng0: Our mysql package doesn't build that library. I have to figure out how to enable it
<ng0>oh! okay
<Common_Era>I don't really know. I know that Refind can boot a BIOS OS on Macs because they have a weird EFI implementation. I think that if I could set guix system init to use the i386-pc directory for Grub, it might work. Maybe I'm just stupid.
<kyamashita>I'm not sure. It's been a while since I've messed with EFI (or perhaps it messed with me?).
<Common_Era>Don't most modern-ish computers use EFI?
<kyamashita>Less. I'm a digital scavenger. :P
<kyamashita>*yes, not less
<Common_Era>Oh. :P
<kyamashita>In theory, what you're saying should work, but I don't know how to *do* it.
<Common_Era>What would happen if I use --no-grub? Because, the computer already has Grub for Debian.
<kyamashita>You should be able to boot from Debian's GRUB, but I imagine keeping track of the kernel path and such might be a pain.
<Common_Era>Well, the command finishes when I use --no-grub.
<Common_Era>I'll try rebooting, I guess.
<kyamashita>menuentry "GNU with Linux-Libre 4.7.2 (beta)" {
<kyamashita> search --label --set /dev/sda1
<kyamashita> linux /gnu/store/1w33nqlw4il84i4xr3pif45insmz82ln-linux-libre-4.7.2/bzImage --root=/dev/sda1 --system=/gnu/store/a4lbnf541sz9ps8pyh7zdmg0bm1lccnc-system --load=/gnu/store/a4lbnf541sz9ps8pyh7zdmg0bm1lccnc-system/boot iomem=relaxed modprobe.blacklist=kvm,kvm_intel
<kyamashita> initrd /gnu/store/a4lbnf541sz9ps8pyh7zdmg0bm1lccnc-system/initrd
<kyamashita>}
<kyamashita>Example GRUB menu entry for GuixSD
<Common_Era>Thanks.
<kyamashita>You're welcome. I'm curious if there's an easier way to do this. Because if there isn't, there should be IMO.
<Common_Era>We'll see if this works.
<j-r>how would one remove older system generations?
<j-r>I'm tring to clean up my grub menu and reclaim some disk space.
<kyamashita>j-r: You have to go into /var/guix/profiles and manually remove them as GuixSD is setup today.
<j-r>kyamashita: I can do that. Thanks.
<kyamashita>You'll see system-<number>-link, you can delete those. Don't delete /var/guix/profiles/system without rerunning guix system reconfigure, though.
<kyamashita>You're welcome. :-)
<adfeno>kyamashita: Doesn't one have to do: guix package --delete-generations=[comma separated list] ?
<adfeno>... then do: guix gc ?
<kyamashita>That's for each users' personal packages. We don't have a subcommand for managing system generations yet, I don't think.
<alezost>adfeno: this is for package generations, not for system ones
<adfeno>Oh....
<adfeno>Wow.
<adfeno>Didn't know that
<j-r>I'm working at the GuixSD system level things.
<alezost>there was some work on that on guix-devel
<alezost>:-)
<j-r>Hopefully I don't have a full reload in my future ;)
<kyamashita>Luckily, we can just point to the (beta) tag. I'm hoping it will be there soon.
<kyamashita>j-r: Same here, heh.
<cehteh>oops ..offloading livelocked here because there was a stale lsh yarrow-randoms-seed.lock
<j-r>So If I wanted to actually contribute to GuixSD, what would be the best way to get involved?
<kyamashita>j-r: I wrote a package for milkytracker because I wanted my tunes on GuixSD, too. Next thing I knew I was writing a bunch more.
<kyamashita>Depends on your skillset, really. Even just using the system can help, not to mention pointing out bugs, missing packages you'd like to see in the future, etc.
<adfeno>j-r: Also, spreading the word is a big contribution.
<j-r>I'm trying to package stumpwm and a few other things.
<j-r>I'm actually an AIX / Linux Engineer by day ;)
<kyamashita>ng0: According to github.com/facebook/hhvm/issues/7090, the mysqlclient_r library is deprecated.
<kyamashita>j-r: Very nice!
<j-r>I'd really like to be a able to pxe boot and network install GuixSD on lvm devices.
<adfeno>j-r: If you do have the time, some day in the morning, during coffee, take wingo's blog post about Conway's law and software, and give it read. It also helps if watch the talks about Guix on media.libreplanet.org (site).
<adfeno>After seeing and reading these, you'll notice how fragment the "packaging" of software is these days, and what Guix solves.
<j-r>adfeno: sure. Never actually heard about Conway's law. Looks interesting.
<j-r>I discovered Guix about 3 month's ago. It would solve many of the problems we are facing with deployment at $WORK.
<j-r>As I am the technical lead for the project to migrate from AIX to GNU/Linux Guix will be in there.
<adfeno>As a free/libre software activist, however, I have to advise you that: the primary goal of Guix and GuixSD is to be free/libre software. And so I also recommend that you make such note to people who listen to you.
<j-r>Not so much for GuixSD as $WORK seems to be allergic to free software.
<adfeno>The allergic ones are to those we must explain the **basics** of the four freedoms to.
<adfeno>We have to at least try. If there's no try, then we have failed.
<j-r>Yes, I'm aware of the free/libre thing. I have FSF and GNU stickers on my $WORK laptop. Makes for some rather interesting discussions at meetings. ;)
<kyamashita>I can imagine.
<j-r>I'm also trying to educate my children and wife on the benefits of free software.
<lfam>Sometimes it takes a while to learn that lesson. It might take some years for someone to experience the negative effects of non-free lock-in to
<sneek>lfam, you have 1 message.
<sneek>lfam, rekado says: I can’t seem to find the Lua patches you wanted me to test with Prosody. Could you please send me a pointer if this is still to be done?
<lfam>Took a while for me anyways :)
<kyamashita>I'm educating my family, too. Especially when they come to me to fix things that require free software (security, removing DRM, no forced upgrades, etc.).
<lfam>So, my oss-sec inbox is filling up a little bit. I wouldn't mind some help keeping on top of security issues!
<adfeno>j-r: Don't worry, it takes time for most people to understand what is at stake
<adfeno>The important thing is to keep trying.
<kyamashita>lfam: I could help once my current set of packages are pushed. I also need to get myself one of those oss-sec inboxes! ;)
<lfam>kyamashita: It's not a very busy mailing list, but it does take some time to figure out how to deal with the issues presented.
<lfam>I have to say, I'm always relieved when I see that we don't package the affected program
<lfam>Which is really a paradoxical response. We *should* want more packages. But people should maintain the packages they add :)
<adfeno>j-r: The most critical environment is where you are employed. At home and college, you can simply refuse to use/fix/teach/install non-(free/libre) software, and propose alternatives, followed by our usual explanations.
<kyamashita>lfam: Indeed.
<adfeno>But at work, unless you have the authority and resposibility to choose which software to use/install/teach/fix/recommend/sell/share/etc... then it becomes complicated, because in most cases you are subordinated to someone.
<j-r>adfeno: As technical lead for the project I'm on I get to have some influence, although not as much as stated at the beginning. We could pick any GNU/Linux distro and virtualization stack that would meet requirements.
<j-r>I'm beginning to think the only option that *meet* requirements are vmware and RHEL. I'd much rather use kvm and some other distro.
<lfam>Interesting, what are these requirements that require that stack?
<jmd>I thought kvm was rather deprecated these days.
<lfam>Sounds like RHEL did a good job of advocating for their software :)
<j-r>as far as I can tell there is a license fee and support or the suits from RedHat play golf with the suits at my company. Typical golf course IT.
<lfam>Ah, I thought it was a technical / support requirement ;)
<j-r>No, mostly political.
<lfam>Most things are
<adfeno>j-r: I'm not a programmer, nor a AIX/"Linux" engineer, but perhaps I can help looking on how to satisfy the requirements.
<lfam>One ignores it at their own peril
<adfeno>You just have to provide us the list of requirements.
<j-r>I've argued up to the CIO, that we would be better served to use free/libre software, take the $$$ saved on licensing and hire FTE.
<lfam>And you would have more control over the software that runs your business :)
<lfam>Although RHEL is not too bad. It's not as if you are choosing between GuixSD and Windows
<j-r>adfeno: I'll see what I can do. Mostly everything has to go through legal, get NDAs signed before we talk to vendors.
<adfeno>And by making use of that money that you would have spent with non-(free/libre) software, you could hire a free/libre software person to make adaptations and give support or consulting for you.
<j-r>The main application is written in house for the last 30 years or so. It doesn't have a chance of compiling on Windows.
<j-r>The biggest thing for the distro is it has to have official support from IBM for DB2.
<adfeno>j-r: "NDA" = Non-disclosure agreement?
<j-r>adfeno: yes. non-disclosure.
<j-r>we're looking at Cent, RHEL, and Ubuntu.
<j-r>All of those are supported at some level.
<adfeno>Does the official support for IBM and DB2 **require** CentOS, RHEL, or Ubuntu?
<lfam>ACTION starts collecting libarchives bug fixes
<j-r>yes, according to our support reps at IBM.
<adfeno>Hm... Is this "requirement" written there, or is it just spoken?
<j-r>It's written, but in pencil at the moment ;)
<adfeno>ACTION wishes people would start writting requirements with generalization in mind, not by stating particular names, or that they would specify bit-by-bit what is needed, instead of particular names.
<j-r>I've built a system around Debian (as I've used that personally forever).
<j-r>Managenent didn't really like that as there is no vendor that sell support at the scale we need (or that management thinks we need).
<adfeno>Did you use that system-built-around-Debian to do work-related tasks?
<j-r>yes I did.
<adfeno>See... They require stuff that even **they** don't know what they are requiring. :)
<adfeno>It would be wise to ask the people responsibe for evaluating IBM and DB2 support what is **really** needed, just ask: package names, plese?
<adfeno>Depending on the packages needed, you can use either GuixSD, or other free/libre GNU+Linux distribution at work.
<j-r>GuixSD still has beta in the name. They are too risk averse for that.
<adfeno>Also, ask then if the packages they indicate have to have specific features enabled (this is the case for most things written in Python these days, a mess of optional functionalities).
<adfeno>Well then, perhaps you can choose other free/libre distro.
<j-r>We have over 150,000 installed instances of OpenSuSE. Can't even look at that one. I think hurt feelings between upper management and Novell (or whoever owned SuSE at the time).
<adfeno>j-r: I fail to understand how your last message relates to my last one.
<adfeno>Of course: as I don't speak English natively, I might have misunderstood the message.
<j-r>management has preconcieved ideas of what distro they want us to actually use. I would like to use a free/libre distro.
<j-r>Haven't really been able to convince my peers that such is better. :(
<ZombieChicken>Are they dead set on offical support from the distro ala SuSe or RHEL?
<ZombieChicken>(at least I recall SuSe having purchasable offical tech support)
<j-r>yeah, they are pretty much set on official support from the distro.
<ZombieChicken>Where is the best place to make suggestions for Guix(SD)?
<adfeno>Organizations these days fail to understand that, even with free/libre distros, it's possible to hire some one to give support and even make packages for such free/libre distro.
***mark_otaris is now known as mark-otaris
<kyamashita>ZombieChicken: from a development standpoint, try the guix-devel mailing list.
<adfeno>It's no different than those non-free ones. The difference only relies on **how** much **work** has to be done **sometimes**.
<adfeno>But this is **also** possible to happen in **non-free** distros.
<ZombieChicken>adfeno: I think some of them are hoping for the legal angle. You can't sue a single person if your infrastructure collapses to recoup damages
<adfeno>So there's no real difference
***snape` is now known as snape
<adfeno>ZombieChicken: Hm...
<j-r>I understand. They've been doing business the same way since 1945. It's hard to change things.
<lfam>I thought IBM predated 1945
<ZombieChicken>I seem to think IBM came around last 19th century
<ZombieChicken>s/think/recall
<lfam>Based on their involvement in the second world war
<ZombieChicken>Anyone else able to reach gnu.org? I seem to be unable to
<kyamashita>ZombieChicken: I can't. No ping response.
<ZombieChicken>Thanks. Good to know it isn't just me
<lfam>:/
<ZombieChicken>I'm assuming my ongoing GuixSD install will likely suffer becasue of that...
<lfam>I'm able to reach hydra.gnu.org
<ZombieChicken>Handy, that
<lfam>But not savannah.gnu.org, so `guix pull` doesn't work
<ZombieChicken>ACTION is really missing --quiet-build right now
<ZombieChicken>I'll have to email guix-devel a few suggestions in the near future
<kyamashita>Nooooooo, PHP! You were compiling so nicely! ;_;
***mark-otaris is now known as mark_otaris
***mark_otaris is now known as mark_otaris_
<ngz>Hello. I have a compressed folder which is basically a bunch of js files and an index.html. I'd like to package it for Guix as an offline application. Unfortunately, I cannot just make a script launching the index.html because some AJAX calls are not possible. I need to launch a local web server. Is it an acceptable trade off for a package? If yes, any ideas on how it could be done in Guix?
<Common_Era>Alright, sorry for the long absence. I've got the refind entry for the SD done. But it says the loader is invalid, even though I'm using the same one as specified in the grub.cfg (<unique, random digits>-system/boot). What am I doing wrong here?
<ZombieChicken>fwiw, I think gnu.org is back up
<Common_Era>It's been down a lot lately, hasn't it?
<ZombieChicken>I don't know. All I know is it was down earlier and now it isn't
<ZombieChicken>and that OpenSMTPD is a hell of a lot saner to setup than most email servers
<Common_Era>It was on and off a couple days ago.
<kyamashita>I remember that.
<Common_Era>Do you have any idea what's wrong with my current setup? I guess I'm on carving a new path?
<kyamashita>Common_Era: I would say so. If you're specifying the right kernel and initrd, I don't know what else to say. Does it mean that GRUB is invalid?
<Common_Era>Well, should I re-install Grub alone?
<Common_Era>Grub might as well have been "corrupted" in some way or another.
<Common_Era>I might look into documenting my experience, if this works.
<kyamashita>Common_Era: Try booting into Debian and reinstalling GRUB from there, if that's easier.
<Common_Era>I've replaced Debian with Guix. I'm doing this from Mac OS X until I get this to be functional. I think I can do it from here.
<kyamashita>You can reinstall GRUB from Mac OS X?
<Common_Era>I'd think so.
<Common_Era>It has access to the required Unix utilities and can (generally) build from source.
<Common_Era>We'll see.
<kyamashita>I know that you could probably chroot into Debian from the GuixSD installation image and do it that way. But like you said, we'll see.
<Common_Era>Getting there.
<kyamashita>What progress have you made?
<Common_Era>I've installed Flex, Objconv, and the real GCC. Building Grub now.
<kyamashita>Ok.
<Common_Era>Do you have any idea what the variable is that I can use to specify my objconv
<kyamashita>I'm not sure, let me see if I can find some info
<kyamashita>So you've already compiled objconv?
<ZombieChicken>gah. Thinks keep stopping
<rekado>quigonjinn: yes, I sent the arm-none-eabi patches out today.
<rekado>we should reduce the number of failures here: http://hydra.gnu.org/eval/109185#tabs-still-fail
<rekado>I’ll try to fix or disable a couple of these bioinfo tools that won’t run on anything but x86_64
<rekado>tomorrow
<rekado>I’d like to see a graph rather than a list there, actually.
<rekado>that would make it easier to see what’s worth fixing first