IRC channel logs

2016-05-14.log

back to list of logs

<LnL>Is there some way to import a specific version of a pypi package?
<LnL>so guix import pypi <package>/<version> seems to work but the build inputs are not generated correctly
<inposa>How do you guys feel about releasing software under UNLICENSE?
<janneke>inposa: I assume you have read http://www.gnu.org/licenses/license-list.html#Unlicense
<inposa>Have not, will read now Thanks!
<janneke>Ok anyway, I don't really understand your question. If you write software and publish it, you get to choose the license.
<inposa>Indeed but I want the most permissive least-headache license possible, apprently that's CC0
<GNUtoo-irssi>hi, with the livecd install, it forced the packages to be taken from the disk
<GNUtoo-irssi>I guess it's because the livecd/liveusb is supposed to be in ram
<GNUtoo-irssi>Is it possible with guix(not guixsd) to do something similar and not write to /tmp/
<GNUtoo-irssi>herd start cow-store /mnt
<GNUtoo-irssi>that is for guixSD
<GNUtoo-irssi>On Parabola, with guix, beside not mounting my /tmp as tmpfs, is there another option?
<fhmgufs>What is Guix doing in /tmp ?
<sneek>Welcome back fhmgufs, you have 1 message.
<sneek>fhmgufs, daviid says: (create-signal <gtk-window> 'bluefox #f '())
<GNUtoo-irssi>it stores compilation stuff
<GNUtoo-irssi>compilation results in OOM because I didn't activate swap, still I've 4G of RAM
<GNUtoo-irssi>Is there a configuration file for guix?
<fhmgufs>But you don't need the compilation stuff afterwards.
<fhmgufs>Ah, you don't have enough tempfs space.
<GNUtoo-irssi>indeed
<GNUtoo-irssi>sometimes it fails with not enough space
<GNUtoo-irssi>sometimes I've some OOM oops
<GNUtoo-irssi>(depending on what I've running aside)
<fhmgufs>I dont' know whether you can change that, afaik the daemon is like Nix daemon. Maybe you get some information there?
<GNUtoo-irssi>I guess it's the downsides of the "declarative" approach
<GNUtoo-irssi>you tell it what to do, not how to do it
<fhmgufs>I don't think that it's normally a problem to have these files in /tmp
<fhmgufs>and this is the standard place for them
<GNUtoo-irssi>I can try to add more ram though
<fhmgufs>Or just enable swap?
<GNUtoo-irssi>that could work too, it's an SSD, but without swap partition
<GNUtoo-irssi>I would need to put the file inside the fs and hope that the swap code isn't too slow
<GNUtoo-irssi>it's supposed to bypass the filesystem anyway
<alezost>ACTION still can't use guix repo through ssh (and git but it's not important) :-(
<alezost>efraim: rekado: do you also have this problem?
<roelj>Is there an option for the guix-daemon to only download substitutes and never build something itself?
<alezost>I don't know, but I don't think so: what if you would want to build your own "foo" package? There can't be substitutes for it
<roelj>Yes, well you'd have to build it somewhere else so it can be substituted.
<roelj>And that's exactly what I'd like to achieve.. run the build process on one machine while it should be installed at another.
<alezost>ah, interesting, well I don't know; I would begin with looking at "guix-daemon --help"
<roelj>If I add an option "--substitutes-only" to the daemon, would that be something the project is willing to upstream?
<roelj>I know it kind of defeats the purpose of the "build daemon" to not be able to build anything, but for the case of a slow machine and a fast machine that can better deal with the build processes, this may be interesting.
<roelj>Or would it then be a better idea to run the daemon on the fast machine anyway..
<roelj>And add networking functionality for communicating between the daemon and the "front-end"
<GNUtoo-irssi>roelj: I'd like that feature
<GNUtoo-irssi>I was thinking that guix(and guixSD) could work as a binary distro
<GNUtoo-irssi>and that the users could still compile stuff if they whished to
<GNUtoo-irssi>so if I really don't want to compile (and I really don't in most cases), that's a good idea
<GNUtoo-irssi>In other words, I thought that all the system could work without compiling, and that only when you want to override the distro's choice you had to compile
<GNUtoo-irssi>mattl_: hi
<mattl_>Hey what's up?
***mattl_ is now known as mattl
<GNUtoo-irssi>mattl: can I PM you?
<GNUtoo-irssi>(it's for something totally unrelated to guix)
<mattl>GNUtoo-irssi: sure
<aleogen>what the difference between guile, scheme, racket, elisp, common lisp, and lisp? Which one should I really invest in while messing around with Guix?
<fhmgufs>aleogen: Guix is written using Guile, an implementation of Scheme.
<fhmgufs>racket is another implementation of that language.
<aleogen>Which is more "up to date"?
<fhmgufs>LISP is a family of languages where Scheme, Elisp and Common LISP belong to
<aleogen>I guess that question doesn't mean anything since Guix uses guile
<aleogen>guile it is
<fhmgufs>And Scheme is the "best" LISP (in my opinion)
<aleogen>Then why is guix using guile?
<fhmgufs>It's *GNU* Guile
<aleogen>excuse me.. gnu guile*
<fhmgufs>;) No, that's one reason, I think.
<aleogen>how does scheme differ from common lisp?
<aleogen>or guile
<aleogen>or how does guile differ from racket?
<fhmgufs>Guile was initially created as an extension language
<fhmgufs>Because of that you can use either Scheme or C
<fhmgufs>to program in Guile
<fhmgufs>(and theoretically every other language)
<fhmgufs>Because Guile provides a way to define multiple language frontends
<fhmgufs>And Common LISP is the common LISP, but it's old
<aleogen>is guile compatible with common lisp at all or even elisp?
<fhmgufs>No, Common LISP, Scheme and ELisp are different languages
<aleogen>but there's an FFI or I can make an extension?
<fhmgufs>But there's an ELisp frontend to Guile
<fhmgufs>So you can program in ELisp, too
<aleogen>no thanks
<aleogen>I like this
<fhmgufs>Normally you would chose Scheme when programming using Guile
<aleogen>Scheme and C, hand in hand, right?
<fhmgufs>Yes, right.
<aleogen>and ther's no restriction to C++14?
<fhmgufs>C++14? It's C
<fhmgufs>not C++
<aleogen>Yes, I'm asking about C++ specifically
<fhmgufs>Of course you can link Guile to C++, too
<fhmgufs>But that doesn't make sense
<aleogen>As long as I write a module to adapt <language> to Guile, I should have no problems
<fhmgufs>Yes, but that's not easy and not useful
<fhmgufs>Because normally you use Scheme
<aleogen>I think it's useful for my own projects, as they're in different languages
<fhmgufs>C++?
<aleogen>C++, haskell, Python, Common Lisp, etc
<fhmgufs>I don't know whether Guile is useful then
<fhmgufs>and whether that would be related to messing around with Guix
<aleogen>It's not exactly useful, but if guix is connfigured with it, well.. that could be helpful
<fhmgufs>What would you want to do then?
<aleogen>just to what extent I can drive guile is really my underlying question haha
<fhmgufs>(concerning Guix and C++ for example)
<fhmgufs>Ok
<efraim>alezost: i just checked, git push still isn't working for me, git fetch over http works atm
<alezost>efraim: thanks for confirmation, such a relief that I'm not alone :-)
<ng0>is there a progress update on getting hydra to a dedicated machine? I read in #libreboot the board is still being tested.
<efraim>does changing the license cause the hash of the package to change?
<efraim>that's one of the fields that doesn't, right?
<alezost>efraim: yes, it doesn't
<efraim>Can I change the license to "it's complicated" http://git.savannah.gnu.org/gitweb/?p=libidn.git;a=blob;f=COPYING;h=e6ea90ab188000e8fc30aa17afbe9387f9763510;hb=HEAD
<efraim>we don't build the java library so I'm seeing gpl2+ gpl3+ lgpl3+ gfdl1.3+
<GNUtoo-irssi>Hi again, the documentation says: guix system vm my-config.scm
<GNUtoo-irssi>Is it safe to have (bootloader (grub-configuration (device "/dev/sda"))) ?
<GNUtoo-irssi>would it touch the host's /dev/sda?
<civodul>GNUtoo-irssi: it's safe; this part is unused when doing 'guix system vm'
<GNUtoo-irssi>ok, thanks
<GNUtoo-irssi>same for filesystem I guess, thanks
<civodul>yes
<catonano>I can't clone the Guix repository anonimously. Has this anything to do with the server glitches that Savanna has been suffering recently ?
<wingo>catonano: i think so :/
<catonano>wingo: thanks