IRC channel logs

2016-05-05.log

back to list of logs

<Digit>got someone intersted in guixsd a bit, but they havnt, because they couldnt find an iso to easily plug into vbox. u guys got any tips for that scenario?
<bavier>Digit: they should be able to boot the disk image in qemu
<Digit>thnx
<rsiddharth>Hello, I'm using guix as a package manager on top of Debian GNU/Linux (testing). Today after I did 'guix pull' and 'guix package -u', I've been unable to use guix from emacs; when I do `M-x guix`, I get this error in the Guix REPL: https://www.refheap.com/3ced93b70f266c7655176936a. I checked this thread https://lists.gnu.org/archive/html/guix-devel/2014-11/msg00534.html, it doesn't seem to be of much help. What could be the problem?
<rsiddharth>list of packages I've installed https://www.refheap.com/4248e4fe9c4ba1ffa58be69af
<rsiddharth>I tried loading `guix-main.scm` from the guile REPL, it loads without any issues: https://www.refheap.com/e5ac53fc90b9dce65f55f0189
<kyamashita>If I have a precompiled binary, how can I point it to the correct system libraries, such as libstdc++.so.6?
<kyamashita>Never mind, I've found the variable I was looking for.
<janneke`>Morning Guix!
<efraim>hai
<frafra>when I use root with "su" no command is available; why?
<janneke`>frafra: what says: echo $PATH?
<frafra> /sbin:/bin:/usr/sbin:/usr/bin
<janneke`>frafra: well, is the command you need in one of those directories?
<frafra>janneke`, cp, ls, guix... everything is missing
<frafra>but if I login as root, I have them
<frafra>PATH is not set correctly if I use su
<janneke`>frafra: you probably want sudo -i or su -
<janneke`>on what system are you?
<janneke`>what does `echo /bin/ls' say?
<frafra>echo /bin/sh says /bin/sh
<frafra>janneke`, su - works correctly :)
<alezost>rsiddharth: re "Unbound variable: memoize": hm, maybe there is some ABI breakage. Could you remove compile cache ("/home/rsd/.cache/guile/ccache/2.0-LE-8-2.0") and try again?
<frafra>how to get the list of available services with herd? I installed openssh and I would like to start it
<alezost>frafra: "herd status" shows the current services, but there is no list of all available services.
<alezost>if you installed openssh, it doesn't mean there appear a service for it
<frafra>alezost, thanks; the openssh packages has no service file?
<alezost>frafra: packages do not have service files; packages and services are independent
<alezost>rsiddharth: ouch, there is some breakage indeed! I have the same issue
<alezost>rsiddharth: ah, I see: commit http://git.savannah.gnu.org/cgit/guix.git/commit/?id=958dd3ce68733 moved 'memoize' to another module. You updated just in time to discover this breakage :-) Thanks for reporting, will be fixed soon
<cow_2001>what's a nice thing to do with guix for a complete n00b?
<cow_2001>what are some super simple packages one could write a description for?
<rekado>hi from OTS 2016!
<frafra>hi rekado :)
<rekado>cow_2001: usually R packages are very simple (useful if you're into playing with statistics).
<rekado>cow_2001: we have importers that generate most of a Guix package expression for you.
<cow_2001>i'm a python dude <_<
<frafra>cow_2001, I'm a python programmer too, but I'm creating a package for a nice C program :)
<robsyme>Hi all.
<alezost>cow_2001: then you can make some python packages, usually they are also simple, look at "...<guix>.../gnu/packages/python.scm". Begin with "guix import pypi <name>"
<alezost>cow_2001: for example, I've just tried: "guix import pypi pyjwt" and got a skeleton of package definition for "python-pyjwt" (we already have this package)
<cow_2001>hmmmm
<cow_2001>how does guix relate to nix?
<robsyme>What is the most guixy/guiley way to write package definitions where two package dependencies require different versions of the same software? Do you just (define deppackage-1.2.3 (package (name ... and (define deppackage-2.0.0 (package (name ... ?
<cow_2001>is this the section of the guide i must read start to finish? https://www.gnu.org/software/guix/manual/html_node/Packaging-Guidelines.html
<foobarry>is R provided by guix? i did "guix package -s r" and got a load of results matching the leter r, and then then the search exploded with Backtrace:
<foobarry>In ice-9/boot-9.scm:
<foobarry> 63: 19 [call-with-prompt prompt0 ...]
<foobarry>In ice-9/eval.scm:
<foobarry> 432: 18 [eval # #]
<foobarry>In ice-9/boot-9.scm:
<foobarry>actually it died on qdox. can someone try:
<foobarry>guix package -s java-qdox
<frafra>foobarry, no results here
<rekado>foobarry: it's called "r"
<rekado>you can use regexes in search too, so guix package -s "^r-" will give you a list of all R packages in Guix atm
<rekado>foobarry: I can reproduce the error with qdox. Will check. Thanks for reporting.
<foobarry>no prob
<foobarry>is the main r language there? i can't see it
<foobarry>rekado: what's the best method for reporting issues?
<rekado>the package is just called "r".
<rekado>reporting bugs is best done via email to bug-guix@gnu.org
<rekado>I should note something about R
<rekado>mixing R packages between Guix and system R is not supported.
<rekado>that's an ABI issue.
<rekado>some R packages need linking with other libraries. When this happens they ultimately depend on libc.
<foobarry>is there an r-core package?
<foobarry>or base
<rekado>when the linking is done with the system toolchain the binaries cannot be loaded with a Guix R.
<rekado>our R package "r" contains all the recommended packages
<foobarry>ah, the -i finds it, but the -s was still too fuzzy
<rekado>this would work: guix package -s "^r$"
<foobarry>thx!
<foobarry>forgot the $
<foobarry>must think in regexp
<alezost>foobarry: rekado: the error with java-qdox was fixed by http://git.savannah.gnu.org/cgit/guix.git/commit/?id=b13cf17fcfb62e
<alezost>foobarry: if you use emacs, you can do "M-x guix-packages-by-name r"
<rekado>alezost: thanks.
<rekado>I was about to push my fix when I saw the commit.
<alezost>:-)
<foobarry>:)
<alezost>rsiddharth: I've described the breakage you found here: http://lists.gnu.org/archive/html/guix-devel/2016-05/msg00146.html
<foobarry>rekado: regarding what you wrote on your blog about centralised mgmt server, and users have to logon to the mgmt server to change guix environments etc - is that still the case?
<rekado>foobarry: no.
<rekado>we now have a simple wrapper that connects to the daemon remotely.
<rekado>profile management now works on all cluster nodes.
<foobarry>thx. is that wrapper in a shareable state?
<rekado>generally, it is.
<rekado>it's really short, too.
<rekado>it just opens socat and makes guix talk over a socket.
<rekado>on the management server we have the daemon running.
<foobarry>i'd be interestd to try it out
<rekado>it's the only server with write access to the store.
<foobarry>on my test cluster that i'm trialling guix on
<foobarry>i have it setup the same way
<rekado>on that server we also need to run a socat listener to forward incoming requests.
<rekado>cool.
<rekado>I will try to write up some simple docs tomorrow.
<foobarry>that would be excellent, many thanks
<rekado>(if possible; there are a couple of semi-urgent sysadmin things I'm supposed to do, but I'll try to squeeze it in)
<foobarry>don't feel obligated
<rekado>one thing that's not working too well for us is using NFS.
<rekado>the daemon writing to the store should (if possible) write to local disks.
<rekado>having the store mounted read-write via NFS on the mgmnt server is pretty bad for performance.
<foobarry>i bet
<rekado>could be our file server / network setup.
<foobarry>what kind of storage array is it?
<rekado>foobarry: I think this is an Oracle ZFS appliance.
<rekado>black box.
<foobarry>we had an old sun ZFS appliance that was dog slow
<rekado>If I could guarantee uptime I'd write to local disk on the management server and export that file system over NFS.
<efraim>from what I've heard its not supposed to do that
<foobarry>some clustered thing 7420?
<rekado>I don't know the details. We have too many of these appliances, different types, all pretty slow.
<rekado>that's currently the biggest annoyance I have with Guix at work.
<rekado>but since profile manipulations (installing or removing software) doesn't happen nearly as often as using the software and switching profile generations it's acceptable in practise.
<rekado>it would be a lie if I claimed it didn't bother me, though.
<rekado>"guix graph" is sooo useful! It's a great aid in explaining Guix and the state of software.
<rekado>ACTION fixed SWT and Tuxguitar
<rekado>ACTION will prepare a patch later
<efraim>i love guix graph
<efraim>does anyone know how to change the status of patches on patchwork?
<frafra>3 questions: 1. I installed openssh, but I can't start as service, it looks like something is missing 2. my .scm packages build correctly and I would like to propose a patch; the online doc talks about using guix from git, but there's no git instruction 3. I installed xfce4 in my lightweight installation, and I don't know how to make available as choice during graphical login
<frafra>:D
<cbaines>For the git repository, do you mean you don't know the command to clone it?
<cbaines>(if so, you can find the command on this page https://savannah.gnu.org/git/?group=guix)
<frafra>cbaines, thank you; no, I didn't know which repository should I clone
<mark_weaver>frafra: see the "contributing" chapter of the manual, specifically "building from git"
<mark_weaver>frafra: we don't yet have an openssh-service, but we have lsh-service
<frafra>mark_weaver, thank you; I read it, but I think I missed something, because it talks about "./bootstrap", and I don't have such kind of file when I enter in the guix environment
<mark_weaver>frafra: I recommend adding (xfce-desktop-service) to your OS services
<mark_weaver>frafra: 'bootstrap' is in the top-level directory of the guix git repo
<frafra>mark_weaver, I've added to config.scm; is it right? I can't see it as choice
<frafra>mark_weaver, ok, so I have to install git, clone the repository and than start the environment, right?
<mark_weaver>frafra: yes
<frafra>ok, now it's clear to me, thank you
<mark_weaver>np!
<foobarry>if you install all-packages, how much space does it take up please?
<foobarry>obviously that doesn't include historical versions which could make the space requirements massive....
<frafra>foobarry, ~3000 pkgs... maybe 300 GB?
<frafra>maybe more? :D
<foobarry>ta. wild guess or educated guess
<mark_weaver>wild guess, I would say
<foobarry>heh
<frafra>it is
<frafra>I've seen that guix package gives you some information about the space that will be used
<mark_weaver>foobarry: out of curiosity, what motivation is there to answer that question?
<foobarry>i'm writing up some info to discuss using guix with our HPC
<foobarry>i'm arming myself with as much info as poss and to field questions that will come
<foobarry>obviously in one year this could multiply by factor of 3x if each package is updated twice
<foobarry>also obviously...
<foobarry>we won't have all packages installed
<mark_weaver>right, that's why I asked
<foobarry>but trolls walk among us
<foobarry>so i thought i'd check if anyone had run it lately
<foobarry>for all packages for lolz
<mark_weaver>well, you could install every package into a profile and then ask "guix size" the size of the profile
<mark_weaver>that would involve first building/downloading everything
<ng0>ACTION wonders if it can be done through guix package -i *
<ng0>possibly not
<ng0>to prevent mistakes
<mark_weaver>and some packages are currently broken
<foobarry>i thoguht there was an all-apackages manifest
<ng0>ah
<ng0>idk
<ng0>have been absent for a while
<foobarry>and i'm a noob
<mark_weaver>foobarry: the sane way to do it would be to write some scheme code to do it, using 'fold-packages' from (gnu packages)
<mark_weaver>which iterates a function you give it on every public packages in (gnu packages *)
<foobarry>its no biggy
<foobarry>i'll do a jedi mind trick
<foobarry>but i will prob need to consider how big the file store needs to be
<mark_weaver>but gracefully ignoring the broken packages would need to be implemented
<foobarry>because if we installed it
<mark_weaver>or else manually specifying a list of packages to omit
<foobarry>its there for good
<foobarry>because users scripts will reference it forever
<mark_weaver>I could do it with a small bit of hacking, but I'm overloaded right now and this doesn't seem important :)
<foobarry>no its certainly not
<foobarry>its not important
<mark_weaver>but fwiw, my wild guess would be less than 100G
<davexunit>the GC will help you reclaim space
<mark_weaver>but I don't know that anyone has tried to install every package before :)
<foobarry>hydra might after GSOC :D
<mark_weaver>well, hydra does have every package that successfully builds, but the problem is that it has several versions of each package
<mark_weaver>so the total disk usage on hydra doesn't tell us much
<foobarry>what is it , out of interest?
<foobarry>the usage
<foobarry>its a good indication of an upper estimate of growth
<mark_weaver>although... it does give us an upper limit. and hydra currently has less than 780G of disk
<mark_weaver>and that's for all four supported architectures: x86_64, i686, armhf, and mips64el
<foobarry>cool thanks
<foobarry>although we would hope to add a lot more packages
<mark_weaver>yes, indeed
<mark_weaver>foobarry: the data at https://www.openhub.net/p/gnuguix might be of interest
<mark_weaver>based on that data, guix seems to be catching on. the future looks bright for guix, I would say
<foobarry>thats a handy page, thanks
<foobarry>seems only rekado is doing it on HPC , to a visible extent?
<mark_weaver>I have no idea, sorry
<mark_weaver>rekado would be a better person to ask about that
<frafra>ok! my package is done :)
<mark_weaver>\\o/
<rekado>so far our Guix NFS share hasn't exceeded 100G.
<rekado>but maybe our case is special.
<rekado>not everyone here uses Guix and they are quite content with keeping the same version for a long time.
<rekado>I'm also running "guix gc" once in a while to get rid of unreferenced stuff.
<rekado>hard to say how it's going to change in the future.
<rekado>but I think Guix storage is a minor concern in the grand scheme.
<rekado>we are more concerned with storage demands for sequencing data.
<rekado>that's petabytes. A couple of TB for Guix wouldn't matter much.
<rekado>you also don't need to keep around binaries when a project is complete. It would be enough to record the Guix commit hash and the manifest of Guix packages in use to reproduce the exact same environment.
<rekado>foobarry: AFAIK Pjotr also uses Guix on HPC (also bioinfo) and he's got a couple of additional bioinfo packages that are not available upstream yet.
<rekado>(He's not on IRC usually but occasionally posts to guix-devel)
<foobarry>thanks, thats helpful
<frafra>patch sent :) let's see what happens
<rekado>IIRC he provided an environment module wrapper for Guix at one of his sites.
<foobarry>oh wow, that would be perfect
<cow_2001>hail hydra.gnu.org!
***rsd is now known as rsiddharth
***circ-user-O0wy1 is now known as AlexisMD
***rsiddharth is now known as Guest84608
***Guest84608 is now known as rsiddharth`
***rsiddharth` is now known as r5d
***r5d is now known as mostlybenign
***mostlybenign is now known as rsiddharth`
<kyamashita>Is there a way to erase previous system generations?
<frafra>cow_2001, lol
<kyamashita>I'm beginning to have "No space left on device" errors when building software.
<mark_weaver>kyamashita: for now, manually delete symlinks in /var/guix/profiles and then rerun "guix system reconfigure"
<mark_weaver>followed by guix gc
<mark_weaver>the reason for the last step is to replace grub.cfg with one that includes references to fewer system generations
<kyamashita>mark_weaver: This works! Thank you. Now let's see if I can get builds going again.
<shymega>hi - i'm trying to setup bluez on my GuixSD system, but i'm not quite sure where to start, in terms of adding bluez to the /etc/dbus-1/system.d folder for integration
<shymega>my bluetooth device is detected, so that's good - and i've tried adding a (dbus-service (list dbus)) line in /etc/config.scm, but it errors on complination, saying that it expects '() instead. I tried that, and got the same error.
<shymega>any ideas? thanks =)
<mark_weaver>it might be that we need a 'bluez-service'. I don't recall hearing reports about bluetooth, positive or negative.
<shymega>ah, right
<shymega>if i can find some spare time, i could try writing one myself - i know a bit of scheme, but predominately a elisp person
<kyamashita>How does one begin hacking on a service? I've played with packages, but I haven't done anything with services yet.
<shymega>i think i saw a info node on it in the guix manual.. but i might be wrong
<kyamashita>I remember seeing something about writing them, but I'm not sure about actually testing it.
<shymega>yeah, possibly 7.2.15 (defining services)..
<mark_weaver>you might also look at the git commits where recent new services were added
<shymega>in which case, i should update my local tree
<jmd>How is the containers feature progressing?
<davexunit>not much activity lately
<davexunit>I'm the only one who hacks on it beyond fixing bugs.
<jmd>Just lack of time or a more fundamental reason?
<davexunit>lack of time.
<davexunit>I've been preoccupied with a lot of "real life" stuff
<shymega>what's that then? real life? sounds interesting
<davexunit>heh
<davexunit>lots of stuff changing, getting ready to move, etc.
<shymega>oh, good luck with all that =)
<davexunit>I would love it if someone wrote a guile interface to cgroups or something
<davexunit>that would help the container implementation
<davexunit>or a guile interface to virtualized networking devices
<shymega>i should read up on guile/scheme, before i start hacking on guix methinks
<shymega>so many dialects
<kyamashita>shymega: I'm also doing that.
<davexunit>or figuring out how to use containers for running x11 applications like a web browser
<shymega>kyamashita: any good resources you're using?
<kyamashita>shymega: I found this HTML tutorial http://download.plt-scheme.org/doc/371/html/t-y-scheme/t-y-scheme-Z-H-1.html#node_toc_start
<shymega>cool, cheers kyamashita
<kyamashita>shymega: No problem. The page works fine without Javascript, too!
<shymega>kyamashita: Always a plus :P
<shymega>One thing i'm still getting used to in Guile/Scheme is the #'s. For true and false, for example. I'm used to just t and nil
<shymega>Hopefully with time I can switch between dialects, like different languages in real life
<kyamashita>shymega: I remember reading about that difference when researching the similarities between Common Lisp and Scheme. Brb.
<kyamashita>ACTION is away
<kyamashita>ACTION is back
<sandro_>Hi to All :)
<shymega>Evening.
<kyamashita>sandro_: Hello!
<sandro_>hello kyamashita :)
<sandro_>i'm a noob about that distriubution; i'm tryed using the usb-stick installer; but i've errors .....
<kyamashita>sandro_: What errors have you gotten specifically?
<sandro_>it is not simply to explain .... but the packages are downloaded .... then when the sistem start to compile, i got errors. probably i make errors about the .scm file ..... :|
<sandro_>I've created four partitions (/boot, / , swap & home)
<cbaines>It could be there was an error compiling one of the packages (assuming no substitude was available)?
<sandro_>I use Funtoo and i know a little also about *BSD systems.
<kyamashita>sandro_: Perhaps you could post your configuration file to paste.lisp.org and post the link here?
<sandro_>Now I go to eat something (excuse me _'_)
<sandro_>But i will create a log file and i'llpaste it on pastebin :)
<sandro_>So i can give more informations :)
<sandro_>write to you later :)
<sandro_>Thanx for friendness :)
<kyamashita>sandro_: You're welcome!
<sandro_>Thank you very much :) :) :)
<sandro_>now i reboot mu system starting with usb-stick :)
<sandro_>bye :)
<kyamashita>bye!
<kyamashita>This is also a good primer for SICP: http://www.shido.info/lisp/idx_scm_e.html
<sandro_>Hi :)
<kyamashita>sandro_: Hello again.
<kyamashita>How'd the USB installation go?
<sandro_>kyamashita: i've retryed with usb-install ... but i go errors (seems error about filesystem; but using smart under gnome-disk-utility my hdd seems without physical troubles
<sandro_>i think that i make errorrs with the .scm files:
<sandro_> http://pastebin.com/vfM486p0
<kyamashita>sandro_: You would need to replace guix-root with the partition you will put the root directory on.
<kyamashita>sandro_: For example, in my configuration I have (device "/dev/sda1")
<kyamashita>sandro_: Everything else looks okay.
<sandro_>kyamashita ... thanks ; but ... how much partitions has your "Guix" ?
<kyamashita>I have three partitions. One root, one encrypted /home, and one swap.
<sandro_>Do You think is better to use only one partition + swap or the "classic" /boot root, swap & home ?
<sandro_>Ah ok ....
<kyamashita>If you are new to partitioning, the simplest configuration would be one root partition (and one swap if you want/need it).
<sandro_>but the fstab will be created automatically or must be written (similar to *too distro) ?
<kyamashita>fstab is created automatically based on the configuration file.
<sandro_>Ok ... thanx
<sandro_>now i retry to install guix :)
<kyamashita>sandro_: Good luck!
<sandro_>kyamashita ... I'm italian ... where are You from ? :)
<kyamashita>sandro_: I'm from the northeastern U.S.
<sandro_>Ah OK :) Pleased to meet You :)
<kyamashita>Nice to meet you too. :)
<sandro_>(and excuse me for grammaticals errors with US language) :|
<kyamashita>It's fine. Your English is pretty understandable.
<sandro_>Thanx very much :) in italy are 22:00 :)
<kyamashita>16:00 here. The internet is so cool. :-P
<sandro_>kyamashita: I'm very happy .... now i will make some experiences with guixSD it is a lovely OS :P
<kyamashita>Thank the Guix and GuixSD developers, they do very good work.
<sandro_>I think so; i must acquire consciousness about this OS .
<sandro_>However, i love source-based .... and later i'd like to build an optimized guix (using -march=native ecc) :)
<sandro_>but ... step by step :)
<davexunit>guix is source-based
<bavier>sandro_: one can adjust build parameters, e.g. compiler flags, but then you can no longer make use of substitutes; it's a tradeoff
<sandro_>but there is a file where "declare" the *FLAGS ?
<bavier>sandro_: not, guix doesn't expose such things currently, but you can dig into the build-systems and adjust default flags and such
<sandro_>e.g.: my Funtoo has in /et/make.conf $ grep FLAGS /etc/make.conf
<sandro_>CFLAGS="-march=native -O2 -pipe"
<sandro_>CXXFLAGS="${CFLAGS}"
<sandro_>FFLAGS="${CFLAGS}"
<sandro_>FCFLAGS="${CFLAGS}"
<sandro_>LDFLAGS="${LDFLAGS} -Wl,--hash-style=gnu -march=native"
<sandro_>However ... now i try others experiments ... cause i want to install correctly guix :P :P :P
<sandro_>step by step i'd like to emprove the knoledge about guix .....
<sandro_>Thanx for Your precious answers :)
<bavier>sandro_: thanks for taking a look :)
<sandro_>bavier: Hi and thanx to You :) i want guix in my PC :P
<sandro_>i'm not expert .... but i want to learn :)
<sandro_>ok ... i go to retry the installation :)
<sandro_>write You later (or tomorrow) :)
<kyamashita>Is Java's SWT functional in Guix?
<kyamashita>I want to see if Replicant's SDK can be ported to Guix.
<rekado>kyamashita: it almost ist.
<rekado>is*
<rekado>I'm about to send a patch to the mailing list that fixes the problems with our SWT package.
<rekado>davexunit: do you know this? --> https://firejail.wordpress.com/
<rekado>"Firejail is a SUID program that reduces the risk of security breaches by restricting the running environment of untrusted applications using Linux namespaces and seccomp-bpf"
<davexunit>rekado: the name sounds familiar, but I don't know anything about it.
<kyamashita>rekado: Good to know.
<rekado>BTW: does anyone know what I need to do to watch embedded videos in epiphany?
<davexunit>that screenshot is what I want to do with our icecat
<rekado>it works fine in icecat, but I don't really like to use icecat that much.
<rekado>it = watching videos
<davexunit>I don't want to use their software to do it, though.
<davexunit>call-with-container can already do most of this
<rekado>yeah, it would be nicer to use call-with-container
<davexunit>I'm curious what they do to make x11 stuff work
<davexunit>I also don't know how it manages to start the application at all if it uses a container
<davexunit>unless they share /usr or something
<davexunit>they might just do that
<sandro_>Hi :)
<sandro_>I've completed the "usb" installation; but now i don't know how to compile the kernel :|
<sandro_>or install it :(
<sandro_>excuse me if i'm "a bit" confused .... :|
<cbaines>sandro_, are you following the manual?
<cbaines>if so, where have you got up to?
<suitsmeveryfine>sandro_: what do you mean? The kernel should already be installed if you've completed `guix system init`.
<sandro_>Hi chains; i've installed using "usb"
<cbaines>Have you got to these steps yet? https://www.gnu.org/software/guix/manual/guix.html#Proceeding-with-the-Installation
<sandro_>so.... i must restart with the usb-installer and install a kernel ?
<sandro_>my last action was : guix system init /mnt/etc/config.scm /mnt
<cbaines>As far as I am aware, some magic happens when you run "guix system init", and once that completes successfully, you just reboot (and remove the USB stick)
<cbaines>Ah, ok
<cbaines>then I believe you are ready to reboot :)
<sandro_>and it is going without errors.... but i've never comprised the next step :( (excuse my ignorance)
<sandro_>i've rebooted; but the kernel is not installed :|
<cbaines>Did you get as far as GRUB?
<sandro_>The grub is installed correctly ... but i've no kernel (i think) .. excuse me ... but i'm very noob about guix :(
<cbaines>Can you describe exactly what you see, and how far you get when attempting to boot?]
<sandro_>Now I'm on Funtoo; but i can paste my grub.conf mounting guix partitions (/boot, / , home)
<sandro_>mount /dev/sdb5 /mnt/
<sandro_>ci74771ht ~ # mount /dev/sdb6 /mnt/home/
<sandro_>ci74771ht ~ # mount /dev/sdb3 /mnt/boot/
<sandro_> http://pastebin.com/Gxcnu3fU
<cbaines>Are you sure that your partition layout matches up with the configuration in the config.scm file you used?
<cbaines>In particular, the bootloader and file-systems bits
<sandro_>just a moment ....
<sandro_> http://pastebin.com/p5bhxqWT
<sandro_>my .scm config file
<suitsmeveryfine>sandro_: please don't use pastebin
<sandro_>Excuse me ...
<suitsmeveryfine>sandro_: this one is better -- http://paste.lisp.org/
<sandro_>what i should use for outputs ?
<sandro_>ok ... thanx and excuse me :)
<suitsmeveryfine>sandro_: It looks as though you've installed the system on the USB drive
<suitsmeveryfine>The internal hard disk is usually named 'sda' and any inserted USB drive 'sdb'
<sandro_>I've used an hdd-usb; but in my 1 TiB hdd there is the "basic" installation of guix.....
<suitsmeveryfine>I see
<sandro_>i've 2 disks
<sandro_>1) 120 GiB ssd
<sandro_>2) 1 TiB hdd
<cbaines>The "(device "/dev/sdb5")" bit differs from my config.scm