IRC channel logs

2016-04-11.log

back to list of logs

<suitsmeveryfine>I'm trying to install but get "suspicious ownership" of xfce4-panel
***drewc_ is now known as drewc
<Jookia>So I hosted a Mumble server + game of freedoom with a friend and it worked fine
<Jookia>davexunit: you may interested in that ^ (played a game of freedoom using mumble on guix as both client and server), it's not packaged yet but it's usable
***vasile_ is now known as vasile
<lfam>Thanks to whoever convinced GNOME to not ask for root's password when changing the backlight
<rekado>sneek later tell fps I'm currently working on packaging beast and rapicorn.
<sneek>Okay.
<rekado>upstream finally got rid of the bundled copy of librsvg, so packaging rapicorn got a lot easier.
<rekado>only the documentation fails to build right now.
<rekado>I think I can prepare a patch by the end of this week.
<efraim>built vifm :)
<efraim>now I have to get the hang of using it
<iyzsong>dose some thing wrong with our hydra? no job is running..
<iyzsong>ok, last evalution is from 4.10 'gnu:master', I guess it's fine. but 'gnome-updates' haven't start since 4.9, it get 'timeout' :(
<kristofer>good morning!
<ng0>gentoo work almost done, I may be able to pickup guix this week again
<ng0>that was one awful weekend of compiling and fixing
<phant0mas>davexunit: http://paste.lisp.org/display/313147
<phant0mas>thank's to rekado 's arm code I fixed it
<phant0mas>it was so damn simple
<phant0mas>actually rekado fixed it, I used his fix
<phant0mas> (add-after 'unpack 'fix-genmultilib
<phant0mas> (lambda _
<phant0mas> (substitute* "gcc/genmultilib"
<phant0mas> (("#!/bin/sh") (string-append "#!" (which "sh"))))
<phant0mas> #t))
<phant0mas>that's it
<phant0mas>now we have the avr libs
<phant0mas>now let's see if we can link to avr-libc
<rekado>woo!
<krl>trying to decide if i should try out nix or guix, what is the difference in maturity etc?
<taylan>krl: Nix is on version 1.11, and NixOS on 16.03. Guix and GuixSD are on version 0.10.0. Guix is pretty stable already, but it might miss some features you want/need.
<krl>i really do like the free software only policy
<catonano>@krl also, guix is integrated with emacs, you have a sort of emacs based dashboard. AND you deal with it in scheme rather than in the nix language. Overall it's more usable. To me that's a huge bonus. But admittedly I don't do anything serious, I don't deploy anything anywhere, I'm just getting my feet wet
<krl>oh, that's pretty rad, didn't know it had emacs bindings
<davexunit>phant0mas: !!!!!
<davexunit>ACTION tries
<davexunit>I *knew* it would be something stupid
<davexunit>phant0mas: building now
<phant0mas>:-D
<davexunit>I can post some patches later
<phant0mas>wait, we first need to make sure it works with avr-libc
<davexunit>thanks phant0mas and rekado
<davexunit>phant0mas: yeah I have some firmware to build
<phant0mas>hahaha :-)
<davexunit>it's how I first noticed this problem
<phant0mas>I was starting to have nightmares with this
<davexunit>I'm glad to be past this issue
<davexunit>my controller project has enough other issues
<phant0mas>yean I see your twitter feed :P
<davexunit>I've tried and failed many times to make an adapter for the ribbon cable
<davexunit>I think the only way to do it right is to buy some copper clad board and some etching solution and actually print a board myself.
<phant0mas>one time at high school I did the same
<phant0mas>the chemicals to remove the extra copper are dangerous
<davexunit>yes that makes me a bit hesitant to go this route
<davexunit>but using copper tape clearly isn't cutting it.
<phant0mas>well the copper board will certainly be more elegant
<davexunit>phant0mas: hmmm
<davexunit>configure: error: cannot compute suffix of object files: cannot compile
<davexunit>for avr-libc
<phant0mas>yes I am investigating this right now
<phant0mas>I have the same problem here
<davexunit>avr-gcc does indeed have all 16 libgcc.a files now, though
<phant0mas>it probably picks the wrong binutils
<rekado>davexunit for reusable etchant try this: http://www.instructables.com/id/Stop-using-Ferric-Chloride-etchant!--A-better-etc/
<rekado>not harmless, but at least you won't need to dispose of it at all (just top it up)
<phant0mas>and someone at comments says it can create explosives if mixed
<phant0mas>wow
<davexunit>heh not sure if its really better
<davexunit>but maybe
<davexunit>need to do my research before trying either approach
<davexunit>phant0mas: acetone peroxide is what terrorists build explosives from
<davexunit>very unstable explosive
<phant0mas>I prefer staying away from things that include "unstable" and "explosive" in the same sentence
<phant0mas>I will stay with my breadboards
<rekado>acetone is not used in the etchant.
<davexunit>rekado: okay, I see that now as I read more of the steps
<davexunit>I'd need some really safe containers to store this stuff in.
<davexunit>got a kid in the house.
<davexunit>rekado: thanks for this, though. it seems much better than the normal method.
<davexunit>I certainly want to be conscious of the impacts of making a hazardous chemical, and greatly reducing waste in the first place is good.
<davexunit>on the subject of package management: https://news.ycombinator.com/item?id=11469315
<davexunit>"Qpm: a package manager for Qt"
<davexunit>...
<davexunit>phant0mas: did you see the test program that failed to compile in avr-libc's config.log?
<davexunit>I can reproduce the failure with 'guix environment'
<davexunit>phant0mas: a search suggests that the build is using the wrong assembler
<phant0mas>yes
<davexunit>the host system's assembler, and not the avr one.
<phant0mas>but why?
<davexunit>that's a great question
<davexunit>avr-libc compiled fine before this multilib fix
<phant0mas>I am looking into that
<iyzsong>oops, someone have restart the 'gnome-updates' jobset (thanks!), but it still get the 'timeout' error :-(
<davexunit>phant0mas: oops, my avr-libc fails even without the genmultilib patch
<phant0mas>I know :P
<phant0mas>I fixed it
<phant0mas>I need to test though
<davexunit>how did you fix it?
<phant0mas>I used cross-gcc's phases :P
<phant0mas>avr-gcc wasn't working as it should be
<davexunit>ah
<davexunit>I guess I should use modify-keyword-arguments or whatever
<phant0mas>yes :-)
<phant0mas>I will send you the changes
<phant0mas>just wait a bit:-)
<davexunit>okay
<davexunit>I'm at work anyhow
<phant0mas>same here :P
<phant0mas>everything else is much more interesting than work..
<davexunit>;)
<davexunit>thanks for helping me out with this
<phant0mas>davexunit: you are welcome :-)
<phant0mas>brb
<davexunit>rekado: the more I read this instructable, the more I feel it is the right way to go.
<davexunit>is there any software in guix for designing circuit boards?
<davexunit>or is there any software I should package for this purpose?
<bavier>davexunit: geda-gaf is packaged
<davexunit>bavier: thanks I'll have a look
<fps>hmm, how can i add a bootstrap step to the gnu-build-system?
<sneek>Welcome back fps, you have 1 message.
<sneek>fps, rekado says: I'm currently working on packaging beast and rapicorn.
<fps>rekado: oh ok :)
<fps>sneek: later tell rekado: ok
<sneek>Got it.
<magnicida>I wonder if anyone else ever tried to install guix on macosx (I know, that's evil }:-)
<davexunit>magnicida: the issue there would be porting the bootstrap binaries
<davexunit>each new OS + processor architecture combination requires porting effort
<davexunit>Nix works on OSX so I know it's possible
<magnicida>hmmm, could it not bootstrap from a local installation of gcc, bash and friends?
<davexunit>no.
<davexunit>it cannot.
<davexunit>but even then there are other issues.
<davexunit>porting is a non-trivial operation.
<magnicida>I see, I was unaware that Guix bootstraps from a predefined set of binaries, I should go back and rtfm
<davexunit>yes, there's a carefully selected set of binaries that are used, and they are identified by their sha256 hashes
<davexunit>if you used any other bootstrap binaries, it would change the hashes of everything built with them
<davexunit>effectively creating an entire new distribution, since our build farm wouldn't be able to provide binaries for any of the package builds.
<magnicida>yeah, i was not considering reusing any binaries ofc
<magnicida>just installing guix on mac, building everything from source
<davexunit>this was under the assumption that we provided OSX binaries in the first place
<davexunit>magnicida: it could be done. the manual documents how to compile the bootstrap binaries for a new platform.
<magnicida>interesting, i'll check that out
<davexunit>if you're really interested, you just might be able to get GNU hello to compile.
<keverets>I'm curious to see the result... I'd like an alternative for the Mac users around here that are using homebrew
<magnicida>I am very interested in using Guix for managing development dependencies and environments, I use GNU/Linux 99% of the time but there is this piece of software that I need to build on a Mac and it would be great to translate the Guix workflow there
<davexunit>keverets: Nix can be used instead of Homebrew.
<magnicida>since it's only about dev environment, the Linux related parts of Guix or binaries are not so important
<davexunit>magnicida: the other important part of porting is discovering assumptions that were made about what the host OS supports. ;)
<magnicida>yep :D
<magnicida>I'm trying now ./configure --with-courage on Mac just to see what happens :/
<keverets>davexunit: good point
<davexunit>it would be nice if Guix could be used, too.
<rekado>davexunit I second the recommendation of geda-gaf and pck
<sneek>rekado, you have 1 message.
<sneek>rekado, fps says: ok
<rekado>pbc
<rekado>they can also be extended with scheme
<davexunit>oh cool :)
<davexunit>pbc? doesn't look like we have a package for that
<rekado>geda-gaf provides gschem, which you'd use for creating the schematics. Then use gschem2pcb (I think) to use with pcb.
<rekado>sorry, pcb, not pbc
<rekado>this keyboard is so broken :(
<davexunit>rekado: awesome
<davexunit>thank you!
<davexunit>and sorry about your keyboard
<davexunit>I might be able to save my crazy controller hacking project with this
<Jookia>i've been following that project on gnu social, its interesting to hear about
<davexunit>I just ordered some cheap copper clad boards from ebay
<davexunit>I have access to a laser printer at my office for printing the pcb designs
<Jookia>nice
<davexunit>if I can get it all to work this will be quite the hack. though the reaction I expect from sharing it will be "what's the point?"
<davexunit>but it's been pretty educational thus far.
<davexunit>rekado: I think that I might be able to make due with just pcb. the board itself will be very simple, but the contacts must be placed precisely in order to make the correct adapter.
<fps>rekado: yo, how far have you got with beastbse/rapicorn?
<davexunit> http://badlock.org/
<davexunit>samba security update coming tomorrow
<fps>the 16.0.0 tarball of rapicorn from github doesn't have configure, so i try to run ./autogen.sh before 'configure
<fps> https://pastee.org/kb45t
<davexunit>fps: should be (zero? (system* "sh" "autogen.sh"))
<rekado>fps: rapicorn fails to build its html docs.
<rekado>I used a git checkout, first commit that removed librsvg
<rekado>at that time there hadn't been a new release yet.
<fps>rekado: oh ok..
<fps>configure.ac:524: error: possibly undefined macro: AC_PYTHON_DEVEL
<rekado>needs autoconf-archive, which I already packaged.
<rekado>I should send this and libpng12 to the MLL.
<rekado>ML
<fps>i have done libpng12, too ;) but without inheriting libpng cause i was impatient
<rekado>it inherits nicely
<rekado>just needed to update the hash and version afair
<fps>i also contacted the author, he might do a proper release tarball with ./configure soon
<fps>[for 16.0.0]
<fps>rekado: yep, i just copied libpng over and changed the version ;)
<davexunit>ACTION just noticed that the CSS for the manual is much improved
<davexunit>very nice!
<janneke>now if only web browsers would bind space bar and other keys like info does
<davexunit>I think some people are working on an online info reader
<janneke>i think html has concepts of <link prev/next/up> .. but those are not being used by documentation generators (texi2html) and not by browsers
<taylan>whoops, manual is giving me 404 on many links
<janneke>yet
<taylan>(if not all)
<taylan>ah, seems it breaks when one directly goes to http://www.gnu.org/software/guix/manual/html_node/ without "index.html" at the end
<taylan>(I have some common gnu.org dir structure memorized so I typed it manually into my browser :P)
<mck>WHOIS rekado
<ng0>irc is not a whois client.
<davexunit>mck: rekado is a robot designed to eliminate proprietary bioinformatics software
<davexunit>EOF
***joachifm is now known as Guest17526
<rekado>fps: html docs build now, but some tests fail for rapicorn.
<rekado>soon!
<rekado>"grep: support for the -P option is not compiled into this --disable-perl-regexp binary"
<rekado>that's needed by the test suite.
<rekado>hmm
<fps>rekado: awesome :)
<kyamashita>Trying to package Red Eclipse, SDL_mixer.h isn't being found...
<kyamashita>The package definition is here: http://paste.lisp.org/display/313180
<bavier>kyamashita: most likely the package doesn't use sdl_mixer's pkg-config file
<kyamashita>Any way I could verify that?
<Jookia>kyamashita: You need to use sdl-union
<Jookia>kyamashita: If it uses cmake or sdl-config, you also need to patch that (I have a diff you can use)
<kyamashita>It uses sdl-config in the Makefile.
<kyamashita>What is sdl-union?
<davexunit>kyamashita: it's a combination of SDL and all its helper libraries
<davexunit>into a file system tree that the sdl-config program is happy with
<Jookia>But you need to patch sdl-config
<davexunit>no
<Jookia>ok then
<davexunit>not necessarily
<Jookia>try it without sdl-config
<Jookia>i mean the patch
<davexunit>I've written several packages that use SDL without needing such a patch
<davexunit>so try what's there first. if it doesn't work then we'll see if the patch will helps.
<davexunit>help*
<Jookia>do they use sdl-config to find SDL?
<kyamashita>It seems like it. I'm seeing "sdl-config --libs" and "sdl-config --cflags".
<kyamashita>It looks like "sdl-config --libs" provides the SDL libraries as arguments in the list.
<davexunit>Jookia: YES!
<davexunit>that's why I wrote sdl-union in the first place
<janneke>/me sees: i686-w64-mingw32-ar: `u' modifier ignored since `D' is the default (see `U')
<janneke> CCLD guile.exe
<janneke>
<kyamashita>davexunit: How do I use sdl-union?
<davexunit>kyamashita: like any other pacakge
<davexunit>package*
<kyamashita>There's no sdl-union package though. What am I looking for?
<davexunit>kyamashita: it's in (gnu packages sdl)
<davexunit>it's not exported from the module
<davexunit>to use it in a module outside of (gnu packages sdl), use (@@ (gnu packages sdl) sdl-union) to refer to it
<Jookia>Why not export it?
<alezost>kyamashita: davexunit: it is exported and it is a procedure
<alezost>kyamashita: look for example at 'manaplus' package
<alezost>or 'abbaye' or 'einstein'
<kyamashita>Ok, I see.
<davexunit>alezost: ah, indeed. that has changed since I wrote it.
<alezost>davexunit: yeah, actually I changed it in commit 40e9466 :-)
<davexunit>alezost: that explains it :)
<kyamashita>It's still not seeing SDL_mixer.h
<kyamashita>Unless I'm just calling the procedure incorrectly
<davexunit>Jookia: now would be the time to share your patch. have you submitted it to us, btw?
<kyamashita>Oh, nvm.
<kyamashita>sdl-union didn't need the extra arguments I provided it, I guess.
<davexunit>so, it's working? or no?
<kyamashita>It made it past the problem file, I'm still waiting for a full build.
<davexunit>cool
<kyamashita>Now it says that it cannot produce an output path...
<kyamashita>I *did* delete the install routine... Let me see if shifting things around can change that.
<davexunit>kyamashita: that means that the build didn't actually install anything
<davexunit>kyamashita: well that would do it!
<kyamashita>The Red Eclipse wiki wants the user to run "make -C src install" to install Red Eclipse.
<kyamashita>How would that look in a package definition?
<davexunit>in a build phase, it would look like this:
<davexunit>(zero? (system* "make" "-C" "src" "install"))
<davexunit>see the 'install' procedure implementation in (guix build gnu-build-system)
<davexunit>the 'zero?' is used to test if the program completed successfully
<davexunit>build phases return #t if they succeeded, otherwise guix considers them failures.
<kyamashita>Cool! Trying that now.
<kyamashita>BTW, is there a decent Guile tutorial around for LISP newbies? Or should I start out with something like SICP?
<davexunit>kyamashita: SICP is a great book to learn about programming that just happens to use Scheme, so I wouldn't recommend for the sole purpose of picking up Scheme.
<janneke>how do i create an enviroment/set-up all the paths for a cross-built package?
<janneke>i cannot get enviroment --system to do what i want
<davexunit>not sure. I don't really do cross building.
<davexunit>only AVR stuff which is a much different story than other cross-building toolchains AFAICT
<janneke>ok
<kyamashita>Okay, so now I'm getting "no rule to make target 'install'".
<kyamashita>So make install needs to be set to run in src/
<janneke>possibly package --search-paths
<davexunit>kyamashita: (chdir "src")
<dirtyhelm>Insane question, is anyone playing around with getting Guix on the Hurd?
<kyamashita>Yes! https://fosdem.org/2016/schedule/event/guixhurd/
<kyamashita>Slides can be found there, I'm not so sure about the video.
<dirtyhelm>Thanks, thats exactly what I was looking for. Very exciting!
<kyamashita>Indeed! It would be cool to be able to easily switch between a Hurd and a Linux-libre kernel.
<davexunit>rekado: I'm finding geda to be pretty nice to use
<davexunit>kicad seems to get all the attention, from what I'm reading.
<mog>yes
<mog>geda is awesome project
<mog>but is very slow in dev time lately
<mog>ACTION picked geda 5 years ago though so im locked in 
<davexunit>it's pretty nice to use, even as a n00b
<mog>geda is very well suited to makefiles and segmented work
<mog>which is why i love it
<Jookia>Is Xfce menu updating unimplemented?
<Jookia>Seems to be broken
<suitsmeveryfine>Hi! I'm preparing a package here. When I run guix lint it complains like this: tabulation on line n. Can I disregard this? I've used the official indentation rules in the Guix Guile mode and they do mix spaces and tabs.
***Basstard1 is now known as Basstard`
<suitsmeveryfine>Or should I manually type in spaces?
<janneke>phant0mas: guile.exe links, sent you an email, lots of cleanups todo
<rekado>suitsmeveryfine: what makes you say that the official indentation rules mix spaces and tabs?
<suitsmeveryfine>In Emacs I mean
<suitsmeveryfine>I was suggested to use the Scheme Guix Guile mode and use C-M-a + C-M-q to apply the correct indentation.
<suitsmeveryfine>Personally it feels wrong to mix tabs and spaces.
<davexunit>suitsmeveryfine: guix has .dir-locals disables the use of tabs for indentation
<davexunit>er, missing words
<davexunit>guix has a .dir-locals file in the root of the source tree which disables the use of tabs for indentation
<suitsmeveryfine>davexunit: does this mean that I don't need to worry about the lint error?
<davexunit>suitsmeveryfine: it means you do. :)
<suitsmeveryfine>or that I've forgot to configure something in my environmnet?
<davexunit>we don't like mixing tabs and spaces
<suitsmeveryfine>right
<davexunit>I set indent-tabs-mode to nil
<suitsmeveryfine>What should I do? :)
<suitsmeveryfine>eh, how? Sorry, I'm an Emacs newbie.
<davexunit>I have this in my emacs config file
<davexunit>(setq-default indent-tabs-mode nil)
<davexunit>but also, the .dir-locals.el file also sets this
<davexunit>so you must have answered "no" to some prompt that asked to use those settings
<suitsmeveryfine>oh, I see
<suitsmeveryfine>Yes, I go get asked something every time I open the file.
<suitsmeveryfine>'The local variables list in "..." contains values that may not be safe'
<suitsmeveryfine>"Do you want to apply it": y, n !
<davexunit>I press ~
<davexunit>er
<davexunit>~
<davexunit>damn it
<davexunit>!
<davexunit>sorry
<davexunit>because I know the settings are safe
<davexunit>you can read them for yourself
<suitsmeveryfine>Ah, now the tabs are gone. Wonderful, thanks!
<davexunit>yw!
<suitsmeveryfine>The guidelines are very strict. I like that!
<davexunit>we try to use a consistent style, yes.
<davexunit>luckily in Scheme it's pretty simple
<davexunit>the style guides I follow for other languages are much longer
<ijp>the scheme style guide is essentially: whatever emacs does, mostly
<suitsmeveryfine>Not just the style guidelines but the requirements on reproducability, licenses and so on
<davexunit>ijp: yup
<davexunit>suitsmeveryfine: yeah, I guess we're pretty strict around here. ;)
<davexunit>hopefully not too strict. I like to think we maintain a high quality system this way.
<suitsmeveryfine>As I say: I like it.
<davexunit>:)
<suitsmeveryfine>I'm not sure if I'll ever do another package after this one though ;D
<davexunit>was it too much work?
<suitsmeveryfine>Yes it was a lot of work, but I'm sure it will be less work next time
<suitsmeveryfine>For this package I had to modify the sources to remove non-free code, disable parts of the gnu build system and manually add certain configure flags
<suitsmeveryfine>It took me three days
<davexunit>part of that difficulty comes from the software itself having a less-than-ideal build system.
<davexunit>and shipping nonfree components
<davexunit>did you use the #:configure-flags argument to specify the extra flags?
<suitsmeveryfine>No, I cannot do that since I need to bypass the whole configure section
<suitsmeveryfine>I use modify-phases
<davexunit>okay
<suitsmeveryfine>Actually, the package only complained about one flag that was set automatically by the gnu build system
<suitsmeveryfine>I asked here if there was a way just to remove that flag (`--enable-fast-install`), but apparently not
<suitsmeveryfine>The last time I tried to build Emacs I saw that it warned about this particular flag, but it was just a warning and not a build error in this case
<davexunit>software that uses the GNU autotools don't break when given that standard flag
<davexunit>looks like the configure script you had was hand-written or something
<suitsmeveryfine>Yes I think so
<suitsmeveryfine>pkg-config was applied on some places but on others it wasn't
<suitsmeveryfine>for example
<davexunit>yeah, that can make packaging hard.
<davexunit>when software sticks with the autotools, things are typically easier to deal with.
<suitsmeveryfine>I've also had to disable a particular feature of the software because the configure script looked for a particular dependency at a pre-defined place
<suitsmeveryfine>After I was done I had a look at the Nix project's package definition and saw that they had done the same.
<lfam>paroneayea: I'm build xscreensaver now. What DE did you test it on? GNOME?
<lfam>s/build/building
<davexunit>hmm, sch2pcb always says "No elements found, so nothing to do."
<davexunit>and I get no .pcb file :(
<suitsmeveryfine>Another question regarding my package. Does this size profile look ok? http://paste.lisp.org/display/312614#9
<lfam>suitsmeveryfine: That's not an atypical size. It's always fun to read the list and wonder, "How does *that* get used?!"
<suitsmeveryfine>Yes, but does this mean that I don't need to select all of them explicitly as dependencies (inputs)?
<lfam>The size profile is a crude representation of the full graph. For example, you definitely wouldn't need to add bash-static to the openttd package definition.
<suitsmeveryfine>OK, but what about mesa? I see that certain games add it as an input but I haven't
<suitsmeveryfine>I used the depencencies listed by upstream
<lfam>I don't know the opentdd package definition. But most of those dependencies are probably lower in the graph. That is, they are not referred to directly by opentdd.
<lfam>Does your package work for you?
<suitsmeveryfine>Yes, it works fine
<lfam>Try doing `guix graph opentdd | dot -Tsvg > graph.svg`
<lfam>And inspecting the result in some image viewer
<lfam>You can also use the `guix gc --r*` tools to inspect the web of references from "close-up"
<suitsmeveryfine>lfam: guix graph: error: opentdd: unknown package
<lfam>Well, most likely you'll need `./pre-inst-env guix graph ...`
<lfam>;)
<lfam>If that's how you're doing things
<suitsmeveryfine>I tried that :)
<suitsmeveryfine>it made no difference
<lfam>Is that how you're building your package?
<suitsmeveryfine>yes
<davexunit>openttd
<davexunit>not opentdd
<suitsmeveryfine>openttd
<lfam>Right, I don't even know what the package is named
<suitsmeveryfine>ah!