IRC channel logs

2016-03-07.log

back to list of logs

<Jookia>It'd require for Guix to be aware of Windows details
<janneke>to deploy binaries? i don't think so
<Jookia>janneke: how would windows handle /gnu/store?
<Jookia>containers for building are an issue too
<Jookia>to my understanding to get things in /gnu/store you need to build them to put them there
<Jookia>using dependencies in the store
<NiAsterisk>eh.... damn
<NiAsterisk>ACTION headdesks
<NiAsterisk>there's a Makefile in Bitmessage
<lfam>Hooray
<NiAsterisk>i was fixed on using python-tools
<janneke>Jookia: we'll see when/if i get around trying it
<janneke>my intent only is to cross-compile
<Jookia>I suppose you could cross-compile and have mingw64 as a dependency with the windows exe files as store outputs, but unless they're statically link they'd depend on things in the store
<janneke>then i expect to have all linux goodies available to fill the store
<Jookia>in the end you could use guix to set up an environment to build statically linked standalone binaries then zip those up
<janneke>yes, that should at least be possible
<Jookia>but if it were shared it'd link to /gnu/store/....gtk-cross-compiled/lib/gtk.dll and in windows it'd be looking for that path
<Jookia>which windows doesn't have :|
<janneke>Jookia: it might, if we provide it
<Jookia>if you take the idea of using guix as a build environment you could have a final step that takes all your dlls from various places and puts them in a directory and change the paths
<Jookia>janneke: are you sure windows would be okay with having such long paths?
<janneke>Jookia: i have no idea
<rain1>hooray!! suceess with encrypted home
<janneke>the only thing i'm sure of is that i like guix waaaay more than gub
<janneke>and if we are to support windows, why not turn-key for all gnu apps?
<rain1>and it does a nice automount with password, you only have to enter once - really good
<Jookia>turn-key?
<janneke>one command to build all binaries for all foreign platforms
<janneke>anyway, i still need some inspiration to really dive into this
<janneke>for now, zZzz
<Jookia>nini
<suitsmeveryfine>rain1: this is good news! Where do you enter the password in the boot process?
<rain1>just before log in
<suitsmeveryfine>you run a bare-bones config right?
<rain1>yeah but i think if you based it off the desktop (or gnome) it would be fine
<rain1>I'm just posting my instructions if anyone likes to look over it
<rain1> https://gitlab.com/rain1/guix-wiki/wikis/Encrypted-home
<rain1>fixed a couple typos
<suitsmeveryfine>only 2G partitions?
<rain1>you can use any size you like
<suitsmeveryfine>sure, I was just surprised
<rain1>this is what I did
<NiAsterisk>i have this note, not commented, on an older package defintion of bitmessage: ;;Makefile todo: PREFIX?=/usr/local replace with "", "/usr" with "" does this mean PREFIX?=/usr/local is something gnu-build-system does not fix?
<suitsmeveryfine>rain1: so it was with the "(needed-for-boot? #t))" that you made it work?
<rain1>yeah
<suitsmeveryfine>so I guess this means that one gets prompted the dev/sda2 password just before the graphical login screen
<suitsmeveryfine>in a desktop setup
<rain1>i think so!
<rain1>will be good to know, I can add a note about it if someone tries it
<suitsmeveryfine>rain1: I'm happy to try it out, but GuixSD is so unstable at the moment
<suitsmeveryfine>I've had multiple failed installs the past few days
<rain1>was it just the downloading stopped?
<rain1>because I found if you just re-run the command it often continues ok
<suitsmeveryfine>yes, last night that was a problem, but I also had build-dependency problems
<suitsmeveryfine>if it wasn't one of the problems it was the other :/
<rain1>augh! yeah it's a struggle especially when it takes a long time
<rain1>getting this info together took me 3 days
<rain1>but i think the mirror speeds it up a lot, and in future the hydra server will be replaced i read
<NiAsterisk>yes
<suitsmeveryfine>An hour or so I successfully rebuilt GuixSD from git on the macbook. A few hours before that the very same checkout gave me a build failure due to dependency issues.
<rain1>I had trouble with my own guixsd build
<rain1>I think it's safer to use the dowload from the site
<suitsmeveryfine>Maybe, but I wanted to build my version to debug my touchpad issue
<rain1>yeah I need to figure out building my own guixsd too, If i want to hack the grub config generator bit
<rain1>which I want to do to contribute towards encrypted root working, hopefully
<suitsmeveryfine>yes, but your guide should be merged with the existing one for encrypted / I think
<suitsmeveryfine>The old one also has a TODO for unencrypted /boot but with encrypted /
<rain1>in my mind there's 3 important configs to figure out: encrypted home (done), encrypted root (next), encrypted boot + having a USB key instead of password
<suitsmeveryfine>yes, all of these configs should be documented I think, but we also need to have the GRUB error fixed
<rain1>whch grub error? do you just mean that it doesn't generate correct grub.cfg when you use crypto?
<suitsmeveryfine>When you use encrypted / including /boot as I do then at the end of the installation process you get a warning that GRUB couldn't be installed and that the installation failed
<rain1>ohh that's new to me
<suitsmeveryfine>the system will then function but GRUB is not protected but can be messed up by the garbage collector
<rain1>I wonder how that's done on a different distro - if there's any special grub invocation or anything
<Jookia>I have a patch for that
<suitsmeveryfine>Jookia: you do?
<Jookia>For libreboot, that is
<rain1>i hope i can get alibreboot computer some day
<suitsmeveryfine>I'd like to see that :)
<NiAsterisk>i see no python-qt4 with grep. are python bindings for qt4 non existent atm?
<Jookia>I have a patch - its on the mailing list needing review + testing, I also found a bug
<Jookia>Let me find it
<suitsmeveryfine>Jookia: great
<Jookia>It breaks 'guix system reconfigure' atm and I haven't debugged it yet
<Jookia>suitsmeveryfine: https://lists.gnu.org/archive/html/guix-devel/2016-03/msg00067.html you can see each patch in the next thread button, they're all very explanatory on a high level even if you don't read the code
<rain1>oh yeah I had guix system reconfigure trash my encrypted system :)
<rain1>I figured it was at least a bit related to grub.cfg
<Jookia>tl;dr: rain1: suitsmeveryfine: https://lists.gnu.org/archive/html/guix-devel/2016-03/msg00071.html
<NiAsterisk>is python-pyqt what I want with python-qt4?
<NiAsterisk>almost reads like it
<Jookia>NiAsterisk: Guix is doing its best to rid itself of qt4
<NiAsterisk>yes, but so is not the application I want to package.
<rain1>is qt4 bad?
<suitsmeveryfine>Jookia: "Symlinks are created for /boot/grub/libreboot_grub.cfg and /boot/grub/autoboot_grub.cfg"
<Jookia>rain1: IIRC it doesn't have security updates
<Jookia>suitsmeveryfine: Yeah
<suitsmeveryfine>I think it's good that you do this, but wouldn't it be enough to modify grub.cfg?
<suitsmeveryfine>by using the cbfs-tool
<rain1>ahh
<Jookia>suitsmeveryfine: You mean to make Libreboot read /boot/grub/coreboot_grub.cfg ?
<suitsmeveryfine>yes
<suitsmeveryfine>well, it would require a user who is willing to reflash
<Jookia>Ironically the reason there's a coreboot_grub.cfg is because I went in to #libreboot to see if there was a solution that could work for both Libreboot and Autoboot, and in the end I think it was decided that coreboot_grub.cfg would also be read
<Jookia>Git version of Libreboot reads coreboot_grub.cfg, but it's not stable yet
<suitsmeveryfine>anyway, it's good to keep the symlinks as you suggested
<suitsmeveryfine>No, libreboot is not very stable at the moment as things are changed back and forth :)
<suitsmeveryfine>so it makes a good companion to GuixSD
<Jookia>I'll have to find out why my code breaks guix reconfigure (I think I know why) then fix that
<Jookia>Then submit another patch
<Jookia>Then I suppose I could ask people here to test it
<suitsmeveryfine>Jookia: I'd be happy to test if you think it would be helpful
<suitsmeveryfine>ah :)
<Jookia>Yay
<suitsmeveryfine>I've got two libreboot machines
<Jookia>Oh great
<suitsmeveryfine>But GuixSD is only installed on one of them
<Jookia>rain1: So to get it mounted at all you had to write needed-for-boot?
<rain1>im not sure if that was all
<rain1>it was important though
<rain1>i had some trouble with qemu too
<Jookia>rain1: What was the key thing to do to get it working
<suitsmeveryfine>Jookia: /home needs to be mounted during the install
<Jookia>oh interesting
<rain1>I also added (dependencies "/")
<rain1>here is the config fiel https://gitlab.com/rain1/guix-wiki/wikis/encrypted-home-config.scm
<suitsmeveryfine>rain1: oh, I missed that part. What does it do?
<rain1>i think without it there is a danger of it trying to mount home without /home existing
<Jookia>rain1: That makes sense
<suitsmeveryfine>rain1: would you mind pasting your contribution as a reply to the existing thread on encrypted / ?
<rain1>can you link me that? I don't know about that thread
<suitsmeveryfine> https://lists.gnu.org/archive/html/guix-devel/2016-01/msg00925.html
<suitsmeveryfine>Jookia: just let me know when you'd like me to test your GRUB fix
<Jookia>suitsmeveryfine: Sure, it won't be for a while though
<suitsmeveryfine>ok, no hurries.
<rain1>I don't know how to reply to a thread since I am not subscribed to the ml
<rain1>i can only create new threads
<suitsmeveryfine>You can't reply even if you subscribe now?
<lfam>You can try copying the subject line into a new email.
<lfam>It's better than nothing
<Jookia>Alright, must dash. Moustache?
<rain1>by the way does anyone like sokoban game? I made a nice guix package for it
<suitsmeveryfine>I'd be happy to try it
<Jookia>Gah, should've logged out before reading that. ;) Which game?
<rain1>hehe
<rain1>it's a puzzle where you push blocks in a warehouse
<rain1>from japan
<suitsmeveryfine> https://en.wikipedia.org/wiki/Sokoban
<suitsmeveryfine>nice animated GIF there
<Jookia>Oh I know of that, but which implementation?
<rain1>usokoban by a chinese developer
<Jookia>usokoban? I've never heard of that one
<rain1>i've changed the code a bit and added lots of levels (warning: which have a variety of strange non-licenses..)
<Jookia>I've heard of XSokoban (I think) and Simple Sokoban
<rain1> https://notabug.org/rain1/usokoban since sokoban.ws/usokoban/usokoban.htm is down and not working a loat
<Jookia>Well you should find out the license for the contents
<rain1>the game itself is GPL
<rain1>GPL3
<Jookia>I think Guix needs it to be commercially redistributable verbatim
<rain1>the levels.. not worth thinking about
<rain1>if someone wants to put it in guix they can do that just without any levels (or find/create some with appropriate license)
<rain1>the culture for creating sokoban levels is different to free software culture
<lfam>I wonder how quickly I could compile webkitgtk if I was willing to $10 / hour for compute capacity on something like EC2
<lfam>willing to pay
<lfam>How many iterations could I get out of that $10?
<Jookia>A few
<Jookia>At least a few
<lfam>Right now it's CPU bound on my machine and it takes a couple hours
<lfam>Between 1 and 2 hours
<Jookia>webkitgtk 2.4 isn't parallel
<lfam>This is 2.10, it seems to be parallelized
<Jookia>Ah, then you can just max it out on EC2 then
<Jookia>Anyways, night all. RIP sneek
<NiAsterisk>webkitgtk is at least ~3 - 12 hours depending on cpu and phase of the moon.
<NiAsterisk>or was that libreoffice?
<NiAsterisk>both pretty heavy
<lfam>Yeah, libreoffice is also very expensive
<NiAsterisk>i had this idea with old computers to provide a build / computation cluster, but electricity + i need to move at some point and eventually sleep in the same room. not nice.
<NiAsterisk>why does (license expat) throw an error in messaging.scm ?
<NiAsterisk>expat is a valid license.
<lfam>NiAsterisk: Most likely the package for the expat software is also in messaging.scm
<lfam>This is why licenses are prefixed in some package modules
<lfam>We hit the same issue with openssl
<NiAsterisk>hm.
<NiAsterisk>how was it solved?
<lfam>prefix the license
<lfam>grep for 'license:expat'
<NiAsterisk>i knwo, but (license license:expat) fails.
<lfam>It will require a change when you import the licenses module (at the top of the file)
<suitsmeveryfine>rain1: grigrig's levels seem to be free. See the bottom of this page https://notabug.org/rain1/usokoban/src/master/levels
<NiAsterisk>ah, okay. what i thought
<NiAsterisk>thanks
<rain1>yeah this is the same kind of non-license as ttf-symbola font, which it was decided cannot be included in guix
<rain1>but one can have a personal repo with unusual things
<suitsmeveryfine>but there is an email address so one could write to the person and ask for a proper license
<suitsmeveryfine>I'll do that now
<rain1>I don't think he would like that, he says not to do that
<suitsmeveryfine>"If there is a desire to write to me - grigr@yandex.ru"
<suitsmeveryfine>"Do not ask me the sanction." Hmm, but maybe one could ask him to give a CC0 license at least
<rain1>I think its' best not to bug him, the symbola guy was also not interested in doing licensing
<rain1>and he is russian so different sort of laws etc.
<NiAsterisk>lfam: would I have to change the entire messaging.scm way of how licenses are defined and with this update every license definition in messaging.scm? would this be okay in just 1 patch with my pybitmessage patch?
<lfam>NiAsterisk: It's probably easier to set it up so that you only need to prefix the expat license. There are some examples in gnu/packages
<NiAsterisk>okay, i'll look for that
<NiAsterisk>thanks
<suitsmeveryfine>rain1: that's too bad.
<suitsmeveryfine>So " You may do everything with these levels" is not enough to be included in GuixSD
<rain1>if you want i can dig up the symbola discussion which is parallel :)
<suitsmeveryfine>No thanks. This is too late for me.
<suitsmeveryfine>I need to go to bed
<suitsmeveryfine>night all
<NiAsterisk>mail.scm is the first and maybe only file with the exception for expat.
<NiAsterisk>right. I see why i commented it in december
<NiAsterisk>mkdir: cannot create directory ‘/usr’: Permission denied
<NiAsterisk>so substitute it is
<NiAsterisk>in the occurence of PREFIX?=/usr/local it would be best to substitute it with PREFIX?= or just simply delete it?
<rain1>you could also try DESTDIR I think? I had success with that
<NiAsterisk>reference: https://github.com/Bitmessage/PyBitmessage/blob/master/Makefile
<NiAsterisk>it has destdir and prefix in lines
<NiAsterisk>imo: delete PREFIX? and PREFIX completely
<NiAsterisk>rain1: what would "PREFIX=" %output in #make-flags do then?
<rain1>im not too sure maybe both variables need set
<NiAsterisk>%output is the generated place in /gnu/store/ right
<rain1>yeah i think so
<rain1>I'm a beginner at this stuff myself so I'm not certain
<NiAsterisk>i think i will try that.. no idea if it will collide with makefile value
<rekado>NiAsterisk: use make-flags.
<aleix>hi there
<aleix>i'm having some trouble running guix. i just built it form source and followed the manual. one of the first thing i tried was: guix package -l
<aleix>which returned: guix package: error: profile '/usr/var/guix/profiles/per-user/aleix/guix-profile' does not exist
<aleix>according to the documentation my profile directory should be created automatically
<rekado>aleix: it will be created once you install a package.
<rekado>"guix package -l" lists all profile generations, but since you haven't installed anything yet, Guix has nothing to show you.
<aleix>rekado: i tried to install the first package suggested by the documentation "guix package -i glibc-locales"
<aleix>which ends up with an error
<aleix>i'm sending an email to help-guix with more details
<roelj>Why does Guix use symbolic links to point to the actual versions of shared libraries, when the hash in the store path makes the link to the library version unique?
<rekado>roelj: I think that's not a Guix thing but a "make install" thing.
<rekado>we just don't do anything to prevent this.
<roelj>rekado: Ah ok.
<efraim>I've got libreoffice-5.1.1.3 building locally, I think 4.5 hours in so far. Anyone want to place a bet on how long it'll take?
<rekado>I'm trying to use (@@ (guix build syscalls) mkdtemp!) in the ant-build-system, but whenever the phase is reached when mkdtemp! should be used it complains:
<rekado> In procedure module-lookup: Unbound variable: mkdtemp!
<janneke>rekado: you (may) have to make sure (guix build syscalls) is added to the builder
<janneke>see #:modules and #:imported-modules
<rekado>janneke: that's for individual packages.
<rekado>I want to use it in a standard build phase for the new ant-build-system
<rekado>it would be annoying if users of this build system would have to add (guix build syscalls) to #:modules
<rekado>it should be enough to do (build-system ant-build-system)
<janneke>ah, okay. guess you've looked at the emacs build system etc for inspiration...
<rekado>I guess one important problem is that I get this error when I add (guix build syscalls) to the used modules:
<rekado> no code for module (guix build syscalls)
<rekado>ah, forgot about the modules list in %ant-build-system-modules (not nice that things have to be duplicated there)
<NiAsterisk>rekado: tried to yesterday, still inherited PREFIC?=/usr/share thing.. or it failed at some other point, i try to figure out this week.
<rekado>NiAsterisk: using make-flags should be sufficient. We're doing this in many places successfully.
<NiAsterisk>i try to.
<rekado>if it's not working feel free to post a paste with the errors + your current code.
<NiAsterisk>wow. have you read the email from linus on lwn about sha1 in the kernel?
<NiAsterisk> https://lwn.net/Articles/132513
<NiAsterisk>rekado: https://ptpb.pw/3HFW includes: Makefile, messaging.scm, build output. I get the idea that I really should dig into guile if I want to stop asking many questions and be more productive on my own. the sad part is, I have it all worked out, the packages I want to do. but not on guix, just in specific languages used for packaging or scripts etc...
<NiAsterisk>I guess it gets easier to debug guile once I've seen enough guile to judge what it wants to say
<jlicht>NiAsterisk: do you have any guile hacking environment setup, or are you just running scripts?
<NiAsterisk>define guile hacking
<jlicht>emacs, geiser et al
<NiAsterisk>prior to guix, I was used to just work around broken and add/remove dependencies from/patch Makefiles, arguments etc.. with guix there's the added challenge of learning to read what errors are trying to tell me. some I already know by now. yes, emacs and geiser. but I have not looked into how to do more than just write code in guix, i have not used geiser or emacs that much in regards to validating/checking
<NiAsterisk>guile code.
<jlicht>(although I have to admit I don't even *know* of any other environment for doing anything guile related)
<NiAsterisk>If you can link me something I could read for a first roundtrip into understanding guile errors, that would be good
<jlicht>Not quite sure how to do this for guix commands, but https://www.gnu.org/software/guile/docs/docs-1.8/guile-ref/Debugging.html can never hurt.
<NiAsterisk>okay, too obvious. thanks :)
<NiAsterisk>wow. everything is nodejs this days (that's npm, right?), isn't it? globe.torproject.org building requires nodejs.
<NiAsterisk>in comparison to gentoo packaging, guix has made me dive into its own source much more to find self explanatory solutions where gentoo only delivers a very good documentation of EAPI and classes.
<NiAsterisk>and probably at some point I stop comparing things to gentoo, once I have ported everything I have on gentoo.
<NiAsterisk>i try what #:make-flags (list (string-append "PREFIX=" (assoc-ref %outputs "out")) will do instead of what I have written, but I need to go afk for a while. if it wrks i'll report back :)
<rekado>NiAsterisk: #:make-flags needs to be a list
<NiAsterisk>even as a list '(#make-flags etc) it failed
<rekado>no, like this:
<rekado>#:make-flags (list "THIS" "THAT")
<rekado>so it's #:make-flags (list (string-append "PREFIX=" (assoc-ref %outputs "out)))
<NiAsterisk>but how do I fit %output in? can I just do "%output"=?
<NiAsterisk>oh
<NiAsterisk>this ( https://ptpb.pw/SHpq ) is with #:make-flags (list (string-append "PREFIX=" (assoc-ref %outputs "out"))))) in the arguments.
<rekado>NiAsterisk: that's because the install target does this:
<rekado>mkdir -p ${DESTDIR}/usr
<rekado>
<rekado>it doesn't use PREFIX there.
<NiAsterisk>ah. that was my second comment from december about
<rekado>also, looking at the makefile it seems that maybe it's not very usable
<NiAsterisk>"replace /usr with "" " i had
<rekado>it generates a script at install time with hardcoded shebang
<NiAsterisk>possibly... so i guess setup.py it is.
<NiAsterisk>and for now, copy and wrap files with python-build for us
<rekado>you could also replace the install phase.
<rekado>some of the stuff they do in the Makefile could just be copied.
<rekado>what's not so useful about the install target there is that the script they generates sets LD_LIBRARY_PATH and makes other invalid assumptions.
<rekado>you can do this in scheme
<wingo>is it possible that /sys isn't mounted in guix-daemon build roots?
<wingo>i am getting an error in a network manager test suite that /sys isn't mounted. hydra.gnu.org never showed this error; i wonder if it has a significantly different system in any way
<rekado>looks like on my x86_64 machine I also need to build perl by myself.
<rekado>unless I disable grafts.
<rekado>I find this confusing.
<NiAsterisk>oof. okay, so it's definitely doable, and I will work on it, but I think I will first upgrade the powwow and send in the changed patch.
<rekado>there certainly are substitutes for perl available.
<rekado>hmm, building perl now.
<rekado>:(
<efraim>now 10 hours in on build libreoffice
<efraim>s/build/building
<NiAsterisk>rekado: re: powwow what ludovic added regarding gpl3+ files, the whole project can then be considered gpl2+ from my angle.
<NiAsterisk>as gpl3+ are only the autconf files
<wingo>git-send-email is amazing
<danielszmulewicz>hello good people, what should LOCPATH point to in the daemon environment?
<wingo>is there a LOCPATH, or is there only GUIX_LOCPATH ?
<civodul>Hello Guix!
<civodul>i see breakage and slowness all around!
<civodul>(and i feel guilty)
<danielszmulewicz>wingo: There is nothing at install time. I'm adding guix to an existing debian distro. But I get this annoying error about the locale.
<danielszmulewicz>wingo: I'm using the distributed systemd init script.
<danielszmulewicz>wingo: That script doesn't set environment variables.
<wingo>you've reached and gone beyond the edge of my knowledge :)
<danielszmulewicz>wingo: Haha. I doubt it.
<danielszmulewicz>wingo: I mean this in a good way. Big fan of your blog.
<civodul>danielszmulewicz: have you seen https://www.gnu.org/software/guix/manual/html_node/Application-Setup.html#Locales-1 ?
<wingo>danielszmulewicz: tx for kind words :)
<danielszmulewicz>civodul: That's the thing. These instructions are inadequate.
<civodul>oh? (sorry i missed context)
<civodul>for guix-daemon you mean?
<danielszmulewicz>civodul: No, you're spot on.
<civodul>GUIX_LOCPATH must also be set in the environment of guix-daemon
<civodul>the .service file doesn't do it for you, indeed
<danielszmulewicz>civodul: Haha. So that's what I was missing, along with everybody else who's installing it on top of an existing distro.
<danielszmulewicz>Let's fix this now.
<jlicht>wow, I was literally just now having problems with this as well
<danielszmulewicz>All we need is to add an environment variable to that script, and instruct the user to install the locales as root as well.
<danielszmulewicz>Where do I contribute?
<danielszmulewicz>But I may get ahead of myself. Am I correct?
<civodul>danielszmulewicz: i think you are :-)
<civodul>so i guess we need to augment that section of the doc, and update the .service.in file as well
<civodul>feel free to send that to guix-devel@gnu.org :-)
<danielszmulewicz>Exactly. And then the onboarding will be perfect.
<danielszmulewicz>Because it almost was :-)
<danielszmulewicz>Do I need to sign something?
<danielszmulewicz>Like in Emacs
<civodul>nothing, just check https://www.gnu.org/software/guix/manual/html_node/Contributing.html
<danielszmulewicz>OK, thanks. Will do.
<danielszmulewicz>I couldn't find the emacs pretest recipe, should I contribute that as well, or is it something people write for themselves without making a fuss.
<NiAsterisk>I updated the powwow patch. in case communcation is bad when i don't CC people anymore :)
<civodul>danielszmulewicz: i guess you could submit such a recipe, but otherwise people can use the --with-source option to build a pretest emacs
<civodul>might be good enough
<danielszmulewicz>civodul: build --with-source returns a path. How do I install it afterwards in my profile? Sorry for the noob question.
<civodul>danielszmulewicz: guix package -i emacs --with-source=xyz
<danielszmulewicz>civodul: Ah, awesome, thanks!
<civodul>you could replace "xyz" with the URL but the file wouldn't be authenticated
<civodul>so it's best to download it and check the signature yourself
<danielszmulewicz>civodul: OK.
<rekado>I wonder if it's a bug that I have to build perl from source on any of my machines when grafts are enabled.
<rekado>I did this once on almost all machines now.
<rekado>both i686 and x86_64
<NiAsterisk>package upgrade wants to build 2 deriviations of openssl. can that be right?
<NiAsterisk> https://ptpb.pw/sZIA
<NiAsterisk>generation 87. okay. maybe I should garbage collect some time
<rekado>gah, I hate working with puppet
<civodul>rekado: i think it's because hydra likes a substitutes for Perl
<efraim>g++: warning: /gnu/store/q7v0pl9sa3n220x53sshl27vjcp5i3bf-orcus-0.11.0/include: linker input file unused because linking not done
<danielszmulewicz>I wrote the following command: guix build emacs --with-source=http://alpha.gnu.org/gnu/emacs/pretest/emacs-25.0.92.tar.xz
<danielszmulewicz>And now emacs is the gnu store, but how do I install it in my user profile?
<danielszmulewicz>I would like to install the pretest version of emacs.
<bavier>danielszmulewicz: `guix package --with-source=http://alpha.gnu.org/gnu/emacs/pretest/emacs-25.0.92.tar.xz -i emacs`
<bavier>try that
<danielszmulewicz>bavier: Thank you. Does this make sense: guix package: error: with-source=http://alpha.gnu.org/gnu/emacs/pretest/emacs-25.0.92.tar.xz: unrecognized option
<danielszmulewicz>What am I missing?
<danielszmulewicz>No --with-source option for guix package command. It appears to be an option for build, not package.
<bavier>danielszmulewicz: I see
<bavier>you can pass a derivation or directory to `guix package -i` I think
<bavier>i.e. the directory that `guix build` prints at the end
<danielszmulewicz>bavier: That appeared to work. Thank you.
<bavier>great
<efraim>build failed 14 hours in
<a_e>:-(
<efraim>I should've known it was coming, mdds needed to be newer for some dependancies than for libreoffice
<efraim>forgot to change it for orcus too
<a_e>So maybe it would be better to not update the dependencies right now, and only update libreoffice?
<a_e>I am just reviewing your patches; maybe that does not make much sense right now?
<efraim>I tried that first, it wanted updated versions of some of the dependancies
<efraim>I'll try to find the libreoffice announcement about the CVEs again, if 5.0.5 is ok then maybe that'll work
<a_e>Hm. That would be easiest for a start.
<a_e>I left my more powerful computer at work, so I will not be able to do a test compilation over night.
<alezost>rekado: re building perl: I experience the same when --no-grafts is not used
<efraim>it wants orcus-0.10.0, I updated it to 0.11.0
<efraim> https://www.libreoffice.org/about-us/security/advisories/cve-2016-0795/ 5.0.5 is safe
<a_e>Okay, let us try this then.
<a_e>Why did you add gtk+ in version 3 in addition to gtk+-2?
<efraim>that part I was least sure about
<efraim>configure said there was a disable gtk3 support option but it wouldn't work for me
<efraim>and switching out gtk2 didn't work for me
<a_e>Strange!
<efraim>very
<a_e>I would suggest to simply update to 5.0.5.2 without any other changes and to push.
<efraim>orcus doesn't list 0.10.0 as being available for download https://gitlab.com/orcus/orcus
<a_e>It is a leave package with a CVE. If people insist, they can go back to a commit that compiles, even if something goes wrong.
<efraim>i'll make sure it at least goes through the configure phase
<a_e>Sounds good!
<a_e>Some day, I will learn to write "leaf" correctly...
<NiAsterisk>make like a tree and leaf?
<a_e>Yes. Or trees and leaves :-)
<lfam>efraim: If libreoffice builds successfully, it should be done in ~5 - 7 hours
<a_e>Some time, we should try to go back to a parallel build.
<lfam>This is interesting. While building libreoffice, there is somebody's email address scrolling by in the sea of text
<lfam>Perhaps it is for gst-plugins-base
<efraim>libreoffice on hydra was 7 hours for the last successful build
<efraim>my machine is slower
<lfam>efraim: For how long has your build been going at this point?
<efraim>it failed after 14 hours due to mismatched versions
<lfam>What do you mean? Should I stop my build and alter a package definition?
<efraim>it wants orcus 0.9.2, which needs mdds-0.12, which means ixion needs to be downgraded a bit
<a_e>efraim: Did you not just say it wanted orcus-0.10?
<efraim>yes, but 0.10 doesn't exist
<efraim>in libreoffice's source tarball mirror they have 0.9
<lfam>If you know what to change, I can make the changes locally now. But I am leaving here soon and I won't be back for a few hours
<a_e>I would suggest to really go with 5.0.5.2 now to solve the security problem.
<a_e>lfam: Maybe you could try this and push later if it succeeds?
<a_e>Afterwards, we can try out which helper libraries to upgrade to which versions.
<lfam>Also, do you know the size of the libreoffice closure? I have 6 GiB free on the partition with the store
<lfam>Okay, I'll continue building based on Efraim's patches from the ML?
<efraim>my 5.1.1.3 on the ML is going to fail
<a_e>No, this seems to fail. Just update the current libreoffice to 5.0.5.2, with only a new tarball and a new hash, and see whether this works.
<a_e>If yes, push.
<lfam>So, I should un-apply efraim's patchset, update libreoffice to 5.0.5.2, and start a new build?
<efraim>yeah, thats what I'm doing on my end
<lfam>Okay
<a_e>Well, just start afresh from master and update to 5.0.5.2.
<lfam>Exactly
<a_e>Thanks!
<lfam>I don't even use this kind of software ;)
<efraim>we'll get the cve fixed with the minimum change, and then work on updating it later
<lfam>Why does a word processor depend on computer vision software from the company that did special effects for Star Wars? ;)
<jmd>lfam: I don't know. Why does a word processor depend on computer vision software from the
<jmd> company that did special effects for Star Wars?
<a_e>lfam: Thanks then for devoting yourself to building it! When pushing, please do not forget to mention that it fixes the two CVEs.
<lfam>a_e: Indeed. Hopefully it works!
<a_e>Logically, it should :-)
<lfam>jmd: I promise you that I wasn't setting up a joke ;) There is no punchline
<lfam>a_e: Hopefully the build failure on i686 will also be resolved. I believe that should be fixed by the ilmbase update
<a_e>Probably so.
<efraim>5.0.5.2 passes configure for me
<lfam>I'm still building vigranumpy
<lfam>Or something related to it
<lfam>BTW, efraim, since you like to update things, please don't update transmission anytime soon. Did you hear about their problems?
<lfam>With the trojaned OS X binary?
<efraim>i heard about 2.90 with the issues
<lfam>Yeah, probably best to wait a while before changing our package
<lfam>ACTION afk
<wingo>heh, i was concerned about gnome polluting the system profile with things i didn't explicitly ask for, but i didn't look at what was already in my /run/current-system/profile
<paroneayea>profile pollution? :)
<paroneayea>also hi civodul !
<wingo>paroneayea: context: http://article.gmane.org/gmane.comp.gnu.guix.devel/17466
<wingo>but it turns out to not really be a problem ;)
<wingo>is there anyone that is using gnome that doesn't have suspend-related problems?
<civodul>say no to profile pollution!
<paroneayea>wow
<civodul>hi paroneayea
<paroneayea>xcb has a lot of manpages!
<civodul>they should be separate
<rekado>hmm, I really don't understand why perl is always built from source when grafts are enabled :-/ Does anyone else also experience this?
<rekado>there are substitutes for perl: http://hydra.gnu.org/job/gnu/core-updates/perl-cpan-meta-yaml-0.012.x86_64-linux
<rekado>erm: http://hydra.gnu.org/job/gnu/master/perl-5.22.1.i686-linux
<rekado>same for x86_64: http://hydra.gnu.org/job/gnu/master/perl-5.22.1.x86_64-linux
<petter>rekado: i've experienced this as well
<a_e>Same for me.
<civodul>rekado: it's a Perl that's not shown here i think
<civodul>one induced by the packages in commencement.scm
<civodul>we'd have to check the graph
<CompanionCube>uh i'm just getting substitute: updating list of substitutes from 'http://hydra.gnu.org'... 100.0% over and over
<CompanionCube>nvm, fixed
<rekado>civodul: is this being built by hydra? I think it's been like this since at least one day.
<NiAsterisk>CompanionCube: yes, this seems to be smething which will get fixed eventually.
<NiAsterisk>had this some days ago, stoped after a few days
<civodul>rekado: Hydra hasn't built anything beyond b134a80 according to http://hydra.gnu.org/jobset/gnu/master#tabs-evaluations
<civodul>mark_weaver reported the issue one or two days ago
<civodul>which led to 49c4fd2aab0c99c32ec338949ff07bd89d2920f6
<civodul>but it seems that this fix doesn't fix much
<efraim>i wanted to check before pushing, OK on pushing the CVE update to libreoffice without fully building it first locally?
<CompanionCube>apparently compiling perl now yay
<civodul>efraim: it would be best it you made sure it actually builds; do you have the CPU power + disk to do that?
<civodul>(and BTW, thanks for working on it!)
<efraim>i have the disk, the cpu part is a bit lacking but it'll complete eventually
<civodul>heh, good :-)
<civodul>if it starts grafting LO, you'd better interrupt it, i think
<civodul>i assume LO is pretty big so grafting it all may be somewhat slow
<NiAsterisk>ACTION gives gnunet-gtk debuging a try
<CompanionCube>no
<CompanionCube>what's the incantation required to build texlive locally but without downloading ~3GiB from hydra
<CompanionCube>nvm
<civodul>--no-substitutes
<NiAsterisk>civodul: is Guix installer somehow able to locate the /gnu/store/ location of a currently used exectuable? what gnunet-gtk puts out for guix with other issues: "checking for GNUnet core... --with-gnunet not specified" what I did on gentoo: --with-gnunet=/usr || die we don't have /usr... so I need to "find" the location of the current generation of $store/gnunet/path
<civodul>NiAsterisk: sure, you could "grep -e --with- gnu/packages/*.scm" for examples of that
<civodul>lemme know if it helps
<NiAsterisk>hm. i should grep more.
<NiAsterisk>thanks
<civodul>np :-)
<NiAsterisk>sure, will do
<gwho>is someone working on a gui installer?
<rekado>gwho: I'm not.
<CompanionCube>hm
<rekado>and I don't know of anyone else who is.
<rekado>but it is on some people's list (my own as well)
<CompanionCube>still looks to be no different from downloading.
<gwho>rekado: you just answered all the questions i had while i was typing...
<gwho>great, you seem to care here about tor users ( avoid pastebin.com, it blocks Tor ). but why are you on freenode that is fully blocking tor?
<NiAsterisk>convinience possibly.
<NiAsterisk>idk
<gwho>or am i missing some way that allow connecting to freenode with tor?
<NiAsterisk>i can neither confirm nor deny how I connect to freenode.
<NiAsterisk>our gnunet seems to live in /bin
<gwho>ah, thanks :)
<NiAsterisk>where fe. gentoo is /usr/bin
<civodul>gwho: until a year ago roughly, it was possible to connect to Freenode via a hidden service
<civodul>OFTC access via Tor is unreliable at best
<NiAsterisk>doesn't work anymore civodul
<civodul>yeah
<NiAsterisk>oftc banned it too, to "fix" tor
<civodul>bah
<CompanionCube>ACTION will just use host distro's texlive
<CompanionCube>until the ~3GiB is split up
<efraim>i connect to freenode through irc://frxleqtzgvwkv7oz.onion
<NiAsterisk>a new hiddenservice for freenode?
<rain1>I didn't know freenode allowed tor
<rain1>are there any good IRC servers that do support tor?
<rain1>(that guix may consider moving to)
<gwho>@admins in this channel: there is a 's' missing in the name of this chan: wrong: http://gnu.org/s/guix/ fixed: https://gnu.org/s/guix/
<NiAsterisk>psyced.org / loupsycedyglgamf.onion
<NiAsterisk>multicast (psyc,irc,xmpp)
<NiAsterisk>and webchat
<NiAsterisk>and there's also hackint and mufhd0/ai
<NiAsterisk>those are the networks I know about
<NiAsterisk>whereI am packaging psyced for guix soon just as a practice.. because with psyc2 (secushare) around the corner, psyc1 will be around until psyc2 is available, and that's it.
<rain1>that's interesting, a new protocorl
<NiAsterisk>hm.. new.
<NiAsterisk>psyc dates back to 89 i think or mid 90s
<NiAsterisk>there was never a psyc1 (it's psyc0.99 currently) specification because of the cloud industry hitting in 2005 very hard, so they had to re-think what they aimed at
<NiAsterisk>thus started development of what is becoming secushare.
<NiAsterisk>in short.
***civodul changes topic to 'GNU Guix | https://gnu.org/s/guix/ | videos at https://gnu.org/s/guix/help/#talks | 0.9.1 is in the works | https://libreplanet.org/wiki/Group:Guix/GSoC-2016 | avoid pastebin.com, it blocks Tor | channel logged: <https://gnunet.org/bot/log/guix>.'
<danielszmulewicz>when I type guix edit emacs, the recipe file is read-only. I need to be super user to edit recipe files?
<gwho>civodul: GREAT! thanks
<alezost>danielszmulewicz: it is read-only because it is in the /gnu/store. You should never modify files in store!
<danielszmulewicz>so what does the command `guix edit recipe' do?
<alezost>danielszmulewicz: it opens a package recipe; you can either clone the guix repo, set it up as described in the manual and modify a package there, or you can inherit your own version of package and put to GUIX_PACKAGE_PATH
<danielszmulewicz>alezost: Ah, so that's that. Thanksè
<gwho>civodul: if you are somehow connected to the admins of gnu.org you could give them a note that there is HSTS missing on the gnu.org page.
<gwho>is there a reason why this link is not working? https://alpha.gnu.org/gnu/guix/guixsd-usb-install-0.9.0.x86_64-linux.xz
<civodul>no idea
<alezost>danielszmulewicz: btw you are not the only one who was confused by read-only file after 'guix edit': http://debbugs.gnu.org/cgi/bugreport.cgi?bug=22587#5
<danielszmulewicz>alezost: Ah, thanks. Probably not. There's a lot of gotchas for a first time user. Is there someone listening?
<alezost>danielszmulewicz: someone listening? Sorry, I don't understand this question
<danielszmulewicz>I mean, there's nothing like a first time user to talk about how to improve access to a a project. Onboarding.
<danielszmulewicz>I have a list of points, a list of gotchas.
<danielszmulewicz>Eveybody new user will encounter them.
<danielszmulewicz>Or rather, every new user is probably encountering them.
<danielszmulewicz>I can make life easier for my successors by telling what those sore points are.
<danielszmulewicz>Do I make sense?
<alezost>danielszmulewicz: you are welcome to send your thoughts to guix-devel@gnu.org or maybe report something as bugs. This will help to improve guix
<danielszmulewicz>alezost: thanks. That's what I meant.
<gwho>when guix is installed, is there a way to update it on a gui-way?
<rain1>probably the closest is the emacs interface
<rain1>its still text mode though
<NiAsterisk>text is still gui... what you mean is like a gtk or ncurses wrapper around functionalities of guix ?
<gwho>yes, something a old non technical person can use with the mouse like on other distributions
<NiAsterisk>that is the ideal goal, maybe it was also a gsoc thing, idk i don't follow everything, but something which should come with maturity... guix is 3 or 4 now i think
<gwho>i like installing the os i use on the computer my dad uses. he always find some bugs i never see and i can report them and make the distro more user friendly
<NiAsterisk>it's on peoples lists, but i'm not aware of anyone working on it currently
<NiAsterisk>I need an guile translation before I do a shot in the dark: (string-append "--with-freeipmi=" (assoc-ref %build-inputs "freeipmi")) as an example. this appends --with-freeipmi= , plus it attaches the output gnu/store/ path of the build-input "freeipmi". now, this freeipmi is in inputs. coming back to gnunet-gtk, it has gnunet in its inputs. I am pretty sure this is how it could work or I will find something
<NiAsterisk>soon, but is the translation I assume right?
<danielszmulewicz>alezost: What is the section in the manual that tals about cloning the repo to edit recipes? I can't seem to find it.
<alezost>danielszmulewicz: (info "(guix) Contributing"). It describes how to build it from git, how to use it, etc.
<danielszmulewicz>I need to build guix in order to edit a recipe?
<lfam>ACTION still building libreoffice 5.0.5.2
<rain1>how did maps go lfam ?
<lfam>rain1: It's on hold while I do the libreoffice build.
<rain1>ok!
<lfam>I built it successfully, but I couldn't run it on my Debian / non GNOME system.
<lfam>I want to try running it from within GNOME on GuixSD
<alezost>danielszmulewicz: if you plan to contribute your edition, then yes; if you want to have and use a modified version of some package, you can make your own module with this package and add a directory with this module to GUIX_PACKAGE_PATH as described in (info "(guix) Package Modules")
<danielszmulewicz>alezost: OK, thank you.
<NiAsterisk>ACTION shoots into the dark with gnunet. hope enough shots will bring me to debug it
<alezost>danielszmulewicz: I personally find it very convenient that you can have a directory with your own packages and modified versions of guix packages using GUIX_PACKAGE_PATH. If you have other questions, you are always welcome to ask here
<lfam>rain1: If you want to try it locally, I can share the patches with you
<danielszmulewicz>alezost: Thank you. That was gracious of you. So far I failed at everything I attempted to do.
<rain1>i don't mind waiting :)
<rain1>for it to get into the main packages
<lfam>Okay, it's not much fun to build. It takes a long time to rebuild some of the dependencies
<lfam>So I think you have made the right choice ;)
<alezost>danielszmulewicz: ouch :(, if you have problems with packaging you can always aks here or at guix-devel@gnu.org or at help-guix@gnu.org
<NiAsterisk>debuging: the art of try and error and try and error and yell at error
<danielszmulewicz>alezost: I'm exagerating a little bit. It's not that bad. I've just installed guix today; The concept is amazing, I really love it. Usability, I don't know.
<danielszmulewicz>I'm 100% with myglc2 regarding the guix edit semantics.
<danielszmulewicz>guix edit implies modifying the recipe.
<danielszmulewicz>But I read your opinion. I'm not starting the debate anew.
<alezost>danielszmulewicz: send your opinion to 22587@debbugs.gnu.org so it will not be lost! If it is so confusing to the newcomers, we should do something about it