IRC channel logs

2015-12-26.log

back to list of logs

<cby>hi
<piyo>hi
<cby>maybe I am missing something, I have been trying to build guix from a git checkout for hours, and I just cannot seem to get the /gnu/store populated
<cby>which stops me from actually running guix command: uix package: error: open-file: No such file or directory: "/gnu/store/af19ma2vm3qhvh3rw6cdivyp98s18bj3-guile-bootstrap-2.0.drv
<cby>is there something else thant './bootstrap && ./configure && make' to do?
<piyo>dumb question but does /gnu/store exist for you?
<cby>it does, it actually gets created on make install
<piyo>ok good
<cby>but empty, apart from a .links directory
<piyo>maybe the problem is not at your end, but at the network end
<cby>piyo: how so? Are the .drv files supposed to be downloaded?
<piyo>yeah i think so?
<piyo>i am not a devel but a foreign guix user
<cby>piyo: all right, I'll stop trying for now then, try again tomorrow. Thanks anyway !
<piyo>:-( sorry it wasnt helping
<cby>maybe it was ! I might just need to sleep on it
<piyo>btw why are you installing via source? I installed the binary package for my debian jessie
<piyo>also i assume you are not trying "guixsd" right now
<fps>hmm, it also depends on the --prefix argument you have on ./configure
<mark_weaver>drv files are not normally downloaded, they are generated by your local copy of guix
<nucleria>Hi.
<nucleria>I'm having a couple problems installing GuixSD on my Dell Studio 1558. The error comes after the "guix system init /mnt/etc/config.scm /mnt" command.
<nucleria> http://imgur.com/GD37nhN any help?
<nucleria>?
<piyo>mark_weaver: noted
<piyo>hello #guix and emacs users, does this code pass for you? http://sprunge.us/LPjE
<goglosh>is there still haskell code in guix?
<_`_>was here a significant amount of haskell code in nix to begin with?
<_`_> https://www.openhub.net/p/nix/analyses/latest/languages_summary
<_`_>s/here/t&/
<_`_>looks like none
<_`_>s/ne$/t/
<piyo>Oh, maybe my installation doesn't have enought time zone information installed.
<piyo>because "date" is /usr/bin/date and emacs is /gnu/store/.../emacs
<piyo>What is package provides the translation for "America/Los_Angeles" to "PDT" timezone?
<piyo>oh maybe its "tzdata"? gonna try installing that now
<noder>nucleria could you please upload your config.scm as well?
<noder>sneek: ask nucleria please provide your config.scm as well
<noder>sneek help
<noder>sneek botsnack
<sneek>:)
<noder>sneek later ask nucleria please provide your config.scm as well
<sneek>Got it.
<cby>hi again
<cby> I asked that yesterday, but made no progress: when building guix from git, I cannot seem to be able to get the store populated, the executables are installed fine, but I cannot use them, I get: "guix package: error: open-file: No such file or directory: /gnu/store/af19ma2vm3qhvh3rw6cdivyp98s18bj3-guile-bootstrap-2.0.drv"
<cby>Am I missing a step?
<cby>oh right, just saw the answer from yesterday. I'll update my question: what can stop 'make' from creating drv files from my local copy of guix?
<rgrau>Hi, I just wrote a package definition (or however it's called), and would like to run guix lint on it, but currently, 'guix line packagename' does not recognize packagename. How should I proceed now?
<fps>rgrau: did you add it to a file in a guix checkout?
<rgrau>Yup, but I'm not running guix from that checkout
<fps>normally you'd then have done: ./pre-inst-env guix lint packagename
<rgrau>aha
<fps>but i suppose you can set the relevant environment variables for your global guix to find the package file, too
<davexunit>use pre-inst-env
<davexunit>that's what you use for development
<rgrau>uh, I'm trying to run ./boostrap and ./configure && make to generate the pre-inst-env from pre-inst-env.in and it's failing to find guile package:
<rgrau>configure: error: Package requirements (guile-2.0 >= 2.0.7) were not met:
<rgrau>
<rgrau>No package 'guile-2.0' found
<rgrau>
<rgrau>I'm trying 'guix environment guix'
<rgrau>we'll see how it goes now :)
<davexunit>that will work
<davexunit>provided your bash config doesn't clobber the env vars that it sets
<NiAsterisk>ACTION test-builds gnunet-gtk
<NiAsterisk>hopefully I can commit the patches for gnunet-gtk and pybitmessage before years end
<NiAsterisk>can't sign the patches though, I'd like to do that for patches when I got my cardreader next month
<NiAsterisk>"gnu/packages/gnome.scm:809:5: warning: possibly unbound variable `xvfb'" when I have ("xvfb" ,xvfb) in (native-inputs) in gnome.scm for a package. where does xvfb reside? guix package -A xvfb didn't help
<davexunit>NiAsterisk: that's because "xvfb" isn't a package
<NiAsterisk>which bigger package is it a part of?
<davexunit>the xvfb program comes with xorg-server
<NiAsterisk>oh. thanks
<NiAsterisk>what are packages like in gnu/packages/python.scm ? all just libraries and small applications in python / for python? because I feel PyBitmessage might be in the wrong file there. it is written in python, that's all. If I put it there, do I need to write one package definition for python2 and one for python(3)?
<davexunit>NiAsterisk: that module is mostly for libraries
<davexunit>NiAsterisk: (gnu packages messaging) seems a better fit
<NiAsterisk>very likely. okay, thanks
<cby>yay! I figured it out! (if anyone cares, there was an inconsistency because of the database in /usr/local/var/guix, removed it and everything's fine again)
<NiAsterisk>hm. pybitmessage requires python2. do I write (package ...) like usual and then add a (package-with-python-2) or what it was below it?
<NiAsterisk>or better, isy there documntation on python2 packaging?
<rekado>NiAsterisk: you would do (arguments `(#:python ,python-2 ...))
<rekado>(if it uses python-build-system)
<NiAsterisk>it does. I'll try and see if I get it right. thanks
<tsyesika_>when you build a package with `guix build` where does it do the building and does it clean up the unpacked files if it fails
<NiAsterisk>theoretically it doesn't even need building. if you check it out from source you can run src/bitmessagemain.py and it works. so it just needs to get copied somewhere
<NiAsterisk>i can paste the log
<NiAsterisk>right
<NiAsterisk>it fails because there's no setup.py
<NiAsterisk>which is not needed
<davexunit>NiAsterisk: the python-build-system accepts a #:python argument
<davexunit>use that to set the python version
<davexunit>and use inputs that also use python2
<NiAsterisk>okay, maybe it does need inputs other than python-setuptools. https://ptpb.pw/HOIs or https://ptpb.pw/HOIs.log (depending on what you use to view the file) is what I got so far.
<NiAsterisk>whis is pointless to show you without the package definition i just realized.
<davexunit>NiAsterisk: well, is there a setup.py file?
<davexunit>perhaps pybitmessage uses a custom build script
<NiAsterisk>there isn't. it just needs to be manually copied iirc. I'll double check with ebuilds I had.
<NiAsterisk>ah yes.. hm. I think I need to look at the ebuild and understand what it did. there are extra functions to install pybitmessage which pybitmessage doesn't have.
<NiAsterisk>it requires PyQt4-$pythonversion for runtime. guix package -A PyQt doesn't list anything, so I assume it's not there?
<davexunit>NiAsterisk: we don't name packages like that
<davexunit>we always use lowercase
<davexunit>and dashes separate words
<NiAsterisk>python-qt then?
<davexunit>-A is also probably not the search type you want, try -s
<davexunit>or better yet, just grep the source code
<davexunit>NiAsterisk: python-pyqt
<NiAsterisk>right :)
<davexunit>'guix package -s PyQT' revealed it
<davexunit>as did 'guix package -A qt'
<davexunit>-s searches synopses and descriptions, -A just searches names
<davexunit>both accept regular expressions for more advanced searches
<NiAsterisk>would `(("python-pyqt" ,python-pyqt-4.11.4) be correct for defining package versions in inputs?
<davexunit>NiAsterisk: you have to find out what the variable name is for that package
<davexunit>it's probably not python-pyqt-4.11.4
<NiAsterisk>ah. right. I should look at the source first before assuming things which I am used to
<NiAsterisk>python-pyqt-4 it is
<NiAsterisk>probably even python2-pyqt-4
<NiAsterisk>all is well and fine, but I think I need to write an setup.py or something for it. or ask upstream to provide one.
<lfam>Does anyone have experience using Guix "interactively" on spinning rust and solid state storage? I imagine that an SSD would significantly improve the experience of working with the store. So much seeking... I'm wondering about other's experiences.
<NiAsterisk>how does one handle external sources (http downloads during make) in guix?
<NiAsterisk>different package, gnunet-gtk, some errors remaining
<davexunit>NiAsterisk: those cannot happen
<NiAsterisk>I/O error : Attempt to load network entity http://www.oasis-open.org/docbook/xml/4.2/docbookx.dtd
<NiAsterisk>glade.xml:3: warning: failed to load external entity "http://www.oasis-open.org/docbook/xml/4.2/docbookx.dtd"
<NiAsterisk> "http://www.oasis-open.org/docbook/xml/4.2/docbookx.dtd">
<davexunit>NiAsterisk: network access during builds is inherently non-deterministic
<NiAsterisk>okay
<davexunit>the only type of build process which may access the network are those whose hash is known in advance
<davexunit>in practice this is just source code downloads
<lfam>NiAsterisk: You are missing at least one dependency in the inputs of your package. Probably docbook-xsl. I believe I addressed this the last time it came up on the mailing list with the WIP gnunet-gtk package. Did you read that thread.
<lfam>?
<NiAsterisk>yes
<NiAsterisk>I'll upload the current working version + log in a moment
<lfam>Okay
<NiAsterisk> https://ptpb.pw/gTfd.log and https://ptpb.pw/cTzY.scm , glade3 extract from gnome.scm and the partial log file.
<paroneayea>hey mark_weaver
<paroneayea>mark_weaver: do you use ntp or something? I recently found out that libreboot/coreboot do not read the system clock
<paroneayea>and would like to find out a nice way to avoid having files written out in 1969/1970
<paroneayea>(brb)
<francis7>paroneayea, hwclock -w
<francis7>adding to libreboot FAQ now
<NiAsterisk>not completely guix related, but would I be able to setup the/any login manager to log me in with a GnuPG card?
<francis7> http://libreboot.org/faq/#epochfail
<francis7>paroneayea, does this solve the problem?
<NiAsterisk>apparently yes, with libpam-poldi
<NiAsterisk>Okay, I think I will take some more time to figure out the problems I have completely on my own, try to read some more sources, see if I can solve the glade3 issue. It's better for understanding and learning, and I think I can do this on my own. If not, I'll be back for more detailed questions.
<nucleria>Hi. I have a picture of a back trace from the "guix system init /mnt/etc/config.scm /mnt" command. If anyone knows how to fix it, I need the help on installing GuixSD to my Dell Studio 1558.
<sneek>Welcome back nucleria, you have 1 message.
<sneek>nucleria, noder says: please provide your config.scm as well
<nucleria>Will do.
<nucleria>Back trace: http://imgur.com/7H903gl config soon.
<nucleria>Okay. Now it won't boot from my USB.
<paroneayea>francis7: giving it a try
<paroneayea>that's interesting
<paroneayea>so
<paroneayea>I can set the clock with "hwclock -w" in debian
<paroneayea>and it works great
<paroneayea>I can restart back into debian and everything's fine
<paroneayea>but if I reboot into guix, then restart
<paroneayea>the time is wrong in debian again
<paroneayea>I wonder why?
<efraim>paroneayea: I have to go to bed soon, but it sounds like an issue I've seen before on macs with a windows partition
<efraim>I never looked that closely at it in the past, but I assumed it was something about an assumption the OS makes about the machine's clock, if its set to UTC or local time
<efraim>the windows partition almost always had the wrong time
<paroneayea>efraim: interesting
<paroneayea>efraim: though why would utc vs local have to do with resetting to 1970?
<efraim>Oh, I didn't realize it reset back to 1970. Mine was always off by 2 hours
<arianvp>any guix people at CCC?
<h0wl3vvd>hello
<h0wl3vvd>is anyone here who is using guixsd and non-free software ?
<rekado>h0wl3vvd: no.
<rekado>well, I am not.
<h0wl3vvd>but maybe someone else, im asking for these ones who does
<NiAsterisk>arianvp: wanted to go but I was too late with booking