IRC channel logs

2015-10-27.log

back to list of logs

<civodul>HotLava: could you report that to bug-guix@gnu.org so we can investigate later?
<HotLava>ok, if you're really desperate you could maybe use objcopy to bulk-rename the symbols, but luckily i don't have to do that :D
<HotLava>sure
<civodul>heh :-)
<lfam>Progress on lua!
<lfam>A bit
<lfam>Does anyone have an example of inherited packages with different make flags? For example, lua-5.1 inherits from lua (i.e. lua-5.2), but they need different make flags to build properly.
<davexunit>lfam: look for instances of 'substitute-keyword-arguments'
<lfam>davexunit: I had found libfm-extra in lxde.scm. What do you think about doing it like that? It seems simpler than substitute-keyword-arguments. Is there an advantage to substitute-keyword-arguments?
<davexunit>I got my Let's Encrypt beta invite a little while ago. guess that means I need to package this: https://github.com/letsencrypt/letsencrypt
<lfam>Ah, I had that on my todo list as well
<davexunit>lfam: that overrides the arguments list entirely.
<lfam>If we package letsencrypt right away I bet some people would install Guix just to get it
<davexunit>is that what you want to do?
<lfam>No, that's totally not what I want to do
<lfam>re: overriding all the args
<davexunit>then you'll want substitute-keyword-arguments
<davexunit>so that you can augment the arguments list.
<lfam>Anybody have ideas about how to make this line shorter? http://paste.lisp.org/+3DJT
<davexunit>lfam: override #:make-flags instead of replacing the build phase
<lfam>I did it that way because the package it inherits from also had the build phase replaced with system* in the same way. Can I still replace make-flags if I am inheriting from lua as it is now?
<davexunit>lfam: no, I guess not.
<davexunit>you can break up that line by splitting on spaces
<davexunit>(string-join '("-fPIC" "-DLUA_USE_LINUX_MYLIBS=-Wl,-E" ....))
<lfam>Oh, will that give it make with all the whitespace quoted properly? I was trying to figure out to do it
<lfam>*give it to make
<davexunit>no, it just concatenates the strings with spaces in between
<davexunit>I'm working off of the assumption that your flags are correct
<davexunit>but it seems like they aren't
<lfam>Oh really?
<davexunit>if you need escaping, then you have to escape them.
<davexunit>MYCFLAGS="-fPIC ..."
<davexunit>or rather, quote them.
<lfam>The way they are quoted now is what works. MYCFLAGS needs to contain that entire line. So if the string gets broken up in the code, it has to get passed to make as one argument.
<davexunit>okay
<davexunit>so, string-join
<davexunit>(string-join '("-fPIC" "-DLUA_USE_LINUX_MYLIBS=-Wl,-E" ....))
<davexunit>(string-append "MYCFLAGS=" (string-join ...))
<lfam>I like that pedagogical technique: zooming out of the function. Well-suited to the language.
<davexunit>:)
<davexunit>gotta go to sleep now
<davexunit>tried to package lets-encrypt for awhile
<davexunit>but I'm 10 dependencies deep into zope libraries with no sign of it stopping
<davexunit>so I give up for now.
<Sleep_Walker>it was really long time ago
<Sleep_Walker>I still hope I'll find time for guix again
<Sleep_Walker>I'm planning to add connman support and some wayland window managers
<Sleep_Walker>but right now I'm digging into ncurses a bit
<efraim>Sleep_Walker: adding connman is just packaging it or does it need a service description also
***Gary is now known as Guest89897
<Sleep_Walker>efraim: it needs service description, starting wpa_supplicant service in advance as service dependency
<Sleep_Walker>my poor guile knowledge prevented me from addin that
<Sleep_Walker>*adding
<civodul>Hello Guix!
<civodul>from http://hydra.gnu.org/build/754899/nixlog/1/tail-reload: kernel/qmetatype.cpp:1943:1: internal compiler error: Segmentation fault
<civodul>oops!
<efraim>i noticed that the libre-linux kernel doesn't have build instructions for armhf or mips64el, so would it make sense to mark those as not for those platforms?
<efraim>i assume davexunit is using a different kernel on his leemote and marking it as a replacement for linux-libre, so is it possible to mark it as #:substitute? #f for only mips and arm?
<civodul>efraim: Linux does build on these platforms, so it's really a problem on our side
<efraim>ok
<civodul>so i would leave 'supported-platforms' as is
<civodul>i think the wip-loongson2f has fixes for linux-libre
<civodul>i plan to look at that branch before the release
<civodul>iyzsong: i've pushed a couple of fixes to dbus-updates, could you look into the remaining failures?
<efraim>lightning on x86_64 from http://hydra.gnu.org/build/723628 failed, built locally for me: @ build-succeeded /gnu/store/iryymc0v20vh5nvi1qcv76rg2q6gp56g-lightning-2.1.0.drv
<civodul>/gnu/store/cz9w2k8554n06yphd9dc35fy8507dwgg-lightning-2.1.0 builds fine on my laptop as well
<civodul>hey, toothbrush0!
<toothbrush0>hi civodul !
<efraim>i'm trying out ricardo's patch for mosaik also, trying to build it for i686-linux
<efraim>build failed
<iyzsong>civodul: sure, and thanks for fixes!
<civodul>yw!
<civodul>current status: http://hydra.gnu.org/eval/107597?compare=master#tabs-now-fail
<jmd>Does the guix installable image boot directly or via grub ?
<efraim>it has its own grub included in the image
<iyzsong>how to boot directly without a bootloader?
<civodul>that's the GuixSD image
<civodul>davexunit!
<davexunit>civodul!
<civodul>:-D
<civodul>good morning, davexunit
<civodul>should we post the thing on Savannah?
<davexunit>civodul: sure, let me add the news entry so you can approve it.
<davexunit>can you edit it after I do that?
<civodul>yes, but maybe i won't even have to? :-)
<civodul>oh i think you have to make each paragraph fit on one line
<davexunit>yeah, stuff like that is what I'm concerned about mostly
<civodul>also please add the blurb from about.txt in guix-maintenance.git
<davexunit>M-x unfill-paragraph ? :P
<civodul>that's the idea :-)
<davexunit>civodul: what heading type do you use for "About GNU Guix"?
<civodul>hmm i forgot, but see the .txt files in guix-maintenance.git, under savannah/
<davexunit>okay looking now
<davexunit>hmmm I don't see it here http://git.savannah.gnu.org/cgit/guix/maintenance.git/tree/
<davexunit>civodul: nvm found it
<davexunit>just some subdirs deep
<davexunit>civodul: I had this as the working title, but I don't like it: "Introducing call-with-container: Linux containers for Guix"
<davexunit>too wordy
<davexunit>maybe just "Guix Containers" or "Containers"?
<davexunit>would anyone care to take a look at my "final" draft? http://paste.lisp.org/display/157590
<civodul>ACTION looks
<civodul>davexunit: maybe add a link to http://www.gnu.org/software/guix/manual/html_node/Invoking-guix-environment.html under "guix environment"
<civodul>otherwise LGTM!
<civodul>oh, and the title
<civodul>ACTION thinks
<pksadiq`>davexunit: line 7: ... notable difference is that 'the' disk images... ?
<davexunit>civodul: under the code snippet for 'guix environment'?
<civodul>under the first occurrence of "guix environment"
<davexunit>or as a link on the text 'guix environment' in the above paragraph?
<davexunit>okay
<civodul>as a link, yes
<civodul>"Guix in the box: When Guix meets Linux containers"
<civodul>too silly?
<davexunit>a bit silly :)
<davexunit>both "Guix" and "Containers" should appear, though, I suppose.
<davexunit>pksadiq`: hmm, I don't think so.
<davexunit>I'm not pointing at a set of disk images, but speaking about disk images in general.
<civodul>davexunit: also maybe a link to http://git.savannah.gnu.org/cgit/guix.git/tree/gnu/build/linux-container.scm#n215 under the first occurrence of call-with-container
<davexunit>sounds good
<davexunit>source code is good
<jmd>source code good. object code bad.
<civodul>"Container provisioning with Guix"?
<davexunit>civodul: sure!
<davexunit>also adding a link where 'guix system' appears
<civodul>or "Docker sucks; Guix will save the world"
<davexunit>hahaha
<davexunit>I won't feel confident enough to say that in a public announcement until it is at feature parity. ;)
<civodul>:-)
<civodul>or "Leveraging synergies between Guix and Linux containers"
<davexunit>annotated with updated text: http://paste.lisp.org/display/157590#1
<davexunit>civodul: let me circle back to you on that one
<civodul>sure
<davexunit>:P
<civodul>the buzzwordy version could be fun if people understand it's 2nd degree
<davexunit>"Container provisioning with Guix" is the best, I think.
<civodul>yeah
<davexunit>higher-order buzzwords
<civodul>:-)
<davexunit>alright, shall I submit this now?
<civodul>this last paste looks good
<civodul>yes!
<davexunit>great!
<davexunit>now I'll have to make sure to get the rest of my patches in before release! :)
<civodul>yep! :-)
<civodul>i'm looking at one of these
<davexunit>civodul: posted
<civodul>approved!
<civodul>i think you can approve them yourself, even
<civodul> https://savannah.gnu.org/forum/forum.php?forum_id=8386
<davexunit>civodul: oh cool :)
<davexunit>I guess I feel like it's too much power to approve my own posts
<civodul>heh
<davexunit>alright, guess I'll post to HN now
<iyzsong>cool!
<civodul>\\o/
<civodul>updated http://www.gnu.org/software/guix/
<davexunit>great
<davexunit>would someone like to submit to r/linux?
<davexunit>reddit frowns upon self-posts
<orly_owl>whats the news
<davexunit>orly_owl: https://savannah.gnu.org/forum/forum.php?forum_id=8386
<davexunit>here's the HN discussion https://news.ycombinator.com/item?id=10457761
<davexunit>upvotes appreciated
<davexunit>front page!!
<davexunit>of HN
<davexunit>woooooo
<civodul>yay!
<civodul>a certain "iyzsong" commented ;-)
<iyzsong>yeah :-)
<davexunit>I don't trust that guy
<davexunit>;)
<iyzsong>lol
<civodul>and paroneayea made a valid comment
<civodul>we could have linked to your message
<davexunit>with invalid markup ;)
<davexunit>civodul: I thought of that, but it seemed best to leave it off.
<civodul>ok
<civodul>it's not on the front page though, is it?
<civodul>seen on HN: "Hypernetes – Multi-Tenant Kubernetes Distribution"
<civodul>pretty heavy on buzzwords
<civodul>or just too smart for me to understand
<davexunit>civodul: it was at #12 a bit ago
<davexunit>I've been afk, so let me check again...
<davexunit>oh nvm
<davexunit>no, it wasn't
<davexunit>I was looking at the new page and thinking that I was on the front page.
<davexunit>ugh
<davexunit>not fully awake it seems
<civodul>heh
<paroneayea>davexunit: I fixed the invalid markup :)
<iyzsong>I update leptonica to 1.72, but it doesn't fix the test failure :-(
<iyzsong>ACTION AFK, good night #guix!
<civodul>night, iyzsong!
<civodul>(already?)
<iyzsong>not really, thanks :-)
<civodul>:-)
<lfam>re: Lua, I probably won't have much time to look into it today, but I replied to the ML explaining the patch a little more. I should have explained more in the original message...
<civodul>ok, thanks lfam!
<davexunit>it's weird. my post has 6 upvotes, but HN hasn't awarded me any "karma" points
<davexunit>I feel like the post is being automatically punished or something. this has happened before.
<davexunit>it has more upvotes that the rest of the 90 latest entires
<davexunit>entries*
<davexunit>would anyone like to submit https://savannah.gnu.org/forum/forum.php?forum_id=8386 to r/gnu and r/linux?
<civodul>would be cool!
<civodul>i could try
<davexunit>I don't think HN front page will happen, though it looks to me like there's enough upvotes and comments to make it stand out from other new submissions.
<civodul>it's weird
<civodul>bah
<davexunit>this has happened to me before. I must have tripped some automated thing that applies a negative weight to the submissions.
<davexunit>submission*
<civodul> https://www.reddit.com/r/gnu/comments/3qfce6/container_provisioning_with_guix/
<davexunit>good thing I'm an admin of r/gnu
<davexunit>"removed by AutoModerator"
<davexunit>wtf
<civodul>uh
<civodul>for /linux, i got: "you are doing that too much. try again in 8 minutes."
<davexunit>someone else should post it, then.
<civodul>yeah
<paroneayea>I'll do it
<paroneayea>and yeah you have to be careful
<paroneayea>reddit can do evil things, like shadowbanning you
<paroneayea>where you get banned, nobody can see you, and you don't even know it
<paroneayea>for posting too much
<paroneayea>I learned this the hard way during the mediagoblin campaign
<paroneayea> https://www.reddit.com/r/linux/comments/3qfdfb/container_provisioning_with_guix/
<davexunit>thank you paroneayea
<paroneayea>/r/linux/ is nice because it gets a good deal of traffic, but is fairly easy to get attention on
<davexunit>yeah
<paroneayea>next up, slashdot? :)
<paroneayea>ACTION preps a slashdot post
<paroneayea>how's this for a slashdot post:
<civodul>davexunit: BTW, could you add the text to guix-maintenance.git, under savannah/ ?
<davexunit>civodul: sure, I can't do that now, but I will when I am able.
<civodul>sure, no rush
<paroneayea><a href="https://savannah.gnu.org/forum/forum.php?forum_id=8386">Container provisioning just landed</a> in <a href="https://www.gnu.org/software/guix/">GNU Guix</a>, the purely functional, scheme-based, totally free software package manager (and with GuixSD, distro too). Containers now work with both the "guix system" command as a lightweight and secure substitution for VMs to launch applications and test reproducible deployments with,
<paroneayea>and a "guix environment" command for launching secure development environments. Since the word "container" has been mentioned, some will no doubt be wondering how this compares to Docker, and fortunately <a href="http://lists.gnu.org/archive/html/guix-devel/2015-10/msg00916.html">such a breakdown has been given</a> on a mailing list post.
<paroneayea>how's that?
<civodul>looks good!
<civodul>s/secure/isolated/ maybe
<paroneayea>good idea
<davexunit>paroneayea: nitpick: capitalize "scheme"
<civodul>yes
<paroneayea>I'll replace the second one with isolated
<davexunit>looks good.
<paroneayea>but leave the first one as secure
<paroneayea>because that's one distinction between us and Docker, for instance, right? :)
<davexunit>best to leave out secure for now.
<paroneayea>ok :)
<davexunit>"as a lightweight substitution for VMs"
<davexunit>user namespaces are still considered rather bleeding edge, and VM implementations are quite battle-tested at this point.
<paroneayea> http://slashdot.org/submission/5154465/container-provisioning-with-guix
<paroneayea> http://slashdot.org/recent upboat on the firehose assuming you see it
<davexunit>upvoted.
<davexunit>I just received an email from someone from Docker
<petter_>upboat? :)
<davexunit>words of encouragement.
<efraim>encouragement or consolation?
<davexunit>they said they thought Guix's differing implementation was cool
<davexunit>and that they used to be a sysadmin looking after multi-user clusters a la what rekado does.
<davexunit>or it seems like a similar thing to what rekado does, at least.
<efraim>cool
<davexunit>civodul: your libc patch was accepted at last!
<taylan>that took them some time O_o
<civodul>davexunit: yeah well, ahem
<civodul>we discussed this during lunch...
<davexunit>:)
<rekado>pbtranscript-tofu fails to build, because its setup.py contains install_requires=[ ..., 'bx-python'] --- or so it seems.
<rekado>bx-python is an input, however, so it doesn't need to be built or anything.
<rekado>I already updated pbtranscript-tofu locally, but that doesn't fix it.
<rekado>this must have broken with the update from python 2.7.6 to 2.7.10 (it did build before, I'm sure).
<paroneayea>btw civodul
<paroneayea>protip from Deb, and she's right
<paroneayea>we should have a bunch of GuixSD stickers to give out
<paroneayea>they're cheap, free advertisement when people put them on laptops
<paroneayea>and inspire a sense of investment in the project
<civodul>paroneayea: agreed!
<civodul>i actually have loads of old Guix stickers at home
<civodul>those that read "the GNU system"
<civodul>but i don't have GuixSD stickers
<civodul>i think it costed me ~50€ back then
<paroneayea>civodul: once we've settled on a logo, we should make Guile logos too :)
<paroneayea>by libreplanet and fosdem for sure
<paroneayea>or has it been settled?
<paroneayea>I love both logos for Guile, though there are so many languages with a lambda in them, I think I may prefer the original one that went with the site
<paroneayea>even though I looooooove the Gambda
<Sleep_Walker>finally bug#21767 :)
<civodul>paroneayea: the logo is settled as far as i'm concerned, but it's a really tough choice
<civodul>but i agree that the lambda is not very original
<civodul>Sleep_Walker: what do you mean?
<Sleep_Walker>civodul: I mean that I'm interested in this problem and I'd like to see some conclusion
<Sleep_Walker>and this report means there are other people interested
<civodul>Sleep_Walker: this problem was news to me, actually
<civodul>because in practice i always install/upgrade the "out" and "debug" things at the same time
<davexunit>paroneayea: do you have any recommendations for places to get stickers that have a good quality/price ratio?
<davexunit>I'd gladly print GuixSD and Guile stickers to hand out at conferences
<davexunit>if they were popular enough, I'm sure the FSF would get them printed and sell them.
<davexunit>they started selling Replicant stickers not too long ago
<paroneayea>davexunit: the FSF might hand them out in sticker packs if we gave them some.
<davexunit>paroneayea: yeah that might be a good idea
<wingo>ohai
<wingo>so whose job is it to make sure (use-modules (mailutils)) works when you have mailutils installed -- guix or mailutils?
<wingo>or guile
<davexunit>wingo: mailutils has guile bindings?
<wingo>davexunit: yes :)
<davexunit>that's cool. :)
<davexunit>so, let me guess, there's a shared library that it needs to load that it can't find?
<wingo>i think there is a file not getting installed actually
<rekado>I would like to test a simple patch on the MIPS build slave, but ... I don't really know how to do it without killing the host.
<rekado>cannot use git, nor guix (too old).
<rekado>"Please create the `/var/guix/profiles/per-user/rekado' directory, with you as the owner."
<rekado>"guix pull" fails with "ERROR: no binding `package-name->name+version' in module (guix build utils)"
<wingo>exciting
<rekado>how do others test stuff on the exotic build slaves?
<rekado>I really just want to add "TARGET=SICORTEX" to the #:make-flags on MIPS, but I don't think it's good to just push this without having tested it on an actual MIPS machine.
<rekado>(package is "openblas")
<rekado>guix is too old on this slave, so "guix environment openblas" just tells me "error: openblas: unknown package".
<davexunit>rekado: I have never done this, but you can copy the derivation of that build to the slave
<davexunit>and then ask guix to built that derivation
<rekado>the derivation should be there already, I think. I'll try this again later.
<davexunit>rekado: can you take that derivation, tweak it, and then add that to the store?
<davexunit>ACTION wishes the container announcement generated more "buzz"
<davexunit>many threads, no comments. oh well.
<civodul>davexunit: yes it's always a bit disappointing
<Sleep_Walker>davexunit: good job :)
<civodul>the actual work remains exciting, though
<civodul>so i'm still happy nonetheless :_)
<davexunit>:)
<davexunit>the 0.9.0 release announcement should generate some discussion, at least.
<civodul>hopefully
<civodul>honestly, i fail to understand how these phenomena work
<civodul>sometimes anecdotal announcements would get a lot of visibility
<davexunit>yeah
<civodul>and sometimes, crucial things go unnoticed
<karhunguixi>maybe it'll be more buzz when non-guix people get a chance to evaluate it
<civodul>yeah
<davexunit>it appears random. it doesn't help that my HN article was penalized for whatever reason.
<davexunit>12 upvotes, 5 comments, 0 points added to my account.
<civodul>heh
<civodul>mark_weaver: i'm looking into incorporating the non-controversial bits of wip-loongson2f
<karhunguixi>civodul, do you have any updates on the monetary donation situation?
<civodul>karhunguixi: unfortunately no, still waiting on the FSF :-/
<karhunguixi>ok
<civodul>i guess they were busy with the FSF30 celebrations
<civodul>but i'll ping them again
<davexunit>yeah, a ping would help.
<davexunit>I've seen the FSF ticket queues. they are crazy.
<davexunit>too many requests, not enough staff to resolve all in a timely manner.
<davexunit>gotta run!
<civodul>a bit scary
<civodul>on Intel ME & co.: http://blog.invisiblethings.org/2015/10/27/x86_harmful.html
<paroneayea>civodul: that looks interesting
<paroneayea>did you read it?
<paroneayea>what's the tl;dr?
<a_e>Thanks for the pointer! This looks like longer reading than just for an evening...
<karhunguixi>in short, it can't be disabled
<paroneayea>on the next depressisode of "This Modern Computer"
<civodul>paroneayea: i'm reading it; the tl;dr is: Intel platforms are screwed
<civodul>and yes, ME cannot be disabled
<paroneayea>civodul: :(
***aeva`` is now known as aeva
<rekado>on hydra-slave0, could someone with root access please run "chown rekado -R /tmp/nix-build-openblas-0.2.14.drv-0/"?
<civodul>rekado: i think that would be mark_weaver