IRC channel logs

2015-10-22.log

back to list of logs

<HotLava>Is it necessary that all guix packages are specified in gnu-system.am at compile time, or can you create additional ones later on?
<civodul>HotLava: this is only for Guix maintenance
<civodul>you can create your own packages without changing that file
<civodul>see also GUIX_PACKAGE_PATH in the manual
<HotLava>Ok, I was actually reading the "Packaging Guidelines" section and got a bit confused because it sounded like it's expected to do stuff in the guix build tree
<HotLava>How does GUIX_PACKAGE_PATH work, does it evaluate all .scm and .go files in the given directory to check if one of them contains the package definition?
<civodul>yes
<civodul>it's for user-provided package definitions
<civodul>ACTION has to reboot damn emacs
<Steap>ACTION almost has a working PyPI refresher \\o/
<civodul>good! :-)
<Steap>is there a proper way of failing in a foo-updater function ?
<civodul>if you use http-fetch, its exceptions are handled down the path
<civodul>i dunno, depends on what kind of failures you have in mind
<civodul>the 'latest-release' procedure of the updater should be robust though
<Steap>the "try: ... except: "
<Steap>kind
<civodul>it might be passed packages that do not actually exist in PyPI
<Steap>yeah
<civodul>see the one in cran.scm, for example
<ArneBab>rekado: are they actually reinventing the distro for haskell?
<Steap>Years of programming have taught me that it is vain to try not to make mistakes, and that one should handle errors well instead
<Steap>civodul: the cran updater is funny because it assumes the package will be found
<Steap>should it not be true...
<civodul>there's actually a big false-if-exception in there
<civodul>so nothing bad can happen
<civodul>that's not something you should do though :-)
<civodul>false-if-exception is evil
<civodul>ACTION -> zZz
<civodul>later!
<HotLava>so, if i copy the hello example package description from the manual and try to build, i get:
<HotLava>benno@grothendieck:~/wrappy$ GUIX_PACKAGE_PATH=. guix build hello
<HotLava>guix build: warning: failed to load '(hello)':
<HotLava>ERROR: no code for module (hello)
<HotLava>is this expected or is my installation screwed up? xD
<detrout>hi, after you run guix system init ...config.scm /mnt should /mnt/etc be populated?
<detrout>(trying to install guix into a vm)
<davexunit>HotLava: "." isn't a valid search path
<davexunit>also, could you paste the file you made?
<davexunit>and tell me what the file name is
<HotLava>changing to an absolute path still gives the same output
<HotLava>it's the example here, copied into a file called hello.scm in the same directory without further modifications: http://www.gnu.org/software/guix/manual/guix.html#Defining-Packages
<davexunit>HotLava: a module named (gnu packages hello) needs to be located in gnu/packages/hello.scm
<davexunit>the documentation needs to clarify this.
<davexunit>thanks for pointing out the omission.
<davexunit>you can change (gnu packages hello) to simply (hello) in that file to avoid moving the file around.
<HotLava>ah, thanks, getting closer :)
<HotLava>although there seems to be another error
<HotLava>guix build: warning: failed to load '(package)':
<HotLava>ERROR: no code for module (package)
<davexunit>did you make a package.scm file or something?
<davexunit>or try to import a module named (package)?
<HotLava>oh, right, there is another .scm file in the same directory
<HotLava>i forgot that it will try to evaluate everything :D
<davexunit>Guix will try to load everything on the path in search of packages, yeah.
<HotLava>seems a bit non-obvious to specify a path instead of a file... unless one is reading *very* closely, the "package module search path" sounds like a search path for additional guile modules
<davexunit>HotLava: you can evaluate stand-alone files, too.
<davexunit>GUIX_PACKAGE_PATH is for including third-party package modules so you could, sya, maintain your own separate set of packages.
<HotLava>ok, so how would i tell guix to build and install a package whose recipe is contained in a specific file? i was looking for this option for a while ;)
<davexunit>HotLava: we actually don't have a convenient option... yet. I've been meaning to write a patch for it for awhile. But!
<davexunit>you can tell 'guix build' to evaluate an arbitrary scheme expression that evalues to a package object
<davexunit>so!
<davexunit>guix build -e '(primitive-load "hello.scm")'
<HotLava>ah
<davexunit>now, your hello.scm file will have to be changed to *return* a package
<davexunit>rather than be a module that defines a variable for the package
<davexunit>here's an example of such a file from a project of mine: https://git.dthompson.us/haunt.git/blob/HEAD:/guix.scm
<HotLava>ok, seems easy enough
<HotLava>thanks :)
<HotLava>and good night
<davexunit>happy hacking!
<davexunit>thanks for letting us know where our docs could use fixin'
<detrout>hi i'm trying to install guixsd into a kvm vm. I follow the manual but on rebooting I get a kernel panic
<detrout>followed section 6 and used the bare bones configuration.scm guix system init <config.scm> /mnt generats a store but empty etc files.
<detrout>are there links to perhaps better config scm files?
<rekado>"there's actually a big false-if-exception in there" (cran importer) --> yes, it's on my list to clean this up eventually.
<karhunguixi>detrout, have you gotten your vm up and running now?
<bavier1>I try to send a few review emails to the list, and my ISP starts blocking them. grrr
<bavier1>anyhow, gotta sleep now. Will send the rest later
<efraim>can someone help me with this copyright? https://bazaar.launchpad.net/~pbzip2/pbzip2/trunk/view/head:/COPYING
<efraim>they listed it as "modified BSD" but it didn't really match any of the BSD copyrights listed on wikipedia
<davexunit>OpenStack packaged for Nix: https://github.com/NixOS/nixpkgs/pull/10399
***patrask is now known as ptrsk
<Steap>davexunit: that is quite crazy
<Steap>I have no idea how to even configure everything from scratch
<taylan>efraim: you could use (non-copyleft "path/to/license")
<efraim>taylan: thanks
***tschwing_ is now known as tschwinge
<efraim>nix is being ported to OSX?
<davexunit>nix has had an OS X port for a long time.
<kmicu>efraim: yes Nix/nixpkgs is used on Darwin https://nixos.org/wiki/Nix_on_OS_X and now pure darwin stdenv is default.
<efraim>oh, i just noticed it when I pulled their updates from github
<Steap>damn
<Steap>we could port Guix to Mac OS X
<Steap>but no Gux developer will ever have a Macbook :(
<mark_weaver>if we did it, it would be more accurate to call it a port to XNU.
<Steap>what is XNU ?
<mark_weaver>it's the kernel underlying OS X
<Steap>I see
<efraim>i have an older macbook pro 3,1 sitting next to me
<efraim>got that as a gift back in 2007
<Steap>efraim: get other friends :D
<efraim>it was actually from my parents, they were switching the family to get away from vista
<efraim>but with the work the debian install team did with a 64 bit kernel and a 32 bit efi implementation I can finally install debian on it
<Steap>\\o/
<detrout>karhunguixi: nope. I'm still stumped. i thought it may have been me forgetting to update the grub boot disk.
<davexunit>an XNU port would be cool, but I don't know if it can be done with only free software.
<bavier>did anyone here have other comments for the wip-haskell-platform-7.10.2-a branch?
<efraim>we had that person a while back who was interested in running guix on top of freebsd
<karhunguixi>Any news on the donation setup? I'm checking https://www.fsf.org/working-together/fund irregularly, but still nothing.
<karhunguixi>(monetary donation that is)
<paroneayea>karhunguixi: ping civodul when on next
<karhunguixi>ok
<rekado>Steap: I have access to a Macbook in the office. It's not used by anyone and I guess I could use it to port Guix, but I have no idea how to even start (I have never used MacOS).
<Steap>rekado: yeah; had to use one once for work, it was a pain :D
<Steap>be careful though
<Steap>who owns the code written/tested on your employer's machines ? :p
<rekado>we're publicly funded and we don't have to sign over copyright to the institute.
<rekado>it should be even less of a problem if I do this at home.