IRC channel logs

2015-10-03.log

back to list of logs

<goglosh>guix system won't reconfigure ever again ;_;
<goglosh>this os is very good at frustrating me
<taylanub>has anyone tried to package Apache Maven?
<taylanub>heh, looking through logs, looks like it already caused headache to a lot of people
<rekado>taylanub: I'm working on it.
<rekado>I'm trying to first package buildr, which is written in Ruby.
<rekado>buildr could be used to build the dependencies of Maven, as they require Maven.
<rekado>since buildr is designed to be a drop-in replacement for Maven, this might work.
<rekado>I don't want to take the shortcut of including the Maven dependencies as binary blobs.
<taylanub>thanks, good to know. for now, I guess I'll just use Leiningen outside Guix for my Clojure needs.
<civodul>hey!
<civodul>any comments on the latest GUIX_LOCPATH proposal?
<mark_weaver>civodul: I'm about to head over to FSF30, and I'm afraid I didn't find time to review your patch, but I agree with what it's advertised to do.
<mark_weaver>ACTION goes offline
<civodul>mark_weaver: ok!
<civodul>enjoy FSF30!
<civodul>are there other cases of search-path env. vars. that look under versioned directories?
<civodul>i don't have one in mind
<civodul>maybe the GTK/GLib variables?
<civodul>iyzsong, rekado: ↑
***silver is now known as Guest5294
<sankey>i'm trying to define a package, but its source code and build files are not at the root of the source tree
<sankey>it's python bindings distributed with the library itself, so all the python stuff is under the python/ directory
<sankey>is there a way to "cd" to that library before building?
<sankey>s/library/directory
<civodul>sankey: yes, sure
<civodul>you need to add a "phase" that does (chdir "foo")
<civodul>see 'racket' for an example of that
<civodul>hydra.gnu.org is unreachable, ouch
<davexunit>civodul: just saw nully run out of the FSF30 place
<davexunit>MIT stuff is down
<davexunit>which means hydra
<civodul>oh, i see
<civodul>are you at FSF30?
<davexunit>civodul: yes, with mark_weaver
<civodul>nice!
<davexunit>francis7 is currently talking about libreboot
<daviid>ACTION wishes he would be there as well!
<civodul>yeah me too!
<zacts>hello
<zacts>so any progress towards adding lvm2 to guix full disk encryption?
<zacts>lvm2 on-top-of a fully encrypted disk
<rekado>I was at the FSF30 satellite party in Berlin. Too bad that for timezone reasons we had no link to the main FSF30 event.
<davexunit>rekado: cool, though :)
<rekado>civodul: GTK looks in versioned directories under the lib path. The same variable is respected by all versions of GTK, though, so obviously setting it is not an option, which is why I suggested adding support for GTK3_PATH and GTK2_PATH variables.
<rekado>do you prefer prefixing the custom variable names with "GUIX_"?
<rekado>(the above is needed to make GTK themes and input methods like IBus work with different versions of GTK.)
<davexunit>oh cool hydra is back up
<rekado>drowning in email again... I feel like I'm letting too many patches slip by without finding the time to review them.
<rekado>if this is a shared sentiment, are you aware of any tools that could help us to keep track of patches to be reviewed?
<karhunguixi>i'm trying to builld from git, but i get into trouble with an ./configure error: "C compiler cannot create executables"
<karhunguixi>output: http://sprunge.us/ZKDe config.log: http://sprunge.us/TUcR
<karhunguixi>if anyone can help, that would be super
<alezost>karhunguixi: you probably installed gcc in your profile, right? You need to install "gcc-toolchain" instead
<karhunguixi>ooh
<alezost>karhunguixi: alternatively you can use "guix environment guix" and then build guix there
<karhunguixi>that got me further, thanks!
<alezost>if you prefer to install the required tools in your profile, then you also need libgcrypt, graphviz, sqlite, help2man (optional), guile-json (optional)
<karhunguixi>hm.. what i want to do is try modifying gnu/system/linux.scm and try
<karhunguixi>i'm following the manual, https://www.gnu.org/software/guix/manual/guix.html#Building-from-Git
<alezost>karhunguixi: yes, so you need to install all required tools and run configure script like this: ./configure --localstatedir=/var --with-libgcrypt-prefix=$home/.guix-profile
<alezost>(I assume you are on GuixSD)
<karhunguixi>i am, yes
<karhunguixi>great, i got further
<alezost>great, tell if you face other issues
<karhunguixi>success! thanks :)
<karhunguixi>what's the purpose of localstatedir?
<taylanub>karhunguixi: it's for local state :P
<taylanub>karhunguixi: a variety of information from your Guix usage is stored there, like your profiles
<taylanub>you can peek into it to get a feeling of the sort of information that goes there. I'm not sure if there's a really clear-cut rule for it.
<karhunguixi>i won't mess up my installation now if i do weird stuff in the git dir and build with ./pre-inst-env ?
<taylanub>if you did 'make install' then no, changes in the git directory shouldn't affect your installation, though it might make you unable to run 'make uninstall' (or cause 'make uninstall's actions to be out-of-sync with what 'make install' had done)
<karhunguixi>i haven't run make install
<taylanub>BTW there's a very convenient way to "bootstrap" a guix installation via precompiled binary tarballs
<civodul>rekado: GTK looks directly under GTK_PATH, not under GTK_PATH/X.Y, right?
<karhunguixi>but i want to modify and test gnu/system/linux.scm
<civodul>rekado: for custom variables, i prefer the GUIX_ prefix, at least for "temporary workarounds"
<taylanub>karhunguixi: if you haven't ran make install, which installation do you mean when you say "won't mess up my installation"?
<karhunguixi>the one i'm running at the moment
<taylanub>karhunguixi: oh, did you already install guix on your system from some other source than the git repository?
<karhunguixi>yes, i'm running GuixSD right now, and want to keep it sane while playing with linux.scm
<taylanub>ooh, I see
<karhunguixi>i want to see if i can add pam_env to it, which should make sudo read variables in /etc/environment
<taylanub>I haven't actually ran GuixSD yet, but it should be fine from all I can imagine
<civodul>karhunguixi: to test this sort of things, i typically try in 'guix system vm'
<karhunguixi>but if i break it beyond repair i still want a functioning sudo :)
<taylanub>make sure that the localstatedir configuration of the git repository corresponds with the one of GuixSD
<karhunguixi>civodul, oh, i'm not familiar with it. I'll have a look
<civodul>that's probably the easiest way
<taylanub>oh, if you'll test a custom-built kernel then yeah, virtualisation is probably a good idea :)
<taylanub>merely running './pre-inst-env guix build foo' can't do harm AFAIK though
<taylanub>anyway, this is going out of my area of knowledge. I better not misinform.
<karhunguixi>yeah, that's how i have understood it
<civodul>likewise, 'guix system vm' doesn't touch your system at all
<karhunguixi>that's perfect for messing with sudo
<karhunguixi>(especially for those who have locked the root account)
<amz3>I'm running guix on top of debian, I managed to compile sly via autoconf and when I try to run a example program it crash with the following error
<amz3>guile: relocation error: /gnu/store/w29667jfv02s1hgmv0yp7nqyywvdv1fz-glibc-2.21/lib/librt.so.1: symbol __shm_directory, version GLIBC_PRIVATE not defined in file libpthread.so.0 with link time reference
<amz3>ok, I think I found the error
<amz3>I did not install guile inside guix