IRC channel logs

2015-08-29.log

back to list of logs

<ifur>davexunit: unless the bug doesn't show up with debugging symbols -- does happen, especially for rare race conditions.
<frob_>hello :-)
<frob_>what locales does the guix installation image come with?
<frob_>after waiting about 10 minutes for guix system init, i got a disappointing "guix system: error: system locale lacks a definition"
<frob_>i should probably switch to en_EN, but i was just wondering what the complete list is
<davexunit>I imagine that any locale supported by glibc will be fine
<davexunit>my 'operating-system' form has this: (locale "en_US.UTF-8")
<frob_>yep, i used (locale "hr_HR.UTF-8")
<frob_>and got the above error message
<davexunit>frob_: okay, I did some digging and I see the issue.
<davexunit>we provide a rather long list of default locales, but hr_HR.UTF-8 is not among them.
<iyzsong>the list is at '/run/current-system/locale'
<frob_>davexunit: that's what i suspected :-)
<davexunit>however, you should be able to add the appropriate locale definition
<frob_>iyzsong: thanks
<iyzsong>I think only en_US can use 'UTF-8', other have to use 'utf8' :-)
<frob_>ah damn, en_US, not en_EN :P
<frob_>silly me
<frob_>failed again lol
<frob_>iyzsong: it's not always "UTF-8"?
<davexunit>(locale-definition
<davexunit> (name "hr_HR.utf8")
<davexunit> (source "hr_HR")
<davexunit> (charset "UTF-8"))
<frob_>davexunit: that's all?
<frob_>nice :D
<iyzsong>yes, you have could add your locale-definition as dave said
<davexunit>that's a guess, but based on the code I think that's it.
<davexunit>that form needs to be added to the 'locale-definitions' field of your OS definition
<frob_>aha, thanks, i'll try it out :-)
<davexunit>(local-definitions (cons your-locale-definition %default-locale-definitions))
<davexunit>the %default-locale-definitions variable may need to be imported, it is from the (gnu system locales) module
<frob_>yup, checking out the docs
<davexunit>cool, good luck.
<frob_>thanks :-)
<frob_>alright, added. let's see how it goes
<frob_>ugh, "/mnt/etc/config.scm:8:0: error: source expression failed to match any pattern"
<frob_>is this ok: "(use-modules (gnu) (gnu system nss) (gnu system locale))"?
<frob_>i don't see any syntax errors
<davexunit>frob_: could you paste the full config on paste.lisp.org?
<frob_>ah, ok
<davexunit>or other such paste site (as long as it isn't pastebin.com)
<frob_>sure :-) just curious, why not pastebin?
<davexunit>frob_: they block tor traffic
<davexunit>and a number of people in this channel browse with Tor enabled.
<frob_>oh i see
<frob_>mhm
<davexunit>including our maintainer.
<frob_>ludo?
<davexunit>yeah
<frob_>oh, didn't know
<frob_>hm, i'm running this in qemu
<frob_>can't think of a way to copy it without shutting down and setting up something like samba
<frob_>i'll be ready in a few minutes
<davexunit>a screenshot might do if the config is short
<davexunit>I have to go afk now, though.
<frob_>ah, ok
<davexunit>maybe someone else can point out the syntax error
<davexunit>line 8 is what it's complaining about
<frob_>i hope so :-)
<frob_>yup
<frob_> http://paste.lisp.org/+3B5L
<frob_>if anyone would like to take a look ^
<frob_>the title of the paste is the error
<iyzsong>frob_: you need '(operating-system (locale-definitions (cons ...)))', 'locale-definitions' is a field of the 'operating-system' record.
<frob_>i was following this https://www.gnu.org/software/guix/manual/html_node/Locales.html#Locales
<iyzsong>also, if you don't use other locales, you can just put use (locale-defdinitions (list (locale-definition ...))) to save disk places.
<frob_>i don't see any locale-definitions
<frob_>oh
<frob_>maybe it's in operating-system's doc
<frob_>eh yeah
<frob_>:P
<frob_>alright, i will try that out
<iyzsong>well, the doc does have it
<frob_>thanks iyzsong
<iyzsong>"you should add the locale definition to the locale-definitions field" :-)
<frob_>yeah haha
<frob_>>That locale must be among the locale definitions that are known to the system—and these are specified in the locale-definitions slot of operating-system.
<frob_>missed it :p
<iyzsong>no problem, good luck!
<frob_>heh, now that i look at my paste, it's kinda silly. i was just doing nothing with the list returned from cons
<frob_>i'm finally getting some promising output btw
<frob_>installing from hydra
<frob_>iyzsong, got a "guix system: error: failed to install GRUB on device '/dev/sdb1'" :-(
<frob_>messages above say "File system 'ext2' doesn't support embedding."
<frob_>and something about blocklists being unrealiable
<frob_>also, /dev/sdb1 is ext4 formatted
<frob_> http://paste.lisp.org/display/154425 anything wrong with my grub config?
<frob_>the full error: https://i.imgur.com/3xDWaXh.png
<frob_>if anyone has suggestions please write here, i will check out the log tomorrow because i have to go now
<frob_>thanks, good night :-)
<iyzsong>sneek: later tell frob_ that you need set '/dev/sdb' (or sda) as device to install GRUB to the MBR. see the manual 'GRUB Configuration' and 'Invoking grub-install'.
<sneek>Will do.
<frob_>iyzsong: yep, "invoking grub" cleared up some things :-)
<sneek>Welcome back frob_, you have 1 message.
<sneek>frob_, iyzsong says: that you need set '/dev/sdb' (or sda) as device to install GRUB to the MBR. see the manual 'GRUB Configuration' and 'Invoking grub-install'.
<frob_>ah, so he notifies me when i first speak
<frob_>cool :-)
<frob_>"Installation finished. No error reported."
<frob_>awesome
<DusXMT>Speaking of Grub, I think I discovered a strange fact about our package: It can't seem to boot multiboot operating systems with modules... it can boot gnumach with no modules, but whenever I try to load any, the bootloader immediately reboots the computer, while with Debian's bootloader, with the same exact menuentries, it works... will have to play around some with it
<DusXMT>(which is a shame, since multiboot's one of Grub's main boasting points)
<rekado->Just wondering: is here someone using GuixSD with wicd without problems? If so, could you please tell me if you needed some special configuration to make it work? Or maybe post your configuration?
<rekado->I'd just like to compare with mine.
<rekado->(It's become a habit for me to do manual networking, but I feel like I escaped from the 1990s.)
<DusXMT>Is there a way I can disable the additional bash-completion rules for my shell and use the built-in behavior? They're just giving me a headache
<DusXMT>The easiest way seems to be to uncomment the "bash-specific initialization" in /etc/profile, but that's a hackish/non-permament fix...
<frob_>are there any plans for implementing labeling of generations?
<frob_>so i could have a name for a generation, kinda like git's tags
<frob_>i think this was mentioned in a talk about guixsd which i watched yesterday but it was in 2012
<frob_>so wondering if it might have changed?
<tima_gt>GuixSD supports NVIDIA drivers?
<tima_gt>open nvidia drivers?
<rekado->tima_gt: GuixSD uses linux-libre.
<rekado->so it contains all free drivers, but it does not include non-free firmware.
<rekado->dependent on your graphics hardware this could mean that it won't work out of the box.
<tima_gt>it will work as [VESA DISPLAY] or [Nouveau]?
<tima_gt>My videocard works perfectly on Trisquel GNU/Linux and in Debian GNU/Linux
<rekado->afaik Trisquel uses linux-libre as well, so I cannot think of a reason why it shouldn't work with GuixSD.
<rekado->drivers are part of the kernel.
<tima_gt>okay thx
<mark_weaver>tima_gt: GuixSD includes Nouveau, and it should be accelerated out of the box
<mark_weaver>rekado-: you need to add 'wicd' to the list passed to 'dbus-service', add (wicd-service) to your 'services', and add 'netdev' to your user's supplementary-groups
<mark_weaver>I also recommend adding 'wicd' to the system-wide 'packages'.
<DusXMT>What can be a possible reason for a python package not to be able to find a module? PYTHONPATH= is set by a wrapper program
<frob_>does anyone know what's happening here? https://i.imgur.com/JPaNxE3.png
<frob_>i could boot into guixsd just fine on the previous installation
<wingo>wow :)
<sneek>wingo, you have 5 messages.
<sneek>wingo, dsmith-work says: The real question is how soon should support for 2.{1,2} be added to geiser? (the 'objcode 'bytecode changes)
<sneek>wingo, daviid says: I'd like to release guile-gnome 2.16.3, but it would make user's life [and mine too] much easier if we also release g-wrap, which I can do, and guile-cairo: could you release guile-cairo 1.10.x?
<sneek>wingo, yenda says: did you manage to replace linux-libre by vanilla linux in guixsd and if so did you wrote something about it ?
<sneek>wingo, daviid says: Andy, could you please add me as a project admin for guile-gnome on savannah, I'd like to be able to update its savannah webpages as well, thanks!
<sneek>wingo, dsmith-work says: master v2.1.0-1920-g4841239 is failing control.test
<frob_>i can get rid of it by changing the terminals
<wingo>hoo, sneekpounce
<frob_>i can switch to the visual terminal and i can see the display manager
<frob_>but why the error
<wingo>ACTION does not know
<civodul>Hello Guix!
<frob_>Hello! :D
<frob_>i'm trying out guix size with the --map-file option but it can't load guile-charting
<frob_>i've installed guile-charting ofc
<civodul>frob_: is GUILE_LOAD_PATH set appropriately?
<frob_>yup
<frob_>GUILE_LOAD_PATH=/run/current-system/profile/share/guile/site/2.0
<frob_>at least i think that's ok?
<frob_>another question: where do i get chsh from?
<frob_>it's not present on my system and "guix package -s chsh" doesn't return any results
<frob_>so, install from source?
<civodul>are you in GuixSD?
<civodul>if yes, simply running 'guix package -i guile-charting' should do
<frob_>civodul, yep, i did
<civodul>and that's on GuixSD?
<frob_>yeo
<frob_>yep*
<civodul>cool
<frob_>guix package -I guile
<frob_>shows guile-charting
<frob_>so what could be the error :/
<civodul>can you try: guile -c '(use-modules (charting))' ?
<frob_>fails
<frob_>ERROR: no code for module (charting)
<civodul>any hints before that?
<civodul>you need to check where it's looking for it
<frob_>in my /gnu/store i can see guile and guile-{json,arm-fixes,bootstrap-guile,cairo,charting}
<civodul>for instance with: strace -o log guile -c '(use-modules (charting))'
<frob_>but, i have 3 different versions of guile-2.0.11 (different hashes)
<civodul>and then: grep charting.scm log
<civodul>what matters here is what's in the profile, not what's in the store
<frob_>mhm, just wanted to be safe and let you know anyway :-)
<civodul>heh :-)
<frob_>i've only just begun getting into scheme
<frob_>and the whole concept of guix is really nice, so forgive me if i don't know some stuff :-)
<frob_>alright, strace installed, 1 sec
<frob_>alright, it's looking for charting.scm in /run/current-system/profile/share/guile/site/2.0/ first
<frob_>which fails with ENOENT
<frob_>and then the same thing but with /gnu/store/<hash>-guile-2.0.11/share/guile/{2.0,site/2.0,site/}
<frob_>and also the dir with the path above (^) but without {...}
<alezost>frob_: why do you use /run/current-system/profile/share/guile/site/2.0/? If you installed it as a user it's in your profile
<alezost>I mean ~/.guix-profile/share/...
<frob_>yeah
<frob_>um, i'm not sure
<frob_>i'm not specifying that path anywhere
<frob_>guile just uses it, i.e. that's how it was when i installed guixsd
<alezost>"guix package --search-paths" should show the proper value for GUILE_LOAD_PATH
<alezost>also there should be ~/.guix-profile/etc/profile file with required env
<frob_>i get 'export PATH="/home/frob/.guix-profile/bin:(...)/sbin"'
<frob_>yep, ~/.guix-profile/etc/profile is there
<alezost>frob_: and that's it? Do you mean there is no 'export GUILE_LOAD_PATH="/home/al/.guix-profile/share/guile/site/2.0'?
<frob_>nope
<frob_>there is not
<alezost>then it looks like you didn't install guile-charting
<frob_>to see what has been installed i can do "guix package -I" right?
<alezost>frob_: do you do this as root, maybe?
<frob_>nope, logged in as a normal user
<frob_>no sudo, nothing
<frob_>guix package -I lists vim, emacs, git, lynx, zsh, strace, openssh and guile-charting
<alezost>oh, maybe you also need to install guile to make "GUILE_LOAD_PATH" and "GUILE_LOAD_COMPILED_PATH" appear
<alezost>try "guix package -i guile"
<frob_>mhm
<frob_>i think i tried that already though
<frob_>oh look, at the end it says
<frob_>>the following env variable defs may be needed
<frob_>so it's not done automatically?
<frob_>and both GUILE_LOAD_PATH AND GUILE_LOAD_COMPILED_PATH are suggested
<alezost>it is done automatically: /etc/profile loads your ~/.guix-profile/etc/profile
<frob_>yeah, i was just checking out /etc/profile
<frob_>alezost: erm, those paths now appeared
<frob_>in my ~/.guix-profile/etc/profile
<frob_>weird
<frob_>i'm pretty sure i ran "guix package -i guile"
<alezost>frob_: it is not weird: they appeared after you installed guile
<alezost>frob_: no, you didn't
<frob_>i guess ;/
<alezost>frob_: your "guix package -I" didn't contain guile
<civodul>GUILE_LOAD_PATH appears in etc/profile only if both guile and (say) guile-charting are available
<frob_>my internet died
<frob_>civodul, hm, ok
<frob_>however, i still get errors
<frob_>"In procedure profile->page-map: In procedure module-lookup: Unbound variable: make-page-map"
<frob_>in guix/scripts/size.scm:185:4
<civodul>frob_: what does "guile -c ..." say now?
<frob_>ERROR: In procedure scm-error: ERROR: no code for module (charting)
<frob_>same thing as before i think
<frob_>i logged out and in
<civodul>yes, so could you try "strace" as i suggested?
<civodul>ACTION goes afk for a while
<frob_>civodul, now it works, i logged out and in
<frob_>for the profile to be resourced i guess
<frob_>yay, "guix size --map-file" now works
<frob_>so the problem was that i didn't install guile, but i also had to log out/in for the GUILE_LOAD_PATH and GUILE_LOAD_COMPILE_PATH to be set
<frob_>(after installing guile)
<civodul>frob_: ok, good that it works!
<frob_>yup :-)
***frob_ is now known as frob
***frob is now known as Guest25263
***Guest25263 is now known as frob_
<karhunkynsi>in guixsd i just typed: "guix refresh --update", and in the output i notice a missing newline. Example: "guix refresh: warning: gnupg: version 2.1.7 could not be downloaded and authenticated; not updatingstarting download of..."
<civodul>karhunkynsi: indeed, thanks for the report
<civodul>i'll push a fix shortly
<civodul>alezost: what's that '-non-nil' function used in Magit?
<civodul>it's unbound here
<alezost>civodul: it is from "emacs-dash" package. Wasn't it propagated by Magit?
<alezost>perhaps ~/.guix-profile/share/emacs/site-lisp/guix.d/dash-2.11.0/ is not in your `load-path' for some reason
<civodul>ACTION looks
<civodul>it is in 'load-path'
<civodul>alezost: i had to C-M-x '-non-nil' and now it works
<civodul>not sure what happened
<alezost>strange, I have never had this issue
<civodul>that happened to me when emacsclient was invoked
<alezost>it looks like -non-nil is used only in `magit-revert-buffers'. I disabled reverting buffers, so maybe that's because I didn't met this issue
<civodul>ah, could be
<alezost>civodul: oh, I think I know what could happen: perhaps you have an old dash (< 2.10.0) from melpa and it was loaded instead of the dash from guix
<civodul>oh
<civodul>indeed!
<alezost>you will probably find that "dash" from guix is in the end of the 'load-path' and another dash (from melpa or whatever) is somewhere in the beginning
<civodul>yes, i found dash-2.7.0 in M-x package-list-packages
<civodul>thanks!
<alezost>np
<civodul>i still have a bunch of stuff in there to get rid of