IRC channel logs

2015-08-16.log

back to list of logs

<sbidin>Is guix-devel okay with unicode characters in the From field?
<sbidin>Ah, looks like it is.
<sbidin`>Okay, I sent that simple GNU Hello package recipe patch for the docs. This is the first time I've sent a patch via email, so fingers crossed I did it right.
<yenda>can you had a 2nd disk in config.scm ?
<yenda>is it a good idea to mount extra disks in config.scm ?
<davexunit>sure
<yenda>so I just add (file-system (device "sdb1"...)) for instance to my list of file-systems ?
<davexunit>yenda: yup
<yenda>ACTION now needs to reboot to test but doesn't want to screw his pomodoro timer :D
<davexunit>bavier: I'm fixing the issue with 'setns' on old glibc versions right now. if you run 'make check TESTS=tests/containers.scm' now, does it pass?
<davexunit>my guess is that all the tests will be skipped, which is good.
<davexunit>I can't think of a system that would have user namespaces available but not have a 'setns' glibc function.
<sbidin`>A package I'm trying to build expects /bin/sh to be accessible during compilation, and fails because it's not. I though adding coreutils as an input would fix this, but it doesn't seem to. How should I proceed?
<sbidin`>*thought
<phant0mas>how does validate-runpath work? Does it only check if the .so files are in the right path?
<davexunit>sbidin`: are you using the gnu-build-system?
<sbidin`>davexunit: No, the haskell one.
<davexunit>there's a patch-source-shebangs phase that should take care of that
<sbidin`>davexunit: I guess haskell-build-system doesn't include it? Anyway, I'm trying to package ghc-time, and it includes C sources that I suppose don't get patched.
<sbidin`>I'll have a look at how the other ghc packages do this, they must have run into the same issue.
<davexunit>sbidin`: I just checked, and haskell-build-system patches shebangs like the gnu-build-system
<davexunit>so I guess the /bin/sh isn't in a shebang
<davexunit>in which you should add an extra phase to your ghc-time package
<sbidin`>davexunit: I just checked and ghc-network fixes this by setting CONFIG_SHELL before the standard-phases.
<davexunit>that uses substitute* to replace /bin/sh in the necessary file(s) with the absolute path to bash
<sbidin`>Yes. :)
<sbidin`>Oh, it seems setting CONFIG_SHELL is easier.
<davexunit>yeah
<davexunit>if that works, much easier.
<davexunit>and you do not need to explicitly add coreutils to the package native inputs
<davexunit>they are already there
<sbidin`>Ah, great.
<sbidin`>
<sbidin`>Lots of Haskell packages have C sources embedded within though, so I expect I'll be peppering this setenv code a lot. I wonder if it should just be a default for haskell-build-system.
<davexunit>yeah, if most haskell projects use a similar environment variable, then I think that would be a good idea.
<yenda>sometimes when I open a session with slim I get a window make session instead of whatever I should get (xfce or i3)
<yenda>do you have that too ?
<sbidin`>yenda: Yes, I've been bitten by that too. Just make sure you've selected xfce or whatever by pressing F1 before logging in.
<sbidin`>It resets if you've entered the wrong password.
<sbidin`>So you have to press F1 again...
<mark_weaver>yenda: you can override that F1 thing completely by having a ~/.xsession file.
<yenda>ok nicice
<mark_weaver>I do that because I want to do some other things like remap caps-lock to control, turn off that primitive beep (xset b off), etc, before running xfce
<yenda>this beep is awfull
<mark_weaver>so, it needs to be an executable script, so it needs a shebang on the first line, chmod +x, and the last thing it should do is 'exec i3' or whatever.
<mark_weaver>yeah, the beep is terrible, and having the key to the left of A being anything other than control is even more horrible for an emacs user, IMO :-/
<mark_weaver>so I also do: setxkbmap -layout us -option ctrl:nocaps
<yenda>so you have setxkbmap in your profile ?
<mark_weaver>yes, and also xset
<mark_weaver>(for "xset b off")
<yenda>I do rmmod pcspkr
<yenda>it doesn't need xset
<mark_weaver>ah, okay
<DusXMT>ACTION had to install xbelld since his sound card doesn't have pcspkr emulation :(
<yenda>I wonder if you need setxmodmap with https://git.dthompson.us/dotfiles.git/blob/HEAD:/dotfiles/.xmodmap
<mark_weaver>yenda: they are two different ways of doing the same thing.
<yenda>but probably, I suppose .xmodmap is a config file for setxmodmap ?
<mark_weaver>I did the xmodmap thing for a long time
<mark_weaver>yenda: there's a program called xmodmap
<mark_weaver>I still had to run it manually, but I did: xmodmap .xmodmaprc
<yenda>ok so a .xsession is simpler
<mark_weaver>yeah, I think you'd need to put somethign in your xsession anyway
<yenda>but is it linled to Xorg as the name would suggest ?
<mark_weaver>and that also solves the problem of not having to pay attention to the F1 thing in slim
<mark_weaver>yeah, I don't know how this is done in wayland
<mark_weaver>it can be configured within GNOME's keyboard settings, so I suppose they would take care of doing the right thing on wayland, but for something like i3, I don't know
<mark_weaver>does i3 even work on wayland?
<mark_weaver>anyway, we can cross that bridge when we get to it.
<yenda>yes ^^
<yenda>to answer your question there is a project to make i3 on wayland
<yenda>but it will be really different
<mark_weaver>okay
<yenda>i3 is just a set of very basic tools, a menu bar, a window manager, dbus, dmenu to start an executable that is in the path
<mark_weaver>well, to be more clear: xmodmap and setxkbmap are both X specific afaik, but .xsession is something that the display manager (slim, etc) runs, so it's not necessary X specific, despite the name.
<mark_weaver>*necessarily
<yenda>ACTION wonders if i3 is more than 1mb
<mark_weaver>I seem to periodically go back and forth between minimal window managers like ratpoison and fancy ones like GNOME or XFCE.
<mark_weaver>but either way, I avoid the mouse. when I use the fancy ones, I use keyboard shortcuts, and anyway I basically live in emacs anyway.
<yenda>I really can't stand fancy ones, I just need emacs fullscreen and browser full screen, with handy shortcut between the two and a fast terminal launcher
<mark_weaver>yeah, same here. emacs and browser, with alt-tab between them :)
<yenda>the terminal being emacs now :)
<mark_weaver>and I even sometimes browse the web within emacs, for sites where it works well.
<mark_weaver>the next time I go back to minimal ones, I'll have to try out some other window managers like i3
<yenda>someday I'll configure helm to browse my bookmarks, switch to icecat directly or eww if the site is fulltext friendly
<mark_weaver>I'm trying to use eww more, but historically I have used emacs-w3m for this, which is much more mature.
<mark_weaver>what is helm?
<mark_weaver>btw, on the subject of browsers: in case you didn't see my message on guix-devel, we have another modern web browser now: epiphany.
<mark_weaver>at first it didn't have proper https support, but that's fixed now.
<davexunit>epiphany uses webkit, right?
<mark_weaver>I recommend using that until icecat 38 comes out
<yenda>yes I saw but I like mozilla stuff
<mark_weaver>davexunit: yes
<davexunit>if emacs xwidgets ever gets upstream, we could have a webkit browser in emacs.
<mark_weaver>I also prefer icecat and will switch back to it, but for now, the version of icecat we have might have some known unpatched holes.
<mark_weaver>or at least there were some security fixes for 38 released recently, but no one has ported them to 31, and it seems no one ever will.
<yenda>mark_weaver: helm is difficult to explain because it's really big. It is a completion engine like ido but also much more. You have helm-M-x for instance that replace M-x and help you dynamically search through function, helm-grep to dynamically grep though dir
<davexunit>I use smex to replace the built in M-x function
<yenda>helm-circe for instance is binded to my f8 key and shows me the irc channels with activity so I can jump in quickl
<mark_weaver>ah, sounds nice
<yenda>helm-find-files is like a dynamic dired
<davexunit>I've been meaning to work in projectile
<davexunit>but it never happens
<yenda>what is nice is that you can make your own helm interface for wathever you want. There is a video on youtube showing how to make an interface for spotify in 15 min
<yenda>davexunit: me too :) I think I only use it for helm-ag, which is a fast grep for within projects
<yenda>anyway back at trying to configure and understand gnus
<yenda>what a nightmare I hope it's worth it
<davexunit>projectile recognizes .git directories and things for other vcs systems and uses them to denote the roots of source trees so that you can, for example, quickly open files for a given project via fuzzy matching
<davexunit>it's a port of a feature from a proprietary editor
<davexunit>I think it would be useful, but I have C-x C-f so ingrained in my muscle memory that I need it to play nice with that
<davexunit>but I haven't been able to come up with something to make it work
<yenda>c-x c-f is binded to helm-find-file in my conf, I think I will add projectile as the first source
<yenda>that way c-x c-f will do that and also be normal out of projects
<yenda>added to my todos
<yenda>ACTION added dd to the keychords to delete a line #worst idea ever
<yenda>every time I type added I delete a line
<davexunit>I want a key sequence to escape from projectile's find file
<davexunit>because I often want to access arbitrary files
<davexunit>ido uses C-f to escape and go back to the regular find file
<yenda>I get you can define C-x C-f as projectile key-map and then C-f as 'find-file within projectile
<yenda>s/get/guess
<yenda> (define-key projectile-mode-map (kbd "C-f") 'find-file)
<yenda>I tried on my config it doesn't work but I think its because instead of 'find-file you need some kind of lambda which exits the helm sesion and opens find-file afterward
<yenda>I settled for C-x p to run projectile, I'll see how it goes, but it's hard indeed to stop doing c-x c-f all the time
<davexunit>maybe I'll try that keybinding
<yenda>what is the most complete font we have for unicode chars ? I'm looking for a fallback to my inconsolata font for special chars
<yenda>I'm tired of all these wierd rectangles
<davexunit>oh yeah, I also need such a font :)
<yenda>I guess the answer is symbola, I was looking around to package it but couldn't find a decent set
<davexunit>I need CJK fonts
<davexunit>font-adobe-source-han-sans looks like the right thing
<yenda>mark_weaver: did you tweak gnus look and feel ? or do you get use to it after a while ?
<davexunit>cool, that font worked.
<yenda>davexunit: did you find a source with proper licence ?
<davexunit>yenda: we already had a package
<yenda>oh nice
<yenda>so you just installed it and no more rectangles
<yenda>?
<davexunit>for most things, yeah.
<davexunit>japanese text and stuff
<davexunit>that wasn't rendering for me before
<davexunit>except in xfce window title bars for some reason
<yenda>I don't think it will help with unicode symbols though
<yenda>You know like animals and stuff people start using nowadays
<paroneayea>projectile looks useful
<yenda>ofc, lets say I'm working on guix, I want to look at licenses name, I just have to type lic to jump there from wherever
<mark_weaver>yenda: I use font-dejavu and font-adobe-source-han-sans:{cn,jp,kr,tw}
<mark_weaver>together, those cover the glyphs I see in practice
<mark_weaver>regarding gnus: it was a steep learning curve, and it works differently than most traditional email clients, but I eventually became accustomed to it, and it's the most featureful emacs mail/news/other reader
<mark_weaver>at this point, it's hard for me to switch to anything else, because I've become so accustomed to it
<paroneayea>mark_weaver: I think mu4e is pretty comparable, and even has some features gnus doesn't (I'm a former gnus user) but it doesn't have the newsreader and "things that are not mail" features gnus has
<mark_weaver>I need to try out mu4e
<mark_weaver>being able to read directly from gmane, gwene, rss feeds, etc, all in one reader, is something I would probably miss
<mark_weaver>but I'm still open to switching
<paroneayea>mu4e's main feature is its searching
<paroneayea>but IMO you need a way to an interface to read by maildir with unread mail... I wrote such a thing though, mu4e-uqueue
<paroneayea>but I guess the source is no longer up because gitorious is down
<paroneayea>I really need to move my old repos
<davexunit>I use the notmuch client + elfeed for reading RSS feeds.
<davexunit>notmuch client for mail, and elfeed separately for RSS feeds, that is.
<davexunit>yessss the rubygems folks fixed the Content-Type header on the gem archives
<mark_weaver>oh, nice!
<davexunit>time to up the ruby packaging velocity
<davexunit>and write 'guix import gem'
<rekado->paroneayea: with mu4e you can also read by maildir folder. (See mu4e~headers-jump-to-maildir.)
<paroneayea>rekado-: yes but I need a list of which maildirs have unread messages
<paroneayea>which is what mu4e-uqueue does
<paroneayea>is give you a list of maildirs to read
<rekado->paroneayea: ah, nice.
<sbidin`>I packaged cabal-install and xmonad. Should I prefix their names with ghc-?
<rekado->sbidin`: I'd say "no", because they are not primarily used as libraries.
<yenda>I gues I'm going to settle for mu4e + elfeed for rss
<yenda>for my sanity
<sbidin`>rekado-: I assumed so, but feared the automatic process that triggers on packages beginning with "ghc-" (that I don't yet understand). For instance, xmonad is used as a library by (ghc-)xmonad-contrib.
<sbidin`>I'll leave out the prefixes.
<sprang>any suggestions for where my figlet package should go? I'm not sure fontutils.scm make sense, since it doesn't really have anything to do with real fonts
<sprang>is there an existing module for silly command line toys? :-)
<sbidin`>Not sure there is any? I can't find any, actually. No cowsay, no sl, ...
<sbidin`>How could I reference zsh as a user's shell within the system config file? I know I have to use G-expressions, but I never used them and cannot find an example.
<sbidin`>Could I just pass in something like (string-append #$zsh "/bin/zsh")?
<sbidin`>That is, #~(string-append #$zsh "/bin/zsh").
<mark_weaver>sbidin`: I believe that's right
<mark_weaver>the latter one
<sbidin`>Thanks! Would a reconfigure then automatically pull in zsh, even if I hadn't listed it in within packages? Assuming I use the module (gnu packages zsh).
<mark_weaver>sbidin`: yes
<sbidin`>Great!
<mark_weaver>you might still want to put zsh in packages though, so that you can put it in shebangs as /run/current-system/profile/bin/zsh
<mark_weaver>and so that 'zsh' will be in your PATH
<sbidin`>Ah, yes, got it.
<mark_weaver>sprang: hmm, I don't know where that would go. maybe just make a new module for now.
<mark_weaver>I often have trouble deciding where packages should go
<yenda>I installed offlineimap, uninstalled, reinstalled
<yenda>first time it worked, now it doesn't find the command
<yenda>mhm actually nothing I install now is a command anymore
<yenda>I deleted .guix-profile how do I recreate the link properly ?
<yenda>I think that's my problem
<mark_weaver>ln -s /var/guix/profiles/per-user/yenda/guix-profile ~/.guix-profile
<mark_weaver>assuming your username is yenda
<yenda>ok that's what I did thanks
<yenda>I guess the problem is that I copied the thing after guix-profile the first time
<yenda>so it was stuck in an old version of the profile
<mark_weaver>ah, okay
<yenda>rekado-: have you installed mu4e on guix yet ? did you copy mu4e folder from mu in the store ?
<davexunit>magit is at version 2.2.0 now. we should update sometime, but maybe leave the old stable version because of how much stuff has changed.
<rekado->yenda: I use mu4e on GuixSD. I did not copy anything.
<yenda>wierd if I don't copy it it doesn't find it
<mark_weaver>davexunit: I looked at updating magit, and noticed that it required some kind of manual intervention when updating, as I vaguely recall, so I held off.
<mark_weaver>but now I've forgotten the details
<davexunit>yeah
<davexunit>I haven't upgraded yet either.
<mark_weaver>but if you want to take care of it, please feel free!
<davexunit>too many things right now. maybe one of the more experienced elisp hackers will do it. :)
<davexunit>sometimes if I mention things here they magically happen shortly thereafter. ;)
<rekado->the only thing I recall about the upgrade is a popup that asks you to confirm new behaviour by adding a line to the init file. If this line is not added the popup appears again the next time Emacs starts.
<davexunit>rekado-: how is the new version?
<mark_weaver>rekado-: that already happened with an earlier update to magit, one that we already have.
<rekado->oh.
<rekado->I use the latest from one of GNU elpa / melpa / marmelade. Haven't tested much, but it looks rather different.
<rekado->(only use the latest in the office. On my GuixSD machine I use whatever comes with Guix.)
<davexunit>it's supposed to be much improved
<enno__>Hello everyone. I do my very first steps with guix sd and the usb stick is booting fine. But unfortunately my network adapter is not working. The r8169 module is probably not working. I want to use r8168 instead. Where can I find this?
<enno__>My board is an Asrock Q1900-itx
<yenda>ok I update magit with melpa I'm going to try it out
<alezost>ACTION has been using the new magit for many months (when it was developed in the "next" branch)
<alezost>IMO it is much much better than the old magit 1
<davexunit>cool :)
<yenda>well this is not a big success
<yenda>ok it's a remain of my /home deletion
<rekado->enno__: are you sure that your network adapter works without non-free firmware?
<enno__>It was working with linux mint before. Don't know
<rekado->GuixSD comes with linux-libre, which does not include non-free firmware or firmware blobs.
<rekado->do you have any diagnostic output?
<rekado->"is not working" is a very broad statement, you know :)
<mark_weaver>enno__: it seems that the 8168 module is not in upstream linux and thus not in linux-libre
<mark_weaver>I see posts on the internet about downloading the driver source from realtek and compiling it
<mark_weaver>for now, could you use ethernet, and then we could help you figure out how to compile that driver and get it working in GuixSD?
<mark_weaver>hopefully it doesn't require non-free firmware
<yenda>adter giving magit a quick try I didn't notice any required configuration and it seems smoother
<yenda>also the ? gives more indications than before which is nice
<mark_weaver>well, I'm not sure about what I'm saying, it's just a guess
<mark_weaver>I only searched for filenames with "8168" in the name in the linux source tree
<mark_weaver>someone(TM) should just update our magit :)
<yenda>btw what does it change when you use emacs internal update system rather than guix ?
<davexunit>for the record, I did try bumping the version but it wasn't a simple "update version number and hash" upgrade.
<davexunit>so I stopped.
<davexunit>yenda: the package manager? nothing.
<davexunit>I use some MELPA packages to supplement what guix gives me.
<davexunit>eventually I hope for that list to shrink to 0.
<alezost>magit2 was mostly rewritten, and a guix package for it will be completely different
<davexunit>yeah
<enno__>@mark_weaver r8168 is for ethernet. So I am stuck at the moment.
<alezost>I think there is a problem in packaging magit 2: it requires dash. We have emacs-dash package, but "dash.el" (which is required for compiling magit files) is placed in /gnu/store/…/share/emacs/site-lisp/guix.d/dash-<version> ← this file name can't be defined, i.e. we can't use (string-append <dash-input> "/share/…")
<mark_weaver>enno__: https://www.h-node.org/ethernetcards/view/fr/315/Realtek-Semiconductor-Co---Ltd--RTL8111-8168B-PCI-Express-Gigabit-Ethernet-controller--rev-06- would seem to indicate that at least some versions of that board can work without blobs
<enno__>@rekado- Ok. Looks like it is non free firmware. Damn. Was not aware of this before
<mark_weaver>so maybe we just need to tweak something.
<mark_weaver>alezost: I don't understand what the problem is. can you elaborate?
<alezost>mark_weaver: Look at the current "magit" package recipe: there is (setenv "EMACSLOADPATH" (string-append ":" git-modes "/share/emacs/site-lisp")). git-modes are not needed anymore, but there should be something similar for dash, but "/share/emacs/site-lisp/guix.d/dash-2.11.0" can't be defined because of the version
<alezost>emacs-build-system put dash files to that directory
<alezost>*puts
<mark_weaver>alezost: okay, but you can scan the directory and find out the version number from that if need be, or use ,(package-version emacs-dash) or something, no?
<mark_weaver>or (dirname (find-files ...))
<mark_weaver>so many options
<mark_weaver>or am I missing something?
<alezost>mark_weaver: yeah, you are right, I would just prefer the constant directory name
<mark_weaver>alezost: do you think we should change the 'emacs-dash' package to install into a directory without the version?
<mark_weaver>would users ever need two versions of emacs-dash installed in the same profile?
<mark_weaver>I guess that wouldn't work well anyway
<alezost>mark_weaver: I don't know, but it's not the 'emacs-dash' thing, but 'emacs-build-system' one
<alezost>I think it doesn't make sence to try to install 2 versions of an emacs package at the same time
<alezost>*sense (time to sleep)
<mark_weaver>ah, I see
<mark_weaver>well, if you think something should be changed in 'emacs-build-system', we should probably discuss it on the ML.
<yenda>davexunit: I installed circe with guix but I'm still hesitant to switch because I use the (use-package) macro in emacs which takes care of all the dowloading and configuring of the packets
<mark_weaver>maybe in the meantime we could just use (package-version emacs-dash)
<yenda>mark_weaver: I packaged a few emacs packages for myself but I used git while guix import "encourages" the use of melpa
<yenda>I was wondering if guix can still look-up for potential upgrades when using a git repo instead of melpa
<mark_weaver>unless something has changed since I last checked, our current lookup for newer versions only works for GNU packages, and furthermore only GNU packages that are in ftp.gnu.org.
<mark_weaver>at some point we should try to make this work for as many packages as we can.
<mark_weaver>yenda: I think it's okay (maybe even preferable) to use a tarball or git repo over melpa for guix packages.
<mark_weaver>but I'd like to hear what other people think about this also.
<alezost>On my opinion there is another ugliness with emacs-build-system: along with *.el[c] files you will get other files from the upstream tarball.
<alezost>Try for exmaple "guix build emacs-dash" and look at /gnu/store/ic22a0y8v5hs8m2vinb9wqig10rjpfgl-emacs-dash-2.11.0/share/emacs/site-lisp/guix.d/dash-2.11.0/ directory
<sbidin`>I ran guix system reconfigure, but it failed building base-initrd.drv. I got a large backtrace ending with "ice-9/boot-9.scm:106:20: no code for module (guix build syscalls)". Not sure what's wrong exactly.
<yenda>I asked forcer about circe and he prefers the use of his github over melpa
<mark_weaver>yenda: I think that's fine. several of our existing emacs packages use git or tarballs already
<mark_weaver>alezost: yeah, I agree that's not so good. I'd encourage you to post to the ML about it.
<alezost>mark_weaver: it is known: <https://lists.gnu.org/archive/html/guix-devel/2015-07/msg00416.html>
<mark_weaver>alezost: would you like to propose a patch?
<mark_weaver>especially since ludovic agreed
<mark_weaver>yenda: in fact, the message alezost just cited reminds me that we can't use MELPA anyway, although I haven't been paying much attention to that discussion.
<mark_weaver>(so maybe my information is stale)
<alezost>mark_weaver: I don't have a patch currently, but I will likely look at it (if Federico didn't beat me)
<alezost>yes, yes, Melpa tarballs can't be used at all
<alezost>because they are refreshed at place every several hours
<yenda>wow lists.gnu.org is so text friendly rms could validate it
<enno__>I now tried to install guix sd on Parallels 10 via usb stick. No luck
<yenda>makes me think that once I get enough time and elisp skills I'll make a function that opens links in eww or icecat depending on a whitelist of text-friendly websites
<yenda>later I'll add filters that make particular site text friendly by formating them
<yenda>does it exist already ?
<mark_weaver>I don't know, but there's a keybinding (&) in eww to load the same page in an external browser.
<mark_weaver>so it's pretty easy to fall back when eww isn't sufficient
<mark_weaver>emacs-w3m has something similar
<yenda>but sometime you know in advance that a website sucks at rendering on eww
<yenda>so it would be awesome that when you press & it saves the website in a list and next time it opens directly in a browser
<yenda>except if you write a filter for it
***francis7 is now known as fchmmr
***fchmmr is now known as francis7
<yenda>ACTION announces caveman-mode
<mark_weaver>yenda: sure, sounds useful
<sbidin`>Is it necessary to run some sort of cleanup action after a failed guix system reconfigure? It seems I'm getting the same error no matter how I change my config.
<mark_weaver>sbidin`: no
<mark_weaver>hmm
<sbidin`>I'll try reverting to the absolute base documentation config.
<mark_weaver>sbidin`: does "guix system build" run from your normal user account fail in the same way?
<sbidin`>I just tried the "typical desktop" config from the docs, it fails the same way.
<mark_weaver>since you run "guix system reconfigure" as root, that may use a different version of guix, if you haven't run "guix pull" as root.
<sbidin`>mark_weaver: Let me see...
<sbidin`>mark_weaver: That's true, I haven't!
<mark_weaver>when you run "guix pull" it only affects that one user. so, if you run is as your user, that won't change it for root, and vice versa.
<mark_weaver>you need to run it as both.
<sbidin`>Thanks! I'll do that now.
<mark_weaver>fortunately, if you run it for both and there are no upstream commits in between, you only have to wait once.
<sbidin`>Ah, that's good. I was wondering about that. :)
<mark_weaver>because the compiled guix will be cached in /gnu/store and simply reused.
<pizzaiolo>mark_weaver: it would be nice to have a license for the screenshots on https://www.gnu.org/software/guix/
<mark_weaver>btw, there's an (IMO) better way to do this, and necessary if you want to contribute to guix anyway: build guix from a git checkout and use that one. then 'git pull' and 'make' is vastly faster.
<pizzaiolo>I want to publish them on Wikipedia, so they need to be CC BY or CC BY SA, for instance
<mark_weaver>pizzaiolo: ah, okay, let me take a look...
<pizzaiolo>:)
<mark_weaver>(I'm sure it's fine, but of course we should formalize it)
<pizzaiolo>yes, otherwise commons admins will delete it swiftly :P
<mark_weaver>pizzaiolo: so, at the bottom of the page it says "Made with ♥ by humans and powered by GNU Guile. Source code under the GNU AGPL." where "Source code" and "GNU AGPL" are links.
<mark_weaver>our website is in git
<mark_weaver>so what more is needed?
<pizzaiolo>ah, you're right
<pizzaiolo>I wasn't sure if AGPL is suitable for images
<pizzaiolo>but I guess it works
<pizzaiolo>I'll upload them under that license :)
<pizzaiolo>thanks
<mark_weaver>np!
<mark_weaver>thanks for working on our wikipedia page :)
<pizzaiolo>no worries
<pizzaiolo>it needs some love
<davexunit>I think our images should be CC BY-SA
<davexunit>I believe our logos are under this license
<pizzaiolo>it's a better license, no doubt
<mark_weaver>what is the proper way to declare the license of an image?
<pizzaiolo>add a short notice around the gallery
<pizzaiolo>something like "screenshots released under CC BY SA"
<pizzaiolo>and then link to the license text
<davexunit>and in our git repo we can add a file that explains the license
<mark_weaver> http://git.savannah.gnu.org/cgit/guix/guix-artwork.git/tree/website/README
<mark_weaver>and the screenshots are in there
<davexunit>ah cool
<davexunit>so are the screenshot public domain (we should say CC0 here)
<davexunit>?
<pizzaiolo>yes, CC0 is better because in some jurisdictions (weirdly) you cannot release stuff into the public domain
<pizzaiolo>and CC0 legally mimicks the PD
<pizzaiolo>for now, I'll consider it as double-licensed under PD and AGPL
<pizzaiolo>I think that's how the justice system would see it anyway
<mark_weaver>I confess I don't know the process for updating our website.
<mark_weaver>the maintainer of guix is away on vacation
<mark_weaver>pizzaiolo: do you think the notice at the bottom of the page will be sufficient for now?
<pizzaiolo>for sure
<pizzaiolo>:)
<mark_weaver>cool, thanks
<pizzaiolo>mark_weaver: this is what it looks like at the moment https://commons.wikimedia.org/wiki/File:Guix-enlightenment-inkscape.png
<mark_weaver>pizzaiolo: LGTM
<pizzaiolo>heh, I know it's wrong but I can't help but pronounce GUI-ks
<sbidin`>Is there a reason why "guix pull" doesn't just fetch a binary?
<sbidin`>I'm hoping the reason is "nobody just got around to implement that yet". :)
<yenda>it's funny at the beginning the commit messages were not as codified
<yenda>I think the most common commit message is "Doh"
<sbidin`>My root's guix pull finished compiling, and then I started my other user's as well. It seems things haven't been cached after all. :D The last commit is 2 hours ago though, so I don't know what has changed these past 20 minutes.
<mark_weaver>sbidin`: if you want, you can just make ~root/.config/guix/latest a symlink to ~/.config/guix/latest
<mark_weaver>and then root will always use the same version of guix as your normal user account
<yenda>For those using magit what do you use when you have unpushed commits and want to integrate latest commit from master ?
<mark_weaver>I *never* use "guix pull", so I don't have direct experience with it.
<mark_weaver>yenda: git pull --rebase
<mark_weaver>I don't know the magit equivalent, if any
<sbidin`>mark_weaver: I'll do that. Thanks!
<mark_weaver>I use magit, but not for pulls and pushes