IRC channel logs

2015-07-01.log

back to list of logs

<ewemoa>rekado: regarding checking for texinfo, it looks like civodul added that bit of code for qemu: http://git.savannah.gnu.org/cgit/guix.git/commit/gnu/packages/qemu.scm?id=bbc08c7940a364fb1084defbb8f6f4d51673fb40 -- may be we can bug him about it when he returns
<davexunit>rekado: that paper you co-authored with civodul is great.
<mark_weaver>davexunit: I think I know the fix for IceCat WebGL.
<mark_weaver>gfx/gl/GLContextProviderGLX.cpp does the dlopen
<mark_weaver>so that just needs to be patched to be an absolute path, I think.
<davexunit>mark_weaver: so we just substitute*? cool.
<mark_weaver>davexunit: but first, can you verify that "LD_LIBRARY_PATH=$(guix build mesa)/lib icecat" has working WebGL for you?
<davexunit>mark_weaver: sure!
<davexunit>just a minute while guix fetches mesa
<mark_weaver>the one thing I'm not sure about is whether the absolute path will be handled correctly. it actually doesn't call dlopen from there, it uses something from NSPR to load libraries, so I'm not sure if it works the same.
<davexunit>ah, perhaps not.
<mark_weaver>if the mesa that you download now is linked to a different shared library than what icecat is linked to, there will be trouble.
<mark_weaver>so it would be better to try:
<mark_weaver>LD_LIBRARY_PATH=$(guix build mesa)/lib $(guix build icecat)/bin/icecat
<mark_weaver>one of the webgl demos on mozilla's site worked for me, anyway.
<mark_weaver>(and didn't before setting LD_LIBRARY_PATH)
<davexunit>mark_weaver: it lives!!
<davexunit>I've been checking various examples here: http://threejs.org/examples/#webgl_buffergeometry_custom_attributes_particles
<mark_weaver>so it works?
<davexunit>yup
<davexunit>works like a charm
<mark_weaver>yay :)
***wtheaker is now known as aaalive
<civodul>Hello Guix!
<civodul>mark_weaver: cURL test failure on wip-diet: http://hydra.gnu.org/build/555639/nixlog/1/tail-reload
<civodul>it's similar to the one you disabled
<civodul>should we do the same?
<ewemoa>civodul: do you recall why there is a bit for checking whether texinfo is missing in the following? http://git.savannah.gnu.org/cgit/guix.git/commit/gnu/packages/qemu.scm?id=bbc08c7940a364fb1084defbb8f6f4d51673fb40&context=96
<civodul>ewemoa: i think at that time there was something inheriting from QEMU and not having Texinfo as an input
<civodul>at least that's the only valid reason for doing this
<civodul>but maybe it's no longer valid here
<ewemoa>civodul: thanks!
<civodul>yw!
<ewemoa>rekado: here is a revised patch for the info files for r: https://pastee.org/mf9r6 -- some lines above in the irc log, you may find some comments from civodul regarding checking for texinfo :)
<civodul>the .info file isn't in the source tarball of R?
<ewemoa>civodul: the info file is made via make info
<civodul>yes, i see, but i was wondering whether they ship it in the tarball
<civodul>normally the GNU standards say to do so, but some packages don't
<ewemoa>civodul: i freshly uncompressed a tarball for the latest R and i don't see any files that have names ending in .info -- may be they can be convinced to ship appropriate info files :)
<civodul>heh :-)
<civodul>in the meantime your patch is welcome!
<ewemoa>civodul: :) on a separate note, i am trying to use dmd as a non-root user -- IIUC, the info file here suggests that starting dmd w/o specifying a config file should cause ~/.dmdconf.scm to be loaded -- but that doesn't appear to be what happens here (though explicitly specifying --config=$HOME/.dmdconf.scm seems to work) -- am i doing something wrong?
<civodul>.dmdconf.scm was replaced by ~/.dmd.d/init.scm some time ago
<civodul>but maybe the on-line manual isn't up-to-date
<ewemoa>civodul: thanks for the pointer -- that works much better! fwiw, the local info file here and https://www.gnu.org/software/dmd/manual/dmd#Jump-Start suggest ~/.dmdconf.scm
<rekado_>I'm thinking about trying incron to keep the local /gnu and the NFS /gnu in sync by watching inotify events. Are new directories under /gnu/store created atomically?
<rekado_>looking at strace output it looks like stuff is installed to /gnu/store/.links first and then moved/linked to the final location at /gnu/store/<hash>-<name>-<version>
<rekado_>I would like to just watch /gnu/store for new directories and individually copy those to the public NFS share.
<rekado_>localstatedir is small enough to sync as a whole every minute with rsync.
<civodul>rekado_: are you really sure you cannot have /gnu and the machine that runs the daemon, and have it export it by itself?
<civodul>it would be much less troublesome than syncing things
<civodul>and syncing would not be atomic, so there would be windows during which users see incomplete directories etc.
<rekado_>civodul: yeah, I can't do that.
<rekado_>I cannot touch the fileserver (it seems nobody can for ... erm ... reasons, I'm sure) and I cannot guarantee availability of this builder VM, so it's not the right place for publishing an NFS share.
<civodul>oh, ok
<civodul>well what you describe might work, it just sounds can-of-wormy ;-)
<rekado_>it's unfortunate, but I don't see any way around syncing.
<rekado_>oh, it is very can-of-wormy indeed.
<civodul>heh, make sure management acknowledges that ;-)
<rekado_>as long as it works(TM) and it remains on our (virtual) machines everything is permitted.
<rekado_>now I just need to ... make it work.
<Steap>For those of you who use both Guix and tox: http://paste.debian.net/273213/ :)
<civodul>Steap: woow, nice!
<civodul>you were fast!
<Steap>civodul: well, this might be because that does not work so well
<Steap>as usual, I'm only showing what works
<Steap>a little trick I learnt while working in the field of reasearch in computer "science" :)
<civodul>:-)
<civodul>you wrote it in Python?
<Steap>I hacked tox
<Steap>so yes
<Steap>discovered some fantastic stuff
<Steap>like, pbr needs git
<Steap>the actual binary
<Steap>that was nice.
<Steap>gonna be flooding davexunit with questions about guix env this afternoon
<civodul>heh
<civodul>so it's some sort of a tox backend?
<Steap>we could say that
<Steap>it's quite differetn from the usual virtualenv backend
<Steap>because you do not create/update a guix env
<Steap>you just start it, and PYTHONPATH is automagically set
<Steap>so it's easier, in a way :)
<Steap>I just have to manually set the PATH
<Steap>which is annoying
<Steap>also, since we launch bash, it reads .bashrc
<Steap>so the env is not exactly "pure"
<civodul>why isn't PATH correctly handled?
<civodul>the default is to launch /bin/sh; if /bin/sh is Bash, it doesn't read .bashrc
<Steap>hum
<Steap>just added "export LOL=42" to my .bashrc
<Steap>$ make && ./pre-inst-env guix environment --pure python-flake8
<civodul> http://www.gnu.org/software/bash/manual/html_node/Bash-Startup-Files.html
<Steap>$ echo $LOL
<Steap>42
<civodul>maybe ~/.profile or /etc/profile sources ~/.bashrc?
<Steap>/etc/profile does
<Steap>but that fucks up the "--pure" thing, doesn't it ?
<civodul>depends on what these files do
<civodul>since it's not a login shell, they're not suppose to fiddle with $PATH, $CPATH, etc.
<jackdaniel>botsnack
<Steap>well .bashrc usually exports PATH
<jackdaniel>sneek: botsnack
<sneek>:)
<civodul>Steap: this should go to .bash_profile actually
<civodul>for decades i did it wrong :-)
<civodul>new news! http://savannah.gnu.org/forum/forum.php?forum_id=8307
<rekado_>jackdaniel: thanks for feeding sneek. It was getting restless already.
<jackdaniel>sure :)
<Steap>civodul: yeah well, people in the real world put it in .bashrc :)
<Steap>might have a hard time selling them guix if we cannot have a real "--pure" option :p
<civodul>well, i don't know
<civodul>we could have an option to use system* (i.e., fork + exec) instead of system
<civodul>maybe that would help?
<Steap>wouldn't we end up reading .bashrc anyway ?
*Steap needs a nap
<civodul>Steap: my idea was to have something like "guix environment foo -E bar --forkexec" where 'bar' would be executed via fork+exec instead of system(3)
<civodul>in that case, no shell involved
<civodul>but i think it's good to use the shell by default
*civodul adds a footnote about .bashrc vs. .bash_profile
<alezost>davexunit: hi, do you prefer to have <davet@gnu.org> in AUTHORS file?
<alezost>(I'm going to clean up the AUTHORS and to add .mailmap)
<alezost>amz3: hi, are you Amirouche Boubekki?
<Steap>He has a right to anonymity.
<alezost>well, I need to know what to put in AUTHORS: amz3 or Amirouche Boubekki, and <amirouche.boubekki@gmail.com> or <amirouche@hypermove.net>
<davexunit>alezost: yeah that's fine.
***necronian_ is now known as necronian
***rvernon is now known as Rastus_Vernon
***breton_ is now known as breton
<Steap>davexunit: would it make sense for guix environment to return the return value of the command specified with --exec ?
<davexunit>Steap: yes, I've been meaning to add that. :)
<davexunit>it's an embarrassing omission on my part.
<davexunit>and I only noticed a few days ago.
<davexunit>patch it! :)
<davexunit>should be a one-liner
<Steap>davexunit: I don't know whether that should be the default behaviour
<Steap>or something that is turned on using an option
<davexunit>Steap: it should.
<Steap>(I need that for guix-tox :p)
<davexunit>the whole point of 'guix environment' is to run a subprocess, so I think it ought to return its status code
<mark_weaver>agreed
<Steap>hum, funny ls /TMP returns 2 on my machine, but if run inside guix env, it returns 512
<Steap>oO
<Steap>oh, it needs status:exit-val
<davexunit>o/ pikos
*davexunit begins to polish gnu/build/linux-container.scm
<davexunit>nvm, that will have to be later.
<davexunit>actually, I will resume my code clean up. :)
<bavier`>the sage build is a beast
<bavier`>i.e. sagemath.org