IRC channel logs

2015-06-20.log

back to list of logs

<mdln>How's that going?
***hopses is now known as hospes
<davexunit>mdln: it's going pretty well.
<davexunit>lots to do still.
<davexunit>attempting to add support for interactive processes within containers
<davexunit>and then it's off to build a daemon!
<mdln>neat!
<davexunit>I also need some code to handle cgroups and capabilities
<davexunit>so much stuff to do
<davexunit>hmmm sshfs doesn't work for me
<davexunit>fuse: device not found, try 'modprobe fuse' first
<davexunit>I ran 'modprobe fuse' as root, to no avail
<mark_weaver>davexunit: there's an environment variable that needs to be set for modprobe to find the modules, and I vaguely recall that it fails silently if it can't find them in the FHS standard place /lib/modules
<davexunit>oh ok, didn't know that
<mark_weaver>on GuixSD, /etc/profile sets: export LINUX_MODULE_DIRECTORY=/run/booted-system/kernel/lib/modules
<davexunit>I'll do a system update with sshfs-fuse included
<mdln>guile
<jackdaniel>hey - any hint how to deal with "Couldn't start Geiser" emacs message on guix-all-available-packages ? M-x geiser starts with guile implementation
<jackdaniel>(same applies to chicken and racket)
<ewemoa>jackdaniel: i don't have a direct answer for you, but if that happened to me, i might try using edebug to follow execution
<jackdaniel>thanks, I'll read about it
<ewemoa>here are sketches of a package for hostapd and a corresponding service: https://pastee.org/2akch https://pastee.org/wvwam -- is there a recommended way to test the service portion?
<amz3>in a vm maybe?
<amz3>i never tried vm support it might be a good reason
<wingo>hello guix
<wingo>i am writing a thing and it uses guile. i want to temporarily enter an environment that has guile, but i don't want to make a guix package yet. what's the right way to do that?
<wingo>i'm on guixsd fwiw
<davexunit>wingo: guix environment --ad-hoc guile
<wingo>tx davexunit :)
<davexunit>yw
<wingo>davexunit: pkg-config --libs guile-2.0 isn't working in that environment. what's wrong
<wingo>?
<lf94>Man I wish I could program on my phone
<lf94>guess I'll just read some theory.
<lf94>rip wrong channel
<amz3>lf94: use scheme scratch ;)
<lf94>heh
<lf94>Unfortunately I don't know any lisp-like languages
<lf94>Closest thing is haskell...which is actually not even comparable.
<lf94>I want to learn lisp-like languages but is it worth it?! I can see them as being "high level" compared to haskell. But I know Python for that.
<amz3>lf94: sorry it's oT, but guile is different it's GNU :)
<amz3>hey, I have got working sigmajs to display dependencies of a pacakge, look inside `sigmajs xp` there is two layouts http://www.hyperdev.fr/_drafts/guix-dependencies-in-sigmajs/
<amz3>I don't know how this can be made useful
<amz3>and if it can be made useful
<lf94>Well once you know one dialect aren't they mostly the same
<lf94>syntactically
<rekado>ewemoa: not sure if you already do this, but please post these snippets as patches to the guix-devel mailing list.
<amz3>definitly maybe, i only did emacs lisp a long time ago, and guile scheme
<rekado>ewemoa: otherwise they may be forgotten.
<ewemoa>rekado: i was hoping to, but i haven't figured out a way to send messages w/ attachments via gmane
<ewemoa>amz3: re: vm -- guix system vm?
<lf94>well knowing emacs lisp would be nice too, considering I use emacs...lol
<lf94>But guile is coming to emacs, isn't it?...
<amz3>ewemoa: I guess
<amz3>ewemoa: we try it together :)
<ewemoa>amz3: he he -- ah, the guix docs here have something about vm in 6.2.13...
<davexunit>wingo: is pkg-config on your $PATH?
<wingo>davexunit: yes
<davexunit>ah, I know what it is.
<davexunit>the environment didn't explicitly include pkg-config, so it's search path was not modified
<wingo>that's strange :)
<davexunit>try: guix environment --ad-hoc guile pkg-config autoconf automake ...
<wingo>will do next time
<davexunit>wingo: there's no way to do it.
<wingo>for now i just installed guile in the profile
<davexunit>the environment needs to know the full set of packages
<davexunit>it takes a union of all package search paths and builds the path by looking at each output and seeing if the relevant directory/file is in it
<davexunit>best to make sure that 'guix environment --pure' works to build, then you should be all set. :)
<wingo>well i already had pkg-config in my env
<wingo>i thought that adding guile would add guile to the pkg-config too
<davexunit>guile doesn't have a native search path for pkg-config stuff
<davexunit>pkg-config does
<davexunit>thus pkg-config must be part of the environment you build.
<wingo>ok :)
<wingo>i can see the logic but it still seems i shouldn't have to mention pkg-config if it's already in my env :)
<davexunit>it's not *really* in the env, though.
<wingo>but it is! i didn't specify --pure
<wingo>on purpose
<davexunit>it's in your user profile
<davexunit>which guix environment has no insight into
<amz3>profile or env?
<davexunit>because your environment variables could be configured any number of ways
<wingo>seems like a bug to me -- if i don't specify --pure then it should use my user profile
<wingo>as part of the input
<wingo>dunno :)
*wingo has unfounded opinions :)
<amz3>ewemoa: I created a bare config.scm and started it with guix system vm bare.scm --share=$HOME/tmp=/$HOME/tmp
<amz3>FWIW I agree with wingo
<davexunit>the env vars you already have are nothing more than side-effects
<davexunit>guix environment cannot consider them.
<amz3>what does --pure do then
<davexunit>clears the environment first
<amz3>which env? bash env or guix env ?
<davexunit>environment variables
<ewemoa>amz3: oh nice -- i was just digging through irc logs and noticed there's a pointer to a sample conf: https://gnunet.org/bot/log/guix/2015-04-29
<wingo>why not make --pure clear env variables, but include packages from the profile?
<davexunit>any environment you build *should* be capable of working with --pure on.
<wingo>that's an opinion :)
<davexunit>because that would defeat the purpose of the tool.
<wingo>ok, i am interested in a different tool
<davexunit>the purpose is to create environments that are similar to what the guix daemon builds
<davexunit>reproducible development environments
<wingo>then why does --pure even exist?
<davexunit>if you rely on stuff in someone's profile, it's not reproducible anymore
<davexunit>because it's convenient to use an impure environment to get tools that aren't needed to build the software, but you want to use anyway
<davexunit>such as git
<ewemoa>amz3: fwiw, davexunit mentioned: build-aux/hydra/demo-os.scm
<wingo>well. i feel i am being argumentative, so i stop now :)
<amz3>ho does it have access to git but not to the profile?
<davexunit>it doesn't.
<davexunit>it just prepends to search paths rather than clearing them first.
<davexunit>so I get to keep my $PATH and such
<davexunit>which is convenient sometimes.
<wingo>impure! unclean!
<wingo>:)
<davexunit>:)
<davexunit>'guix environment' works a lot like nix-shell does
<amz3>I don't understand why the default mode ie. impure mode (?) doesn't have access to profile I will read guix i Guess
<davexunit>eventually, it will be able to create a container similar to what the daemon creates
<davexunit>because your profile isn't the only thing that determines what environment variables you currently have
<davexunit>they could be *anything*
<davexunit>and furthermore the user default profile is a special case of all possible package profiles
<amz3>davexunit: go back to work ;))
<wingo>it's saturday!
<wingo>wheeeeee
<amz3>:))
<davexunit>yeah, I have some chores to do before I can get out of the house and take a trip to visit friends/family
<davexunit>aaand I want to get to my practice space and play my drums before I hit the highway
*davexunit goes afk
*amz3 drums his keyboard nonetheless
*wingo making a new scheme
<amz3>really?
<wingo>yeah, based on guile, written in guile, targetting microcontrollers
<wingo>so written in scheme but not self-hosted
<DusXMT>wingo: what kind of uControllers?
<amz3>maybe you heard about micro python? it go supported by european space agency
<amz3>the kind that goes to spaaaace
<wingo>nice!
<wingo>DusXMT: right now the atmega328p
<wingo>but i'm really ignorant and still learning lots of stuff :)
*amz3 will add a command to create dot output for package depdendencies
<amz3>I though there was something like this already
<jackdaniel>hm, still no clue, geiser just won't start when invoked with geiser-repl--start-scheme (narrowed down from guix-all-available-packages), throwing an error err's value is (error "localhost/37246 System error") ; (tried different port, same result)
<rekado>wingo: http://microscheme.org/ ?
<ewemoa>amz3: ooo, $(guix system vm build-aux/hydra/demo-os.scm) in the guix source directory seems to have worked :)
<amz3>my command failed I'm trying yours
<amz3>I did not do $() ... hopefully it will work
<amz3>ewemoa: how do you know it succeed ?
<amz3>there is window that pops!
<alezost>jackdaniel: hi, do you have any "guix.el" related settings? How did you install Guix (or do you use GuixSD)?
<amz3>ewemoa: it works! can you test hostapd? on my side, I can't really try it. I'm already using wifi to connection to some kind of internet
<amz3>(my poor internet cnx)
<jackdaniel>alezost: i have only (require 'guix-init nil t) with load-path directed to guix-profile site-lisp
<jackdaniel>I use guix (not guixsd), and all worked perfectly fine
<alezost>jackdaniel: hod did you install guix and geiser?
<jackdaniel>lately I've turned avahi-daemon on (from void linux repositories), but turning it off doesn't change a thing
<jackdaniel>hm, I've used binary from site and followed guide, and geiser is from guix as well as guile
<alezost>jackdaniel: wait a second, do you mean "guix.el" used to work but then something happened and it don't work anymore, right?
<jackdaniel>alezost: yes
<jackdaniel>I did guix pull / guix refresh as well a few days ago
<alezost>jackdaniel: perhaps geiser refuses to connect to "localhost"? Check your hosts
<jackdaniel>hostname "localhost" is there
<alezost>not sure if it will answer, but try "ping localhost"
<jackdaniel>works (pings localhost.localdomain, but it's resolved correclty)
<alezost>jackdaniel: ok, try (setq guix-use-guile-server nil)
<jackdaniel>this makes everything work (at least guix-all-…-packages)
<alezost>jackdaniel: then the problem is definitely that geiser can't connect to localhost
<jackdaniel>ok, thanks. I'll try to investigate it further
<jackdaniel>probably I've changed something when configuring avahi
<alezost>jackdaniel: no problem; you may stay with (setq guix-use-guile-server nil). The only disadvantage would be: you can't search for packages while there is some active operation in *Guix REPL* buffer.
<jackdaniel>hm, I believe all will be fine with GuixSD, I just have to create "dirty"-linux package to have network working and I want to switch
<alezost>jackdaniel: relating to "localhost" problem: you may try the following: 1. Start guile server in some console: "guile --listen" and 2. Use "M-x connect-to-guile". It will prompt you about host and port (use the default 37146). Try both "localhost" and "127.0.0.1" for host.
<jackdaniel>ip address works
<alezost>as expected :-)
<jackdaniel>thats weird since I can even access my directories with C-x C-f ssh://localhost:/
<alezost>yeah, that's strange, dunno how that may happen
<alezost>at least if you face some similar problem, you'll know about "localhost"; it might be that geiser is not the last thing having issues with localhost
<jackdaniel>yes, it's useful information indeed :)
<wingo>rekado: written in c, bad macros
<wingo>also this is definitely a scratch-an-itch project :P
***hopses is now known as hospes
<zacts>mark_weaver: davexunit: I just pre-ordered the new 'Little Prover' book by Daniel Friedman
<JamesJRH>fchmmr, mark_weaver: Hi.
<mark_weaver>(continuing a comparison of Nix vs Guix that started on #libreboot)
<JamesJRH>mark_weaver: So what do you think of Haskell?
<mark_weaver>JamesJRH: it's true that Scheme is a less pure language than Nix's custom language.
<JamesJRH>Okay.
<mark_weaver>but in fact we use a purely functional subset of scheme in our package descriptions
<mark_weaver>and anyway, most of the code that actually builds the software in Nix is in Bash, Make, etc.
<mark_weaver>in our case, a bit more of it is in Scheme, but we too depend mostly on the build systems provided by the upstream packages themselves.
<JamesJRH>mark_weaver: So my reasoning is that if I'm going to switch from Nix-the-language to some other language, that other language should be a pure one. I'd be happy to switch to Haskell.
<mark_weaver>okay, so Haskell has a lot of great things going for it, but it's not nearly as good at creating custom domain-specific languages as Scheme is.
<mark_weaver>basically, we leverage Scheme's very powerful hygienic macro system to good effect.
<mark_weaver>and we avoid the use of state anyway
<mark_weaver>so in this case, I think Scheme is a better choice
<zacts>I'm learning Haskell too right now
<zacts>Haskell and (scheme)
<JamesJRH>mark_weaver, fchmmr: But aside from these technical details of which language you or I or they prefer, it really annoys me that Guix keeps getting branded as the Parabola or Triquel counterpart to NixOS, when in fact it differs not only by philosophy of libre software, but also by language technicalities.
<mark_weaver>okay. I haven't implied that it's like Parabola or Trisquel.
<mark_weaver>but of course we make comparisons to Nix. it's based on precisely the same concepts, after all, with almost the same daemon.
<mark_weaver>same store. it's possible in fact that have both Nix packages and Guix package coexisting in the same store.
<mark_weaver>(although they'd be based on different libraries and compilers right down the bootstrap)
<JamesJRH>mark_weaver: Not you, fchmmr has implied this alot. I think even nearly every time that I've mentioned NixOS in a conversation with him. (Hence I also pinged him.)
<JamesJRH>Also, others have implied this.
<mark_weaver>let's put it this way: if you like the concept behind NixOS but want a fully libre system, then Guix is the only game in town.
<mark_weaver>but indeed, whereas Trisquel and Parabola are almost identical to their non-libre counterparts, Guix has *completely* different package descriptions, a different way to describe the packages, and a different system for building the packages.
<mark_weaver>so I don't know, I can see both sides of this.
<JamesJRH>Guix is a conflation of 2 very different missions. 1 of which I kind of either don't agree with, or at best am neutral to, but not willing to make the effort to relearn something that I consider, at best, on-par. The other (the software liberty mission), I'm totally behind and this is a big aspect of my life.
<mark_weaver>so I guess the fact that Scheme is not a purely functional language is a big problem from your perspective?
<mark_weaver>you prefer the Nix language?
<mark_weaver>or rather, a mixture of Nix language and bash?
<mark_weaver>and C++ :)
<mark_weaver>(which we intend to replace with Scheme as well, at some point)
<JamesJRH>I kind of like the Nix language. I only have I think 2 things I don't like about it, and 1 of them actually isn't anything to do with the language but the tradition of 2-space indentation. The other being something strange going on with quoting quoted dollar signs, which I have to look-up each time.
<JamesJRH>17:53:19 < mark_weaver> so I guess the fact that Scheme is not a purely functional language is a big problem from your perspective? ← Yes.
<JamesJRH>17:54:13 < mark_weaver> or rather, a mixture of Nix language and bash? ← There have been discussions of replacing this with pure alternatives on the nix-dev mailing list.
<mark_weaver>even though our package descriptions are written in a purely functional style? I literally can't think of a single example of a package description that mutates state in the Scheme code.
<JamesJRH>I want to move away from Bash and such, but to something pure, when possible.
<jackdaniel>(setf *overwrite* t)
<mark_weaver>and even if the rest of our code, our use of state is *extremely* rare.
<mark_weaver>and most of it is memoization, which Haskell does implicitly.
<JamesJRH>mark_weaver: The thing is, then why would I move from Nix, which already is pure, to Scheme which is pretty much pure, if you say so? Even if it's as pure as Nix, I'd be relearning something that's just different, for about the same practical benefit.
<ijp>if you don't want to move from nix, don't
<mark_weaver>well, you say that software liberty is a big aspect of your life.
<mark_weaver>but yeah, it's your choice :)
<JamesJRH>mark_weaver: But what about allowUnfree = false?
<JamesJRH>I can use Nix without any nonfree software.
<JamesJRH>NixOS*
<mark_weaver>does that end up using linux-libre?
<mark_weaver>I suspect that they're idea of "unfree" is not as vigilant as ours
<mark_weaver>but anyway, I really don't have time or interest to try to convince you. use whichever system you wish.
<mark_weaver>s/they're/their/
<JamesJRH>I don't know, but I can try it. These things are on my todo list.
<JamesJRH>18:00:34 < mark_weaver> I suspect that they're idea of "unfree" is not as vigilant as ours ← My idea of unfree /is/ as vigilant as yours, so if I determine that it's not truly nonfree, I'll nag them on the mailing list.
<mark_weaver>e.g. I vaguely remember reading that if you try to install firefox, Nix wants to install flash player as well.
<JamesJRH>I have Firefox installed, but apparently no Flash player. However, Totem seems to be presenting itself as ‘a Flash video player’, but I've never got it to work.
<JamesJRH>mark_weaver: Currently I don't /depend/ on any proprietary software on my system, I just need to get round to installing LibreBoot, fitting my new Atheros 11n WiFi card, and installing Linux-libre.
<fchmmr>JamesJRH, it's easy.
<fchmmr>Do it today.
<mark_weaver>okay, here's the thing. most people who run NixOS will end up tempted to install proprietary software.
<JamesJRH>I've had this on my todo list for over a year, but I'm struggling with other issues that are delaying me in many ways.
<mark_weaver>to the extent that it becomes popular, most people will not set that flag, or will at some point be tempted to remove the flag, because it's so easy to do.
<JamesJRH>18:06:36 < mark_weaver> okay, here's the thing. most people who run NixOS will end up tempted to install proprietary software. ← I wish to remain part of the NixOS community in order to be part of the persuading of other community members to keep to software liberty, and not be tempted.
<mark_weaver>okay, as you wish
<JamesJRH>mark_weaver: I'm more in to the ‘capture and educate’ philosophy, allowing people to come from any technological standpoint and be directed toward software freedom.
<mark_weaver>to be honest, my impression is that the real reason is that you are placing more importance to a dubious technical advantage.
<JamesJRH>fchmmr: I need to backup, and I have a serious problem with managing my files to the point of disability. I want to write software to help me, but I don't know enough to write what I need.
<jackdaniel>JamesJRH: keep it in your home and rsync it regularily
<mark_weaver>and I can sympathize with where you are coming from. purely functional programming is important. it can be done in scheme, and non-purely functional programming can be done in Haskell too, btw.
<JamesJRH>I've also found 2 people that might be able to help. The first did work-for-hire and I nearly went into collaboration to get what I need, but then he got a job and was so busy that he didn't reply to my email that actually specified what I was thinking of.
<mark_weaver>and I think you done see the advantages that Scheme has over Haskell in this application.
<JamesJRH>The other person went silent a couple of weeks ago. :-/
<mark_weaver>s/done/don't/
<mark_weaver>but anyway, I've said my piece...
<fchmmr><JamesJRH> fchmmr: I need to backup, and I have a serious problem with managing my files to the point of disability. I want to write software to help me, but I don't know enough to write what I need.
<fchmmr>JamesJRH, it's really easy
<fchmmr>just use rsync, and put the command in your crontab
<JamesJRH>mark_weaver: I wish to have a 100% libre NixOS + LibreBoot on both my ThinkPad X60 Tablets, and 100% libre NixOS on my BeagleBone Black and PandaBoard ES. Eventually I'll conquer my phone too, which is why I've been contacting Fairphone and people behind Neo900 trying to do my best to persuade them to get RYF certification. I'm not something who thinks it's okay to have nonfree blobs in the kernel
<JamesJRH>.
<mark_weaver>Okay, I'm glad to hear it.
<mark_weaver>unfortunately, the Neo900 definitely won't be eligible for RYF based on my conversation with them. they are committed to using a wireless chipset that requires a non-free blob to be uploaded to it.
<JamesJRH>fchmmr: I don't know why I find it so hard, but I do. I'm seeing BtrFS and CoW as something that'll majorly help in how I plan to back things up, without worrying about incremental backups.
<jackdaniel>making backups on the same drive might be unwise
<JamesJRH>Currently I'm using BtrFS on my backup external hard drive, but not on this laptop yet (I've got a BtrFS partition that'll install NixOS 15.06 onto though).
<JamesJRH>I don't know how to make the kernel syscalls to control BtrFS's CoW though.
<mark_weaver>JamesJRH, fchmmr: and now, this conversation should probably move back to #libreboot :)
<mark_weaver>or maybe #nixos
<JamesJRH>mark_weaver: #librespeech is more general.
<JamesJRH>That's where I usually talk to fchmmr.
<mark_weaver>okay
<JamesJRH>Seeing as the people I was going to ask to work-for-hire seem to have become unavailable or gone completely silent, I should probably get on and bite the problems myself. I've attempted before (years ago, using Python), and failed, but this time I'm more experienced.
***hopses is now known as hospes
***init is now known as exio4
***exio4 is now known as init
***kmic is now known as kmicu
***jackdani1l is now known as jackdaniel
***rvernon is now known as Rastus_Vernon
***joehillen_ is now known as joehillen
***Gonbe is now known as _`_
***joehillen_ is now known as joehillen