IRC channel logs

2015-05-08.log

back to list of logs

<vmlinuz88>I'm looking for something to calculate the base32 checksum of a source tarball. How is it calculated for the packages in guix? is there a way to do it programatically with scheme?
<vmlinuz88>mark_weaver Do you know?
<mthl>"guix download" diplays the checksum no?
<mark_weaver>as does: guix hash <filename>
<vmlinuz88>even for packages that aren't in the repo?
<mark_weaver>yes
<vmlinuz88>Okay cool
<mark_weaver>any file
<mark_weaver>guix download also adds it to the store
<mark_weaver>but I usually use guix hash
<vmlinuz88>awesome, thanks!
<mark_weaver>np!
<vmlinuz88>also, fortune-mod doesn't appear to have a license or COPYING file, so I'm not sure what to put for the (license ) argument.
<mark_weaver>look at the copyright notices on the source files, and on the debian copyright file
<vmlinuz88>Debian copyright file says "This program falls under the BSD copyright", and it lists 4 clauses.
<vmlinuz88>so it would be bsd-4 then
<vmlinuz88>after updated the file, I get ERROR: Unbound variable: bsd-4
<vmlinuz88>when running guix refresh
<mark_weaver>vmlinuz88: games.scm imports (guix licenses) with a prefix of "license:", so from this module you must write: license:bsd-4
<vmlinuz88>mark_weaver Thanks. Also, I'm trying to test a conky package definition, and when running 'guix build conky --keep-failed', I get an error at the configure phase that says "Can't locate your x11 installation"
<zacts>hello
<vmlinuz88>I have X11 installed on my main system, and I also installed xorg-server package via guix, so the X binary is in my .guix-profile
<mark_weaver>vmlinuz88: guix builds are done within an isolated build container and chroot, so it doesn't matter what you've installed anywhere.
<mark_weaver>the only things available to the build are the packages listed as inputs.
<vmlinuz88>mark_weaver okay, makes sense now
<mark_weaver>what you need depends on what libraries the package uses. most modern graphical programs rely on some toolkit like gtk+, but maybe this just uses libx11 or something
<mark_weaver>configure scripts generated with autoconf create a 'config.log' file that contains details of what tests were done and what went wrong.
<vmlinuz88>Yeah, I figured that this might be the case earlier when I had the same issue with pkg-config, so I added pkg-config to inputs and included the module. I tried it with xorg and it failed, but I think I might have had 'xorg' in both the module declaration and the input. I just realized now that I need xorg for the module and xorg-server as the input.
<mark_weaver>well, it's unlikely that 'xorg-server' would be needed as an input
<mark_weaver>X programs typically need the libraries, but not the server itself
<zacts>hm... I still haven't yet made the full switch over to guix yet
<zacts>I'm still on debian
<zacts>I just need a few packages for school
<zacts>but eventually this will happen! :-)
<vmlinuz88>configure was looking for X. but it passed that portion of configure now, so it's working.
<vmlinuz88>hmm
<vmlinuz88>I'm going to try with the libx11 package as an input, instead of xorg-server
<vmlinuz88>yep, still works, so libx11 will suffice
<vmlinuz88>well this is strange...
<vmlinuz88>before I got it to work, it said "Checking for X...no", but now that it has passed, it says "Checking for X11"
<vmlinuz88>I mean, that's why I assumed it needed the X binary
<vmlinuz88>zacts guix is still in alpha stage
<vmlinuz88>good night all!
<vmlinuz88>mark_weaver Thank you for the help.
<mark_weaver>np, good night!
<rekado_>fixed GCJ. Will push the changes in a few minutes. This should fix a number of other packages.
<bavier>rekado_: there is some non-free software in the shogun source.
<iyzsong>civodul: hi! the 'etc-profile' will fails if union-build gave a read-only 'etc' directory (just 1 input contains 'etc').
<civodul>oh
<civodul>did that happen to you?
<iyzsong>yes, my root user few packages, only 'man-db' have 'etc' entry. so, it fails when try to install new packages..
<civodul>ok
<civodul>that's easily fixed i think, let me see
<vmlinuz88>mark_weaver Hello. I wrote a package definition for conky, but it is failing to build at configure phase. It complains about not having Lua51 (lua-5.1); but I have included the lua module as well as lua-5.1 as an input.
<vmlinuz88>the specific package it is looking for is 'lua5.1'
<davexunit>vmlinuz88: is pkg-config a native input? it might rely on that to find libraries.
<rekado_>bavier: it seems that you are right. I thought disabling it with "-DUSE_SVMLIGHT=OFF" was enough, but I suppose I should add a snippet to delete anything related to svmlight.
<vmlinuz88>davexunit, How do I set up pkg-config native?
<vmlinuz88>oh, wait
<davexunit>vmlinuz88: check other package definitions
<davexunit>an rgrep for "pkg-config" will turn up tons of examples
<rekado_>(I remember problems finding lua; wasn't here a problem with the pc file for lua?)
<iyzsong>also, if conky use pkg-config to detect lua, it may fails.. Our lua don't come with a '.pc' file now.
<iyzsong>yeah
<vmlinuz88>davexunit pkg-config is now a native input, but still get configure error complaining about missing lua5.1
<davexunit>vmlinuz88: you'll have to dig into the configure script to figure out how it's looking for lua
<vmlinuz88>okay
<rekado_>bavier: seems that it's just two files: src/shogun/classifier/svm/SVMLight.{cpp,h}
<rekado_>bavier: have you found anything else?
<bavier>rekado_: those are files I noticed
<bavier>I'm not sure whether we'd also want to remove mention of the SVMLight package from the documentation too.
<rekado_>ah, there are actually a few more files.
<rekado_>the README mentions them.
<rekado_>bah, the README is not correct. Some of the files listed as under a non-free license are actually released under GPLv3
<rekado_>so, it's these two files and functions inside #ifdef USE_SVMLIGHT in kernel/kernel.cpp
<civodul>iyzsong: xfce and gnustep don't provide share/xsessions/, so how does it work with slim?
<civodul>s/gnustep/windowmaker/
<iyzsong>civodul: xfce4-session does have it. And we could provide a windowmaker.session as same as for ratpoison.
<iyzsong>currently, windowmaker is hard-coded as 'auto-login-session' :-
<civodul>iyzsong: yes but aren't we supposed to use the 'xfce' meta-package?
<iyzsong>civodul: yes, xfce4-session is propagated by the 'xfce' meta package.
<civodul>ah i see
<civodul>good
<civodul>iyzsong: BTW, do you know why most icons are missing when i start Xfce?
<civodul>mark_weaver mentioned seeing many icons, but not me
<civodul>i tried adding dconf and gnome-terminal to the global profile but that didn't help
<iyzsong>have no idea, do you use the 'GNOME' icon theme? (in Settings->Apperance->Icons)
*civodul tries
<iyzsong>when try to build the cache in profile-hooks, I note the 'gtk-update-icon-cache' can only output the cache in-place. it's not clear to me how to implement it >.<
<civodul>ooh, it works well with the GNOME icon theme
<civodul>but that's not the default
<civodul>oh
<iyzsong>civodul: what will you do for the 'etc-profile'? make it a input to 'union-build' or '(mkdir "etc")' before 'union-build (require chanegs)'?
<iyzsong>if the latter, I think we can run '(mkdir 'share/icons/hicolor')', and run 'gtk-update-icon-cache' after the 'union-build' in build-profile.
<bavier>rekado_: thanks for looking into it
<iyzsong>a union-build hack: the output can containes pre-made directories, then inputs just merge with that. Not good obviously, but handy IMO.
<civodul>iyzsong: i've just pushed a fix for the etc/profile issue you reported
<civodul>iyzsong: re gtk-update-icon-cache, can't we use a profile "hook"?
<civodul>or you mean we make the profile's share/icons writable, and from there we run gtk-update-icon-cache?
<iyzsong>civodul: oh, that's good.
<iyzsong>civodul: yes
<civodul>still, it would be preferable to use a profile hook if that's possible
<civodul>it doesn't sound great to hard-code a gtk-update-icon-cache invocation in build-profile
<iyzsong>we can copy all the icons to the output, after cache, delete them. or patch gtk-update-icon-cache to allow output to a customized location.
<iyzsong>that's what I can think so far
<civodul>ok
<civodul>isn't there a gtk-create-icon-cache command or something like that? :-)
*civodul looks at https://developer.gnome.org/gtk3/stable/gtk-update-icon-cache.html
<iyzsong>nope ;-
<civodul>what about creating a hook that (1) creates the union of all the share/icons, and (2) runs gtk-update-icon-cache in that directory?
<vmlinuz88>iyzsong So if lua doesn't come with a .pc file, I would need to set the environment vars LUA51_CFLAGS and LUA51_LIBS. Since guix builds in a chroot, where would I set these variables to? I would have to pass them as arguments in the package definition.
<iyzsong>civodul: that's fine
<civodul>iyzsong: would you like to try that? :-)
<iyzsong>civodul: ok, but in a few days..
<iyzsong>vmlinuz88: you can pass them as #:make-flags or #:configure-flags or use 'setenv' in a #:phases
<civodul>iyzsong: sure, np!
<vmlinuz88>iyzsong, yes that's what I meant, I would have to pass them as #:configure-flags. But what should I set these variables to?
<iyzsong>vmlinuz88: ah ok, see audacity.scm for a example.
<vmlinuz88>izysong Thanks!
<iyzsong>sure :-)
<rekado_>vmlinuz88: you can refer to any input with (assoc-ref inputs "name") where inputs is bound in (lambda* (#:key inputs #:allow-other-keys) ...)
<rekado_>vmlinuz88: for make-flags you can use %build-inputs instead of "inputs"
<vmlinuz88>rekado_ gotcha
<rekado_>"%" denotes magic :)
<mthl>civodul: About the website, are you ok with a (guix-url "...")?
<civodul>mthl: yes, sounds good!
<mthl>civodul: ok :)
<civodul>mthl: and now you have commit access, so you can unleash your creativity ;-)
<civodul>(don't screw your exams though ;-))
<mthl>civodul: nice!
*civodul goes afk for a while
<mthl>civodul: actually there is no real challenge, it's just my "conscience professionnel" :)
***rohan_ is now known as ajnirp
<bavier>is there a way for 'guix build' to fetch the build log files from hydra?
<davexunit>no
<bavier>hmm
<mark_weaver>bavier: I've wanted the same thing
<bavier>yeah, seems like a useful option
<bavier>I wanted to check e.g. the configure log for the octave that hydra built
<mark_weaver>I can tell you how to find that on hydra's web interface if you like
<bavier>I did find it on hydra eventually
<bavier>thx though
<mark_weaver>okay
<paroneayea>well this should be... entertaining :) http://www.reddit.com/r/linux/comments/35ao11/canonical_has_announced_plans_to_switch_all/
<davexunit>oh boy
<davexunit>glad someone in the comments is mentioning nix, at least.
<cmhobbs_>i wonder what that will mean for trisquel
<davexunit>good question
<mark_weaver>wow, ubuntu is really going off the rails
<cmhobbs_>it's probably a little soon for me to react this way but i'll likely not continue to use trisquel if they follow suit. debian has been Good Enough on my home machines and would suffice on work provided rigs
<mark_weaver>trisquel should switch to being based on debian
<paroneayea>it's also interesting to compare nix (and guix) and snappy http://sandervanderburg.blogspot.com/2015/04/an-evaluation-and-comparison-of-snappy.html
<paroneayea>oops
<paroneayea>thought I was in #userops :)
<cmhobbs_>ha, sorry :(
<cmhobbs_>i'll keep the chat relevant here
<cmhobbs_>mark_weaver, isn't that what gnewsense does?
<paroneayea>no reason to apologize
<mark_weaver>well, yes
<cmhobbs_>and it's a package manager, so it's relevant :D
<paroneayea>yeah :)
<mark_weaver>I wonder how active gNewSense is these days
<paroneayea>cmhobbs_: it's def relevant, I just already linked that post in here a while ago
<paroneayea>worth linking again though
<paroneayea>it's a good post
<cmhobbs_>i just took the conversation off the rails :D
*mark_weaver goes afk
<alfplayer>hi Guix
<alfplayer>where is test-suite.log after guix system init from the Guix USB 0.8.1?
<mark_weaver>you only get test-suite.log when you "make check" in the guix source code tree
<mark_weaver>anyway, gotta run now...
<alfplayer>thanks
<alfplayer>so that ./test-suite.log mentioned in the output was deleted?
<davexunit>I don't understand.
<davexunit>you should dump the log somewhere
<davexunit>I don't see why a test suite would have run been run for guix
<davexunit>s/have run/have/
<alfplayer>davexunit: that test suite failed so the whole command failed
<davexunit>which test suite, though? why is it running a test suite?
<alfplayer>davexunit: "you should", so maybe I should use |& tee mylogfile.log
<davexunit>it's obviously trying to build some piece of software from source
<alfplayer>davexunit: many packages were compiled
<alfplayer>I used the standard installation instructions from the guide
<alfplayer>I'd tell you what it was but I couldn't undestand as I couldn't scroll back
<bavier>alfplayer: are substitutes enabled?
<alfplayer>I'll try to get an output with |& and tell more about this
<davexunit>yeah, you're not getting substitutes.
<alfplayer>(my first time ever with Guix)
<davexunit>if guix is downloading binaries, stop.
<bavier>I don't think substitutes were on by default for 0.8.1
<davexunit>ah, yeah then it's easy to just enable those.
<davexunit>otherwise it's incredibly likely that a system booted from a VM image cannot build everything from scratch.
<davexunit>er, disk image.
<alfplayer>bavier: I used this instructions, but I don't know if it answers your question
<alfplayer> https://www.gnu.org/software/guix/manual/html_node/System-Installation.html
<davexunit>you'll also need to enable substitutes. our next release has this automatically enabled.
<alfplayer>it will take about 4 hours before I can have the log again
<davexunit>alfplayer: see https://www.gnu.org/software/guix/manual/html_node/Substitutes.html#Substitutes
<davexunit>you'll need to run a command similar to 'guix archive --authorize < hydra.gnu.org.pub'
<alfplayer>davexunit: I should just run that in the USB shell? no chroot or anything different?
<davexunit>yeah
<alfplayer>I remember getting many .drv's in the output, so it was not enabled as explained in that link
<alfplayer>I can try that
<alfplayer>thanks
<bavier>alfplayer: let us know how everything goes
<alfplayer>bavier: ok, I hope so
<rekado->why is icedtea6 failing all of a sudden? It's not finding gcj/libgcj-config.h
<rekado->bleh :/
<civodul>bavier: it should be easy to hack 'guix build' to do that, though
<civodul>i think Nix does that nowadays
<bavier>civodul: cool
<mark_weaver>I'd like an option to make the substituter fetch build logs in addition to the build outputs
<civodul>but the substituter doesn't know about build logs, in the daemon/substituter protocol
<civodul>so that would rather be a 'guix build' feature
<civodul>rekado-: looks like gcj is back to life! http://hydra.gnu.org/eval/104121