IRC channel logs

2015-03-05.log

back to list of logs

<civodul>davexunit: if it's a GSoC, it'll depend on the candidate
<civodul>adding a few RPCs is surely easier
<davexunit>civodul: okay, so maybe I'll leave that detail out
<civodul>yeah
<civodul>alxsp: so which idea exactly? :-)
<civodul>the topic is definitely relevant
<civodul>alxsp: a project worth pursuing in that area is https://lists.gnu.org/archive/html/guix-devel/2013-09/msg00159.html
<civodul>pepperleekpotato: also for user help
<pepperleekpotato>Thanks civodul.
<civodul>alxsp: i have to go, but don't hesitate to drop by again here or on guix-devel
<civodul>good night/day!
<pepperleekpotato>Heya. I'm thinking of running the dhclient command - once - on/after boot. In which file/script should I put this?
*davexunit redownloads the world
<ph4nt0mas>sneek: later tell alxsp that repo on github is mine
<sneek>Got it.
***ljhms_ is now known as ljhms
<rekado>the libarchive build fails for me on i686.
<rekado>"test_option_b" has two failures.
<rekado>this blocks a couple of other packages, including qt, cmake, poppler.
<Sleep_Walker>grub build is failing for me, because it expects <freetype/ftsynth.h>, but there is only <freetype2/ftsynth.h>
<Sleep_Walker>I'd say I should patch grub to expect the other path, but I can also create symlink for freetype2 --> freetype as more general workaround
<Sleep_Walker>but not clean one
<Sleep_Walker>WDYT?
<Sleep_Walker>hm, gentoo fixes the grub as well - http://goo.gl/T9FpC1
<rekado>it's annoying when after a git rebase my stashes no longer apply cleanly. Git tries to be helpful and interleaves my stashed changes with committed changes, but that just makes it more difficult to rebase the stash.
<phant0mas>good morning guix
<civodul>Hello Guix!
<atheia>Good morning civodul!
<civodul>hey, atheia
<rekado>the runtime error in solfege is related to SVG support in pygtk.
<Sleep_Walker>morning
<rekado>something like "gtk.gdk.pixbuf_new_from_file('my_imagefile.svg')" fails in a python session where pygtk is loaded.
<rekado>maybe this can be fixed by propagating librsvg from python2-pygtk.
<iyzsong>rekado: what come to my mind is gdk-pixbuf's loaders.cache, I will check it first
<rekado>I added librsvg to solfege already, but that didn't fix it. I had to add libpng for png support and that worked without problems. Not sure why SVG support would cause problems.
<Sleep_Walker>fix for grub build sent to guix-devel
<civodul>ooh, Digital Mars people unhappy
<civodul>appeared in 2001 says http://en.wikipedia.org/wiki/D_(programming_language)
<civodul>where "ours" appeared in 2003
<civodul> http://lists.gnu.org/archive/html/guile-user/2003-04/msg00007.html
<rekado_>nice, we didn't have a naming discussion in a while ;)
<Sleep_Walker>backtrace http://sprunge.us/YITQ
<Sleep_Walker>happened during `guix system init -c 3 ~/config.scm /guix/'
<taylanub>when foo.pc says libfoo requires libbar and libbaz, does that mean I should add them as propagated inputs to libfoo?
<taylanub>the situation I'm facing is ffmpeg's ./configure, using pkg-config, saying 'libass not found', when it's in fact there, and looking into config.log indicates that the error was because actually harfbuzz or enca wasn't found, which libass requires
<iyzsong>taylanub: Yes, please make them 'propagated-inputs' of libass.
<taylanub>ok
<davexunit>lol the creator of the D programming language asked us to change the name of dmd
<rekado_>would a partial expansion of the name do? dmd --> daemad
<civodul>i thought about "sms" for "service managing services"
<civodul>or "systemg"
<civodul>:-)
<rekado_>I also thought "sms" would be a nice name.
<civodul>not easy to search for though
<civodul>it has the advantage of being at Levenstein distance 1 of "rms"
<davexunit>SMS is the text message protocol
<rekado_>:)
<rekado_>re "systemg": "2. People might think it is a dig at systemd." (to paraphrase http://lists.gnu.org/archive/html/gnu-system-discuss/2015-01/msg00047.html)
<civodul>folks!
<civodul>we are currently seeking advice about the name issue
<civodul>so please do not respond
<civodul>thanks
<Sleep_Walker>:D
<Sleep_Walker>guys, have you noticed the backtrace I posted like 3 hours ago?
<rekado_>gah! so much Java stuff to package ...
<davexunit>rekado_: that's how i feel about ruby
<davexunit>hundreds and hundreds of gems to package...
<rekado_>I'm fairly familiar with ruby but not at all with Java. All this ant and maven stuff with circular dependencies, download magic ... It's mind-numbing.
<davexunit>hoping some more ruby users come along to help now that the build system works decently.
<davexunit>plenty of circular dependencies in ruby, too.
<rekado_>I'll try to help you with packing some ruby stuff when I'm off work.
<davexunit>but no one ever notices them because no system does full builds of the entire ruby depedency tree, including running the test suite.
<davexunit>the "development dependencies" are where it gets circular.
<rekado_>with the Java stuff I'm working on right now it seems that I can't even disable tests because they are embedded as annotations and assertions.
<rekado_>so the whole thing just fails compilation unless all these test libraries are around.
<davexunit>civodul: just read the thread about the event loop for dmd and adding a repl server. do you think the cooperative REPL server will meet your needs?
<rekado_>It doesn't help that all these build recipes are written in XML. After a while my mind just goes blank.
<davexunit>I should delve into the dmd code sometime...
<davexunit>my experience writing Sly's event loop might be helpful.
<civodul>davexunit: your experience would definitely be useful
<civodul>and yes the cooperative REPL server is part of the answer
<civodul>but dmd still needs its own even loop thing
<davexunit>yes
<civodul>i would rather avoid doing the obvious imperative loop
<davexunit>I use a tail-recursive loop
<davexunit>and prompts to abort/resume the loop
<civodul>makes sense
<civodul>and to add a port to the poll set of the loop, you abort with the new port as an argument?
<davexunit>civodul: I don't deal with ports and poll sets, so I don't know about that part!
<davexunit>needs research
<civodul>ok
<rekado_>I would like to build packages that are not part of GNU Guix. I have a project directory $PROJECT containing ./rekado/packages/something.scm.
<rekado_>I cannot seem to let guix allow me to build packages from that module though, even when I add $PROJECT to GUILE_LOAD_PATH.
<rekado_>Ah, the manual says I should be using "-L"
<bavier`>rekado_: there's also GUIX_PACKAGE_PATH
<rekado_>right, found that afterwards. I was just confused as I had internalised the fact that package modules are really just ordinary guile modules.
*taylanub just can't figure out where to find libcdio-paranoia
<taylanub>aha, http://ftp.gnu.org/gnu/libcdio/
<taylanub>now what kind of freakish versioning is that? :(