IRC channel logs

2015-01-25.log

back to list of logs

***kmic is now known as kmicu
<DusXMT>Are there any expctations GSD has over the kernel? (ie. can I configure it to have only what I need, and to have it in-kernel)
<jgrant>As regarding the earlier conversation, I am not an expert, you should be able to use DMD to set kernel modules -- if that's what you're talking about.
<jgrant>At least some.
<DusXMT>No, I'm talking about building acustom kernel formyself, inheriting from the linux-libre package anc changing thebuild phase
<DusXMT>(okay, I need a new kb, this spacebar is not responding)
<jgrant>DusXMT: Like changing general build options, for Linux-libre?
<DusXMT>jgrant: changing the kernel config, so I can have a fine-tuned kernel
<jgrant>What is "config" in this sense? Linux.scm?
<DusXMT>I've already figured out how, I'm just asking whether GSD has any expectations over it (features that have to be enabled in order for the system to work)
<jgrant>Ah.
<jgrant>Not sure.
<DusXMT>jgrant: I think you've never built a custom kernel :P
<jgrant>I've never had a real reason to.
<jgrant>What's the general purpose, nowadays?
<jgrant>I'm sure there are usecases, but I can't see falling into one.
*jgrant looks at clock ...
<jgrant>I really should be in bed; It's edging to 4am already. :^/
<DusXMT>For GSD, it would be so that the ethernet driver gets loaded right away and so the networking service doesn't fail when it boots, because of a not-yet-loaded module
<DusXMT>And I just like having a fine-tuned kernel
<jgrant>DusXMT: Is that a more common issue? I think that's what is going wrong with my GSD install on my custom box.
<jgrant>Or the service is generally set up wrong, or etc, etc.
<DusXMT>There's a bug report about it
<DusXMT>it'sa common thingindeed
<jgrant>Okay, I'm going to be smart and actually plan to go to bed. Peace, hope you figure it out DusXMT. o/
<rekado>ardour and jack2 both use a build system made from waf, a meta build system.
<rekado>ardour and jack2 both are rather sane in that they use common build phase names (like "configure", "build" and "install"), but waf allows for any name.
<rekado>I wonder if the default case for waf deserves its own build system.
<rekado>essentially it's just the default build phase names passed as arguments to ./waf
<DusXMT>Because I'm still rather new to Scheme and Guix, could someone more experienced took at what I wrote and say if I'm doing it the right way? (it works, by the way, but I'm sure I could've done things better): http://paste.lisp.org/display/145369
<DusXMT>*look
<DusXMT>s/it the right way/things right/
<rekado>DusXMT: get-list-item already exists as list-ref
<rekado>DusXMT: to override arguments you may want to check out the gcc module which uses substitute-keyword-arguments instead of hacking your own.
<DusXMT>rekado: great, I'll look into both of those, thanks
<jxself>davexunit: I have a subtitle that made srt2vtt die.
<davexunit>jxself: oops! can I get a backtrace?
<davexunit>thanks for trying it out
<jxself>Even better, I can give you the subtitles: http://jxself.org/eng-subtitle.srt
<jxself>It's the subtitles from http://en.wikipedia.org/wiki/The_Cage_%28Star_Trek:_The_Original_Series%29 after having been OCRed.
<davexunit>jxself: thanks
<rekado>weird. I have a very simple package that makes guix build fail in the patch-source-shebangs phase: ERROR: In procedure stat: No such file or directory: "./config.guess"
<davexunit>jxself: subtitle 84 is blank
<davexunit>is that valid SRT?
<jxself>I believe so. I'm trying to determine.
<davexunit>okay, I can change things a bit to allow it.
<jxself>I checked the original and subtitle 84 there says Engage.
<jxself>Probably an OCR error that it was missed I guess? Hmmm.
<davexunit>sorry, 85
<davexunit>jxself: I have a patch to push, if indeed a blank line is valid
<davexunit>reading http://www.matroska.org/technical/specs/subtitles/srt.html
<jxself>I found another blank one and fixed that and another where the wrong letter was identified (an L was changed to a 1)
<jxself>Overall the OCR processed seems to have worked well.
<davexunit>judging from the spec, I think that a blank line is useless, but valid
<davexunit>so I will push up this patch
<davexunit>jxself: commit f891b76 has the fix. it worked for the subtitles you gave me.
<jxself>Thank you good sir.
<jxself>I've also added the missing text too.
<davexunit>cool :)
<jxself>I also had another idea.
<jxself>I ran the program with no options and it just sat there. Ideally, when invoked with no options it should print out name/version/usage details on standard out and then exit successfully?
<davexunit>hmmm, that's a tricky one.
<davexunit>because doing that would eliminate a potential use case: piping input in and outputting to stdout
<davexunit>wget -O - http://jxself.org/eng-subtitle.srt | srt2vtt
<jxself>Ah ha. I hadn't thought of that.
<davexunit>so, I agree about the usability problem, but I don't know a good way to fix it right now without harming functionality.
<davexunit>maybe forcing '-o' to be specified?
<davexunit>and if you want stdout, use '-o -' ?
<grasshopprWhoppr>some programs normally sit and wait for input
<davexunit>yes, grep does it.
<davexunit>among others.
<_`_>or cat
<davexunit>meow.
<_`_>:3
<davexunit>jxself: have you encountered any other blocker issues? if it works well enough for your OCR'd subtitles, I'd say it's good enough to clean up and release.
<jxself>I suppose it's time to pull your updated version and try again. Just a moment...
<davexunit>before I release, I want to write proper modules for the procedures so that it may be used as a library, and give better backtraces when it blows up :P
<jxself>Yeah, it seems to work just fine.
<davexunit>yay!
*jxself hugs davexunit
<davexunit>always cool to write something that someone else actually finds useful.
<jxself>Yes, and that I'll use probably every day.
<jxself>Or at least most days.
<davexunit>keep reporting bugs ;)
<davexunit>I'll try to make a proper release soon and make a guix package.
<davexunit>packaging for other distros will be left up to interested parties.
<mark_weaver>DusXMT: yes, there are some important modules needed by guix-daemon. one requirement is: CONFIG_DEVPTS_MULTIPLE_INSTANCES=y
<mark_weaver>you also need support for several kinds of namespaces
<mark_weaver>I don't know if you need all of these, but: CONFIG_NAMESPACES=y
<mark_weaver>CONFIG_UTS_NS=y
<mark_weaver>CONFIG_IPC_NS=y
<mark_weaver>CONFIG_USER_NS=y
<mark_weaver>CONFIG_PID_NS=y
<mark_weaver>CONFIG_NET_NS=y
<mark_weaver>these are the most likely ones to be missing, I think.
<mark_weaver>this should really be documented, obviously.
<DusXMT>mark_weaver: thanks
<mark_weaver>welcome!
<DusXMT>By the way, there seems to be a bug in the most recent netpbm package, the checksum is incorrect, I've submitted a bug report but it didn't come in yet
<DusXMT>s/checkum/source checksum/
<mark_weaver>jgrant: it's good that you started with "I am not an expert", but that's an example of a question that you probably shouldn't have tried to answer at all.
<mark_weaver>if everyone on this channel jumped in to try to answer every question, even if they had no clue, do you know what this channel would be like?
<mark_weaver>DusXMT: okay, thanks for reporting it. it turns out that 'netpbm' is only package that uses the 'svn-fetch' origin method, so I'm guessing that it's not deterministic (on the assumption the Andreas tested 7d8379a76 properly before pushing it).
<DusXMT>mark_weaver: also, the link that saffronsnail claimed to be down works again, https://lists.gnu.org/archive/html/bug-guix/2015-01/msg00035.html ; the server was probably temporarily down
<mark_weaver>DusXMT: actually, it turns out that it's Andreas's site. he put the tarball there since upstream doesn't provide one. I think he put it back because of the bug report.
<mark_weaver>(at some point it got removed from his site)
<mark_weaver>anyway, I closed that bug after Andreas changes the package to use svn-fetch, but maybe we need to reopen it.
<mark_weaver>well, nevermind that, you already created a new bug report.
<mark_weaver>DusXMT: it's strange that your bug report is still not visible. it's been about 20 minutes
<mark_weaver>(or more)
<DusXMT>mark_weaver: I've sent it several hours ago... probably because I changed to a different (non-gmail) webmail provider, and I haven't yet passed the anti-spammer test
<mark_weaver>makes sense
<DusXMT>Is there any way to check that list? Or can only Ludo do that?
<mark_weaver>oh, I see the problem. Andreas updated to a newer version of netpbm in 03c2776535, but didn't update the hash.
<DusXMT>Oh. In that case, feel free to obliterate my bug report once it arrives :)
<mark_weaver>DusXMT: that's an area of ignorance for me, how spam filtering works on incoming bug reports.
<mark_weaver>I don't have admin access to the mailing lists, anyway. I guess Ludo is the one to ask.
<jxself>davexunit: Oh, and after all that it appears that VLC doesn't have support for WebVTT subtitles.
<davexunit>jxself: :(
*jxself sighs
<davexunit>well, if you ever use HTML5 video...
<jxself>Yeah.\\
<jxself>My hope was to include them inside the file though.
<davexunit>yeah, that's a bummer.
<jxself>Well, at least they are in there so whenever they can be used...
<rekado>I find this very puzzling that the patch-source-shebangs phase fails because of the attempt to stat a file that does not exist (config.guess)
<rekado>no, actually, the file *does* indeed exist.
<rekado>hmm.
<rekado>ah, the file is a symlink to some out-of-tree file. Yuck!
<civodul>Hello Guix!
<DusXMT>Hi Ludo!
<civodul>mark_weaver: your suggestion re grub.cfg makes sense, yes
<civodul>i'm not sure what effect --class has, if any
<civodul>but for the rest, yes
<civodul>oh http://paste.debian.net/142098 is by alezost
<DusXMT>civodul: it's useful for themes, they can display different classes of entries differently
<civodul>i see
<civodul>like HTML classes basically
<civodul>i guess it's a good idea to use them
<alezost>civodul: hi, "--class"-es do not have much effect; I just use them in my "grub.cfg" for no particular reasons
<DusXMT> http://www.gnu.org/software/grub/manual/html_node/menuentry.html#menuentry
<mark_weaver>rekado: in cases like that, we often use a 'snippet' to remove the dangling links.
<mark_weaver>well, sometimes we've used phases too, but snippets seem a bit nicer for this.
<mark_weaver>one relevant reason to choose between phases or snippets/patches is that the latter methods will affect the source code returned by "guix build -S <package>", and the former won't.
<mark_weaver>in this case it doesn't matter much
<jgrant>I'm having an issue trying to run skribilo from guix, on my hostmachine. When I try to run something .guix-profile/bin/skribilo hello.skb -o hello.pdf it complains that setlocale in an unknown argument.
<civodul>jgrant: you probably need to define $LOCPATH to point to your libc's locales
<mark_weaver>civodul: there is an issue with LOCPATH though: I don't see how to make my login bash initialize locales properly.
<mark_weaver>it apparently tries to load locales before loading the RC files.
<mark_weaver>so, on my non-GSD machines (novena and yeeloong), I always see errors about locales when logging in.
<mark_weaver>(and my login bash presumably has broken locales)
<civodul>mark_weaver: one could use pam_login to define LOCPATH
<civodul>(not very convenient, but...)
<mark_weaver>but isn't that system-level configuration, whereas my locales are per-user?
<mark_weaver>I don't know what I'd configure LOCPATH to in PAM on a non-GSD system that would be reasonable.
<jgrant>I just woke up a few ago ... am I doing something blatantly wrong and just not noticing it? "export LOCPATH=$rootdir/usr/lib/locale/"
<mark_weaver>anyway, I have to go afk for a few hours. happy hacking!
<jgrant>mark_weaver: o/
<jgrant>I mean, LC_ALL & LOCPATH are all pointing to /usr/lib/locale
<jgrant>Does Guix not use the hostsystem's paths, at all? Am I supposed to be defining somewhere outside of the typical environment variables on my host system?
*DusXMT guesses he'll have to resort to expression->initrd if he wants to boot without loading any modules... time to get the hands dirty, might as well learn some more scheme-ishness
*jgrant is considering just going to the "extreme" solution and doing what he was planning ultimately and just installing Guix on my mainbox.
<jgrant>The big annoyance is the lack of support of ISOs.
<jgrant>I think I'm just going to try to circumvent my issues, by running Finnix installing Guix via finix, then boostrapping an install to the local system.
<civodul>mark_weaver: good point
<civodul>mark_weaver: i guess there's a chicken-and-egg issue when using a Guix bash as the login shell
<civodul>perhaps a "trampoline" is needed
<rekado>the currently available version of netpbm does compile but it has one test failure.
<rekado>I'm on commit a6ae52fe142781e236901add1461fdbf80420215
<rekado>(That's the commit where Andreas fixed the hash.)
<civodul>uh
<civodul>might be worth reporting it to the list
<rekado>will do
<civodul>there's indeed a number of failures at http://hydra.gnu.org/jobset/gnu/master#tabs-evaluations