IRC channel logs

2014-09-06.log

back to list of logs

<davexunit>later everyone
<mark_weaver>good night!
<tadni_>davexunit: Happy belated birthday.
<svetlana>'bind' isn't packaged i think?
<jxself>Seems not. Perhaps add it to the wishlist?
<svetlana>dunno I don't think I have an account...
<svetlana>yea apparently I do... added it in
*davexunit is going to push 30 python packages to master
<davexunit>packages pushed.
*ijp claps politely
<davexunit>heh
<svetlana>you can also clap impolitely? I didn't know that's possible :)
<ijp>it's all about timing
<ijp>and volume
<Tsyesika>morning :)
<svetlana>hi
<DusXMT>'ello
<Ulrar>guix pull really need a progress indicator of some sort
<DusXMT>Ulrar: try --verbose
<DusXMT>it should be toggled by default imho
<Ulrar>DusXMT: Is it safe to ^C and re-run it with that ? It's been running for hours
<DusXMT>Yup
<DusXMT>I think it's doing more than just compiling the .scm files, it's probably building the toolchain and stuff, did the same for me the first time I did it on a fresh system
<Ulrar>Ha yeah, that's better now
<Ulrar>thanks
<Tsyesika>morning :)
<Tsyesika>right i shall try and fix the usb drive again to try guix :P i am determined!
<Tsyesika>couldn't get it to build on os x
<DusXMT>Tsyesika: perhaps you could try something like a Live CD if it still doesn't work and build guix on that?
<Svetlana>there is a released image; why are you trying to build if i may ask? :)
<Tsyesika>DusXMT: don't have any CD drives :P
<DusXMT>that reminds me of my netbook...
<Tsyesika>err well i got a macbook (i know i know - evil and stuff) and my thinkpad has an ultrabay inplace of the hdd so i can have two hdds in
<Tsyesika>*inplace of the cd drive
<Ulrar>And it doesn't boot on usb ?
<Tsyesika>it does, i just donno where my usb drive is
<Tsyesika>:P
*Tsyesika is disorganised
<DusXMT>Then you need to boot with a floppy ;)
<Ulrar>Yeah, I had to look for it too
<Ulrar>So used to have .iso files
<DusXMT>Mixed news: Abiword finally builds (the executable itself) and it is NOT statically linked (which is great), but the opendocument plugin doesn't build, but I don't think fixing it will be a big problem (hopefully)
<leth>could someone highlight me please?
<mark_weaver>leth: what do you mean "highlight me" ?
<mark_weaver>DusXMT: sounds like good progress!
<mark_weaver>Tsyesika: I wouldn't expect Guix to work on OS X. It targets GNU systems only.
<DusXMT>mark_weaver: I figured out what to do now, now to write a long patch that fixes the build systems of all plugins
<leth>mark_weaver: well you just did, my irc client highlights when people address me over irc, this is commonly known as highlighting.
<leth>addresses
<leth>or address?
<mark_weaver>ah, right. I wasn't familiar with that term, but I know what you mean.
<mark_weaver>leth: "address" is proper there.
<mark_weaver>if the subject was singular (e.g. if you change "people" with "someone"), then it would be "addresses"
<mark_weaver>s/with/to/
<leth>ah yes, thank you.
<mark_weaver>welcome!
<Ulrar>mark_weaver: You'll often see it written just hl too
<mark_weaver>*nod*
<Tsyesika>mark_weaver: sure :)
<mark_weaver>sneek: later tell cantstanya: regarding ZFS, I don't see how we could include it because its license is not compatible with the license used on Linux (GNU GPL v2), and therefore I think it's not legal for us to distribute a Linux kernel that includes ZFS.
<sneek>Got it.
<DusXMT>How about Reiser4? I heared it's a pretty good filesystem
<DusXMT>it doesn't come in stock kernels though
<mark_weaver>DusXMT: I don't see a reason why we couldn't include it, but probably not in our default kernel.
<mark_weaver>(in general, we try to stay close to upstream)
<DusXMT>okay, patch ready, now to wait 2 hours to see if it worked...
<davexunit>hey #guix
<davexunit>so, I have minetest packaged. yay!
<davexunit>however, the actual main minetest game data comes separately, since the minetest engine is modular.
<davexunit>I wrote a package for this, too.
<davexunit>my problem is..
<davexunit>that minetest searches a path like /usr/share/minetest/games for game types.
<davexunit>I would like it to search /share/minetest/games within the user's profile. I don't how to accomplish this.
<DusXMT>davexunit: That doesn't sound too hard, you have to track down where the hardcoded prefix directory comes from and change it to use the one it was built with
<DusXMT>then, just write a patch to do the change after unpacking and viola
<davexunit>DusXMT: it's not that easy, because the game data is *not* in that directory
<davexunit>it's a separate item in the store, and it's totally optional.
<DusXMT>hm... you're right
<davexunit>afaict there's no env var that I can change to make it work, so I might be screwed.
<DusXMT>Is it written in C? You might be able to use getenv ("HOME") and then add .guix-profile/ to it and use that instead of the hardcoded /usr
<davexunit>DusXMT: that's brittle. what if your profile is located elsewhere?
<DusXMT>hm... Ideally, one would implement a new command-line option to specify the path to the game
<DusXMT>If you do that, you might even want to submint the patch upstream and get it merged
<davexunit>an env var would be ideal
<davexunit>so I could use guix's native-search-paths package field to specify it
<ijp>it won't help you at the moment, but you could ask the developers to add it
<mark_weaver>davexunit: you'll probably have to patch the source code to lookup an environment variable instead of simply using a constant string literal.
<mark_weaver>either a separate environment variable for this game, or else $HOME and then append /.guix-profile/share/minetest/games
<mark_weaver>it might actually be best to first try a separate env var, or else fall back to $HOME/.guix-profile/share/minetest/games
<davexunit>mark_weaver: talking to the devs right now about a patch of this nature.
<davexunit>:)
<mark_weaver>the thing is, users probably won't know to set the env var, so the fallback is good, but the fallback won't work if the game is installed system-wide (in /run/current-system/profile) or if the user wants to use an alternate profile.
<mark_weaver>davexunit: ah, good!
<davexunit>minetest will also search ~/.minetest for this data, so I don't know if I really need the fallback, but maybe.
<mark_weaver>I suppose being able to set a search path would be ideal
<davexunit>I'm going to focus on a patch I can submit upstream.
<mark_weaver>sounds good
<davexunit>and use the 'native-search-paths' field in the guix package to output the correct env var setting to the user.
<mark_weaver>the reason I suggest a search path (with potentially multiple dirs) is because it would be good to allow both $HOME/.guix-profile/share/... and /run/current-system/profile/share/...
<davexunit>agreed.
<davexunit>or whatever profile dir the user is using!
<mark_weaver>to be searched, in case some games are installed system-wide, and others just per-user. (and for guix, both of those should probably be the fall-back path if the env var is not set)
<philed>Super beginner question: what's the best way to work with guile in emacs in guix? I was looking to try gds, but I can't find it.
<davexunit>philed: geiser
<philed>davexunit: Thanks. Is it competitive with swank?
<davexunit>I haven't really used swank, but it fills a similar niche.
<davexunit>I really like geiser.
<philed>Well, at least I can get it working!
<Ulrar>Mh, my guix pull failed after a day of compiling because symlink doesn't exist ?
<DusXMT>Ulrar: mkdir -p ~/.config/guix
<DusXMT>Ulrar: I, and one another person had the same problem
<DusXMT>It shouldn't last as long this time, since it only needs to compile the guix .scm files and nothing more
<Ulrar>All right, that worked, thanks
<Ulrar>It's updating into /root, so it's updated only for root ?
<DusXMT>Did you run the command as root?
<DusXMT>if yes, then yes, it only installed it for root. But you can cheat the system, you can $ mkdir -p ~/.config/guix in your home directory and create a link ~/.config/guix which points to where /root/.config/guix/latest points to
<DusXMT>s|create a link ~/.config/guix|create a link ~/.config/guix/latest|
***Sleep_Walker is now known as protein-prophet
<mark_weaver>Ulrar: generally, when you install packages with guix (guix package -i ...) you should run that command under your normal user id.
<mark_weaver>guix-daemon should be run as root though.
<mark_weaver>ditto for guix pull
<mark_weaver>sorry, I mean that "guix pull" should normally be run as your normal user id.
<mark_weaver>s/as/under/
<Ulrar>But if I run it as my normal user, won't root be using an outdated version of guix that can't parse /etc/config.scm ?
<mark_weaver>ah yes, indeed you should run it as root to update commands that will be used by root, and that includes guix system reconfigure
<mark_weaver>sorry for the confusion.
<Ulrar>I guess there is no reason to run an outdated version of guix anyway, so best update for everyone ?
<mark_weaver>probably so
<mark_weaver>since I work on guix development, I always run guix from git working directory.
<mark_weaver>so I never run "guix pull", and even when I run "guix system reconfigure", I have root run the copy from my git checkout.
<Ulrar>I see
<mark_weaver>I put a little script in ~/bin/guix that does: exec /home/mhw/guix/pre-inst-env guix "$@"
<Ulrar>What exactly is pre-inst-env ? see that from time to time in the doc
<mark_weaver>the other nice thing about doing it this way is that I can carry local patches to guix, and git provides nice tools for rebasing my local changes onto the latest upstream guix.
<mark_weaver>Ulrar: it's a script that sets a bunch of environment variables (e.g. PATH and GUILE_LOAD_PATH) so that guix can run from the build directory instead of the copy installed by "make install".
<mark_weaver>in fact, you don't have to run "make install" at all.
<mark_weaver>however, beware that even when using pre-inst-env, it will still use the files from ~/.config/guix/latest if they exist. that's the directory that's populated by "guix pull".
<mark_weaver>if you want to switch to the git method, then I'd recommend deleting that directory
<Ulrar>Good to know, thanks
<civodul>Hello Guix!
<davexunit>hello civodul
<civodul>hey
*civodul -> zZz