IRC channel logs

2014-09-03.log

back to list of logs

<davexunit>how does one generate a hash for software that is fetched from a git repo?
<davexunit>I checked out the relevant tag, and ran 'guix hash -r .' in the project root
<davexunit>but that doesn't generate the right hash.
<davexunit>a-ha, got it. need to download a snapshot of the repo sans the .git directory.
<tadni_>davexunit: What are you working on? :^P
<davexunit>tadni_: seeing how far I can get packaging mediagoblin
<tadni_>davexunit: Aw, neat! :^)
<davexunit>just submitted a patch that adds a postgresql package. that one was as easy as it gets.
<davexunit>has anyone had to deal with such an error: ZIP does not support timestamps before 1980
<tadni_>davexunit: No, never ... that's strange. What is complaining, guix proper?
<davexunit>it's a python script
<davexunit>guix sets all timestamps on files to the UNIX epoch
<davexunit>ZIP requires timestamps > 1980
<davexunit>I wrote packages for 5 python libraries... that's all the tedium I can handle right now.
<civodul>Hello Guix!
<sneek>civodul, you have 1 message.
<sneek>civodul, artyom-poptsov says: Yes, my FTP server was down due to a NAT problem. Should be fixed now. BTW, thanks for pointing that out.
<Svetlana>Hello.
<Svetlana>turns out I can enable virtualisation in this bios and loading kvm and kvm-intel modules does not return errors; disk image build complains that it "Could not access KVM kernel module: Permission denied"
<civodul>hi Svetlana
<civodul>make sure /dev/kvm is accessible, as noted in the manual
<civodul>look for /dev/kvm at http://www.gnu.org/software/guix/manual/guix.html#Invoking-guix-system
<tadni_>Hrm, trying out guix.el -- and running guix-all-available-packages gives me "condition-case: Couldn't start Guix REPL. Perhaps the port 37246 is busy."
<tadni_>Well, the guix repl says "ERROR: no code for module (guix config)" -- odd.
<civodul>looks like a %load-path issue
<civodul>can you check the value of %load-path under *Guix REPL*?
<tadni_>*Guix REPL* looks to be read-only.
<civodul>hmm it shouldn't be
<Svetlana>"/dev/kvm device node must exist and be readable and writable by the user and by the daemon’s build users. " means I should make it world writable? or add myself & build users to a group and chown it to that group, chmod 660?
<civodul>yes, you could create a "kvm" group and add those users to that group
<civodul>or just chmod 666 /dev/kvm
<tadni_>Hm, well not enough time the morning to mess with it anymore. Classes then nap, before I can play some more ...
<tadni_>Oh well, off to classes. Peace for now #guix. o/
<alezost>tadni_: guix.el from <https://github.com/alezost/guix.el> is a bit outdated. Most likely you didn't install Guix in a default site directory (/usr/share/guile/site/2.0/guix/) so (guix config) module is not found. "guix.el" will be merged into guix git repo very soon and this problem will disappear.
<alezost>civodul: I noticed a couple of little things that should be fixed, so the merging is postponed for a day.
<Svetlana>i did chmod 666 /dev/kvm; i now get "ioctl(KVM_CREATE_VM) failed: 16 Device or resource busy"
<Svetlana>:o
<civodul>alezost: sure!
<civodul>Svetlana: are there several concurrent qemu processes?
<alezost>tadni_: if you really wish to try it now, you can replace "(%site-dir)" with your guix directory (where "config.scm" is placed) in "guix-helper.scm"
<Svetlana>yes there were, thanks
<Svetlana>where does disk-image thing write the image /to/ ?
<Svetlana>it did manage to exit without errors now
<civodul>the image is written to the store
<civodul>'guix system disk-image' write the name of the result at the end
<civodul>the file name, that is
<Svetlana>I was using "./pre-inst-env guix system disk-image --image-size=800MiB gnu/system/install.scm" and I'm not sure where specifically it wrote it to
<civodul>Svetlana: to /gnu/store
<civodul>just re-run it, and it will print the file name again
<davexunit>slow and steady... http://paste.lisp.org/display/143592
<sneek>Welcome back davexunit, you have 1 message.
<sneek>davexunit, nalaginrut says: could you elaborate the issue you mentioned about Artanis?
<Svetlana>oh! the last line :)
<Svetlana>thanks
<civodul>davexunit: woow, sounds cool!
<civodul>indeed the next step will be to come up with an 'operating-system' definition
<civodul>that would be great
<DusXMT>just for the sake of an example, here's mine: http://pastebin.com/9kEKqsBt
<DusXMT>I wonder, can one arbitrarily import/export store entries with guix archive?
<DusXMT>guix archive --export only seems to take guile package structures into consideration
<davexunit>civodul: I have ~30 more python libraries to package.
<davexunit>if/when I finish this, I'll have a big patch set. :)
<civodul>ouch :-)
<DusXMT>I'd like to copy qemu-headless-1.3.1 over to a different machine, as it takes a while to compile, yet it says the package doesn't exist. But guix sysstem reconfigure and init both use it
<davexunit>civodul: the pains of the bleeding edge ;)
<DusXMT>If I try without the version, it gets 2.0
<davexunit>I packaged 7 libraries yesterday, I think.
<paroneayea>hi, everyone :)
<paroneayea>I guess it's time for me to set up a VM for guix
<davexunit>paroneayea: yay!
<civodul>grr, my daughter pulled the router's plug
<civodul>maybe that's a sign that i should stop hacking for a while ;-)
<civodul>davexunit: i had that idea of writing a 'guix template' tool, which would generate a template package definition from a source tarball
<civodul>so for setup.py things, it would DTRT
<civodul>otherwise it would also scan things like configure.ac for hints
<davexunit>civodul: hehe, how old is your daughter? I live with a 4 year old.
<civodul>3.5
<davexunit>I'm surprised my computers haven't been broken yet. :)
<davexunit>sometimes I leave a laptop unattended on the couch
<civodul>that's risky :-)
<davexunit>yup!
<civodul>we've never had problems with the laptops so far
<davexunit>maybe I should try writing a hacky template tool for pypi packages.
<civodul>yeah, dunno how many packages are needed for it to pay off
<davexunit>I'd still have to fill out things like the synopsis and description by hand.
<civodul>yes
<davexunit>I feel that for ~30 it might be worth it to reduce the workload.
<civodul>probably
<civodul>it would also give you a better feeling of achievement ;-)
<davexunit>yes indeed
<davexunit>just generating the boilerplate, downloading the tarball and hashing it would be a big help.
<davexunit>yay, pypi has a JSON api
<davexunit>tonight, I shall harness guile-json and guile's http client for great justice.
<civodul>yup
<civodul>it's nice when there are modules here and there that you can just glue together
<civodul>(something Python developers take for granted, i suppose)
<davexunit>python has the jackpot for that stuff
<Svetlana>davexunit: look after dust -- couches and even tables like it
<davexunit>just another reason why picking a general purpose programming language was the right way to go.
<civodul>yes
<davexunit>this is all so exciting
*civodul shuffles modules around
<civodul>Steap: BTW 'guix lint' is pretty cool
<civodul>do you plan to patch all the stuff it reports? :-)
<civodul>ttyl!
<DusXMT>I wonder, what for exactly does guix system init and reconfigure need qemu-headless?
***jxself_ is now known as jxself
<alezost>civodul: should I push a single commit (with guix.el) into master or rewrite emacs-ui branch with it at first?
<civodul>alezost: either way is fine
<civodul>you can push directly to master
<davexunit>it's happening!
<civodul>:-)
<alezost>civodul: ok, have been pushed to master, thanks. I think emacs-ui branch can be deleted now (?)
<davexunit>WOOOOOOOOOOOOOOO!!!!!!
*Tsyesika needs to get around to trying guix :)
<alezost>davexunit: yeah, now it needs to be tested to be sure I didn't mess it up :-)
<davexunit>hopefully I can try it out tonight
<davexunit>but my main mission is to write a pypi->guix script. :)
<davexunit>alezost: congrats on the merge. you've worked really hard on guix.el. I'm excited to try it out again.
<davexunit>I want to model my guix-web project after guix.el
<davexunit>also, guix.el is a really interesting application of geiser.
<davexunit>I didn't really know that you could use geiser in that way.
<alezost>davexunit: thanks, the scheme side of "guix.el" is not very good though
<alezost>davexunit: in what way?
<davexunit>programatically evaluating scheme code through geiser.
*tadni_ is slowly edging away at this "emaculate" GNU and Emacs config. He'll probably will get stumpwm packaged before he releases it though. Ratpoison is now the default over guile-wm, because guile-wm kept crashing ocassionally.
<civodul>alezost: wo0t!
<civodul>alezost: yes, you can delete emacs-ui
<tadni_>alezost: Congrats.
<alezost>davexunit: ah, I just used `geiser-eval--send/wait' function for that
<alezost>tadni_: thanks
<davexunit>I really need to read guix.el to see how it deals with some packaging situations. like having more than 1 package with the same name and version. I remember it being discussed on the list.
<civodul>and yes, a lot of hard work, congrats!
<civodul>davexunit: you have yet to mail the list about guix-web, no? :-)
<davexunit>civodul: heh, maybe someday.
<civodul>heheh
<tadni_>Ah, so guix.el is in the emacs packgae now?
<davexunit>tadni_: no it's part of guix
<civodul>alezost: would you like to prepare a news entry on Savannah?
<tadni_>davexunit: I'm saying the emacs package definition, for guix.
<davexunit>no, I don't think so.
<davexunit>guix.el gets installed with the guix package, to the directory where emacs looks for extensions
<alezost>civodul: thanks, emacs-ui branch is deleted. I have no idea how to do that (Savannah news)
<civodul>alezost: just log in on https://sv.gnu.org/p/guix, and then go to News -> Submit
<alezost>davexunit: object-address is used as a unique identifier for packages
<civodul>alezost: the text can use some markup: https://savannah.gnu.org/cookbook/?func=detailitem&item_id=125
<civodul>(if you don't want to bother, i can do it)
<davexunit>alezost: ah, okay. thanks!
<davexunit>alezost: have you seen guix-web? it's guix.el for the web: http://media.dthompson.us/mgoblin_media/media_entries/22/Screenshot_from_2014-08-15_091343.png
<alezost>davexunit: yes, I saw it but I didn't try to use it
<davexunit>that's okay. it's not particularly usable yet. :)
<civodul>ooh, it can install things now, cool!
<davexunit>(it's a hack)
<davexunit>you can only install a single package.
<davexunit>at a time.
<davexunit>it's flawed because the entire installation process happens while the http request is open.
<tadni_>So ideally, we are 2/3rds of the way or-so for frontends already. A web and/or slickish interface, a emacs interface, and we "need" (I've heard expressed desire for) a ncurses based one. :^)
<davexunit>a GTK interface would be desirable, too.
<civodul>yes
<tadni_>davexunit: Like a proper one, or maybe just like a wrapper of sorts, for guix-web?
<davexunit>I don't see guix-web being very useful once a GTK interface exists.
<davexunit>but making guix-web has been fun, anyway :)
*tadni_ looks into see when the last release of guile-gnome has been.
<davexunit>someone in #guile is working on modernizign guile-gnome
<civodul>davexunit: guix-web hacking is gonna be even more fun when ijp completes their scheme2js compiler :-)
<civodul>or ijpman i should say
<alezost>civodul: thanks, I am going to write the news (but when I do something I always have a feeling that I do it wrong)
<jxself>scheme2js sounds interesting.
<davexunit>civodul: that will be very exciting since the majority of the guix-web code will probably end up being javascript
<tadni_>So, two bigish gui applications conciveably on the horizon would be a "proper" gui installer, a'la Fedora or Ubuntu -- and an "app store" like interface for browsing Emacs packages. I wonder for the latter if we could arrange packagekit support for/from GNOME and just use gnome-software?
<civodul>alezost: you must be a perfectionist :-)
<civodul>which is good IMO
<davexunit>tadni_: packagekit's architecture won't work for guix, as-is.
<civodul>indeed
<davexunit>and I don't think the devs were keen on changing it for guix.
<tadni_>davexunit: Yeah, that's what I expected. I wonder how much of pain it would be just to get guix working in it, sans the packagekit ... or if it would really be a lot easier/smarter to make yet-another-gui-application-browser.
<davexunit>a frontend using guile-gnome would be best, imo.
<civodul>i think so
<civodul>all the cleanup/factorization done for guix.el will be beneficial to other UIs
<davexunit>agreed, I'm excited to check out what has been made easier.
<davexunit>figuring out how to install a package was pretty tough.
<tadni_>davexunit: I suppose. If GNU distro proper, gets big enough -- maybe some GNOME devs will look into eventually, idk. :^P
<civodul>davexunit: there's probably still room for improvement, but it's a lot better now
<davexunit>:)
<davexunit>I'll try tackling bulk package installation/removal/upgrade in guix-web sometime
<DusXMT>davexunit: does guix-web require an HTTP server, or can it simply be run by opening the page in a browser in a normal directory?
<jxself>tadni_: In theory they're supposed to care now since GNU packages are supposed to work well together and whatnot. I think there's a blurb about that in the Maintainers document.
<civodul>in theory...
<davexunit>DusXMT: guix-web uses guile's HTTP server. you can just start guix-web and browse to localhost:8080
<civodul>alezost: i have to go, but i'll "approve" the news item tomorrow if it's there
<civodul>good night/day!
<jxself>There is news? :)
<tadni_>civodul: o/
<civodul>guix.el!
<jxself>Ah ha - Yes, definitely something that should appear on planet.gnu.org.
<tadni_>jxself: Yeah -- I'm more interested to see the general reaction of the GNOME devs, hopefully when/if GNU disto gets some major attention ... then we won't see much restiance.
<davexunit>if GNU were the solar system, GNOME would be an exoplanet.
<tadni_>I mean, providing an relatively easy means to not use systemd should be a priority ... I'd be fairly shocked if that actually happens in GNOME proper. We might have a few devs interested in that, but ends up being a hardish to maintain fork.
<tadni_>davexunit: I don't think the GNOME Foundation helped them to stay truish to that GNU Ethos. Many people I've talked to doesn't know that GNOME is a GNU project even. Also remember when that guy wanted to seperate GNOME from GNU?
<jxself>Heh. Yeah, Every now and again they seem to have some sort of existential crisis. Are they a GNU package or not? etc.
<davexunit>yeah, well the GNOME foundation seems to be in close contact with the FSF, at least. GNOME people are always featured prominently at libreplanet.
<davexunit>maybe if this whole GNU distro sillyness gets traction they could be convinced to stick closer to GNU?
<Tsyesika>is guix ready to be used as your main distro?
<Tsyesika>(yet to try it)
<jxself>Depends on your needs I suppose.
<tadni_>Tsyesika: Probably not, depends on your need though.
<Tsyesika>very minimal i guess :P I just write code all day xD
<davexunit>Tsyesika: for me, it's getting pretty close, but not quite there.
<tadni_>If you need wifi, for one, that's kindaish a no-go.
<Tsyesika>ah
<Tsyesika>yeah i do
<davexunit>it does work... but it's difficult.
<Tsyesika>i see
<tadni_>Tsyesika: You can do it, but you need to manually load kernel modules at boot each time and too wpa_supplicant seems finiky.
<davexunit>blockers for me are easy wifi setup, ssl, and swap partition.
<jxself>Why hasn'
<jxself>er Why hasn't someone packaged up SSL stuff?
<Tsyesika>hm probably doable I am use to dealing with gentoo installs a lot :P
<davexunit>jxself: it's a non-trivial problem. mark_weaver has some plans to fix it, I think.
<DusXMT>I'd love Libreoffice, but considering it's a gigantc project, I think I'll just package abiword (should be easy since gnumeric is already packages) and use that, unless someone does it faster than me
<jxself>Emacs!
<davexunit>yeah, we lack big graphical applications like that.
<Tsyesika>:P
<davexunit>guix is almost usable for hackers, though.
<Tsyesika>maybe i can package some stuff if i ever get around to running it
<tadni_>davexunit: I was hoping when I first heard of the GNU distro becoming a thing, that it would become the "GNOME OS" they've been talking about for near 3 years ... but it seems that all the features they want to do will be based around linux, such as "application sandboxing" via containers and the like ... so I'm not convienced such a thing will happen. A fair amount of "that" I think is due to the development being funded by Redhat
<tadni_>though.
<Tsyesika>i have very limited scheme experiance though
<davexunit>Tsyesika: you can run guix on your existing GNU/Linux OS, btw.
<davexunit>that's how I package things.
<Tsyesika>oh if pumpa packaged, maybe i could do that? :P
<Tsyesika>node?
<davexunit>Tsyesika: one of our goals is to make it as easy as possible for people without Scheme experience to create a package.
<DusXMT>Tsyesika: I had no scheme skills when I came. Now, I can write simple package definitions and simple scheme scripts
<davexunit>Tsyesika: node is packaged, pumpa is not.
<Tsyesika>:P
<tadni_>Tsyesika: I have very little general programming experience, and was able to package like 2-4 things. It's not that hard, really.
<davexunit>success stories! look at that!
<jxself>Ta Da.
<Tsyesika>:)
*DusXMT feels kinda evin running Vi on his GNU system
<DusXMT>*evil
<Tsyesika>:o
<davexunit>and people have, for *decades*, claimed that lisp is too hard to learn!
<Steap>DusXMT: that's the right editor!
*tadni_ probably isn't a good "everyman testomonial" though ... just for the fact that he's used and costumized stumpwm and emacs for years, in-spite of not knowing how to program.
<Tsyesika>i don't think scheme or lisp are inherantly hard i just don't have much experiance with them
<Tsyesika>i spend 99% of my life in python
<Tsyesika>:P
<davexunit>:)
<davexunit>you'll be just fine. feel free to ask questions here or on #guile
<tadni_>davexunit: Once you get past the parens, which any editor should handle 80% of those anyways ... just learning Elisp as more-or-less a first lang (by no means know for beauty/elegance like Scheme) has been a delight.
<davexunit>I still don't know elisp as well as I shou.d
<davexunit>should*
<tadni_>Fundementally, Lisps have easier syntax than most other langs.
<jxself>Obligatory http://xkcd.com/297/
<Tsyesika>well if i use guix lots i am sure i'll become a regular here, although recently this isn't as true usually if i use distro a lot i tend to be involved in the community
<tadni_>davexunit: I mean, you may be able to "wait it out" for guilemacs ... though, obivously elisp isn't going away.
<tadni_>:^P
*tadni_ attempts to figure out why guix.el is not loading when he starts a fresh emacs instance. It's not tab-completing to find it at all.
<davexunit>tadni_: probably not in your load path?
<davexunit>and if so, did you (require 'guix) ?
<Tsyesika>right i'm heading to bed, i will make time to try guix tomorrow :)
<tadni_>Tsyesika: Peace. o/
<davexunit>night Tsyesika
<tadni_>davexunit: Well, if guix.el is now supposed to be in the defualt emacs loadpath ...?
<davexunit>I wouldn't count on that
*tadni_ looks to where guix.el even got installed to.
<alezost>tadni_: it should be in /usr/share/emacs/site-lisp/ most likely
<alezost>tadni_: if so, check that your emacs has that dir in `load-path'
<tadni_>"/gnu/store/6a9jxdmcb4b7s210ncj9sdjc4d1gh0xk-emacs-24.3/share/emacs/site-lisp" has no guix.el
<alezost>tadni_: how did you install it?
<tadni_>alezost: I just pulled it and reinstalled emacs?
*tadni_ could be way off.
<tadni_>As in guix pull*
<alezost>tadni_: no, "guix pull" will not install it, you need to install the whole Guix for that
<tadni_>alezost: Ah! Makes sense.
<alezost>tadni_: and you don't need to reinstall emacs
*tadni_ needs to take shortner naps, he gets in a fog and can't do basic reasoning after these ... :^P
<tadni_>Well, guix latest is installed ... but it didn't seem to add related guix.el bits to emacs/site-lisp/
<alezost>tadni_: how did you install it so quickly?
<tadni_>alezost: I already had it pulled, so I just "guix guix package -i guix"?
<tadni_>OH!
<tadni_>Brain, man.
<tadni_>I think I need to run around a bit to wake or something ...
*tadni_ will play with it on his Fedora box later, rather than his dedicated one.