IRC channel logs

2014-07-13.log

back to list of logs

***svetlana is now known as gry
<civodul>Hello Guix!
<davexunit>hey civodul
<mark_weaver>hi folks!
<civodul>yay, Sunday!
<civodul>:-)
<civodul>davexunit: did you have a chance to prepare the news entry etc.?
<davexunit>I will do it now.
<civodul>ok, cool
<civodul>take your time though, it's Sunday ;-)
<davexunit>i've got a bit of time before I head over to my parent's house for the day.
<Steap>Is there a string-something procedure that return '< '> '= like version-compare ?
<civodul>Steap: no, but there's string<?, string>?, and string=?
<mark_weaver>Steap: there are procedures 'string-compare' and 'string-compare-ci', though the usage is a bit different.
<Steap>Yes, I've seen those, but I liked the way version-compare worked :)
<mark_weaver>(string-compare s1 s2 (const '<) (const '=) (const '>))
<civodul>oh, didn't know that one
<Steap>oh, looks nice
<Steap>thanks
<mark_weaver>np!
<jxself>I'd like to submit a patch to update the kernel to 3.15.5 (or maybe I'll wait for 3.15.6 since that should be happening soon.) Either way, in doing so I see that I need to compute some sort of sha256/base32 hash. It's not clear to me how to do that without installing Guix because the output of sha256sum is in a different format. Do I really need to install Guix in order to compute a hash?
*jxself goes about installing Guix
<DusXMT>I tried installing guix system, but it fails to boot: can't find the hard drive. What should I do in this case?
<davexunit>civodul: I just submitted a news entry. I found myself struggling to write up a good summary.
<davexunit>Tweak as needed.
<civodul>jxself: you can compute the hash with sha256sum, which prints in in hex
<civodul>and then Guix has tools to convert back in "nix-base32" format
<civodul>DusXMT: what did you install exactly? Guix or the whole system?
<civodul>davexunit: cool, let me see
*civodul seems to use IRC like email :-)
<civodul>davexunit: does the event have a web page?
<davexunit>oh yeah, should've put that in.
<DusXMT>civodul: The entire system. I used the example configuration from the info file, changing some fields inside, and then just ran guix system init
<davexunit> http://www.open-bio.org/wiki/Codefest_2014
<DusXMT>If the disk is in AHCI mode, it says that it can't find /dev/sda3 and I get thrown into a guile prompt. If it's in IDE mode, it just kernel panics (Attempted to kill init!)
<civodul>davexunit: i added markup for the links and approved, thanks!
<davexunit>thank you!
<civodul>DusXMT: you're using the image i posted a while back, right?
<civodul>it could be that it lacked the right driver
<DusXMT>civodul: The image's base32 sum is: a3qd195igia45xz6fk3va8yab6f6rsnp . I think I should try building my own to see which driver it needs
<civodul>DusXMT: yes, it you can, try "./pre-inst-env guix system disk-image --image-size=900MiB gnu/system/install.scm" from current master
<civodul>that should give you the image, but with a load of drivers
<DusXMT>civodul: Oh, I thought you meant kernel image... No, I just installed the system to another partition with "guix system init"
<DusXMT>but still worth a try I guess
<civodul>i was speaking of the USB stick image
<civodul>but if you're using 'guix system init', even easier
<civodul>could you just "git pull" and then retry 'guix system init' from the new tree?
<DusXMT>okay, going to do
<civodul>great, thanks!
<DusXMT>civodul: same error, "fsck.ext4: No such device or address while trying to open /dev/sda3\\nPossibly non-existent or swap device?
<DusXMT>"
<civodul>DusXMT: and is /dev/sda3 the right device?
<civodul>note that the 'file-system' declaration can use partition labels or UUIDs
<DusXMT>I'm pretty sure, that's what it is on the host OS at least, and I see no kernel messages about SATA.. I'll try to use a partition label
<DusXMT>s/host OS/main OS/
<civodul>oh but wait
<civodul>hmm
<civodul>/ is mounted from the initrd
<civodul>so you may need to add that driver to the initrd
<civodul>do you know what kernel module is needed?
<DusXMT>Not yet, I'll try to figure it out. Once I do, how can I add it in?
<DusXMT>(it shouldn't be hard, I just need to disassemble the one of my main os)
<civodul>perhaps "lsmod" or "dmesg" on the host can give hints
<civodul>to customize the initrd, you can add an 'initrd' field to the 'operating-system' declaration
<civodul>and there, use (base-initrd #:kernel-modules '("foo.ko"))
<civodul>hmm, not quite actually
<DusXMT>sorry for the amateurish question, but how do you execute commands in quile (I currently know only very little scheme)
<DusXMT>*guile
<davexunit>DusXMT: what do you mean? are you looking for a prompt to type scheme expressions into?
<DusXMT>davexunit: no, I'm in a half-booted guix system, in the initrd's guile. I want to execute system commands, such as `ls', if possible.
<davexunit>ohhhh
<civodul>DusXMT: for that, i typically do (use-modules (ice-9 ftw)) and then (scandir "/")
<davexunit>DusXMT: use `system`
<civodul>which is admittedly less convenient than 'ls' ;-)
<davexunit>and there's an even better answer!
<civodul>davexunit: actually there are no binaries except guile in the initrd
<civodul>so you can't even run ls
<davexunit>ohhhh
<civodul>yeah
<civodul>that's not a problem when everything goes well, of course ;-)
<DusXMT>hmm.. I wanted to see if it, by some coincidence, contained the driver I needed, and just didn't load it
<civodul>if you look at gnu/system/linux-initrd.scm:base-initrd, you'll see that it contains just the bare minimum
<civodul>but i've justed added a new option, in commit fa16f84
<civodul>so one can do: (base-initrd #:extra-modules '("foo.ko"))
<civodul>well, not exactly like this
*civodul needs to write doc
<DusXMT>ah, excelent, thank you