IRC channel logs

2014-04-15.log

back to list of logs

<phant0mas>forgot a commented flag in there
<phant0mas>:P
<phant0mas>remove it
<phant0mas>I don't think it needs it
<phant0mas>civodul: how do you suggest doing it if I remove ‘substitute-keyword-arguments’?
<phant0mas>he left...:-(
***tschwing_ is now known as tschwinge
<taylanub>hahaha, guix-download.sh fails because stupid telekom redirects to some "navigation help" page for the unknown domain name
*taylanub sends bug report
<civodul>Hello Guix!
<atheia>mornin' civodul :-)
<manolis_>hello civodul phant0mas here , I am at a university lab so I am using this username :P
<manolis_>we need the 'pre-configure and 'install-locales phases from glibc but the moment I get back home I will recheck it. Maybe we do not need everything from there after all
<civodul>ah pre-configure yes
<civodul>install-locales no
<civodul>actually we need just the /bin/pwd part of pre-configure i think
<manolis_>ok I will be home in a hour and I will send an updated patch
<civodul>ok!
<phant0mas>civodul: sending patch
<afdds>civodul: My understanding is that a derivation either has 'derivation-input's or is a fixed-output derivation, is it correct?
<taylanub>I first ./configure'd with --prefix=$HOME/usr, then realized it's proper to install it as root, reconfigured, re-ran make and installed in /usr/local, but the daemon keeps creating $HOME/usr/var, where can I change this while avoiding a full recompilation ?
<civodul>afdds: not quite: fixed output derivations also have inputs
<civodul>it just turns out that their output is known in advance
<afdds>civodul: I've sent you the code via /q.
<civodul>yup
<taylanub>OK, my problem was solved by re-running ./bootstrap and manually touching the .cc files of some binaries that still had old pathes within them, then remaking.
<taylanub>could have just re-built everything by the time I found out, but oh well, that's how you learn :P
<taylanub>(learn to make better use of grep -a in this case)
<afdds>civodul: Did the original version of my code succeed on your machine? On a sidenote, how long did it take to compute the list of inputs for 'hello' (I'm referring to the graph from the manual).
<afdds>s/./?/
<civodul>afdds: i didn't try :-)
<civodul>taylanub: "make distclean" and redo
*civodul has to go
<afdds>civodul: I'm asking because the original version takes more than five minutes on YeeLoong.
<civodul>that's very possible because you would keep visiting the same derivations over and over again
<civodul>ttyl!
<afdds>Then I hit Control-C.
<taylanub>Is there a reason LOCALSTATEDIR/profiles/per-user/USER isn't created automatically, or am I doing something wrong ? A user also can't create it themselves because LOCALSTATEDIR is owned by root.
<phant0mas>taylanub: you can just create the folder per-user/USER and make the user owner of that USER fodler
<taylanub>phant0mas: sure, but I see no reason this wouldn't be done automatically.
<phant0mas>taylanub: you are right on that :-)
<phant0mas>civodul: did you check the updated patch? :-)
<afdds>civodul: 'memoize' didn't make a difference. I'm trying on a simpler model.
<afdds>The problem is that I want to "modify" the list I'm mapping over. I suspect that an exit continuation could be helpful, but I'm failing to make it work.
<civodul>afdds: you could question my hypothesis by adding a pk somewhere
<civodul>to see if i guessed wrong
<civodul>just print the derivation, and call it to see what it does
<afdds>civodul: I suspect the same. But I don't want to deal with derivations for now. The output is verbose and the DAG is quite big, so it's hard to follow. I'm trying on a simpler data.
<afdds>s/a//
<afdds>I'll post some code soon, but first I want to evaluate it step-by-step myself.
<civodul>the procedure you posted looked good though
<phant0mas>civodul: which part of the patch has wrong indentation? I followed exactly the style from the other packages
<phant0mas>in the patch I sent (name ...) part is exactly under (inherit ..) as I saw from other packages
<phant0mas>
<phant0mas>and we still need to overide the configure flags because we don't need the same with the linux gcc
<phant0mas>linux glibc I meant
<civodul>phant0mas: (name ...) should be aligned with the 'a' of "(package"
<civodul>re configure flags, but you could inherit from glibc/hurd no?
<civodul>at least share between glibc/hurd and glibc/hurd-headers
<phant0mas>you mean glibc/hurd-headers to inherit from glibc/hurd? yeah that could happen
<phant0mas>and I just realized I had the wrong impression on where the (name ..) should be aligned :P
<civodul>ok :-)
<phant0mas>and I just realized that builds on my laptop where failing due to small size of tmp folder
<phant0mas>never had these kind of problems with my main pc :P
<civodul>oh
<phant0mas>yeah it seems it has a maximum tmp folder size of 2G
<phant0mas>on my laptop
<afdds>civodul: I want to get (1 (2 3) (4 (5 6)) 7). This http://slexy.org/raw/s21bNJ7YBK doesn't work because the state is not shared between the 'foo' calls (see the first occurrence of lst: () in the output). Is there a workaround?
<civodul>hmm, i don't wanna look in detail right now
<civodul>i think you should avoid call/cc, except for playful purposes :-)
<afdds>I'll ask on #guile.
<civodul>yes, or #scheme
<taylanub>I just installed a whole bunch of packages, but all the binaries seem to segfault...
<taylanub>I take that back, only some
<civodul>oh
<civodul>which ones segfault?
<taylanub>wait, sorry, it's not that, I think it's probably because I set LD_LIBRARY_PATH to include the Guix profile directory and then some non-Guix binaries tried to load Guix libraries
<taylanub>(not-by-Guix-installed binaries tried to load by-Guix-installed libraries, I mean)