IRC channel logs

2014-03-28.log

back to list of logs

<mark_weaver>we could have some notion of "priorities" for derivations, such that the daemon would try to build the highest-priority derivations first.
<mark_weaver>and then all of the download derivations would be higher priority than the others.
*dfsdfds is writing the proposal
<mark_weaver>it could potentially have other uses as well.
<civodul>yeah
<mark_weaver>trying to eliminate the use of hash tables in union.scm makes me realize that we need more purely-functional data structures in guile.
<mark_weaver>vhashes really aren't a good fit here.
<mark_weaver>I need to be able to efficiently *replace* map elements, not merely add a new one to the front.
<dfsdfds>Have you seen ijp's library?
<mark_weaver>yeah, no doubt there's some great stuff there, although he doesn't pay much attention to efficiency (beyond asymptotic complexity).
<dfsdfds>(I'm not sure how mature it is, though.)
<mark_weaver>ijp is a very smart guy though.
<mark_weaver>but for this purpose, I'm sure it would be fine.
<mark_weaver>HAMTs are really what I want here, or alternatively a balanced tree.
<civodul>mark_weaver: i looked a bit at it, and noticed that it's easy to build a file->inputs mapping, but then the problem is that we want not only the mapping, but also the list of files
<civodul>and with vhashes, that's inconvenient
<mark_weaver>exactly.
<civodul>so maybe we'll leave it this way
<civodul>as incredible as it may sound ;-)
<mark_weaver>yeah, for now that might be best.
<mark_weaver>there are other higher priority things to work on.
<civodul>exactly
<mark_weaver>and maybe we can get HAMTs into guile soonish :)
<civodul>would be nice :-)
<mark_weaver>is 'expect' okay to update in master?
<civodul>and we should really tweak ijp into pushing some of its pfds lib into Guile
<civodul>yes
<mark_weaver>the main piece we need for HAMTs is to be able to produce a stream of hash values for arbitrary objects such that hashstream(A) and hashstream(B) are equal if and only if A and B are 'equal?'.
<mark_weaver>i.e. there must be no collisions.
<mark_weaver>(if we look far enough down the stream)
<mark_weaver>everything else is trivial.
*dfsdfds has sent the proposal
<phant0mas>good morning guix
<sirius>Xorg (installed with Guix) can't be run on my machine because it doesn't find the driver modules. If I run it with the -modulepath option, it finds the modules but is still unable to load them. Does someone here know how this can be fixed?
<sriharsha>sirius, are modules compiled freshly for the Xorg version installed by Guix?
<sirius>I installed them with Guix too (for example: xf86-video-intel)
<sriharsha>sirius, can you paste the output of `ldd /path/to/module'?
<sirius>sirius@SIRIUS10:~$ ldd .guix-profile/lib/xorg/modules/drivers/intel_drv.so
<sirius> linux-vdso.so.1 (0x00007fff127fe000)
<sirius> libpciaccess.so.0 => /gnu/store/w8piyjamdwy33mxmy672l8fkx0fw0lqv-libpciaccess-0.13.1/lib/libpciaccess.so.0 (0x00007f4ca03b6000)
<sirius> libdrm_intel.so.1 => /gnu/store/17lviqspx5v6qa66j393xq8j3r7xyi5c-libdrm-2.4.46/lib/libdrm_intel.so.1 (0x00007f4ca0196000)
<sirius> libdrm.so.2 => /gnu/store/17lviqspx5v6qa66j393xq8j3r7xyi5c-libdrm-2.4.46/lib/libdrm.so.2 (0x00007f4c9ff8a000)
<sirius> libgcc_s.so.1 => /gnu/store/6z7k9ms4sf367c3phl7djhb740ly3dqi-gcc-4.8.2/lib/libgcc_s.so.1 (0x00007f4c9fd74000)
<sirius> libc.so.6 => /gnu/store/hf5kklv837xbfcv6gc7gpsj36l69j3sj-glibc-2.19/lib/libc.so.6 (0x00007f4c9f9ca000)
<sirius> /lib64/ld-linux-x86-64.so.2 (0x00007f4ca0809000)
<sirius>When I use the -modulepath option the Xorg.0.log file states the following error: [ 35112.888] (EE) Failed to load module "intel" (invalid argument(s) to LoadModule(), 1)
<sriharsha>sirius, pls tell us the full command you are using
<sriharsha>for launching Xorg
<sirius>X -modulepath .guix-profile/lib
<sriharsha>try: X -modulepath "$HOME/.guix-profile/lib/xorg/modules"
<sriharsha-iris>sirius, oh, wait, the man page for Xorg says that -modulepath is only available when run as root.
<sriharsha-iris>-modulepath searchpath
<sriharsha-iris> Set the module search path to searchpath. searchpath is a comma separated
<sriharsha-iris> list of directories to search for Xorg server modules. This option is only
<sriharsha-iris> available when the server is run as root (i.e, with real-uid 0).
<sirius>ok, I try to run it as root
<sriharsha-iris>ok, you will have to change the $HOME accordingly then
<sirius>It worked
<sriharsha>OK, glad to hear that :)
<sriharsha>by the way, which driver are you using?
<sirius>Isn't it possible to run X as a standard user (without root privileges)?
<sriharsha>ah, I see it as intel in your output
<sirius>Yes.
<sriharsha>you can run as standard user, but you will not be able to use the modulepath option
<sriharsha>what you can do is to edit /etc/Xorg.conf
<sriharsha>to include the following lines:
<sriharsha-iris>Section "Files"
<sriharsha-iris>EndSection
<sirius>Ok, thanks. I'll try that.
<sriharsha>you will have to change the ModulePath here accordingly
<civodul>Hello Guix!
<civodul>there's --no-substitute for a proper bug fix :-)
<atheia>:-)
<atheia>g'day civodul.
<civodul>hey atheia
<mark_weaver>on current master, python 3.3.3 fails to build on my x86_64 box, apparently because it can't open ptys.
<mark_weaver>"OSError: out of pty devices"
<mark_weaver>during the tests
<bavier>so, I went through package definitions looking for things like (alist-replace 'foo (lambda* (#:key #:allow-other-keys #:rest args) ... (apply foo args) ...) %standard-phases) and replaced those with new phases before or after the replaced phase
<mark_weaver>bavier: cool!
<bavier>mark_weaver: my only concern would be about grouping of certain actions. If you replace and augmented install phases, e.g., with the standard install phase followed by an additional action, you lose the logical grouping
<zacts>lo
<bavier>general question: how much of a file needs to be changed before appending your name to the copyright header:
<civodul>bavier: i'd say a few names
<civodul>*a few lines
<civodul>:-)
<civodul>GNU's maintain.texi has something about "legal significance"
<bavier>civodul: thanks, that's just what I was looking for
<phant0mas>I was running errands for my professors the whole day, now back to work
<zacts>heh, I'm trying to find and decide on a new cloak.
<zacts>guix/geek would be cool!
<zacts>or guile/scheme/geek
<zacts>but I need to contribute more for that probably.
<zacts>I currently have freebsd/lover from the freebsd guys
<zacts>I'm way tired of it
<zacts>mark_weaver: civodul: but if you wouldn't mind looking into this, I will also, that would be cool! re: 'guix/geek'
*civodul knows nothing about IRC cloaks
<bavier>I've got patches for about 23 different package modules that are mostly just "cleanup" of recipes. Should they go in core-updates so that they don't cause too many unnecessary rebuilds?
<civodul>core-updates is really for updates to gcc, glibc, coreutils, tar, etc. (things in %final-inputs)
<civodul>for the rest, master is usually fine
<bavier>ok, I've checked that all packages still build fine. should I post patches to the list, or can I just push?
<civodul>maybe you could post, so we see what kind of cleanup it's about :-)
<civodul>if it touches this many packages, it's probably a good idea
<bavier>will do
<bavier>I have to go afk, so that post will have to wait till after the weekend. ciao!
<zacts>civodul: http://freenode.net/faq.shtml#projectcloak
<zacts>wait let me ask #freenode about this..
<phant0mas>civodul: you were right
<phant0mas>getting some issues with building but gonna apply some patches on the glibc
<zacts>phant0mas: you are the guix + hurd person right?
<phant0mas>yes
<zacts>nice!
<phant0mas>searching the debian patches....
<civodul>brave hacker ;-)
<phant0mas>:P
<mark_weaver>ah, I now have access to the GCC compile farm :)
<zacts>civodul: ok, I see what needs to happen for cloaks. freenode is currently updating their group registration system. Once that happens, mark_weaver or civodul can register an official freenode guix group. Then users can request civodul or mark_weaver for a cloak, such as 'guix/geek'. :-)
<zacts>anyway, I may look at trying to import i3wm once I finish some homework.
<civodul>mark_weaver: oooh, congratulations :-)
<civodul>took a month? or more?
<mark_weaver>just under 2 months.
<civodul>:-)