IRC channel logs

2014-03-12.log

back to list of logs

<ph4n70m4s>before I continue I will do the transition to gnu store
<ph4n70m4s>great, problems with guix daemon....
<civodul>what kind?
<ph4n70m4s>suddenly I started getting this
<ph4n70m4s>failed to connect to `/usr/local/var/guix/daemon-socket/socket': No such file or directory
<ph4n70m4s>I stopped the daemon
<ph4n70m4s>restarted it
<ph4n70m4s>nothing
<ph4n70m4s>stopped it again tried to start it manually
<mark_weaver>I think this is because of the recent change in where it looks for the files.
<ph4n70m4s>socket in use
<mark_weaver>you need to create a symlink.
<mark_weaver>it used to look in $prefix/var/nix
<mark_weaver>now it looks in $prefix/var/guix
<mark_weaver>so you should create a symlink from one to the other
<ph4n70m4s>ok
<mark_weaver>ditto for $prefix/var/log/nix and $prefix/var/log/guix
<civodul>yes, that's the problem
<civodul>do "ln -s nix guix" here and there ;-)
<civodul>i know this is annoying, but soon it'll be behind us
<ph4n70m4s>did that in both places
<ph4n70m4s>guix package: error: failed to connect to `/usr/local/var/guix/daemon-socket/socket': Connection refused
<ph4n70m4s>....
<civodul>the daemon is still listening on the other socket, it seems
<civodul>did you restart it?
<ph4n70m4s>I killed it with fire
<ph4n70m4s>I disabled it
<ph4n70m4s>and then
<ph4n70m4s> I tried to start it manually
<ph4n70m4s>but I am getting socket in use
<ph4n70m4s>something is wrong here
<civodul>there's a daemon still running
<civodul>most likely
<ph4n70m4s>okay I fixed it
<ph4n70m4s>:-)
<ph4n70m4s>the daemon didn't won't to cooperate
<ph4n70m4s>want*
***tschwing_ is now known as tschwinge
<civodul>Hello Guix!
<phant0mas>when I do "./pre-inst-env guix build -c 4 -K {something } --target=i686-pc-gnu" what is guix doing? is it crossbuilding the recipe according to the target?
<civodul>phant0mas: yes
<civodul>so first it tries to build the cross-compilation toolchain
<civodul>but for i686-pc-gnu is cannot build it yet
<civodul>which is why you'll need to change cross-base.scm & co. to tell it what to do
<phant0mas>so the glibc/hurd recipe I am building now should be in base.scm or cross-base.scm ?
<civodul>phant0mas: it should be in base.scm, that's perfect
<civodul>but cross-base.scm will need some knowledge too
<zacts>I wonder how difficult it will be for me to build guix on slackware.
*zacts is currently running slackware.
<zacts>also, what style of distro is guix designed to be like? rolling-release. I like rolling-release distros where I don't ever have to do a full reinstall in between release cycles.
<dfdsfssd>civodul: Still around?
<civodul>yes!
<dfdsfssd>Good!
<dfdsfssd>I'd like to ask about the 'file' argument that's used by %nar-signature-error once more.
<dfdsfssd>Since we decided to copy/paste 'assert-valid-signature', it's not an issue in nar.scm. But I still have to get a filename from somewhere in 'substitute-binary.scm'.
<dfdsfssd>Since "copying the relevant bits" means that I'd have to raise the same errors as in 'assert-valid-signature', which use 'file'.
<civodul>you could simply do (raise (&message (message "invalid signature")))
<civodul>instead of using &nar-signature-error
<dfdsfssd>Ugh.
<dfdsfssd>Haven't though of it.
<dfdsfssd>t*
<civodul>or you can pass (file #f)
<civodul>lemme check
<dfdsfssd>(file #f) works.
<dfdsfssd>... But using &message instead of a more specific error defeats the whole point of using SRFI-35.
<civodul>yeah
<civodul>even better is to use 'file' to pass the actual name of the file being restored
<civodul>you have that information, right?
<civodul>file = item in /gnu/store
<dfdsfssd>You mean a filename?
<civodul>a file name, yes
<dfdsfssd>Well, I can't get it from port, as you know, but we could probably add a 'file' argument. Fine with you?
<dfdsfssd>Where can we get a filename, though? I think we could get it from 'fetch-narinfo', no?
<dfdsfssd>Or we could try &message for now since copy/pasting is a temporary solution.
<dfdsfssd>It's getting too ugly...
<civodul>just use (file #f) and we'll see
<dfdsfssd>Got it.
<civodul>i don't have the code at hand so it's hard to tell
<dfdsfssd>Oh, OK.
<phant0mas>civodul: How can I tell the guix build command to build glibc using the sans-free gcc?
<civodul>phant0mas: try this: ./pre-inst-env guix build -e '((@@ (gnu packages cross-base) cross-libc) "i686-gnu")'
<phant0mas>where cross-libc should be a recipe that inherits glibc/hurd ,like the current one for linux glibc, in cross-base.scm
<phant0mas>right?
<civodul>phant0mas: in the example above, (@@ (gnu packages cross-base) cross-libc) means "the 'cross-libc' variable in the gnu/packages/cross-base.scm module"
<civodul>in you look in there, 'cross-libc' is actually a function that returns a package
<civodul>that package "inherits" glibc
<civodul>so you could change that to: (inherit glibc/hurd)
<phant0mas>i think I got it :-D
<civodul>heheh :-)