IRC channel logs

2014-03-06.log

back to list of logs

<davexunit>hey #guix
<davexunit>working on a package for the glib-networking library.
<davexunit>having an issue with gnutls
<davexunit>checking for GNUTLS... yes
<davexunit>checking location of system Certificate Authority list... configure: error: could not find. Use --with-ca-certificates=path to set, or --without-ca-certificates to disable
<davexunit>this seems related to the discussion on the mailing list awhile ago about how we handle the location where certificates are stored.
<mark_weaver>davexunit: my opinion on what to do is recorded in the ML thread :)
<mark_weaver>I'm still carrying a patch in my private branch
<mark_weaver>davexunit: pkg-config should be a native-input
<mark_weaver>(the network that hosts my server is down, so I can't receive/send email at present)
<civodul>Hello Guix!
<phant0mas>hello civodul
<phant0mas>I am working with the hurd guys about the packaging of hurd's glibc
<phant0mas>we have some problems but I according to braunr I can find the solution in the debian package of hurd's glibc
<civodul>hey phant0mas
<civodul>oh, what kind of problem?
<phant0mas>getting a message from glibc that headers files are too old
<phant0mas>and when I pass libpthread as a glibc addon
<phant0mas>how to pass flags to libpthread configure when called from glibc configure
<civodul>ok
<civodul>so you've reached the level where you can cross-compile libc?
<phant0mas>in order to crosscompile libc you need the mach headers and the hurd headers
<phant0mas>we have both so we can do it
<phant0mas>and I will put libpthread as an addon to libc
<phant0mas>so it will be easier to make it work together
<civodul>yes, but i thought fiddling with base.scm and cross-base.scm could prove non-trivial
<civodul>so i'm glad if you found your way :-)
<phant0mas>I get the feeling I will still have to change somethings
<phant0mas>but first I have to find out how the debian did it
<phant0mas>I will inform you with my progress as soon as I have something new
<civodul>but Debian doesn't cross-build etc.
<phant0mas>but according to the hurd guys I should check the debian packages on how they solved the various problems I ran into
<civodul>that's because the Hurd folks are actually Debian folks :-)
<phant0mas>:-/
<civodul>i'd like to think that Nixpkgs would be easier to understand, but the stuff in Nixpkgs didn't use libpthread as an add-on
<phant0mas>it's much easier to understand
<phant0mas>but it would benefit as if I can make libpthread work as an addon
<phant0mas>they had problem making glibc work with it while they were separate
<phant0mas>problems*
<rigelk>hi there ! I hava written a package definition but don't know how to test it ; any ideas ?
<civodul>phant0mas: yeah
<civodul>rigelk: yes, try "./pre-inst-env guix build the-package" from your build tree
<civodul>there's some info in the 'HACKING' file
<rigelk>thanks civodul, but 'the package' is not yet known to my guix tree and i don't know how to add it
<civodul>rigelk: typically you can make a gnu/packages/the-package.scm file, starting with a (define-module (gnu packages the-package) ...) declaration
<civodul>from there on it should be known
<rigelk>ok, i've just moved my .scm to that folder. but still unknown... is there a command to refresh the tree, like `guix refresh` or something ?
<civodul>and it starts with the appropriate (define-module ...) clause?
<civodul>look at the other files in there as examples
<civodul>also http://www.gnu.org/software/guix/guix-ghm-andreas-20130823.pdf gives some guidance
<rigelk>thx civodul, the latter proved vital.
<civodul>i reckon the manual could use some help...
<rigelk>you mean the manual could be improved ?
<civodul>yes
<civodul>rigelk: did it work?
<davexunit>hey #guix, I have a package that should theoretically only need curl to build, but it fails in the linking phase because zlib, ssl, sasl2 can't be found.
<davexunit>adding cyrus-sasl, openssl, and zlib as inputs allows the build to succeed, but I think I'm just papering over a problem with that.
<davexunit>and having to use openssl (gnutls didn't work) worries me too.
<civodul>davexunit: either it actually depends on those, or it depends on a lib that depends on those but doesn't NEED them (in ELF terms)
<davexunit>I think it's because of curl
<davexunit>curl is an optional input, and if I leave it out the build succeeds.
<davexunit>curl is built to use gnutls
<davexunit>here's the package in debian https://packages.debian.org/squeeze/ncmpcpp
<davexunit>gotta go! will check this out more later!
<rigelk>civodul: i won't be able to test any further today, but i got errors with `make sync-synoses`. I'll be back in 20h to keep on testing ;)
***jmd` is now known as jmd
<phant0mas>civodul: I need your advice, because my head has stucked right now about the steps I should follow for crossbuilding glibc for hurd...
<civodul>do you have a glibc package definition?
<phant0mas>I am writing it now
<phant0mas>okay I should first solve the problem with the addon and then I will be back
<civodul>how do you know you have a problem if you don't have the package definition yet? :-)
<civodul>some background info: the cross-compilation toolchain is built using the recipes in cross-base.scm
<civodul>building a cross toolchain goes like this
<civodul>:
<phant0mas>because I am crossbuilding it i my system normally as well :-)
<civodul>1. build a "sans-libc" cross-compiler
<civodul>2. cross-build a libc
<civodul>3. build the final cross-compiler, which uses that libc
<civodul>that's what cross-base.scm does
<phant0mas>okay let me get on that
<phant0mas>thanks civodul
<civodul>step 1 corresponds to: guix build -e '((@@ (gnu packages base) cross-gcc) "i686-gnu")'
<mark_weaver>in case someone else has already faced this issue: what elisp vars do I have to set to get M-$ working in Emacs in Guix?
<mark_weaver>it tells me: No word lists can be found for the language "en_US".
<mark_weaver>I have the aspell and aspell-dict-en packages installed
<civodul>mark_weaver: per aspell.scm: Use 'export ASPELL_CONF="dict-dir $HOME/.guix-profile/lib/aspell"' to use them.
<civodul>did you do that?
<civodul>(definitely suboptimal, yes)
*civodul has to go
<civodul>ttyl!
<mark_weaver>thanks civodul!
<phant0mas>why when I try to build with ./pre-inst-env guix build a recipe from cross-base I get the error unknown package
<phant0mas>
<phant0mas>?
<bavier```>phant0mas: sometimes and "unknow package" can occur if there's an error in the recipe; syntax error or undefined symbol, etc.
<bavier```>you can check that with ./pre-inst-env guile -c '(use-modules (<module>))'
<phant0mas>ok
<sf3s8sd>mark_weaver: do you have time to talk about SRFIs now?
<mark_weaver>sf3s8sd: hi
<mark_weaver>what would you like to know?
<sf3s8sd>I need SRFI-78 to test weinholt's code. Does Guile support it?
<sf3s8sd>And what's the preferred way to install the SRFI module?
<sf3s8sd>If it's requires a lot of effort, I'd rather rewrite the tests using SRFI-64, which is supported.
<mark_weaver>guile doesn't have srfi-78 built in, but maybe the reference implementation works. I don't see why it wouldn't.
<mark_weaver>you could import it into guix the same way srfi-64 was imported.
<sf3s8sd>Okay. Thank you.
<mark_weaver>I don't know whether civodul would want it imported though, you'd have to ask him.
*davexunit pushed ncmpc package
<davexunit>I'm still having problems getting ncmpcpp to build.
<davexunit>curl is an optional input, and when I use it the build fails unless I include openssl, cyrus-sasl, and zlib as inputs as well.
<bavier```>the patchutils tests use gendiff in some places. I'm tempted to just skip those tests, rather than pack up rpm and use it as an input.
<bavier```>would it make any sense at all to have rpm available as a package in guix?
<mark_weaver>I'd just skip those tests.