IRC channel logs

2014-02-17.log

back to list of logs

<erwerd>mark_weaver: Is it OK to use 'get-bytevector-all' to read the signed hash file? (I haven't been using Guile for a while, so I want to make sure I'm doing it right.) Then I pass the result to 'base64-encode'.
<mark_weaver>erwer
<mark_weaver>oh well, he left. anyway, yes, 'get-bytevector-all' is the right way to read a binary file into a bytevector.
<mark_weaver>wow, icuc4 has code to generate ELF.
<mark_weaver>amazing.
<mark_weaver>so the bug is in icuc4's own linker, apparently.
<mark_weaver>hmm, now it seems that the bug is in patchelf.
<mark_weaver>yup, the bug is in patchelf...
<mark_weaver>unbelievable. From patchelf.cc:
<mark_weaver>#ifdef MIPSEL
<mark_weaver>/* The lemote fuloong 2f kernel defconfig sets a page size of 16KB */
<mark_weaver>const unsigned int pageSize = 4096*4;
<mark_weaver>#else
<mark_weaver>const unsigned int pageSize = 4096;
<mark_weaver>#endif
<mark_weaver>
<mark_weaver>jmd: to answer the question you asked earlier on #guile: 'z' is not a valid base-32 digit, given the digits used by 'string->number'.
<mark_weaver>(which are 0-9 followed by a-z)
<jmd>mark_weaver: That seems then to be different to the format expected by guix's base32
<mark_weaver>yes, of course
<jmd>Why of course?
<mark_weaver>how would 'string->number' guess what set of digits you want to use?
<mark_weaver>if you look at the docs for 'string->number', it actually says that the radix must be 2, 8, 10, or 16.
<mark_weaver>as an undocumented extension, we actually allow anything up to 36
<jmd>Yeah I noticed that too.
<jmd>So what does base32 expect?
<mark_weaver>but in all cases, the set of digits is a prefix of "0123456789abcdefghijklmnopqrstuvwxyz"
<mark_weaver>well, there are different sets of digits. two sets of interest to us are the ones expected by Nix and RFC 4648. See guix/guix/base32.scm line 143
<jmd>They omit the vowels. How rude!
<mark_weaver>not all of them. 'i' is there.
<mark_weaver>and 'a'
<jmd>Why the hell are there two sets?
<mark_weaver>I don't know the history
<mark_weaver>we inherited it from nix. maybe civodul knows.
<mark_weaver>they also omitted 't'
<mark_weaver>maybe they omitted the most frequent letters to reduce the likelihood of misinterpreting something else as a nix hash, since they scan binaries for the hashes.
<jmd>that would make sense.
<phant0mas>I am back guys
<phant0mas>apparently my professor wants me to write a driver for a network controller on a zed board :P
<phant0mas>but for now back to guix :-)
<taylanub>phant0mas: Write it for the Hurd !
<phant0mas>somebody needs to fix the mig building guide on gnu.org
<phant0mas>it's outdated
<phant0mas>almost done with mig recipe just double checking
<phant0mas>and my to-do list is getting bigger
<mark_weaver>phant0mas: I can sympathize with the growing TODO. my Guile and Guix TODOs have both been growing, and show no signs of getting any smaller.
<mark_weaver>regarding the driver: I used to write drivers for hardware about 25 years ago.
<phant0mas>any advices you can give me?
<phant0mas>and I don't even want to think our age difference :P
<mark_weaver>I think *I'm* the one who would prefer not to think about age differences, LOL :)
<mark_weaver>well, I was quite young at the time I wrote those drivers, anyway.
<mark_weaver>(in my teens)
<mark_weaver>ah, he left.