IRC channel logs

2013-08-02.log

back to list of logs

<antono>i found answer in HACKING
<antono>‘./pre-inst-env guix build mypackage’.
<Steap>oh
<Steap>this just builds packages from the distirbution
<antono>yep. but its ok for me
<antono>for now
<Steap>well
<Steap>time to sleep
<oitofelix>Steap: Good night.
<amirouche>héllo again :)
<amirouche>sorry yesterday I was very tired and closed by mistake the IRC software
<amirouche>basically I got skribilo compiling from HEAD without lout
<amirouche>but the guix recipe doesn't work
<amirouche>I need t override the default ./configure phase and remove --fast-install (or something like that)
***dysinger_ is now known as dysinger
<amirouche>antono: where is the .dev for guix ? I'm wondering how to you solve the libgcrypt dependency
<amirouche>s/.dev/.deb
<amirouche>ok I didn't install the headers
<amirouche>wheee I built guix from source :D
<amirouche>from git I mean
<Steap>good
<Steap>so, how did you manage to fetch skribilo ?
<amirouche>skribilo I did finish skribilo
<amirouche>s/did/did not
<amirouche>skribilo is a git repository on github
<amirouche>with a tag
<amirouche>since this is not a release
<amirouche>it can be downloaded as tarball
<amirouche>I mean since it's tag I can download it as tarball
<amirouche>but since it's not a proper release I need to run autoconf
<amirouche>autoconf succeeds but configure fails because there is not --fast-install or something in skribilo makefile
<amirouche>I tried to remove --fast-install, pass arguments to configure manually, replace the configure phase
<Steap>oh shit, that's hacky
<amirouche>I managed to make none of them working
<amirouche>^^
<Steap>Honestly, I don't think such a hack is gonna get merged
<amirouche>of course not but it's good for learning
<Steap>It would probably be best to backport the patch
<amirouche>which patch ?
<Steap>and it would avoid running autoconf
<Steap>well, between the latest release and HEAD
<amirouche>I already tried didn't work
<amirouche>I mean could make it work
<Steap>there must be a patch that prevents skribilo from building the doc when lout is not found, right ?
<Steap>Backporting that would be nice
<Steap>or, even simpler
<Steap>Just package lout
<amirouche>lout is packaged actually :)
<Steap>this seems to be a piece of cake, honestly
<Steap>oh
<amirouche>oh
<Steap>Well
<amirouche>so I can use the release :)
<Steap>then add it to the inputs ?
<Steap>:p
<Steap>yes
<amirouche>yes
<amirouche>we are genius ;)
<Steap>(well, wasn't exactly a piece of cake to package lout, I just looked at the code)
<amirouche>hydra seems to timeout a lot and guix doesn't seem to like redirections
<amirouche>so --no-substitutes fails too
<amirouche>also the output of guix mix the builds O_o so it's difficult to follow
<Steap>--bo-substitutes should work
<Steap>it just says "don't use hydra.gnu.org"
<Steap>so
<Steap>Will I ever have some time to hack stuf
<Steap>f
<Steap>Why do all mail clients suck that much
<amirouche>hydra is down
<amirouche>I think
<amirouche>I'm forcing the build with an infinite loop
<amirouche>(:
<Steap>what ?
<Steap>(hydra is proably wonderful, but it's always down)
<Steap>(civodul and I used to use it at work, it was always down too :D)
<amirouche>each time I try to build something with --no-subtitutes, it will fail for something because it can't download a dependency
<amirouche>then everything happening in parallel is cut and guix abord
<amirouche>now I found the failing dependency
<amirouche>ImageMagick 6.8.0
<Steap>that's incredibly weird
<amirouche>well, I removed the infinite loop ;)
<Steap>hope so
<Steap>espacially if each iteration sends a request to hydra.gnu.org :)
<amirouche>two weeks already and the best I can do in guile is (+ 3 2)
<Steap>yeah, when coming from other languages, it's weird
<Steap>but well, Guix DSL is nice
<amirouche>yes
<Steap>have you managed to do (* 3 2) yet ?:p
<antono>amirouche: antono.info/files/guix_0.3-1_amd64.deb
<antono> http://antono.info/files/guix_0.3-1_amd64.deb :)
<antono>not yet published git repo
<amirouche>antono: thx
<amirouche>I find my way actually :)
<antono>i'll cleanup stuff and publish it later
<antono>ok
<antono>amirouche: what is your way to build custom package from definition?
*antono brb
<amirouche>antono: «./pre-inst-env guix build something-you-created» in git after running ./bootstrap and configure
<amirouche>but right now hydra is down
<amirouche>rebuilding from scratch gives some headaches
<amirouche>actually it was on my side
<amirouche>hydra is down
<amirouche>but the dns server in my router is kind of lazy
<amirouche>I hate it
<Steap>it's really a huge issue
<Steap>One of the ideas we had was to use a P2P system to distribute binaries
<amirouche>it would be nice
<amirouche>better than centralized stuff
<amirouche>talking about that do you use some P2P search engine ?
<Steap>we need to build a web of trust for that
<Steap>not that easy
<Steap>no, but civodul uses Seeks :)
<amirouche>ok
<amirouche>if upstream starts to change release tarballs, things will get complicated
<amirouche>I understand now why gentoo maintains a mirror of the tarballs
<amirouche>I already so seeks somewhere, checking now
<amirouche>P2P collaborative filter on top of metasearch engine. Seeks also implements a websearch proxy and a mini Web server
<amirouche>well not what I expected
<Steap>Upstream usually does not change tarballs
<amirouche>then it was a download error
<Steap>Sometimes they remove old tarballs
<Steap>but well
<Steap>I think the FreeBSD ports work without mirrors
<Steap>and they do not have too many issues
<antono>guys, how are you resolve this (when ./configure from git):
<antono>423.49
<antono>checking for the Guix system type... x86_64-linux
<antono>./configure: line 6757: syntax error near unexpected token `GUILE,'
<antono>./configure: line 6757: `PKG_CHECK_MODULES(GUILE, guile-2.0 >= 2.0.5)'
<amirouche>antono: did you install pkg-config ?
<amirouche>and guile-dev ?
<Steap>do you have pkg.m4 ?
<Steap>antono: cf. HACKING
<antono>guile-dev - yes
<antono>looking for pkg.m4
<antono>ls $ACLOCAL_PATH | grep pkg.m4
<antono>pkg.m4
<antono>same problem
<amirouche>antono: pkg-config ?
<Steap>$ pkg-config --exists guile-2.0
<Steap>damn, got this bug again
<Steap>substitute-binary: guix substitute-binary: warning: try `--no-substitutes' if the problem persists
<Steap>even though I use --no-substitutes
<amirouche>Steap are you doing gnome packaging ?
<amirouche>i will be back
<antono>amirouche: pkg-config is installed
<antono>from debian package... same as guile
<antono>however autoconf installed from guix
<Steap>amirouche: no, not yet
<Steap>amirouche: we have gtk+ packaged, though
<Steap>antono: $ pkg-config --exists guile-2.0
<antono>pkg-config --exists guile-2.0 && echo "yes"
<antono>yes
<Steap>damn
<Steap>rerun ./bootstrap maybe ?
<antono>no success
<antono>all the story in one termcast: http://shelr.tv/records/51fc26de96608048d2000034
<antono>configure from tarball always works well
*antono hates autoconf
<Steap>A video of one's shell ?
<Steap>What's wrong with text ? :p
<Steap>where is pkg.m4 on your machine ?
<Steap>and are you sure ACLOCAL_PATH is well set ?
<amirouche>I had the exact same error as you I install pkg-config and it worked
<amirouche>I also installed guile-2-dev
<amirouche>libguile
<Steap>it's a common error
<Steap>installing pkg-config and setting ACLOCAL_PATH should do the trick
<amirouche>also you have to run boostrap again
<amirouche>or run autoreconf
<amirouche>...
<amirouche>antono: did you run ./boostrap again ? to rebuild configure?
<antono>yes
<amirouche>strange
<antono>git clean -xdf && ./bootstrap && export ACLOCAL... && ./configure
<amirouche>yep
<amirouche>saw that in the screencast at last
<amirouche>I just did a some hours ago
<amirouche>I don't remember what did the trick
<Steap>grep pkg-config config.log
<amirouche>maybe try to remove the MACRO that is failing and ./boostrap again