IRC channel logs

2013-04-16.log

back to list of logs

<civodul>Hello Guixers!
<civodul>hello!
<Steap>hey!
<Steap>civodul: is there a page on gnu.org that explains how to format commit messages ? :p
<civodul>ah
<civodul>Steap: http://www.gnu.org/prep/standards/html_node/Change-Logs.html
<civodul>but you could really just mimic the other commits
<civodul>like you already did, actually
<Steap>civodul: when modifying a function defined inside another one, which one should I name in the Changelog ?
<Steap>Both ?
<civodul>Steap: (outer)[inner]: Change foo.
<civodul>you're becoming an expert with all these GNU things ;-)
<Steap>civodul: not sure if it's a good thing.
<Steap>(outer)[inner]{even more inner}
<civodul>depends on your criteria :-)
<Steap>* guix/scripts/packages.scm (guix-package) [process-actions]: 'guix package --upgrade' is now the same as "guix package --upgrade=''".
<Steap>does this look good ?
<civodul>it should be low-level, like: When upgrading, use "" when REGEXP is #f.
<Steap>It doesn't really explain why we're doing these changes, then
<bubu^>hi, make check fails for 4 tests, is this known ?
<bubu^>FAIL: tests/builders.scm
<bubu^>utils, packages and union.scm
<civodul>bubu^: sounds like it could be a real issue
<civodul>is it "master"?
<civodul>Steap: no it doesn't
<bubu^>guix-0.1.tar.gz
<civodul>ah, hmm
<civodul>can you paste the corresponding .log files?
<civodul>otherwise it may be easier to use git master for now
<civodul>(we plan to have a release in the coming weeks)
<bubu^>seems i shouldn't have run "make check" as root
<civodul>ah, yes
<civodul>that's a bad idea in general
<bubu^> http://pastie.org/private/pmrs6rvj0t2iqty6csusg
<bubu^>alors guix-package fails badly if the daemon isn't launched
<bubu^>also*
<bubu^>:|
<bubu^>tired
<civodul>what Guile version is it?
<bubu^>guile master
<bubu^>but letme update it
*bubu^ tired of distributions only having guile 1.8
<civodul>bubu^: take Guile 2.0 (like 2.0.9)
<civodul>or stable-2.0 if from Git
<bubu^>yes i will
<bubu^>$ guix-package
<bubu^>error: while creating directory `/usr/local/var/nix/profiles/per-user/bubu': Permission non accordée
<bubu^>Please create the `/usr/local/var/nix/profiles/per-user/bubu' directory, with you as the owner.
<bubu^>I thought the profile was in my $HOME
<civodul>yes and no
<Steap>bubu^: it's a symlink to /usr/local/var/...
<civodul>yes
<bubu^>oh, could you add an entry for this in the manual ?
<bubu^>in the daemon setup section
<Steap>civodul: is it possible to create the profile somewhere else, though ?
<bubu^>this wasn't clear for me
<civodul>Steap: it has to be a GC root, and that's a good place for that
<Steap>civodul: but it requires root privileges
<civodul>bubu^: not sure how to add that
<civodul>would you like to propose a patch? :-)
<bubu^>just so that people don't get surprised or/and understand what is happening
<bubu^>no sure I have enough background for this :)
<bubu^>and my english is terribad ;)
<civodul>ok, i'll see what i can do
<civodul>bubu^: actually the "Invoking guix package" section mentions this
<civodul>as least in current Git
<bubu^>For each user, a symlink to the user's default profile is automatically created in $HOME/.guix-profile.
<bubu^>yes :)
<bubu^>but but there is no mention that the system administrator has to create the directory in /usr/local/var/nix and change the ownership of the directory
<bubu^>for the profile
<civodul>currently it says: "It must be created by ‘root’, with USER as the owner. When it does not
<civodul>exist, ‘guix package’ emits an error about it."
<bubu^>had to kill guix-daemon, killed my memory :(
<civodul>hm?
<bubu^>it was using more than 500 Mo for "guix-package -A"
<bubu^>and started to swap on the hard drive
<bubu^>ok fine then for the documentation, I was too quick to read and/or expected this to be specified before
<bubu^>but that was my mistake
<civodul>bubu^: there's a bug in Guile < 2.0.9 where omitting the optional arg for -A or -I does that
<bubu^>:o ! must be this
<civodul>so you need to use "guix-package -A ''"
<civodul>or upgrade to Guile 2.0.9 :-)
<bubu^>btw I'm compiling guile-2.0.9 now
<bubu^>yes
<civodul>great
<civodul>Steap: it seems that CMake has test failures
<Steap>civodul: then I think we should remove it and hope people will stop using it.
<civodul>ahah, you know how to talk to me ;-)
<civodul>still...
<Steap>I'll push Python and --upgrade
<Steap>then I'll take a look at it
<bubu^>does guix-package -A fetches the package list from some mirror ?
<bubu^>(guix only proposes "old" guile-2.0.7 !)
<civodul>bubu^: no, it takes it from the list of gnu/packages files available locally
<civodul>2.0.9 is one week old, BTW :-)
<civodul>(and 2.0.8 never existed)
<bubu^>yes, but the thing is, if you want to make some "distribution" package manager, I really think it is vital to have means to keep upstream releases up to date and propose them as quickly as possible
<civodul>yes, of course
<civodul>but you're using 0.1
<bubu^>(doesn't mean to force for update before some tests, though some "masks" maybe)
<civodul>now there's a "guix pull" command to retrieve the list of packages
<bubu^>I know :)
<bubu^>it's in an early stage
<bubu^>but i'm so frustrated with package manager atm that i'm a bit raging
<bubu^>going for some sleep then
<civodul>g'night!
<Steap>civodul: can we see the logs on Hydra ? :p
<civodul>still not :-/
<civodul>i did spend a bit of time investigating, but failed
<civodul>i'd have to try again
<civodul>grr
<Steap>Well, then it's compilation time!
<Steap>Building binutils
<Steap>I might have gc'ed too much
<Steap>I ran guix gc /nix/store/path/to/cmake
<Steap>Not sure why it ended up deleting lots of files in /nix/store :/
<civodul>Steap: it's "guix gc --delete /nix/store/..." :-)
<civodul>maybe that should be improved though
<Steap>Usage: guix gc [OPTION]... PATHS...
<Steap>is a bit unclear
<civodul>oh yes that's weird