IRC channel logs

2023-05-08.log

back to list of logs

<rekado>yet another Python package depending on jupyter that has this error: InvalidRequirement('Expected end or semicolon (after version specifier)\n tinycss2>=1.1.0<1.2\n ~~~~~~~^')
<rekado>has anyone figured out where this comes from?
<rekado>perhaps we’re patching some requirements.txt somewhere and forgot the trailing semicolon?
<rekado>the problematic line is in python-bleach
<rekado>and indeed: a comma is missing there
<rekado>this has been fixed upstream
<efraim>does bleach vendor html5lib?
<rekado>don’t know
<efraim> https://sources.debian.org/src/python-bleach/5.0.1-2/debian/patches/Don-t-vendor-the-included-html5lib.patch/
<rekado>I only looked at the bad requires.txt
<efraim>randomly looked to see if I could find the same file with the error
<rekado>hopefully the upgrade to 5.0.1 fixes the remaining jupyter-related packages that are currently broken.
<efraim>I got it, the debian patch looks like a simple substitution* snippet
<rekado>any idea what this means? https://elephly.net/paste/1683550027.html
<rekado>the code in question is part of GCC
<rekado>the package merely includes <list>
<efraim>no idea, would building it with CFLAGS=-std=gnu11 or CXXFLAGS=-std=gnu++14 help? (the defaults for gcc-10)
<efraim>ACTION has to go
<rekado>I tried building with gcc-10 (and -8, and -6), but it’s all the same
<rekado>the package itself sets CXXFLAGS:
<rekado>set(CMAKE_CXX_FLAGS "-std=c++11 -DLOG_MAX_LEVEL=0 -D__GXX_EXPERIMENTAL_CXX0X__ -O3 -g3 -pedantic -pedantic-errors -Wall -fmessage-length=0 -fno-strict-aliasing -Wconversion")
<rekado>
<rekado>set(CMAKE_C_FLAGS "-D__GXX_EXPERIMENTAL_CXX0X__ -O3 -pedantic -pedantic-errors -Wall -fmessage-length=0 -Wconversion")
<rekado>