IRC channel logs

2022-10-03.log

back to list of logs

<yewscion>Hello all, trying to figure out how to incorporate gwl into my workflow (pun semi-intended). I'm confused as to what is happening to the stdout of my processes, though: When I run `guix workflow run` for a gwl script, I see the `info:` outputs, but not the actual stdout outputs. It seems like `(system)` calls are working (tried using `sleep` and it did indeed sleep for the right time) so I think it's really just `display` and friends
<yewscion>that I need advice on.
<old>Would you share an example of your workflow?
<old>Maybe in a pastebin?
<yewscion>old: Sure. I'm mostly doing testing right now; here's a MWE: https://paste.debian.net/1255879/ . I'm using an example from the fosdem '21 slides: https://archive.fosdem.org/2021/schedule/event/guix_workflow/ . And here is an example of the output I get: https://paste.debian.net/1255880/
<old>Right. You're not going to have outputs directiry from the procedure into your terminal. I think you have to specifie a file instead
<old>If you look at the examples on https://www.guixwl.org/manual/gwl.html, you will see that processes are declared with outputs (files)
<old>If you want to display something from the process to show on your terminal, I believe that stderr would work.
<old>So in your case, `(display "choo choo" (current-error-port))`
<old>I might be wrong here, but IIRC I've debugged my workflow like that
<yewscion>Ahh, Okay. That makes sense.
<yewscion>Sorry, very new to this concept.
<old>No worry we're for that :-)
<old>s/for/here for/
<rekado>yewscion: also note that GWL is shaped by its users. If you can articulate a desire to change its behavior we can probably find a way to make it happen.
<yewscion>rekado: old: Copy that! Thanks for the warm welcome, I'm glad to have found such a friendly community.