IRC channel logs

2022-02-23.log

back to list of logs

<rekado>I always just did export GUIX_EXTENSIONS_PATH=$PWD/guix/extensions
<rekado>this needs to be an absolute file name
<efraim>is it possible without manually setting GUIX_EXTENSIONS_PATH?
<zimoun>hi!
<efraim>o/
<zimoun>rekado_: hum, I tried export GUIX_EXTENSIONS_PATH=$(pwd)/guix/extensions and it has not worked. Hum? Do you use the ./pre-inst-env?
<zimoun>efraim: because the patch 2 modifies the Julia build system and so rebuild all, I also removed all the trailing #t and fix a minor bug with the build system and --cores=1. I expect to reply today. :-)
<efraim>zimoun: sounds good :)
<efraim>I did `GUIX_EXTENSIONS_PATH=/home/efraim/workspace/guix-send-email/guix/extensions/ guix --help` and saw send-email in the help menu
<zimoun>efraim, yeah me too. Then try “guix workflow -h”
<efraim>I don't actually have guix workflow
<efraim>I did try adding guix-send-email to a channels and didn't see a share/guix/extensions folder, that might be an easier way to try to fix it
<zimoun>ah ok. GUIX_EXTENSIONS_PATH works pretty well, and GWL via “guix install” just works. I want to tweak GWL from source and try my tweaks. :-) Well, I am asking the usual dev. gwl workflow. ;-)
<zimoun>efraim, v2 sent. Let me know. https://issues.guix.gnu.org/issue/54088#22
<efraim>Wooo! I'll look at it soon
<rekado_>zimoun: I cannot reproduce this.
<rekado_>yes, for development I use pre-inst-env
<zimoun>rekado_: hum?! It works using “shell -C”, so I should have someting broken.
<zimoun>thanks for having checked.
<rekado_>hmm, there’s a weird problem with the GWL
<rekado_>No variable named texlive-default-updmap.cfg in #<interface (gnu packages tex) 7f0e7f7090a0>
<zimoun>yeah, I have seen that
<rekado_>I’m not refering to any packages at all.
<rekado_>what’s that about?
<zimoun>I do not know, I have tried to reproduce. Have you?
<rekado_>I added that variable some with a Guix commit some weeks ago.
<rekado_>yes, I can reproduce this.
<zimoun>not tried
<zimoun>ouch!
<rekado_>my guess is that somewhere something’s mixed
<rekado_>we’re using an old version of Guix for the library
<rekado_>all package lookups should happen through the inferior.
<zimoun>that’s it, I guess.
<rekado_>even worse: I can only reproduce this after adding a “require-packages” line to the top
<rekado_>otherwise I get “ice-9/boot-9.scm:1752:10: error: source expression failed to match any pattern: process”
<zimoun>hum ?!
<rekado_>I wonder if that’s due to a wisp reader update
<zimoun>the last wisp update is from Nov.
<zimoun>any reason to produce guix/extensions/workflow.scm via Makefile and not via configure?
<rekado_>don’t know
<rekado_>compilation of the simple hello.w fails
<rekado_>(I see that when I unhide the warning output)
<rekado_>“failed to create path for auto-compiled file "/home/rekado/dev/gx/gwl/hello.w"”
<rekado_>I don’t get it
<rekado_>maybe I should just catch up on sleep
<zimoun>How toddler is going? Better?
<rekado_>ugh, my problem: something in ~/.cache/guile/ccache/ was root-owned…
<rekado_>zimoun: still fever
<rekado_>still sleepless nights, screaming every hour for half an hour
<rekado_>at 5am she finally slept
<rekado_>it’s been like this since Friday night
<zimoun>ouch!
<zimoun>Using ff4be11, ./pre-inst-env guix workflow run doc/examples/example-workflow.w works for me.
<zimoun>Hum, no: «error: 2.06 No variable named texlive-default-updmap.cfg in #<interface (gnu packages tex) 7f1da85f4f00>»
<rekado_>it’s HMPV; we’re still lucky that it’s a rather mild case (i.e. no need for hospitalization)
<rekado_>so… I can no longer reproduce this
<zimoun>ouch, all the best with this serious virus
<rekado_>so, inside a Guix environment for GWL I cannot reproduce this
<rekado_>outside I can
<zimoun>yep, me too, indeed.
<rekado_>maybe something’s up with the “guix” package?
<zimoun>so it is related to the guix version.
<rekado_>the “ambient” Guix on GUILE_LOAD_PATH…?
<rekado_>same with unset GUILE_LOAD_PATH and GUILE_LOAD_COMPILED_PATH
*rekado_ —> dinner
<zimoun>Guix update Wed Jan 19 by 1ef7a03a14; TeX fix Mon Feb 7 by 805af862c6f0f6c54b74125bff8d348ae8f8e6f8 .
<zimoun>when I install gwl, then “guix workflow” uses the same guix as the one reported by “guix describe”, right?
<zimoun>On the other hand, when I run gwl via pre-inst-env, “guix workflow” uses the guix provided by the package guix.
<rekado_>there are always two guices: one is the library, the other is the inferior
<rekado_>FWIW pre-inst-env makes no difference in my case
<rekado_>it’s not GUILE_LOAD_{,COMPILED_}PATH
<rekado_>something else about the environment
<zimoun>euh, after “guix install gwl”, “guix workflow” uses the Guix (as library and inferior) returned by “guix describe”, no?
<zimoun>however, inside “guix shell”, this Guix (library and inferior) is the one from the package, right?
<rekado_>with an inferior opened at /gnu/store/qd8rf3fqp22bfi4iv4wm48ib36bz46q2-profile it works; but with an inferior at /gnu/store/jvm9fl7wh9bk7n5q66m1aq6h48vg6zk4-profile it doesn’t
<rekado_>“uses” is unclear
<zimoun>use as in use-module (library)
<rekado_>it *should* use whatever it was built with
<rekado_>that’s the point of guix/extensions/workflow.scm.in
<rekado_>inside of “guix shell” we have the problem that the “guix” command is the *old* Guix
<rekado_>so that works, no surprise here
<rekado_>because that old Guix doesn’t *have texlive-default-updmap.cfg
<rekado_>I’ll try to reproduce this with *just* an inferior
<zimoun>just to be sure, “guix foo“ loads the files under GUIX_EXTENSIONS_PATH but then this ’foo’ file use-module from the caller Guix, right?
<zimoun>yes, I agree about the *old* Guix.
<rekado_>I think everything becomes clear when you look at the code of guix/extensions/workflow.scm.in
<rekado_>it replaces the load paths and *then* launches itself
<zimoun>therefore, after installing, ‘guix workflow’ uses Guix-library defined by Guix-package and then launches an inferior of Guix-current, right?
<rekado_>correct
<rekado_>the problem here is not with Guix as a library, but with the inferior.
<rekado_>in particular: the profile hook.
<zimoun>yeah, I understand.
<rekado_>this all happens at around line 300 in gwl/workflows.scm
<rekado_>there we do (run-with-store (inferior-store) …)
<rekado_>unfortunately, it’s difficult to debug these things :-/
<zimoun>’define-class’? GOOPS? Other?
<zimoun>how I can share the store with ‘guix shell -C’?
<zimoun>how can I display all the log events?
*zimoun has to go, see you later