IRC channel logs

2021-01-27.log

back to list of logs

<rekado_>nixo_: the example fails because /tmp doesn’t exist in the container. I think we should mount a tmpfs at /tmp by default.
<rekado_>nixo_: the example is bad, though, because I want to discourage the use of absolute file names in workflows
<rekado_>it’s better to make them relocatable by using relative file names
<rekado_>so I changed the examples
<rekado_>but I’ll mount the tmpfs anyway and credit you for reporting the bug
<rekado_>thanks!
<efraim>anyone have experience using slurm? should I be able to take a list of ~40 items and run 4 tasks on 4 machines and have the others queued up or is it normal that they all try to run at the same time?
<civodul>efraim: i've used it a bit but never configured/administrated it, so i'm not sure
<civodul>i think the queue configuration is quite complex, you can define lots of criteria (different queues with different constraints such as task duration, number of cores, etc.)
<efraim>i would've thought tasks-per-node would do something for me but no luck
<efraim>i'll look more into it later, it seems I've missed lunch and i'm on to linner now
<civodul>missing lunch because of slurm, that's terrible!
<zimoun>hi!
<zimoun>rekado: I was thinking about 2 things. #1 Do you think it should be possible to have «Litterate Programming» with GWL? Somehow, reverse code and comment. Something like Org-mode/babel or RMardown. Well, a reader à la Skribilo without parenthesis including GWL,
<rekado>would it not make more sense to add GWL support to org-mode babel?
<rekado>(is any support even necessary when you can tangle the file to produce the GWL workflow definition?)
<zimoun>Because I can count on my fingers the number of org-mode babel users. ;-)
<zimoun>And #2 Gitlab-CI or friends use YAML to describe what to do. Does it make sense to replace by GWL? Maybe integrate to a Cuirass-like.
<civodul>org-mode and babel are relatively popular
<civodul>now, we could have a Jupyter kernel for GWL for optimal hype :-)
<zimoun>Come on guys! Even if Konrad told me that Org was quite popule to their MOOC about Reproducible Science, Org is not popular. Otherwise, it would exist OrgHub. :-)
<zimoun>And Jupyter Notebook are so ugly and against long-term principles since the files are not human-reable. IMHO.
<rekado>I don’t know. A key feature of literate programming is reordering and reassembly. Babel already does it.
<rekado>we wouldn’t be able to implement this straight in the GWL without developing yet another surface syntax layer
<rekado>I think the better option is to *make* Org popular instead of adding yet another project for literate programming
<civodul>yup
<civodul>popularity is relative; org is not as popular as Jupyter, but it's more popular than Guix, for instance
<civodul>(i don't have any figures, just a wild guess)
<zimoun>Org will never be adopted because it is too Emacs-centric. And Org-babel only runs on Emacs.
<zimoun>Ok, so if I would like to sell to my colleagues, the only way is to have an GWL-Studio with a pre-configured Emacs. As Proof-General does for Coq for instance. If I understand correctly, that’s the direction you would take, right?
<zimoun>(assuming support of GWL by Babel, etc.)
<rekado>I don’t know… it’s a lot of work to build a pre-configured Emacs (again).
<rekado>Perhaps a separate project that implements Org features in Guile…?
<rekado>which then could be used with any editor.
<civodul>at work we have funding for a 6-month internship, not a proper salary but like 500-600 €/month, which could work for a local pre-master student
<civodul>the tricky bit is finding a good student/assignment match
<zimoun>cool! Do you have ideas for “assignment”?
<civodul>zimoun: nothing specific yet, i have to think about it
<civodul>could be guix-jupyter, could be benchmarking, archival, guix-pack-as-a-service, guix bisect, dunno
<civodul>i guess it'll depend on the person
<zimoun>guix bisect?
<civodul>yeah, a vague idea
<civodul>probably too vague to an internship actually :-)
<zimoun>what is the vague feature?
<civodul>like git bisect, but applied to deployed software
<civodul>to find which channel commit introduced a failure or something
<civodul>i told you it's vague :-)
<zimoun>cool about export-channels and export-manifest, it works well for Docker pack produced by Guix.
<zimoun>well, not a review, just various tests and proof-read the doc.
<civodul>that's already a lot, thanks for taking a look!
<civodul>so you created a Docker pack, then ran --export-* on it?
<civodul>i hadn't thought about it, but it's a nice use case
<zimoun>yes, to me, it is a “killer” feature. :-)
<zimoun>now, I would like to see if it is possible for Singularity.
<zimoun>and Guix would become the correct tool for producing containers, somehow. :-)
<civodul>heh :-)
<civodul>rekado: i'll push the inferior-package->manifest-entry memoization patch shortly