IRC channel logs

2025-01-21.log

back to list of logs

<lechner>mwette / Hi, with libguile starting guile, what is the overall of your effort?
<lechner>goal
<mwette>It will enable one to compile a binary that can be transferred to a like system, sans guile install, and execute. I probably have no use for it now, but it's been requested many times over the years. Just wanna see if it can be done.
<rlb>guile equivalent of rust/go/whatever "static linking"...
<rlb>Looks 3.0.10 is going to build most everywhere -- still not on debian/hurd, and apparently x32 doesn't work, but I'm not sure if that one's likely to persist. (Looks like it has another range issue.): https://buildd.debian.org/status/package.php?p=guile%2d3%2e0 -- m68k won't be finished for days.
<dsmith>deno seems to do that very well. Bundle up everyting into a single executable.
<apteryx>Hey Guilers! Could I petition once more to get the patches resolving https://bugs.gnu.org/67255 and https://bugs.gnu.org/67412 merged?
<apteryx>is it possible to switch to the guile debug vm during execution, after launching with --no-debug ?
<singpolyma>👋 is there a way in guile to use eg open-pipe* with OPEN_BOTH, write some string to the command, then signal that the input to the command is over and read the output it generates?
<ray1729>singpolyma: this approach using `pipeline` was suggested here by dsmith a while ago: https://paste.debian.net/1346170/
<singpolyma>ray1729: thanks, this seems like what I want
<lshoravi>Hi daviid: Is it possible to override initial values for slots? Say I am defining a class based on <gtk-widget>, and I would like to override layout-manager. Can I do it in the class definition, or do I have to override initialize?
<daviid>lshoravi: defining a layout manager is more complicated then what you seems to think it is - g-golf provides two examples you may look at, in <g-golf>/examples/gtk4, layout-manager and layout-manager-2 - please also carefully read the upstream documentation as you read the examples, and make sure you understand what needs to be done to provide a specialized layout-manager subclass
<lshoravi>daviid: I meant more slots in general. Say I want to override the orientation of a box. (define-class <my-box> (<gtk-box>) (orientation #:init-value 'vertical)) doesn't seem to override the slot?
<lshoravi>the slot being the `orientation` property here
<daviid>no, but that is a goops problem, which in your example, (re)defines a( new) orientation slot, it does not inherit and changes the init-value of the inheritied one ... you have to initialize those slots as part of the intialized specialized method for your class
<daviid>or nor define the orientation slot in your subclass and sets the property when instantiating, make (make <my-box> #:orientation 'vertical)
<daviid>*nor not define .. and set ...
<lshoravi>OK, thanks
<lshoravi>I see you specialize `initialize` in some of the examples
<daviid>lshoravi: yes, let me know if you need more help