IRC channel logs

2025-01-14.log

back to list of logs

<rlb>yeah, I'm not *confident*, but so far, those seemed to mostly go together, and do fix the build failures.
<sneek>wb dsmith!!
<dsmith>sneek, botsnack
<sneek>:)
<wehlutyk>Hello Guile!
<wehlutyk>I'm trying to play around with guile-cv and a webcam input
<wehlutyk>but so far I can't figure out what would be the proper way to get camera captures
<wehlutyk>reading OpenCV instead of Vigra points to guile-gnome-gstreamer (which seems old), and guile-gocv
<wehlutyk>any advice for other libraries, or how to feed guile-cv with a camera input?
<anemofilia>Hello
<anemofilia>I'm trying to use (ice-9 suspendable-ports) and (ice-9 popen) to gather a continuous stream of lines a command outputs
<anemofilia>But it doesn't seem to work
<anemofilia>Does anyone here have any experience doing something similar?
<dsmith>anemofilia, Check out pipeline.
<anemofilia>Hmmm, I seems promissing
<anemofilia>Thanks :)
<dsmith>One of the great things about pipeline is you can independently close the input to the pipe. Some progs don't produce output until stdin is closed (like "sort")
<dsmith>Another thing to pay attention to is buffering
<anemofilia>I guess I'm doing something wrong, the port still seems blocking
<anemofilia>Ah, I guess I found an answer
<anemofilia>Not a good one though
<anemofilia> In Guile we would like to preserve the ability to write
<anemofilia>straightforward blocking networking processes of all kinds, but under
<anemofilia>the hood to allow those processes to suspend their requests if they
<anemofilia>would block.
<anemofilia> To do this, the first piece is to allow Guile ports to declare
<anemofilia>themselves as being nonblocking. This is currently supported only for
<anemofilia>file ports, which also includes sockets, terminals, or any other port
<anemofilia>that is backed by a file descriptor.
<lechner>Hi, how would I make myself a 'define-public*' please?
<dsmith>lechner, Check out ice-9/optargs.scm around line 255
<lechner>dsmith / thanks!
<lechner>Hi, will #:unwind? #t return with the last value in the exception handler?
<dsmith>lechner, Sorry. I've no clue
<daviid>sneek: later tell wehlutyk guile-cv doesn't offer any webcam nor scanner image(s) capture api, you have to capture using other tool/lib ... including microscope/tomography apps ... it's called cv, so in the long run the name remanes valid, but in its current state, it is more a (scientific) image processing lib (then a computer vision) - i am not aware of what guile-gocv - if you want to use gstreamere, use g-golf
<sneek>Got it.
<daviid>*the name remains valid ...
<daviid> sneek: later tell wehlutyk i recently became aware of the existence of a Gimp typelib, so you can use it using g-golf: fire guile, then ,use (g-golf) and (gi-import "Gimp"), assuming you installed the gir1.2-gimp-3.0 package of your distro - the api doc is here https://developer.gimp.org/api/3.0/libgimp/
<sneek>Got it.
<daviid>and installed the latest g-golf as well ofc ...
<rlb>I've had intermittent 00-repl-server.test failures:
<rlb>ERROR: 00-repl-server.test: repl-server: HTTP inter-protocol attack - arguments: ((system-error "fport_write" "~A" ("Broken pipe") (32)))
<rlb>It looks like they may be caused by load/contention somehow -- I wondered if it might be only when I was running "make -jN check", and so I tried:
<rlb>$ parallel -j 3 ./check-guile -- 00-repl-server.test 00-repl-server.test 00-repl-server.test
<rlb>and that makes it fairly easy to reproduce the problem -- not every time, but often.
<rlb>Though I haven't looked at the test carefully enough to know if it's OK running in parallel, so could just be same symptom, slightly different cause.
<rlb>(parallel with itself)
<rlb>I mean