IRC channel logs

2024-12-17.log

back to list of logs

<mwette>Another way, less attractive to me, would be to add a separator token: (define-x (foo x y) "doc .." (user "John Doe") ... (prompt "? ") -- expr0 expr1 ...) where you use `(syntax-case x (--) (...))'
<lechner>mwette / okay, thanks! maybe i'll wait with that until I settle on an interface
<daviid>dthompson: wingo recently patched guile with read-c-struct write-c-struct which for which "... unless cross-compiling, the field types are evaluated at macro-expansion time."
<daviid>cow_2001: see https://git.savannah.gnu.org/cgit/grip.git/tree/grip/support/slib.scm?h=devel and glob.scm in the same dir (see in the comment in the slib module, for where it comes from and who wrote it ...)
<cow_2001>huh!
<cow_2001>this should really go into guix
<daviid>though i dot like the procedure name, nor its api anynmore (should rewrite it) here is an example of how to use it to retreive files based on some glob pattern, recusrively or not, case sensitive or not ... https://git.savannah.gnu.org/cgit/grip.git/tree/grip/file.scm?h=devel#n89
<daviid>then you'd do (get-filenames (getcwd) #:like "*.scm")
<daviid>as an exemple ... you may want to write your own glob wrapper proc, but feel free to use the one in grip, it's free s/w ...
<daviid>cow_2001: i am pretty sure guix has some glob(ber) as well, worth asking in #guix
<lechner>daviid / thanks for those comprehensive answers!
<lechner>Hi, what could be a reason, please, why this macro stops working when exported from another file? https://bpa.st/J44A