IRC channel logs

2024-12-06.log

back to list of logs

<sneek>Yey! dsmith is back
<dsmith>sneek, botsnack
<sneek>:)
<ArneBab>dsmith: don’t forget that thanks to mes that C compiler can be bootstrapped from a tiny hand-validatable binary: https://www.gnu.org/software/mes/ — stage0 builds M2-planet and Mescc-tools which build TinyCC which builds glibc/binutils/gcc (version 2) which build more recent versions that then build Guile.
<ArneBab> https://bootstrappable.org/projects/mes.html
<mdj>sneek: botsnack
<sneek>:)
<mdj>sneek, later tell civodul, dthompson I applied my psyntax patch which temporarily reverts 7379049d3.
<sneek>Okay.
<mdj>!help
<mdj>!help help
<AwesomeAdam54321>Hi, is there a Guile library for displaying images present in the current directory?
<morenonatural>AwesomeAdam54321, you can use guile to go over files in a directory and call _something_ on that path... probably `xdg-open` in linux distro or `open` in MacOS
<morenonatural>can you expand on what you're trying to achieve?
<AwesomeAdam54321>morenonatural: My program reads a choose-your-own text adventure written in an ad-hoc format, and it has the option of displaying images specified at certain points in the story
<AwesomeAdam54321>I'm rewriting it from Python to Guile as a way to practice programming in it
<AwesomeAdam54321>s/in it/in Guile Scheme
<morenonatural>can you share some code? was it already displaying images in Python?
<AwesomeAdam54321>morenonatural: The Python code is here: https://codeberg.org/AwesomeAdam54321/chooventerp
<AwesomeAdam54321>Displaying images works with the Pillow module
<morenonatural>ah, I see
<morenonatural>yup, according to docs "will open default viewer"
<morenonatural> https://pillow.readthedocs.io/en/stable/reference/Image.html#open-rotate-and-display-an-image-using-the-default-viewer
<morenonatural>you'll be safe with running `xdg-open path-to-img` (linux distro) or `open path-to-img` in MacOS
<AwesomeAdam54321>Thanks :)
<AwesomeAdam54321>I also learned about match-let today
<millido>last question from guile-guest was from this user, joined with mu bouncer now :)
<morenonatural>how do y'all get a (shell) script or some data exploration done with guile (ie: about 300 LOC)? use guix to setup both emacs and guile? use guix to even set up Emacs packages?
<morenonatural>I dunno guix terms correctly but... one guix environment for all-things-short-scripting? one per script? once I'm done with an env, should I keep Emacs if I'm only going to run it with guile?
<morenonatural>I watched this one System Crafters vid and the presenter seemed to spend a lot of time to set up a proper dev env (keywords: guix hall)