IRC channel logs

2024-11-22.log

back to list of logs

<apteryx>ljoit
<apteryx>err
<paul_j>Afternoon all! I am setting up my laptop to learn more about guile, so I can more effectively work with my guix install on a small home server. When compiling a small test program, I am running into an error message which I think is related to a missing load-path: "Unbound variable: ge:compile". The laptop is running gentoo linux, and this error message is given to me when pressing C-x C-e in emacs. I have installed geiser, and
<paul_j>geiser-guile, but don't have any configuration setup yet. I would welcome any pointers as to how this can be resolved. Thank you!
<paul_j>(I have also started the geiser REPL already)
<morenonatural>I'm using `let' bindings for a `alist->vhash` and a string query object, continually evaluating `vhash-assoc' with `string=?' on Emacs/geiser-guile _sometimes_ spits out #f
<morenonatural> https://paste.debian.net/1336435/
<morenonatural>using guile 3.0.8 on debian bookworm, btw
<GNUtoo>Hi, is there an easy way to identify if a file is an ELF in Guile?
<morenonatural>it seems my problem had to do with mixing hash, hashq & hashv variants
<Arsen>GNUtoo: "is an elf" is a pretty weak check so I suppose something like this works:
<Arsen>scheme@(guile-user)> (define (is-elf file) (call-with-input-file file (lambda (f) (bytevector=? (get-bytevector-n f 4) #vu8(#x7F #x45 #x4C #x46)))))
<Arsen>scheme@(guile-user)> (is-elf "/bin/ls")
<Arsen>$1 = #t
<Arsen>scheme@(guile-user)> (is-elf "/etc/passwd")
<Arsen>$2 = #f
<Arsen>unsure how idiomatic.. I don't write scheme too much
<Arsen>paul_j: that's interesting, might be my fault even
<Arsen>could you check qlist -Iv guile
<lilyp>if this is for guix, it should also have some checks in (guix build gremlin)
<old>You can also check against the string "\x7fELF" if that's more readable
<Arsen>paul_j: hmm, I don't see that locally
<civodul>probably relevant, the ‘elf-file?’ procedure from Guix: https://git.savannah.gnu.org/cgit/guix.git/tree/guix/build/utils.scm#n350
<GNUtoo>thanks
<GNUtoo>elf-file?
<GNUtoo>oops, I meant that I'll use elf-file?. Thanks a lot.
<paul_j>Arsen: output from qlist: dev-scheme/guile-3.0.10-r102
<paul_j>I'm sure it's more likely my fault (or omission)!!
<paul_j>For context, this laptop is running a mixture of stable and unstable packages. I installed guile 2.2.7-r1 in May, but did nothing with it. Guile 3 was installed on the 9th November. My efforts to get it running with emacs over the last few days is the first time I have tried to use it.
<paul_j>Last world update - in the last week
<old>anyone know why 3.0.10 is not on Guix?
<rlb>May be because it's broken on 32-bit -- that's fixed in main, though. (That's why it's not in debian, at least.)
<old>aaah
<old>arch linux does not care about 32-bit I suppose
<old>since they have 3.0.10
<rlb>They must not build there.
<rlb>build/test (at least)
<rlb>At least if I understood the problem correctly.
<rlb>(definitely did not build on debian 32-bit)
<wolfdog>yeah arch linux dropped 32-bit support a while ago
<wolfdog>early 2017, i think
<Arsen> 18:29:05 <paul_j> Arsen: output from qlist: dev-scheme/guile-3.0.10-r102
<Arsen>yes that's my code
<Arsen>how could I reproduce that
<yewscion>Hello Guile! I am rebuilding my server (OS is Slackware Current) and I was installing a custom package that contains guile code. However, upon trying to run that code, auto-compilation fails with the error here: https://paste.debian.net/1336459/ I've also included the full install process, and the output of env. Any suggestions?
<morenonatural>yewscion, probably wrong path for loading .go files, not sure about the flags for `configure` script to add /lib64/guile/3.0
<morenonatural>or where should they go
<yewscion>Oh, I didn't notice that it was being installed to /lib64/... That's why, then. That's meant to only be for OS-stock stuff in Slackware.
<yewscion>Thank You morenonatural, I'll go fix that!