IRC channel logs

2024-11-14.log

back to list of logs

<daviid>*write a tcl/tk canvas 'model' using nyacc/ffi-helper, iirc
<daviid>mwette: no big deal either, just wanted to port it to g-golf, for fun and bug tracking in case it would reveal a bug ...
<mwette>Oh, the tcl/tk thing. I've been working on that, but I don't have any cairo in there. I'm working on the (tk-like) Packer (subclassed from GtkContainerClass).
<mwette>gtkinter.scm: https://paste.centos.org/view/91364ebe
<mwette>tk-like syntax needs work
<daviid>ok tx - no url i can follow, if you still work on it ...
<sneek>dsmith: wb!
<dsmith>sneek, botsnack
<sneek>:)
<dsmith>There's a good bot
<sneek>ACTION wags
<mwette>lol
<lechner->Hi, how may I trigger a vhanghup syscall from Guile, please?
<old>lechner-: https://paste.sr.ht/~old/ac4b537b18a83ed1ffff02394a7cb53ba5b309a3
<lechner->old / i'm so dumb! that will work with ioctl too. thanks!
<daviid>fwiw, i released g-golf 0.8.0-rc9 - https://lists.gnu.org/archive/html/guile-user/2024-11/msg00033.html
<ekaitz>wingo: i found the error with the calls
<ekaitz>now I have some others :)
<ekaitz>but I think these are easier to solve than that one
<mwette>nice
<ekaitz>:)
<dsmith>yey!
<ArneBab>dthompson: I mostly care about that hoot doesn’t cause pressure on regular Guile to worsen algorithmic complexity of things that already work. Changing string performance (even if some parts get faster in exchange for others getting slower) could badly break lilypond, and that must not happen.
<ArneBab>dthompson: is there a way to create backend-specific implementations? “if this is run on hoot, use string-flavor-hoot, otherwise use string-flavor-c”)
<ArneBab>Damn, I created an unfixable unbalanced paren ☺
<dthompson>ArneBab: I don't think that's an issue but also it's a two way street. guile should be allowed to change sometimes.
<dthompson>the issue being strings in hoot vs. strings in guile. they're two separate implementations. one doesn't affect the other.
<rlb>fwiw, and depending on what we're talking about, the utf-8 stuff I've been doing has/had nothing to do with hoot, i.e. I started and did that independently (as far as I know).
<rlb>My impression has been that the intention to move to utf-8 internally is "long-standing" (fsvo long-standing), and that almost certainly means notable change in algorithmic complexity.
<rlb>(But I may also have misunderstood.)
<ekaitz>wingo: https://paste.debian.net/1335537/ this is the alignment issue we talked about yesterday but more obvious
<ekaitz>the line 14 shows a jump that is not jumping to an aligned address, but the instructions are aligned
<dsmith>ekaitz, Where *should* it be jumping to?
<ekaitz>dsmith: idk but surely not to an address that ends in A
<ekaitz>0, 4, 8 and c are the valid endings
<dsmith>Hmm.
<ekaitz>it's simply because it's jumping to the center of an instruction
<dsmith>Right.
<dsmith>I guess what I'm asking is what is the intended target of that jump? Some code that already exits? Something that is currently being generated?
<ekaitz>that jump should jump over the literal pool
<ekaitz>which is right after the veneers in the example
<dsmith>So 0x0000003f87e97588 ?
<ekaitz>probably
<ekaitz>because the emit_literal_pool adds the jump, then all the literal pool and then patches the jump to point to the end, so yeah
<dsmith>So sounds like it calculating the size of the literal pool incorrectly?
<ekaitz>that can be
<ekaitz>or maybe the jump is patched incorrectly
<dsmith>Maybe something like not multiplting by the size of a pool item?
<ekaitz>hmmmmm
<dsmith>Any nice budget friendly risc-v boards? Like a beaglebone or rpi type of board?
<ekaitz>yeah VisionFive2
<ekaitz>that's what I'm using
<dsmith>ACTION looks
<ekaitz>it's like... 200 bucks?
<ekaitz>a little bit less i think
<rlb>There's also the pine-something (no idea how it fares), and just saw the announcement of a motherboard for the framework, but that's ~200 I think...
<ekaitz>also if you don't want to run an OS the rpi pico 2 is a riscv machine i think
<ekaitz>or has some subprocessor or something
<dsmith>Thinking about eventually moving the bot to a new home. Currently on a beaglebone. Something risc-v would be cool.
<ekaitz>the visionfive2 has served me well during the guix bootstrapping work for riscv
<ekaitz>and still is
<rlb>(ahh, it was the star64 that I saw mentioned on the pine front...)
<dsmith>Hmm. https://pine64.com/product/star64-model-a-4gb-single-board-computer/ ?
<rlb>yeah, there's an 8g version too maybe?
<rlb>(No real experience with pine.)
<rlb>And this was I think the current state of the framework mb https://deepcomputing.io/deepcomputing-launches-early-access-program-for-dc-roma-risc-v-mainboard-for-framework-laptop-13/
<dsmith>I don't think that runs Linux. (Yet?)
<rlb>Oh, right, no idea.
<rlb>There is also a case for framework mbs, fwiw: https://frame.work/products/cooler-master-mainboard-case (I haven't tried a framework yet, but I may.)
<rlb>fsvo "case" :)
<ekaitz>OH i think this is working
<ekaitz>dsmith: exactly was some kind of pointer magic I did wrong!
<dsmith>Yey!
<ekaitz>wingo! got it!!!
<ekaitz>i need to fix a couple of small details but guile runs with the JIT active for RISC-V
<dthompson>wow nice job ekaitz!!
<rlb>nice
<ekaitz>dthompson: Yay!
<ekaitz>thanks!
<dsmith>Hmm. Looks like someone has Debian on it: https://blog.fluxcoil.net/posts/2024/09/debianizing-star64-and-ipv6-for-lan/
<ekaitz>dsmith: i think we can run guix in the visionfive2
<lechner->mwette / Hi, do callbacks work with Nyacc's FFI Helper?
<dsmith>ekaitz, I haven't gone down the guix rabbit hole (yet?) Been pretty much stuck to Debian since 1.0
<ekaitz>dsmith: wanna lose your sanity?
<ekaitz>i can be your shaman if you want
<dsmith>I'd prefer to hang on to what little shreads remain
<ekaitz>:)
<ekaitz>dsmith: you can still `apt install guix`
<ekaitz>so i have some last issue to fix: get_callr_temp was added to lightening after i did this support and it's failing
<ekaitz>it uses LD register in Aarch but I don't know what to use in riscv
<ekaitz>i tried with RA register, but it's failing the associated test
<wingo>ekaitz: nice!!!
<ekaitz>wingo: i just need to fix that thing and it should work
<ekaitz>but i don't know how to fix at the moment
<ekaitz>ra should work
<ekaitz>but it doesn't
<dpk>rlb: one thing i’m concerned about performance-wise with string-set! in a UTF-8 implementation like yours is the R6RS custom ports API
<dpk>custom input ports more or less depend on O(1) string-set! to be performant
<dpk>for R7RS Large i’m proposing a do-over where they use u32vectors instead, acknowledging that existing R6RS code using the R6RS API might just be very slow
<dpk>does Guile have some kind of native custom textual port functionality that has a better API?
<rlb>In general, of course, with utf-8 you likely need to switch to "string builder" or "join fragments" or... style approaches.
<rlb>or other bulk "all in one" transformations/filters/etc.
<dpk>right, for building up a string from chunks that’s a good idea anyway to avoid quadratic re-allocations
<rlb>yep
<rlb>I did a lot of that sort of thing in the proposed changes, but as you say, doesn't help if your chosen primitive is string-set!
<rlb>can't really do that anymore
<dpk>but consider the read! argument to make-custom-textual-input-port specifically https://www.r6rs.org/corrected/html/r6rs-lib/r6rs-lib-Z-H-9.html#node_idx_682
<dpk>that uses a string as a buffer where the consumer of this API is required required to write n characters into n consecutive positions in the string
<rlb>right, some apis aren't really compatible with utf-8.
<dpk>(only one ‘required)
<dpk>(also a closing quotation mark, sigh)
<dpk>possibly the solution here is to special-case the creation of the string that’s passed in so it has 4 times as many bytes ready in its buffer as the count argument, but that might complicate the implementation generally …
<dpk>or you just accept R6RS custom ports are going to be slow, but hence my question: does Guile have some other way to create a custom textual input port that doesn’t already depend on this particular access pattern being fast?
<dpk>if the R6RS way is slow, i at least want an implementation-specific way that’s fast
<rlb>I may not be a likely candidate to answer that -- not sure I've done much with custom ports yet.
<dpk>(i = programmers constructing custom textual I/O ports in general)
<lampilelo>hello